abclinuxu.cz AbcLinuxu.cz itbiz.cz ITBiz.cz HDmag.cz HDmag.cz abcprace.cz AbcPráce.cz
AbcLinuxu hledá autory!
Inzerujte na AbcPráce.cz od 950 Kč
Rozšířené hledání
×

včera 18:11 | Nová verze

Společnost Oracle oficiálně oznámila vydání Java SE 9 (JDK 9), Java Platform Enterprise Edition 8 (Java EE 8) a Java EE 8 Software Development Kit (SDK). Java SE 9 přináší více než 150 nových vlastností.

Ladislav Hagara | Komentářů: 0
včera 12:11 | Komunita

Na Humble Bundle lze získat hororovou počítačovou hru Outlast (Wikipedie) běžící také v Linuxu zdarma. Speciální akce končí v sobotu v 19:00.

Ladislav Hagara | Komentářů: 1
včera 10:33 | Humor

Mozilla.cz upozorňuje na Knihu Mozilly (Wikipedie), tj. velikonoční vajíčko ve Firefoxu. Zobrazit jej lze zadáním about:mozilla do adresního řádku. Aktuální verze Firefoxu obsahuje proroctví 15:1 "Dvojčata Mamonu se rozhádala a jejich souboje uvrhly svět do nové tmy. Zvířeti se ale tma hnusila. A tak se stalo mrštnější a silnější, šlo vpřed a jeho počty rostly. A zvíře přineslo oheň a světlo do tmy". Firefox 57 bude obsahovat proroctví 11:14. To je zatím jenom v angličtině. Pomoci lze s překladem do češtiny.

Ladislav Hagara | Komentářů: 8
včera 01:22 | Zajímavý projekt
Před měsícem byla spuštěna kampaň na podporu chytrého telefonu Librem 5, jenž by měl respektovat bezpečnost, svobodu a soukromí uživatelů. Cílem kampaně je vybrat alespoň milion a půl dolarů. Aktuálně je vybráno přes 600 000 dolarů, tj. 40 %. Kampaň poběží ještě další měsíc. Podporu projektu oznámilo KDE i GNOME.
Ladislav Hagara | Komentářů: 26
včera 00:55 | Komunita

Agentura DISA (Defense Information Systems Agency) publikovala (pdf) Ubuntu 16.04 Security Technical Implementation Guide (STIG) (zip), tj. doporučené bezpečnostní nastavení Ubuntu 16.04. Ubuntu se tak dostalo mezi unixové operační systémy a linuxové distribuce AIX, HP-UX, Oracle Linux, Red Hat a Solaris [reddit].

Ladislav Hagara | Komentářů: 2
21.9. 22:55 | Bezpečnostní upozornění

CSIRT.CZ informuje, že byly vydány nové bezpečnostní aktualizace, které opravují několik zranitelných míst v Sambě. Útočník může využít zranitelnosti s cílem získání přístupu k potenciálně citlivých informací. Uživatelům a správcům je doporučeno, aby zkontrolovali bezpečnostní opatření pro CVE-2017-12150, CVE-2017-12151 a CVE-2017-12163 a provedli potřebné aktualizace.

Ladislav Hagara | Komentářů: 0
21.9. 21:44 | Komunita

Společnost Red Hat aktualizovala svůj slib ohledně softwarových patentů. Slib nově zahrnuje i open source software pod permisivními licencemi.

Ladislav Hagara | Komentářů: 0
21.9. 08:55 | Komunita

Do 22. září probíhá v Mountain View konference XDC2017 (X.Org Developer's Conference). Na programu je řada zajímavých přednášek. Sledovat je lze online. K dispozici je záznam přednášek ze včerejšího dne.

Ladislav Hagara | Komentářů: 0
20.9. 17:33 | Nová verze

Byla vydána nová stabilní verze 1.12 (1.12.955.36) webového prohlížeče Vivaldi (Wikipedie). Z novinek vývojáři zdůrazňují možnost zobrazení metadat u digitálních fotografií, vylepšený panel stahování a omezení sytosti barvy zdůraznění (YouTube). Nejnovější Vivaldi je postaveno na Chromiu 61.0.3163.91.

Ladislav Hagara | Komentářů: 40
20.9. 10:55 | Nová verze

Byla vydána verze 4.0 programovacího jazyka Swift (Wikipedie). Zdrojové kódy jsou k dispozici na GitHubu. Ke stažení jsou oficiální binární balíčky pro Ubuntu 16.10, Ubuntu 16.04 a Ubuntu 14.04.

Ladislav Hagara | Komentářů: 5
Těžíte nějakou kryptoměnu?
 (5%)
 (3%)
 (17%)
 (75%)
Celkem 558 hlasů
 Komentářů: 22, poslední 29.8. 11:23
    Rozcestník

    Dotaz: Instalace PacmanXG4 a Yaourt v Arch Linuxu (Linux Bridge)

    26.12.2012 10:32 historicalmartin
    Instalace PacmanXG4 a Yaourt v Arch Linuxu (Linux Bridge)
    Přečteno: 853×

    Dobrý den,

    Jsem začátečník v Linuxu a rozhodl sem se utábořit v Arch Linuxu, potažmo Linux Bridge.. Sice budou mnozí z vás namítat, že to pro začátečníka není dobrá volba, ale našel sem si přímou poddistribuci "Linux Bridge", což má být out-of-the-box..
    Vcelku hezká instalace, ale po nainstalování OS jediný vrásek: nemá Pacman-gui, tedy mnou oblíbený správce softwaru "PacmanXG4" který sem viděl u Cinnarchu.
    K jeho funkčnosti je ještě potřeba "Yaourt" který se napojí na AUR - ofificiální repozitáře v Arch linuxu..
    Zkoušel sem to vyřešit pomocí příkazového řádku, ale bezúspěšně.. Najde se mezi vámi nějaký Guru co poradí?? Ono to asi nebude tak komplikovaný, jen mi ta příkazová řádka ještě tolik nechutí..
    Jinak zvolil sem grafické rozhraní Xfce..

    příkazy:

    pacman -S pacmanxg4

    pacman -U (vložený link pro stažení z AUR nebo cesta ke složce v počítači se staženým archivem)

     

    Pacman mi stáhl archiv z linku, ale odmítl ho otervřít, prý poškozený archiv a chybný pgp podpis, přitom se jedná přímo o repozitář AUR..

    ani jedno a obdobně instalace Yaourt nefunguje.. Mohl by mi někdo popsat stručněji postup instalace "PacmanXG4"?

     

    Předem děkuji...

    Odpovědi

    26.12.2012 11:11 MadCatX
    Rozbalit Rozbalit vše Re: Instalace PacmanXG4 a Yaourt v Arch Linuxu (Linux Bridge)

    Tímto postupem pacmanxg4 bohužel nainstalujete. Na AURu je k dispozici příslušný "balíček", který nainstalujete takto.

    1. Stáhněte tarball s PKGBUILDem
    2. Rozbalte tarball a sestavte balíček
      tar xvf pacmanxg4-bin.tar.gz
      cd pacmanxg4-bin
      makepkg -c
           
    3. Pokud se balíček sestaví, nainstalujte jej
      su -c "pacman -U pacmanxg4-bin-4.13.10-1-x86_64.pkg.tar.xz"
           

    V seznamu závislostí yaourt není, tudíž jej není nutné instalovat - instaloval by se ale stejným způsobem. Příkaz pacman -U se sice používá k ručnímu zadání cesty k balíčku, musí ale jít skutečně o balíček ve formátu, kterému rozumí pacman. Takové balíčky na AURu nejsou, AUR obsahuje pouze tzv. PKGBUILDy (a někdy i další soubory). PKGBUILD je předpis, podle kterého ABS (Arch Build System) balíček sestaví. O ABS si můžete přečíst na Arch Wiki.

    Max avatar 26.12.2012 11:18 Max | skóre: 65 | blog: Max_Devaine
    Rozbalit Rozbalit vše Re: Instalace PacmanXG4 a Yaourt v Arch Linuxu (Linux Bridge)
    Tak to je samozřejmě špatně. "pacman -U" nainstaluje lokální balíček, popř. provede upgrade. Na AUR nejsou žádné balíčky. Na AUR jsou jen jejich definice, podle kterých dojde k vytvoření balíčku.

    Pro nainstalování balíčku z AUR máš dvě možnosti :
    1) ručně :
    # stahnout definici balíčku (PKGBUILD apod.) :
    wget -c https://aur.archlinux.org/packages/pa/pacmanxg4-bin/pacmanxg4-bin.tar.gz
    
    # rozbalime
    tar xvfz pacmanxg4-bin.tar.gz
    cd pacmanxg4-bin
    
    # vytvorime balicek
    makepk
    
    # nainstalujeme balicek jako root
    sudo pacman -U pacmanxg4-bin-4.13.10-1-x86_64.pkg.tar.xz
    

    2) pomocí nástroje yaourt :
    # pridame si repo, ktere obsahuje nastroj yaourt :
    nano /etc/pacman.conf
    ...
    [archlinuxfr] 
    Server = http://repo.archlinux.fr/$arch
    
    # provedeme update db
    pacman -Sy
    
    # nainstalujeme yaourt :
    pacman -S yaourt
    
    # pomocí yaourt nainstalujeme pacmanxg, nejdrive ale zjistime, jake mame moznosti (vyhledame, co je vsechno dostupne v AUR):
    yaourt -Ss pacmanxg
    
    # nyni si vybereme balicek, ktery nam bude vyhovovat nejlepe a ten nainstalujeme :
    yaourt -S pacmanxg4-bin
    
    Zdar Max
    Měl jsem sen ... :(
    Max avatar 26.12.2012 11:21 Max | skóre: 65 | blog: Max_Devaine
    Rozbalit Rozbalit vše Re: Instalace PacmanXG4 a Yaourt v Arch Linuxu (Linux Bridge)
    Oprava (nějak batrojovi zlobí klávesnice) "makepk" -> "makepkg"
    Zdar Max
    Měl jsem sen ... :(
    26.12.2012 11:30 historicalmartin
    Rozbalit Rozbalit vše Re: Instalace PacmanXG4 a Yaourt v Arch Linuxu (Linux Bridge)
    Všem Vám moc děkuji, zatím se mi to nevede, takže zkusím vše udělat podle vašeho popisu a když to nepůjde, tak sem zkusím zkopírovat terminál..
    26.12.2012 11:43 historicalmartin
    Rozbalit Rozbalit vše Re: Instalace PacmanXG4 a Yaourt v Arch Linuxu (Linux Bridge)
    Zvolil sem Maxovu 2. možnost, přepsal sem v terminálu:

    # Repository entries are of the format: # [repo-name] # Server = ServerName # Include = IncludePath

    Na

    # Repository entries are of the format: # [archlinuxfr] # Server = http://repo.archlinux.fr/$arch # Include = IncludePath

    Ale jak to mám uložit a zase se vrátit zpět do terminálu? Dole je psáno "^O - Uložit" "^X - Ukuončit Ale kam to mám zadat? Ten zbytek už podle mne bude bezproblému.
    26.12.2012 12:23 MadCatX
    Rozbalit Rozbalit vše Re: Instalace PacmanXG4 a Yaourt v Arch Linuxu (Linux Bridge)
    Pokud to editujete v nano, pak ^X = CTRL+X atp...
    Václav 26.12.2012 13:48 Václav "Darm" Novák | skóre: 26 | blog: Darmovy_kecy | Bechyně / Praha
    Rozbalit Rozbalit vše Re: Instalace PacmanXG4 a Yaourt v Arch Linuxu (Linux Bridge)
    Ještě bych doporučil z řádků #[archlinuxfr] a # Server = odstranit znaky #. Označuje se tím komentář, takže by byly řádky v konfiguráku ignorovány.
    Cross my heart and hope to fly, stick a cupcake in my eye!
    26.12.2012 16:21 historicalmartin
    Rozbalit Rozbalit vše Re: Instalace PacmanXG4 a Yaourt v Arch Linuxu (Linux Bridge)
    MadCatX, děkuji máte pravdu, to mi nedošlo..

    Václav "Darm" Novák, rovněž děkuji, došlo mi to jelikož to s "#" neudělalo změnu, nevěděl sem, že se jedná o komentáře, ale chybami se člověk učí..
    26.12.2012 18:09 historicalmartin
    Rozbalit Rozbalit vše Re: Instalace PacmanXG4 a Yaourt v Arch Linuxu (Linux Bridge)
    Můžu ještě poprosit jak vyřešit závislosti:

    $ yaourt -S pacmanxg4-bin

    ==> Downloading pacmanxg4-bin PKGBUILD from AUR... x pacmanxg4-bin.install x PKGBUILD Comment by mrbit (2012-11-06 22:09) http://almin-soft.nx0.ru/pacmanxg_4x_series.html not found !!!!

    Comment by minoshi (2012-11-08 11:35) to by mrbit : fixed

    by wiggly : is 4.13.1 fix broblem?

    by evilgnome : 1.you can find code of pacmanxg on my site. 2.Because i have not 64bit. Are you ready make it?

    Comment by mrbit (2012-11-08 12:17) ok.. now work. thanks

    Comment by deepb (2012-11-26 20:05) Replace source=("http://almin-soft.nx0.ru/data/files/pacmanxg/download.php?get=pacmanXG4.tar.bz2") to source=("pacmanXG4.tar.bz2::http://almin-soft.nx0.ru/data/files/pacmanxg/download.php?get=pacmanXG4.tar.bz2") in PKGBUILD

    Comment by minoshi (2012-11-29 17:19) to deepb : made

    pacmanxg4-bin 4.13.10-1 (Ne led 29 18:13:19 UTC 2012) ( Unsupported package: Potentially dangerous ! ) ==> Edit PKGBUILD ? [Y/n] ("A" to abort) ==> ------------------------------------ ==> y

    Please add $EDITOR to your environment variables for example: export EDITOR="vim" (in ~/.bashrc) (replace vim with your favorite editor)

    ==> Edit PKGBUILD with: makepkg

    ==> Vytváří se balíček: pacmanxg4-bin 4.13.10-1 (St pro 26 14:10:26 UTC 2012) ==> Kontrola runtime závislostí... ==> Chybějící závislosti: -> lib32-libx11 -> lib32-gcc-libs ==> Kontrola buildtime závislostí... ==> CHYBA: Nelze vyřešit všechny závislosti. ==> pacmanxg4-bin dependencies: - pacman (already installed) - lib32-libx11 (building from AUR) - lib32-gcc-libs (building from AUR)

    Jakým způsobem nainstalovat tyto závislosti:

    lib32-libx11 lib32-gcc-libs

    Je toto správně??

    Edit PKGBUILD with: makepkg

    Nelze nainstalovat jako s právy "root" ani s právy běžného uživatele, je nějaká třetí možnost??
    Max avatar 26.12.2012 23:06 Max | skóre: 65 | blog: Max_Devaine
    Rozbalit Rozbalit vše Re: Instalace PacmanXG4 a Yaourt v Arch Linuxu (Linux Bridge)
    1) Dal jsi "y", že chceš editovat PKGBUILD, aby jsi se přesvědčil, že je ok a není to nějaký červ, což je u věcí z AUR běžná věc (po prohlídnutí PKGBUILDU / ukončení editoru, se automaticky pokračuje ve skládání balíčku, někdy je součástí definic nejen PKGBUILD soubor, ale i další soubory, takže se yaourt může ptát víckrát na různé soubory, jež jsou součástí definic)
    2) yaourt zjistil, že nemáš definován žádný výchozí editor, takže se tě zeptal, čím by jsi chtěl PKGBUILD editovat
    3) napsal jsi, že chceš pro editaci použít program "makepkg", což je trochu mimo mísu, toto není žádný editor
    Zdar Max
    Měl jsem sen ... :(
    26.12.2012 21:03 historicalmartin
    Rozbalit Rozbalit vše Re: Instalace PacmanXG4 a Yaourt v Arch Linuxu (Linux Bridge)
    Nevíte co je zde za chybu?? A jak jí vyřešit??

    Please add $EDITOR to your environment variables

    for example:

    export EDITOR="vim" (in ~/.bashrc)

    (replace vim with your favorite editor)

    ==> Edit PKGBUILD with: makepkg

    /usr/bin/makepkg: řádek 1466: pro „here“ dokument nelze vytvořit dočasný soubor: Na zařízení není volné místo

    /usr/bin/makepkg: řádek 1475: pro „here“ dokument nelze vytvořit dočasný soubor: Na zařízení není volné místo

    /usr/bin/makepkg: řádek 1553: pro „here“ dokument nelze vytvořit dočasný soubor: Na zařízení není volné místo

    ==> Vytváří se balíček: pacmanxg4-bin 4.13.10-1 (St pro 26 20:59:01 UTC 2012)

    ==> Kontrola runtime závislostí...

    ==> Chybějící závislosti:

    -> lib32-libx11

    -> lib32-gcc-libs

    ==> Kontrola buildtime závislostí...

    ==> CHYBA: Nelze vyřešit všechny závislosti.

    /usr/lib/yaourt/pkgbuild.sh: řádek 48: echo: chyba zápisu: Na zařízení není volné místo

    cat: chyba při zápisu: Na zařízení není volné místo

    /usr/lib/yaourt/pkgbuild.sh: řádek 50: echo: chyba zápisu: Na zařízení není volné místo

    /usr/lib/yaourt/pkgbuild.sh: řádek 57: echo: chyba zápisu: Na zařízení není volné místo

    /usr/lib/yaourt/pkgbuild.sh: řádek 58: echo: chyba zápisu: Na zařízení není volné místo

    /usr/lib/yaourt/pkgbuild.sh: řádek 59: echo: chyba zápisu: Na zařízení není volné místo

    /usr/lib/yaourt/pkgbuild.sh: řádek 60: echo: chyba zápisu: Na zařízení není volné místo

    /usr/lib/yaourt/pkgbuild.sh: řádek 61: echo: chyba zápisu: Na zařízení není volné místo

    ==> CHYBA: pkgname nemůže být prázdné.

    ==> CHYBA: pkgrel nemůže být prázdné.

    ==> CHYBA: pkgver nemůže být prázdné.

    ==> CHYBA: není dostupný pro architekturu 'x86_64'.

    Všimněte si, že mnohé balíčky potřebují přidat řádek do PKGBUILD,

    jako arch=('x86_64').

    Unable to read PKGBUILD

    Max avatar 26.12.2012 22:59 Max | skóre: 65 | blog: Max_Devaine
    Rozbalit Rozbalit vše Re: Instalace PacmanXG4 a Yaourt v Arch Linuxu (Linux Bridge)
    Jednak to vypadá, že nemáš definován výchozí editor (to ale nevadí), viz hláška :
    Please add $EDITOR to your environment variables
    
    Takže do "~/.bashrc" stačí u konkrétního uživatele vložit :
    export EDITOR="nano"
    
    Hláška :
    Na zařízení není volné místo
    
    Je snad myslím také velmi jasná, ne?
    Zdar Max
    Měl jsem sen ... :(
    27.12.2012 01:01 historicalmartin
    Rozbalit Rozbalit vše Re: Instalace PacmanXG4 a Yaourt v Arch Linuxu (Linux Bridge)
    Právě že není moc jasné, když mám na disku 15 GB volného místa, přičemž mám jeden oddíl "/"..

    díky Martin
    Max avatar 27.12.2012 01:30 Max | skóre: 65 | blog: Max_Devaine
    Rozbalit Rozbalit vše Re: Instalace PacmanXG4 a Yaourt v Arch Linuxu (Linux Bridge)
    Hlásí to stejnou chybu, i když tam nepíšeš úplný blbosti typu "makepkg" do pole, kde má být jméno textového editoru apod.?
    Zdar Max
    PS: pokud ano, tak by se stejně hodil výpis "df -h"
    Měl jsem sen ... :(
    Max avatar 27.12.2012 01:32 Max | skóre: 65 | blog: Max_Devaine
    Rozbalit Rozbalit vše Re: Instalace PacmanXG4 a Yaourt v Arch Linuxu (Linux Bridge)
    Jinak doufám, že jsi četl komentář výše #12
    Zdar Max
    Měl jsem sen ... :(
    Václav 28.12.2012 11:24 Václav "Darm" Novák | skóre: 26 | blog: Darmovy_kecy | Bechyně / Praha
    Rozbalit Rozbalit vše Re: Instalace PacmanXG4 a Yaourt v Arch Linuxu (Linux Bridge)
    yaourt balí balíky v /tmp/, na který Arch defaultně používá tmpfs (/tmp/ je v RAM)

    Řešení je buď zrušit tmpfs (neradím kvůli výkonu), nebo přesměrovat build do jiného adresáře (odkomentovat v /etc/yaourtrc řádek TMPDIR = a nastavit tam nějakou jinou cestu do které může zapisovat uživatel)
    Cross my heart and hope to fly, stick a cupcake in my eye!
    27.12.2012 08:51 JanM | skóre: 28
    Rozbalit Rozbalit vše Re: Instalace PacmanXG4 a Yaourt v Arch Linuxu (Linux Bridge)
    I přes snahu použít "out-of-the-box" distro byste asi měl alespoň pročíst nějaké wiki stránky, jinak hrozí že náhodným zkoušením neznámých příkazů budete v lepším případě instalovat znovu, v horším příjdete o nějaká data.

    Sekce "nano Usage": https://wiki.archlinux.org/index.php/Nano#nano_Usage

    Sekce "Installing packages": https://wiki.archlinux.org/index.php/Arch_User_Repository#Installing_packages

    Beginner's Guide: https://wiki.archlinux.org/index.php/Beginners'_Guide

    Strýček Google: co hledám site:wiki.archlinux.org

    Man pages: např. "man pacman", byť uznávám, že bez znalosti logiky věci (co je to pacman a k čemu se používá) může být manuálová stránka dost k ničemu. Pak nezbývá, než prohledat wiki.
    27.12.2012 10:28 historicalmartin
    Rozbalit Rozbalit vše Re: Instalace PacmanXG4 a Yaourt v Arch Linuxu (Linux Bridge)
    MilanK, Ano máte pravdu, ale jak jsem již výše uvedl testuji to ve Virtualboxu a případná reinstalace je na pár minut, takže mi žádné riziko nehrozí..

    Max, Zkusím to a dík..
    29.12.2012 16:54 historicalmartin
    Rozbalit Rozbalit vše Re: Instalace PacmanXG4 a Yaourt v Arch Linuxu (Linux Bridge)
    Můžete ještě poradit??

    Podle Maxe sem zkusil obě metody a v obou případech skončím na stejném místě.. "Nelze vyřešit všechny závislosti"

    Vytváří se balíček: pacmanxg4-bin 4.13.10-1 (So pro 29 16:40:40 UTC 2012)

    ==> Kontrola runtime závislostí...

    ==> Chybějící závislosti:

    -> lib32-libx11

    -> lib32-gcc-libs

    ==> Kontrola buildtime závislostí...

    ==> CHYBA: Nelze vyřešit všechny závislosti.

    Jak mám nainstalovat tyto závislosti??

    Je na ně nějaký jednoduchý příkaz, neboť při instalaci přímo těchto pkg balíčků mi vyjde error, protože na nich jsou závislé další závislosti.

    -> lib32-libx11 -> lib32-gcc-libs
    29.12.2012 19:16 historicalmartin
    Rozbalit Rozbalit vše Re: Instalace PacmanXG4 a Yaourt v Arch Linuxu (Linux Bridge)
    Instalace proběhla úspěšně, závislosti jsem instaloval ručně jednu po druhé..

    Po spuštění, mi ale naběhlo pouze holé okno, v angličtině, nezobrazili se v něm ani písmena ani grafická část..

    Napíše mi to "access violation" narušení přístupu

    Jediné co se zobrazí jsou logy..

    Pak mi to ještě mezi "errors" napíše, že všechno OK, jenom "repacman check" napíše "error".. Po chvíli to zamrzlo..

    Také se mi zdá, že nezobrazuje celý obsah AUR..

    V krajním případě budu instalovat přes příkazový řádek, ale zajímá mně, kde se stala chyba..

    Založit nové vláknoNahoru

    Tiskni Sdílej: Linkuj Jaggni to Vybrali.sme.sk Google Del.icio.us Facebook

    ISSN 1214-1267   www.czech-server.cz
    © 1999-2015 Nitemedia s. r. o. Všechna práva vyhrazena.