abclinuxu.cz AbcLinuxu.cz itbiz.cz ITBiz.cz HDmag.cz HDmag.cz abcprace.cz AbcPráce.cz
AbcLinuxu hledá autory!
Inzerujte na AbcPráce.cz od 950 Kč
Rozšířené hledání
×
dnes 17:25 | IT novinky

Do prodeje (Farnell) se dostal jednodeskový počítač Tinker Board (unboxing). Jedná se o konkurenci Raspberry Pi 3 od společnosti Asus. Porovnání (jpg) těchto počítačů například na CNXSoft. Cena Tinker Boardu je 55 £.

Ladislav Hagara | Komentářů: 0
dnes 14:44 | Zajímavý projekt

Byla zveřejněna pravidla hackerské soutěže Pwn2Own 2017, jež proběhne od 15. do 17. března v rámci bezpečnostní konference CanSecWes ve Vancouveru. Soutěžit se bude o více než milion dolarů v pěti kategoriích. Letos se bude útočit i na Ubuntu. Jedná se již o 10. ročník této soutěže.

Ladislav Hagara | Komentářů: 1
dnes 13:33 | Nová verze

Po sedmi měsících vývoje od vydání verze 5.7 byla vydána verze 5.8 (YouTube) toolkitu Qt. Z novinek lze zmínit například Qt Lite pro vestavěná zařízení. Nově jsou plně podporovány moduly Qt Wayland Compositor (YouTube) a Qt SCXML (YouTube). Současně byla vydána verze 4.2.1 integrovaného vývojového prostředí (IDE) Qt Creator.

Ladislav Hagara | Komentářů: 0
dnes 11:52 | Pozvánky

Lednový Prague Containers Meetup se koná ve čtvrtek 26. ledna 2017 od 18:00 v Apiary, Pernerova 49, Praha 8. Přijďte se podívat na přednášky o Enterprise Kubernetes a Jenkins as a code.

little-drunk-jesus | Komentářů: 0
dnes 11:40 | Pozvánky

Program letošního ročníku konference Prague PostgreSQL Developer Days, která se koná již 15. a 16. února 2017 na ČVUT FIT, Thákurova 9, Praha 6, byl dnes zveřejněn. Najdete ho na stránkách konference včetně anotací přednášek a školení. Registrace na konferenci bude otevřena zítra (24. ledna) v brzkých odpoledních hodinách.

TomasVondra | Komentářů: 0
včera 02:20 | Zajímavý článek

David Revoy, autor open source webového komiksu Pepper&Carrot nebo portrétu GNU/Linuxu, upozorňuje na svém blogu, že nový Inkscape 0.92 rozbíjí dokumenty vytvořené v předchozích verzích Inkscape. Problém by měl být vyřešen v Inkscape 0.92.2 [reddit].

Ladislav Hagara | Komentářů: 0
včera 02:02 | Komunita

Øyvind Kolås, hlavní vývojář grafických knihoven GEGL a babl, které využívá grafický program GIMP, žádá o podporu na Patreonu. Díky ní bude moci pracovat na vývoji na plný úvazek. Milník 1000 $, který by stačil na holé přežití, se již téměř podařilo vybrat, dalším cílem je dosažení 2500 $, které mu umožní běžně fungovat ve společnosti.

xkomczax | Komentářů: 12
21.1. 23:54 | Pozvánky

DevConf.cz 2017, již devátý ročník jedné z největších akcí zaměřených na Linux a open source ve střední Evropě, proběhne od pátku 27. ledna do neděle 29. ledna v prostorách Fakulty informačních technologií Vysokého učení technického v Brně. Na programu je celá řada zajímavých přednášek a workshopů. Letos je povinná registrace.

Ladislav Hagara | Komentářů: 0
21.1. 22:11 | Nová verze

Byla vydána verze 1.0.0 emulátoru terminálu Terminology postaveného nad EFL (Enlightenment Foundation Libraries). Přehled novinek v poznámkách k vydání.

Ladislav Hagara | Komentářů: 0
20.1. 17:00 | Nová verze

Byl vydán Docker 1.13. Přehled novinek na YouTube a v poznámkách k vydání na GitHubu. Docker umožňuje běh aplikací v softwarových kontejnerech (Wikipedia).

Ladislav Hagara | Komentářů: 7
Jak se stavíte k trendu ztenčování přenosných zařízení (smartphony, notebooky)?
 (11%)
 (2%)
 (73%)
 (3%)
 (10%)
Celkem 377 hlasů
 Komentářů: 31, poslední dnes 19:19
Rozcestník
Reklama

Dotaz: Ubuntu - nesplněné závislosti

10.10.2014 20:01 miro
Ubuntu - nesplněné závislosti
Přečteno: 1176×
Prosím o radu jak opravit závislosti v Ubuntu 12.04. Výpis terminálu:
root@localhost:~# apt-get upgrade
Čtu seznamy balíků… Hotovo
Vytvářím strom závislostí       
Čtu stavové informace… Hotovo
Pro opravení můžete spustit „apt-get -f install“.
Následující balíky mají nesplněné závislosti:
 linux-generic : Závisí na: linux-image-generic (= 3.2.0.51.61) ale 3.2.0.70.84 je nainstalován
 linux-headers-generic : Závisí na: linux-headers-3.2.0-51-generic ale není nainstalovaný
 linux-headers-generic-pae : Závisí na: linux-headers-3.2.0-51-generic-pae ale není nainstalovaný
E: Nesplněné závislosti. Zkuste použít -f.
root@localhost:~# apt-get -f install
Čtu seznamy balíků… Hotovo
Vytvářím strom závislostí       
Čtu stavové informace… Hotovo
Opravuji závislosti… Hotovo
Následující balíky byly nainstalovány automaticky a již nejsou potřeba:
  linux-headers-3.2.0-45 linux-headers-3.2.0-48 linux-headers-3.2.0-45-generic linux-headers-3.2.0-48-generic
  linux-headers-3.2.0-48-generic-pae linux-headers-3.2.0-45-generic-pae
Pro jejich odstranění použijte „apt-get autoremove“.
Následující extra balíky budou instalovány:
  linux-generic linux-headers-generic linux-headers-generic-pae
Následující balíky budou aktualizovány:
  linux-generic linux-headers-generic linux-headers-generic-pae
3 aktualizováno, 0 nově instalováno, 0 k odstranění a 2 neaktualizováno.
3 instalováno nebo odstraněno pouze částečně.
Potřebuji stáhnout 0 B/6 560 B archivů.
Po této operaci bude na disku použito dalších 0 B.
Chcete pokračovat [Y/n]? y
dpkg: nesplněné závislosti zamezily konfiguraci balíku linux-headers-generic:
 linux-headers-generic závisí na linux-headers-3.2.0-51-generic; avšak:
  Balík linux-headers-3.2.0-51-generic není nainstalován.
dpkg: chyba při zpracovávání linux-headers-generic (--configure):
 problém se závislostmi - nechávám nezkonfigurované
Žádné apport hlášení nebylo vytvořeno, protože již byl dosažen MaxReports
                                                                         dpkg: nesplněné závislosti zamezily konfiguraci balíku linux-generic:
 linux-generic závisí na linux-image-generic (= 3.2.0.51.61); avšak:
  Verze linux-image-generic v systému je 3.2.0.70.84.
 linux-generic závisí na linux-headers-generic (= 3.2.0.51.61); avšak:
  Balík linux-headers-generic zatím není zkonfigurován.
dpkg: chyba při zpracovávání linux-generic (--configure):
 problém se závislostmi - nechávám nezkonfigurované
Žádné apport hlášení nebylo vytvořeno, protože již byl dosažen MaxReports
                                                                         dpkg: nesplněné závislosti zamezily konfiguraci balíku linux-headers-generic-pae:
 linux-headers-generic-pae závisí na linux-headers-3.2.0-51-generic-pae; avšak:
  Balík linux-headers-3.2.0-51-generic-pae není nainstalován.
dpkg: chyba při zpracovávání linux-headers-generic-pae (--configure):
 problém se závislostmi - nechávám nezkonfigurované
Žádné apport hlášení nebylo vytvořeno, protože již byl dosažen MaxReports
                                                                         Při zpracování nastaly chyby:
 linux-headers-generic
 linux-generic
 linux-headers-generic-pae
E: Sub-process /usr/bin/dpkg returned an error code (1)
Chyba sice umožnila updatovat neaktuální balíky (s přepínačem -f), ale při pokusu o nainstalování nového balíku to opět skončí chybou:
root@localhost:~# apt-get -f install traceroute
Čtu seznamy balíků… Hotovo
Vytvářím strom závislostí       
Čtu stavové informace… Hotovo
Pro opravení následujících můžete spustit „apt-get -f install“:
Následující balíky mají nesplněné závislosti:
 linux-generic : Závisí na: linux-image-generic (= 3.2.0.51.61) ale 3.2.0.70.84 se bude instalovat
 linux-headers-generic : Závisí na: linux-headers-3.2.0-51-generic ale nebude se instalovat
 linux-headers-generic-pae : Závisí na: linux-headers-3.2.0-51-generic-pae ale nebude se instalovat
E: Nesplněné závislosti. Zkuste spustit „apt-get -f install“ bez balíků (nebo navrhněte řešení).
Stroj je Thinkpad s Centrinem, které nemá podporu PAE. Mám ho na ssh 250km daleko, takže bych celkem nerad udělal nějakou fatální chybu.

Řešení dotazu:


Odpovědi

Pavel 'TIGER' Růžička avatar 10.10.2014 20:19 Pavel 'TIGER' Růžička | skóre: 38
Rozbalit Rozbalit vše Re: Ubuntu - nesplněné závislosti
A updatoval si nejdříve databázi balíků, před upgradem?
10.10.2014 20:24 miro
Rozbalit Rozbalit vše Re: Ubuntu - nesplněné závislosti
apt-get update byl předtím spuštěn.
Pavel 'TIGER' Růžička avatar 10.10.2014 20:30 Pavel 'TIGER' Růžička | skóre: 38
Rozbalit Rozbalit vše Re: Ubuntu - nesplněné závislosti
A nemáš nějaké přidržené balíky, které se neaktualizují? Já je řeším pomocí apt-get sidt-upgrade (v debianu). Máš tam jen oficiální zdroje, nebo i neoficiální?
Pavel 'TIGER' Růžička avatar 10.10.2014 20:31 Pavel 'TIGER' Růžička | skóre: 38
Rozbalit Rozbalit vše Re: Ubuntu - nesplněné závislosti
oprava: apt-get dist-upgrade
10.10.2014 20:50 miro
Rozbalit Rozbalit vše Re: Ubuntu - nesplněné závislosti
Přidržené balíky tam byly (musely se vybrat nějak automaticky při instalaci), apt-get -f dist-upgrade bohužel nepomohlo:
root@localhost:~# apt-get -f dist-upgrade
Čtu seznamy balíků… Hotovo
Vytvářím strom závislostí       
Čtu stavové informace… Hotovo
Opravuji závislosti… Hotovo
Propočítávám aktualizaci… Hotovo
Následující NOVÉ balíky budou nainstalovány:
  libgnome2-bin python-lockfile
Následující balíky budou aktualizovány:
  duplicity libgnome2-0 linux-generic linux-headers-generic linux-headers-generic-pae
5 aktualizováno, 2 nově instalováno, 0 k odstranění a 0 neaktualizováno.
3 instalováno nebo odstraněno pouze částečně.
Potřebuji stáhnout 263 kB/269 kB archivů.
Po této operaci bude na disku použito dalších 520 kB.
Chcete pokračovat [Y/n]? y
Mám:1 http://cz.archive.ubuntu.com/ubuntu/ precise-updates/main libgnome2-bin i386 2.32.1-2ubuntu1.1 [15,7 kB]
Mám:2 http://cz.archive.ubuntu.com/ubuntu/ precise-updates/main libgnome2-0 i386 2.32.1-2ubuntu1.1 [51,6 kB]
Mám:3 http://cz.archive.ubuntu.com/ubuntu/ precise/main python-lockfile all 1:0.8-2ubuntu1 [8 714 B]
Mám:4 http://cz.archive.ubuntu.com/ubuntu/ precise-updates/main duplicity i386 0.6.18-0ubuntu3.5 [187 kB]
Staženo 263 kB za 0s (1 117 kB/s)
Vybírám dosud nevybraný balík libgnome2-bin.
(Čtu databázi … nyní je nainstalováno 309419 souborů a adresářů.)
Rozbaluji libgnome2-bin (z …/libgnome2-bin_2.32.1-2ubuntu1.1_i386.deb) …
Nahrazuji soubory ve starém balíku libgnome2-0 …
Připravuji nahrazení libgnome2-0 2.32.1-2ubuntu1 (pomocí …/libgnome2-0_2.32.1-2ubuntu1.1_i386.deb) …
Rozbaluji náhradu libgnome2-0 …
Vybírám dosud nevybraný balík python-lockfile.
Rozbaluji python-lockfile (z …/python-lockfile_1%3a0.8-2ubuntu1_all.deb) …
Připravuji nahrazení duplicity 0.6.18-0ubuntu3.1 (pomocí …/duplicity_0.6.18-0ubuntu3.5_i386.deb) …
Rozbaluji náhradu duplicity …
Zpracování spouštěčů pro balík man-db …
dpkg: nesplněné závislosti zamezily konfiguraci balíku linux-headers-generic:
 linux-headers-generic závisí na linux-headers-3.2.0-51-generic; avšak:
  Balík linux-headers-3.2.0-51-generic není nainstalován.
dpkg: chyba při zpracovávání linux-headers-generic (--configure):
 problém se závislostmi - nechávám nezkonfigurované
Žádné apport hlášení nebylo vytvořeno, protože chybová hláška naznačuje, že se jedná o chybu způsobenou předchozí chybou.
                                                                                                                         dpkg: nesplněné závislosti zamezily konfiguraci balíku linux-generic:
 linux-generic závisí na linux-image-generic (= 3.2.0.51.61); avšak:
  Verze linux-image-generic v systému je 3.2.0.70.84.
 linux-generic závisí na linux-headers-generic (= 3.2.0.51.61); avšak:
  Balík linux-headers-generic zatím není zkonfigurován.
dpkg: chyba při zpracovávání linux-generic (--configure):
 problém se závislostmi - nechávám nezkonfigurované
dpkg: nesplněné závislosti zamezily konfiguraci balíku linux-headers-generic-pae:Žádné apport hlášení nebylo vytvořeno, protože chybová hláška naznačuje, že se jedná o chybu způsobenou předchozí chybou.

 linux-headers-generic-pae závisí na linux-headers-3.2.0-51-generic-pae; avšak:
  Balík linux-headers-3.2.0-51-generic-pae není nainstalován.
dpkg: chyba při zpracovávání linux-headers-generic-pae (--configure):
 problém se závislostmi - nechávám nezkonfigurované
Nastavuji balík python-lockfile (1:0.8-2ubuntu1) …Žádné apport hlášení nebylo vytvořeno, protože chybová hláška naznačuje, že se jedná o chybu způsobenou předchozí chybou.

Nastavuji balík duplicity (0.6.18-0ubuntu3.5) …
Nastavuji balík libgnome2-bin (2.32.1-2ubuntu1.1) …
Nastavuji balík libgnome2-0 (2.32.1-2ubuntu1.1) …
Zpracování spouštěčů pro balík libc-bin …
ldconfig deferred processing now taking place
Při zpracování nastaly chyby:
 linux-headers-generic
 linux-generic
 linux-headers-generic-pae
E: Sub-process /usr/bin/dpkg returned an error code (1)
Jendа avatar 10.10.2014 20:27 Jendа | skóre: 73 | blog: Výlevníček | JO70FB
Rozbalit Rozbalit vše Re: Ubuntu - nesplněné závislosti
Většinou prostě ty rozbité balíky odstraním (buď přes apt, nebo přes dpkg) a nainstaluju znova, pomůže to.
„To jsem nedávno zjistil, že naše televize jde ovládat po síti. Docela mě to překvapilo.“ „Jo? A kdo vám ji ovládal?“
Pavel 'TIGER' Růžička avatar 10.10.2014 20:32 Pavel 'TIGER' Růžička | skóre: 38
Rozbalit Rozbalit vše Re: Ubuntu - nesplněné závislosti
No nevím, jestli v tomto případě by to bylo vhodné, když se jedná o jádro a notebook je daleko ....
Jendа avatar 10.10.2014 20:35 Jendа | skóre: 73 | blog: Výlevníček | JO70FB
Rozbalit Rozbalit vše Re: Ubuntu - nesplněné závislosti
Tohle jsou jenom metabalíky.
„To jsem nedávno zjistil, že naše televize jde ovládat po síti. Docela mě to překvapilo.“ „Jo? A kdo vám ji ovládal?“
Pavel 'TIGER' Růžička avatar 10.10.2014 20:41 Pavel 'TIGER' Růžička | skóre: 38
Rozbalit Rozbalit vše Re: Ubuntu - nesplněné závislosti
Jo jo, už taky blbě koukám. Měly by jít odebrat a nic jiného sebou nebrat, takže by to tak šlo řešit. Ovšem, kdyby náhodou chtěli sebou něco vzít, tak tu akci zruš a napiš to sem, než bys to provedl.
10.10.2014 20:59 miro
Rozbalit Rozbalit vše Re: Ubuntu - nesplněné závislosti
Proběhlo to v pohodě, brát sebou to nechtělo nic, vypadá to, že se systém vzpamatoval. Díky moc za pomoc.
10.10.2014 20:58 miro
Rozbalit Rozbalit vše Re: Ubuntu - nesplněné závislosti
Jak primitivní, ale jak účinné! :-)) Díky moc, problém vyřešen.

Založit nové vláknoNahoru

Tiskni Sdílej: Linkuj Jaggni to Vybrali.sme.sk Google Del.icio.us Facebook

ISSN 1214-1267   www.czech-server.cz
© 1999-2015 Nitemedia s. r. o. Všechna práva vyhrazena.