abclinuxu.cz AbcLinuxu.cz itbiz.cz ITBiz.cz HDmag.cz HDmag.cz abcprace.cz AbcPráce.cz
AbcLinuxu hledá autory!
Inzerujte na AbcPráce.cz od 950 Kč
Rozšířené hledání
×
včera 23:33 | Zajímavý software

Byl vydán ShellCheck ve verzi 0.4.6. Jedná se o nástroj pro statickou analýzu shellových skriptů. Shellové skripty lze analyzovat na webové stránce ShellChecku, v terminálu nebo přímo z textových editorů. Příklady kódů, na které analýza upozorňuje a doporučuje je přepsat. ShellCheck je naprogramován v programovacím jazyce Haskell. Zdrojové kódy jsou k dispozici na GitHubu pod licencí GPLv3.

Ladislav Hagara | Komentářů: 0
včera 23:33 | Pozvánky

Czech JBoss User Group zve na setkání JBUG v Brně, které se koná ve středu 5. dubna 2017 v prostorách Fakulty informatiky Masarykovy univerzity v místnosti A318 od 18:00. Přednáší Pavol Loffay na téma Distributed Tracing and OpenTracing in Microservice Architecture.

… více »
mjedlick | Komentářů: 0
včera 11:33 | Zajímavý článek

Národní centrum kybernetické bezpečnosti (NCKB) vypracovalo (pdf) 26 podrobných bezpečnostních doporučení pro síťové správce. Tato doporučení jsou nastavena tak, aby je bylo možné aplikovat v každé instituci. Jsou rozdělena na tři základní části: bezpečnost infrastruktury, bezpečnost stanic a serverů a bezpečnost uživatelů.

Ladislav Hagara | Komentářů: 9
včera 05:55 | Komunita

Prezident Nadace pro svobodný software (FSF) Richard M. Stallman vyhlásil na slavnostním ceremoniálu v rámci konference LibrePlanet 2017 vítěze Free Software Awards za rok 2016. Ocenění za společenský přínos získal SecureDrop (Wikipedie). Za rozvoj svobodného softwaru byl oceněn Alexandre Oliva (Wikipedie).

Ladislav Hagara | Komentářů: 0
včera 04:44 | Nová verze

Byla vydána verze 0.7.0 debugovacího nástroje cgdb. Mezi novinky patří například zvýrazňování syntaxe jazyka Rust. Podrobnosti v poznámkách o vydání.

Neel | Komentářů: 0
25.3. 22:00 | Komunita

Portál Stack Overflow po roce opět vyzpovídal své uživatele, jedná se především o vývojáře softwaru, a zveřejnil (podcast) detailní výsledky průzkumu. Průzkumu se letos zúčastnilo více než 64 tisíc vývojářů. Jejich nejmilovanější platformou je linuxový desktop. Ten je také druhou nejpoužívanější platformou vývojářů.

Ladislav Hagara | Komentářů: 7
24.3. 11:55 | Komunita

Vývojový tým OpenSSL ve spolupráci s iniciativou Core Infrastructure konsorcia Linux Foundation spustil proces přelicencování této kryptografické knihovny ze současné licence na licenci Apache Licence v 2.0 (ASLv2). Nová licence usnadní začleňování OpenSSL do dalších svobodných a open source projektů. Všichni dosavadní vývojáři OpenSSL (Authors) obdrží v následujících dnech email s prosbou o souhlas se změnou licence.

Ladislav Hagara | Komentářů: 32
24.3. 01:11 | Komunita

Před třemi týdny Mozilla.cz představila projekt Photon, jehož cílem je návrh a implementace nového vzhledu Firefoxu. Včera zveřejnila první náhled vzhledu Photon. Práce na projektu Photon jsou rozděleny do pěti týmů, které celkem čítají 19 lidí. Zaměřují se na zlepšení prvního spuštění Firefoxu a zaujetí nových uživatelů, celkovou úpravu vzhledu, zlepšení animací, zrychlení odezvy uživatelského rozhraní a také upravení nabídek. Vývoj lze sledovat v Bugzille.

Ladislav Hagara | Komentářů: 50
23.3. 20:00 | Komunita

OneDrive pro firmy je již ve webových prohlížečích na Linuxu stejně rychlý jako na Windows. Microsoft opravil chybu z listopadu loňského roku. OneDrive pro firmy běžel na Linuxu mnohem pomaleji než na Windows. V popisu chyby bylo uvedeno, že stačilo v prohlížeči na Linuxu nastavit v user-agentu Windows a vše se zrychlilo. Odpovědí Microsoftu bylo (Internet Archive: Wayback Machine), že Linux není podporován. Po bouřlivých diskusích na redditu i Hacker News byla chyba nalezena a opravena.

Ladislav Hagara | Komentářů: 9
23.3. 19:00 | Zajímavý projekt

Byla vyhlášena soutěž Hackaday Prize 2017. Soutěž je určena vývojářům open source hardwaru. Pro výherce je připraveno celkově 250 tisíc dolarů. Každý ze 120 finalistů získá tisíc dolarů. Nejlepší pak navíc 50, 30, 20, 15, 10 a 5 tisíc dolarů. Jedná se již o čtvrtý ročník soutěže. V roce 2014 zvítězil projekt globální sítě open source pozemních satelitních stanic SatNOGS. V roce 2015 zvítězil open source systém pro řízení elektrických invalidních vozíků pohybem očí Eyedriveomatic. V roce 2016 zvítězil modulární robot Dtto.

Ladislav Hagara | Komentářů: 0
Jak se stavíte k trendu ztenčování přenosných zařízení (smartphony, notebooky)?
 (14%)
 (2%)
 (71%)
 (3%)
 (10%)
Celkem 947 hlasů
 Komentářů: 72, poslední 1.3. 11:16
    Rozcestník

    Dotaz: CISCO ling aggregation nefinguje

    15.1.2015 11:10 dotaz
    CISCO ling aggregation nefinguje
    Přečteno: 289×
    Zdravim,
    potreboval bych poradit, snazim se udelat bonding ze 2 stoju XXX, YYY, kazdy pripojeny 2 opt.kabely do CISCO (nexus rada 3000). Ale podle iperfu stale dostavam 10G rychlost, ac bych cekal 20G. Neporadite co je v konfiguraci spatne?
    CISCO CONFIG:
    interface port-channel1
      description xxx-linkagr
      switchport mode trunk
      switchport trunk allowed vlan 2
      flowcontrol receive on
      flowcontrol send on
    
    interface port-channel2
      description yyy-linkagr
      switchport mode trunk
      switchport trunk allowed vlan 2
      flowcontrol receive on
      flowcontrol send on
    
    ------------------------------------
    
    interface Ethernet1/45
      description xxx-bond1
      switchport mode trunk
      switchport trunk allowed vlan 2
      flowcontrol receive on
      flowcontrol send on
      channel-group 1 mode active
      no shutdown
    
    interface Ethernet1/46
      description xxx-bond2
      switchport mode trunk
      switchport trunk allowed vlan 2
      flowcontrol receive on
      flowcontrol send on
      channel-group 1 mode active
      no shutdown
    
    interface Ethernet1/47
      description yyy-bond1
      switchport mode trunk
      switchport trunk allowed vlan 2
      flowcontrol receive on
      flowcontrol send on
      channel-group 2 mode active
      no shutdown
    
    interface Ethernet1/48
      description yyy-bond2
      switchport mode trunk
      switchport trunk allowed vlan 2
      flowcontrol receive on
      flowcontrol send on
      channel-group 2 mode active
      no shutdown
    
    BONDING NA STROJICH:
    XXX:
    cat /proc/net/bonding/bond0
    Ethernet Channel Bonding Driver: v3.6.0 (September 26, 2009)
    
    Bonding Mode: IEEE 802.3ad Dynamic link aggregation
    Transmit Hash Policy: layer3+4 (1)
    MII Status: up
    MII Polling Interval (ms): 200
    Up Delay (ms): 0
    Down Delay (ms): 0
    
    802.3ad info
    LACP rate: slow
    Aggregator selection policy (ad_select): stable
    Active Aggregator Info:
    	Aggregator ID: 7
    	Number of ports: 2
    	Actor Key: 33
    	Partner Key: 32768
    	Partner Mac Address: f0:7f:06:84:2b:81
    
    Slave Interface: eth2
    MII Status: up
    Speed: 10000 Mbps
    Duplex: full
    Link Failure Count: 1
    Permanent HW addr: 0c:c4:7a:1e:3e:02
    Aggregator ID: 7
    Slave queue ID: 0
    
    Slave Interface: eth3
    MII Status: up
    Speed: 10000 Mbps
    Duplex: full
    Link Failure Count: 1
    Permanent HW addr: 0c:c4:7a:1e:3e:03
    Aggregator ID: 7
    Slave queue ID: 0
    
    
    
    YYY:
    cat /proc/net/bonding/bond0
    Ethernet Channel Bonding Driver: v3.6.0 (September 26, 2009)
    
    Bonding Mode: IEEE 802.3ad Dynamic link aggregation
    Transmit Hash Policy: layer2 (0)
    MII Status: up
    MII Polling Interval (ms): 200
    Up Delay (ms): 0
    Down Delay (ms): 0
    
    802.3ad info
    LACP rate: slow
    Aggregator selection policy (ad_select): stable
    Active Aggregator Info:
    	Aggregator ID: 3
    	Number of ports: 2
    	Actor Key: 33
    	Partner Key: 1
    	Partner Mac Address: f0:7f:06:84:2b:81
    
    Slave Interface: eth2
    MII Status: up
    Speed: 10000 Mbps
    Duplex: full
    Link Failure Count: 1
    Permanent HW addr: 0c:c4:7a:1e:0a:2c
    Aggregator ID: 3
    Slave queue ID: 0
    
    Slave Interface: eth3
    MII Status: up
    Speed: 10000 Mbps
    Duplex: full
    Link Failure Count: 1
    Permanent HW addr: 0c:c4:7a:1e:0a:2d
    Aggregator ID: 3
    Slave queue ID: 0
    
    IPERF:
    YYY:
    iperf -s -p 12345
    ------------------------------------------------------------
    Server listening on TCP port 12345
    TCP window size: 85.3 KByte (default)
    ------------------------------------------------------------
    [  4] local 147.xxx.yyy.zzz port 12345 connected with 147.xxx.yyy.zzz port 57091
    [ ID] Interval       Transfer     Bandwidth
    [  4]  0.0-60.0 sec  65.6 GBytes  9.39 Gbits/sec
    
    
    XXX:
    iperf -c yyy -p 12345 -t 60
    ------------------------------------------------------------
    Client connecting to yyy, TCP port 12345
    TCP window size: 85.3 KByte (default)
    ------------------------------------------------------------
    [  3] local 147.xxx.yyy.zzz port 57091 connected with 147.xxx.yyy.zzz port 12345
    [ ID] Interval       Transfer     Bandwidth
    [  3]  0.0-60.0 sec  65.6 GBytes  9.39 Gbits/sec
    

    Řešení dotazu:


    Odpovědi

    15.1.2015 11:48 rpajik | skóre: 18 | blog: rpajikuv_blog
    Rozbalit Rozbalit vše Re: CISCO ling aggregation nefinguje
    V jednom TCP spojeni dosahnete rychlosti maximalne jednoho portu, takze ten test iperfem neni relevantni.
    15.1.2015 11:53 nelson | skóre: 16 | blog: jakesi_cosi
    Rozbalit Rozbalit vše Re: CISCO ling aggregation nefinguje
    Řekl bych, že propustnost tohoto bondu je 2x10Gbps - při dvou různých připojeních je možné dosáhnout v součtu 20Gbps, nikoli 20Gbps na jeden přenos.
    15.1.2015 11:55 hermelin | skóre: 22
    Rozbalit Rozbalit vše Re: CISCO ling aggregation nefinguje
    Ale takhle LACP preci nefunguje. Neumi udelat z 2x10GB 20GB port vuci jinemu stroji. Kdyz zkusis iperf ze dvou stroju soucasne na treti stroj tak pak by oba meli jet 10GB protoze LACP rozlozi zatez z ruznych klientu pres ruzna rozhrani a na serveru se vyuziji obe sitovky na max. Ale aby z jednoho PC slo diky LACP 20GB na druhy tak to nejde. Tady by to slo udelat pouze tak ze bys nemel ty sitovky v bondu ale normalne klasicky kazda zvlast a rozlozil by si zatez napr tim ze by na kazde sitovce bezela jina sluzba apod.
    15.1.2015 12:01 dotaz
    Rozbalit Rozbalit vše Re: CISCO ling aggregation nefinguje
    aha, diky
    15.1.2015 20:59 Ivan
    Rozbalit Rozbalit vše Re: CISCO ling aggregation nefinguje
    nejsem si jistej, ale mozna by to slo. implicitne se bere zdrojova a cilova MAC adreasa packetu, z toho se udela hash a z toho se urci kterym dratem to potece. LACP se da pouzit i na vyssi vrstve, pak - myslim - se hashuje i cilo portu. zalazi to jen na volbe hashovaciho algoritmu.

    Řešení 1× (BigWrigley)
    16.1.2015 07:26 Michal Kubeček | skóre: 71 | Luštěnice
    Rozbalit Rozbalit vše Re: CISCO ling aggregation nefinguje
    S xmit_hash_policy nastavenou na layer3+4 opravdu půjde rozkládat i provoz mezi jednou dvojicí adres, ale pořád jen v případě, že to bude více než jedno spojení.
    16.1.2015 11:34 dotaz
    Rozbalit Rozbalit vše Re: CISCO ling aggregation nefinguje
    Nastavil jsem to xmit_hash_policy tak jsak jste psal, pustil 2 paralelni iperfy na ruznych portech, kazdy bezi cca 9.90 Gbits/sec. Dekuji

    Založit nové vláknoNahoru

    Tiskni Sdílej: Linkuj Jaggni to Vybrali.sme.sk Google Del.icio.us Facebook

    ISSN 1214-1267   www.czech-server.cz
    © 1999-2015 Nitemedia s. r. o. Všechna práva vyhrazena.