abclinuxu.cz AbcLinuxu.cz itbiz.cz ITBiz.cz HDmag.cz HDmag.cz abcprace.cz AbcPráce.cz
AbcLinuxu hledá autory!
Inzerujte na AbcPráce.cz od 950 Kč
Rozšířené hledání
×
dnes 11:33 | Zajímavý článek

Národní centrum kybernetické bezpečnosti (NCKB) vypracovalo (pdf) 26 podrobných bezpečnostních doporučení pro síťové správce. Tato doporučení jsou nastavena tak, aby je bylo možné aplikovat v každé instituci. Jsou rozdělena na tři základní části: bezpečnost infrastruktury, bezpečnost stanic a serverů a bezpečnost uživatelů.

Ladislav Hagara | Komentářů: 1
dnes 05:55 | Komunita

Prezident Nadace pro svobodný software (FSF) Richard M. Stallman vyhlásil na slavnostním ceremoniálu v rámci konference LibrePlanet 2017 vítěze Free Software Awards za rok 2016. Ocenění za společenský přínos získal SecureDrop (Wikipedie). Za rozvoj svobodného softwaru byl oceněn Alexandre Oliva (Wikipedie).

Ladislav Hagara | Komentářů: 0
dnes 04:44 | Nová verze

Byla vydána verze 0.7.0 debugovacího nástroje cgdb. Mezi novinky patří například zvýrazňování syntaxe jazyka Rust. Podrobnosti v poznámkách o vydání.

Neel | Komentářů: 0
25.3. 22:00 | Komunita

Portál Stack Overflow po roce opět vyzpovídal své uživatele, jedná se především o vývojáře softwaru, a zveřejnil (podcast) detailní výsledky průzkumu. Průzkumu se letos zúčastnilo více než 64 tisíc vývojářů. Jejich nejmilovanější platformou je linuxový desktop. Ten je také druhou nejpoužívanější platformou vývojářů.

Ladislav Hagara | Komentářů: 5
24.3. 11:55 | Komunita

Vývojový tým OpenSSL ve spolupráci s iniciativou Core Infrastructure konsorcia Linux Foundation spustil proces přelicencování této kryptografické knihovny ze současné licence na licenci Apache Licence v 2.0 (ASLv2). Nová licence usnadní začleňování OpenSSL do dalších svobodných a open source projektů. Všichni dosavadní vývojáři OpenSSL (Authors) obdrží v následujících dnech email s prosbou o souhlas se změnou licence.

Ladislav Hagara | Komentářů: 24
24.3. 01:11 | Komunita

Před třemi týdny Mozilla.cz představila projekt Photon, jehož cílem je návrh a implementace nového vzhledu Firefoxu. Včera zveřejnila první náhled vzhledu Photon. Práce na projektu Photon jsou rozděleny do pěti týmů, které celkem čítají 19 lidí. Zaměřují se na zlepšení prvního spuštění Firefoxu a zaujetí nových uživatelů, celkovou úpravu vzhledu, zlepšení animací, zrychlení odezvy uživatelského rozhraní a také upravení nabídek. Vývoj lze sledovat v Bugzille.

Ladislav Hagara | Komentářů: 44
23.3. 20:00 | Komunita

OneDrive pro firmy je již ve webových prohlížečích na Linuxu stejně rychlý jako na Windows. Microsoft opravil chybu z listopadu loňského roku. OneDrive pro firmy běžel na Linuxu mnohem pomaleji než na Windows. V popisu chyby bylo uvedeno, že stačilo v prohlížeči na Linuxu nastavit v user-agentu Windows a vše se zrychlilo. Odpovědí Microsoftu bylo (Internet Archive: Wayback Machine), že Linux není podporován. Po bouřlivých diskusích na redditu i Hacker News byla chyba nalezena a opravena.

Ladislav Hagara | Komentářů: 6
23.3. 19:00 | Zajímavý projekt

Byla vyhlášena soutěž Hackaday Prize 2017. Soutěž je určena vývojářům open source hardwaru. Pro výherce je připraveno celkově 250 tisíc dolarů. Každý ze 120 finalistů získá tisíc dolarů. Nejlepší pak navíc 50, 30, 20, 15, 10 a 5 tisíc dolarů. Jedná se již o čtvrtý ročník soutěže. V roce 2014 zvítězil projekt globální sítě open source pozemních satelitních stanic SatNOGS. V roce 2015 zvítězil open source systém pro řízení elektrických invalidních vozíků pohybem očí Eyedriveomatic. V roce 2016 zvítězil modulární robot Dtto.

Ladislav Hagara | Komentářů: 0
23.3. 15:00 | Bezpečnostní upozornění

Byla vydána Samba ve verzích 4.6.1, 4.5.7 a 4.4.12. Řešen je bezpečnostní problém CVE-2017-2619. Pomocí symbolických odkazů a souběhu (symlink race) lze "teoreticky" získat přístup k souborům, které nejsou sdíleny. Linuxové distribuce jsou postupně aktualizovány (Debian).

Ladislav Hagara | Komentářů: 0
23.3. 07:43 | Nová verze

Na Steamu se objevil port hry Arma: Cold War Assault (Operation Flashpoint) pro Mac a Linux. … více »

creon | Komentářů: 30
Jak se stavíte k trendu ztenčování přenosných zařízení (smartphony, notebooky)?
 (14%)
 (2%)
 (72%)
 (3%)
 (10%)
Celkem 941 hlasů
 Komentářů: 72, poslední 1.3. 11:16
    Rozcestník

    Dotaz: openWRT

    22.3.2015 21:09 lertimir | skóre: 59 | blog: Par_slov
    openWRT
    Přečteno: 468×
    A ještě jeden problém s openWRT a to, že mi nechodí pakety mezi wifi a lan. Naklikal jsem konfiguraci v luci a v /etc/config/wireless je
    config wifi-iface
            option device 'radio0'
            option mode 'ap'
            option encryption 'psk2+ccmp'
            option key 'xxxxx'
            option network 'lan'
            option ssid 'AAAA'
    
    
    a v /etc/config/network je
    config interface 'lan'
            option force_link '1'
            option type 'bridge'
            option proto 'static'
            option ip6assign '60'
            option _orig_ifname 'eth0.1 wlan0 wlan1'
            option _orig_bridge 'true'
            option ipaddr '10.0.0.140'
            option ifname 'eth0.1'
            option netmask '255.255.0.0'
    
    
    Mělo by odpovídat i dokumentaci, ale obě sítě wifi i lan se dostanou do vnějšího světa, ale mezi sebou ne.

    Řešení dotazu:


    Odpovědi

    22.3.2015 22:07 NN
    Rozbalit Rozbalit vše Re: openWRT
    Pokud spatne nevidim tak jsou rozhrani premostene. Hm.. ty pakety ani nevylezou, nebo vylezou, ale uz se nevrati odpoved?
    23.3.2015 08:52 Petr Šobáň | skóre: 79 | blog: soban | Olomouc
    Rozbalit Rozbalit vše Re: openWRT
    Tady taky nechápu prostě u mě na první zapnutí to funguje OK.

    Jak jsem říkal minule nebude zrada v tom že na routeru se snažíš mít síť 10.0.0.140, ale modem od O2 i když je přepnutý do brigde má pořád 10.0.0.138? A pak možná hapruje něco - nevím co když nepošleš komplet nastavení.

    Nebude jednoduší to resetnout do default a pouze tam pro pokusy nastavit PPPoE k modemu a další wifi a nechat IP routeru prozatím na default jak se to bude chovat?

    PS. Jinak máš správně přepnutý modem do bridge a na routeru nastavené PPPoE?
    23.3.2015 12:05 lertimir | skóre: 59 | blog: Par_slov
    Rozbalit Rozbalit vše Re: openWRT
    k PS. Vnější linka funguje. modem je v bridgi, openwrt má PPPoE a přistupové udaje k vytáčené lince. to je v pořádku.

    Změna na default. no je to možné, ale bylo by s tím dost práce. v síti je server, který má NFS,sambu, cups (a backuppc), (dříve také dhcp a dns) a celkem cca 9 stanic, pár win většina lin a nfs/samba shary a tiskárny jsou na nich nakonfigurované, někde i na přímé IP. Musel bych to vše projít, a někdy jsou do notebooky, které manželka a děti tahají s sebou. Takže jsem síť adresně dělal stejnou jako předtím. Přepnutím do default openWRT odstřihnu vnitřní nastavení.

    A víš to jistě, že ten modem má IP po přepnutí do bridge? (comtrend) když jsem ho nastavoval do bridge modu v konfiguraci internet-comtrend-ethernet-pocitač tak jsem po přepnutí do bridge se už k němu nijak nedostal.

    A i když by tedy adresu měl, nějak nerozumím, jak by existence adresy na vnějším rozhraní měla ovlivnit chování routeru na interním rozhraní. Nicméně beru to v potaz, že tam nějaká vazba může být. Když doma na síti nikdo nebude pracovat (což je tak od 1 do 6 zkusím se k modemu dostat a změnit mu adresu. myslel jsem že ji ted nemá. původně byla stejná jako ted u routeru 10.0.0.140. Jak se dostanu domů pošlu úplnější konfigurace
    24.3.2015 00:20 Petr Šobáň | skóre: 79 | blog: soban | Olomouc
    Rozbalit Rozbalit vše Re: openWRT
    Je to jednoduché prostě si na noteboku nastav IP 10.0.0.1 a kabel píchni do lan konektoru na modemu a můžeš se na něj klidně dostat - jak jinak by jsi nastavoval parametry modemu po přepnutí do bridge (nějaké věci se udělají samy - vypne se DHCP server na modemu některé ne)

    Tak prostě skus modemu změnit IP na nějakou jinou 192.168.100.1 co to udělá.

    A proč jsi se na něj po přepnutí do bridge nedostal jednoduše protože se vypnul DHCP server, ale pokud si nastavíš IP tak se tam dostaneš.

    Jinak taky mrkni na PPPoE jakou IP dostáváš (pokud nemáš veřejnou IPv4) protože neveřejné od O2 taky používají 10.x.y.z z hlavy jakou IP nevím. (Pokud bude zájem můžu odpoledne mrknout.)
    24.3.2015 07:48 lertimir | skóre: 59 | blog: Par_slov
    Rozbalit Rozbalit vše Re: openWRT
    Je to sice původně O2 ADSL modem, ale ne O2 síť, takže veřejnou adresu mám. A to kdy jsem se na modem nedostal byly už situace, kdy na něm žádny DHCP neběžel. pouze (viz schema ve vedlejsím dotazu, dělal jen router/nat) statické adresy na počítači a na modemu. Přesto jsem se na něj nedostal.
    24.3.2015 07:49 lertimir | skóre: 59 | blog: Par_slov
    Rozbalit Rozbalit vše Re: openWRT
    a jo tak schema je v tomhle dotazu.
    24.3.2015 10:43 Petr Šobáň | skóre: 79 | blog: soban | Olomouc
    Rozbalit Rozbalit vše Re: openWRT
    A změnil si tomu modemu tedy IP?

    Nevím jak se totiž bude chovat OpenWRT když router OpenWRT bude mít 10.0.0.140 a tu stejnou bude mít i modem takže se bude vyskytovat stejná IP i na wan konektoru a co to udělá s ARP tabulkou.

    Jinak v konfiguraci mám:
    config interface 'lan'
    	option ifname 'eth0.1'
    	option force_link '1'
    	option type 'bridge'
    	option proto 'static'
    	option ipaddr '192.168.1.1'
    	option netmask '255.255.255.0'
    	option ip6assign '60'
    
    Máš v konfiguraci lan v bridge zaškrtnuté i ty wifi?
    26.3.2015 02:18 lertimir | skóre: 59 | blog: Par_slov
    Rozbalit Rozbalit vše Re: openWRT
    Díky za rady. Problém je vyřešen a byl jinde než jsem dlouho hledal. K routeru byl jako hlavní switch domu připojen starší managovatelný switch Cisco. Do schématu jsem ho nezahrnul, protože jsem jej bral jako transparentní zařízení. Do openWRT jsem doinstaloval tcpdump a začal monitorovat, co se děje (nebo neděje) v síti. Skrz openWRT pakety vždy prošly, ale na switchi se zadrhly. Po mnoha zkouškách a testech jsem vypsal přiřazení portů na switchi.
       1    30b5.c2xx.xxxx    STATIC      Gi0/1 
       1    50e5.49xx.xxxx    STATIC      Gi0/2 
       1    50e5.49xx.xxxx    DYNAMIC     Fa0/21
       1    f46d.04xx.xxxx    DYNAMIC     Fa0/14AC 
    
    A to co mne vyděsilo byla položka "STATIC" u gigabitových portů. MAC adresa u portu je skutečně adresa routeru a je tam jediná, tedy nejsou tam už MAC adresy systémů z wifi. A skutečně přehození spoje (switch-router) z gigabitového portu na Fast se ve výpisu příslušného portu změnilo se na "DYNAMIC" a na něm jsou všechny adresy z wifi a konektivita, každý s každým je. Uf. Do té chvíle na Gi0/1 a 2 byly jen server a hlavní pracovní stanice tedy jediné MAC a to bylo OK. (musím si trochu více přečíst dokumentaci k cisco switchum.

    (Na bridgi je IP pořad nezměněné a evidentně jeho hodnota nemá na toto vliv.)
    26.3.2015 23:03 lertimir | skóre: 59 | blog: Par_slov
    Rozbalit Rozbalit vše Re: openWRT
    Už jsem i zjistil, čím jsem si ten problém způsobil. Na gigabitových portech byl původně hlavní bytový server a hlavní pracovní stanice. A já jsem si kdysi před lety v grafickém rozhraní switche nakliknul z původní role "none" do role "desktop". (myslel jsem si tuším tehdy, že třeba bude optimalizovat řazení paketů, ale to, že změní Dynamické na statické přiřazení MAC adres mne nenapadlo)

    Založit nové vláknoNahoru

    Tiskni Sdílej: Linkuj Jaggni to Vybrali.sme.sk Google Del.icio.us Facebook

    ISSN 1214-1267   www.czech-server.cz
    © 1999-2015 Nitemedia s. r. o. Všechna práva vyhrazena.