abclinuxu.cz AbcLinuxu.cz itbiz.cz ITBiz.cz HDmag.cz HDmag.cz abcprace.cz AbcPráce.cz
AbcLinuxu hledá autory!
Inzerujte na AbcPráce.cz od 950 Kč
Rozšířené hledání
×

dnes 01:22 | Zajímavý článek

Julia Evans pomocí svých kreslených obrázků proniká do Linuxu a informačních technologií. Vedle ucelených zinů publikuje také jednotlivé kreslené obrázky (RSS).

Ladislav Hagara | Komentářů: 5
včera 13:22 | Zajímavý software

Jordi Sanfeliu vydal verzi 1.0.0 svého unixového jádra Fiwix (Wikipedie) určeného také pro výuku operačních systémů. Dle článku na OSNews na něm začal pracovat již před více než dvaceti lety. Zdrojové kódy jsou k dispozici na GitHubu pod licencí MIT. Stáhnout a vyzkoušet lze živou disketu nebo CD s GNU/Fiwixem.

Ladislav Hagara | Komentářů: 4
včera 06:00 | Nová verze

Byla vydána nová verze 10.7 open source alternativy GitHubu, tj. softwarového nástroje s webovým rozhraním umožňujícího spolupráci na zdrojových kódech, GitLab (Wikipedie). Představení nových vlastností v příspěvku na blogu. Vývojáři GitLabu zdůrazňují Web IDE (YouTube) a SAST (Static Application Security Testing) pro Go a C/C++.

Ladislav Hagara | Komentářů: 1
22.4. 14:00 | Zajímavý článek

David Revoy, autor open source webového komiksu Pepper&Carrot nebo portrétu GNU/Linuxu, zveřejnil na svém blogu recenzi notebooku Librem 13 od společnosti Purism. Používá jej již sedm měsíců a s ním i jako umělec spokojen. Potřebu francouzské AZERTY klávesnice vyřešil přelepkami. Na displej se podíval kalibrační sondou, barvy vyladil pomocí open source softwaru DisplayCAL, v aplikaci Inkscape nastavil zvětšování na 170 % aby 1 cm v Inkscapu byl 1 cm v reálu. Webovou kameru, mikrofon, Wi-Fi a Bluetooth lze na Librem 13 hardwarově vypnout.

Ladislav Hagara | Komentářů: 7
21.4. 23:44 | Komunita

Několik posledních verzí GNOME Shellu obsahuje chybu způsobující memory leak (únik paměti). Viz například videozáznamy verzí 3.26 nebo 3.28. Nalezení chyby #64 a její opravě se věnuje Georges Basile Stavracas Neto v příspěvku na svém blogu [reddit].

Ladislav Hagara | Komentářů: 2
21.4. 10:33 | Komunita

V pondělí měl na YouTube online premiéru otevřený krátký 2D film Hero vytvořený v 3D softwaru Blender. Cílem stejnojmenného projektu Hero je vylepšit nástroj Grease Pencil (tužka) v Blenderu 2.8.

Ladislav Hagara | Komentářů: 4
20.4. 23:22 | Nová verze

Byla vydána verze 4.0 kolekce svobodného softwaru umožňujícího nahrávání, konverzi a streamovaní digitálního zvuku a obrazu FFmpeg (Wikipedie). Přehled novinek v Changelogu (GitHub).

Ladislav Hagara | Komentářů: 0
20.4. 17:22 | Komunita

Včera vydanou hru Rise of the Tomb Raider pro Linux lze do pondělí 23. dubna koupit na Steamu s 67% slevou. Místo 49,99 € za 16,49 €.

Ladislav Hagara | Komentářů: 0
20.4. 16:11 | Komunita

Na Humble Bundle lze získat počítačovou hru Satellite Reign (Wikipedie, YouTube) běžící také v Linuxu zdarma. Speciální akce končí v sobotu v 19:00.

Ladislav Hagara | Komentářů: 5
20.4. 15:44 | Zajímavý software

Společnost Apple koupila před třemi lety společnost FoundationDB vyvíjející stejnojmenný NoSQL databázový systém FoundationDB (Wikipedie). Včera byl tento systém uvolněn jako open source pod licencí Apache 2.0. Zdrojové kódy jsou k dispozici na GitHubu.

Ladislav Hagara | Komentářů: 0
Používáte na serverech port knocking?
 (2%)
 (7%)
 (46%)
 (27%)
 (17%)
Celkem 367 hlasů
 Komentářů: 29, poslední 5.4. 12:25
    Rozcestník

    Dotaz: Kolízia balíčkov dvoch súčasne nainštalovaných programov

    6.12.2015 13:01 kenco
    Kolízia balíčkov dvoch súčasne nainštalovaných programov
    Přečteno: 452×
    Zdravím Vás, som používateľom ElementaryOS Freya. Pri východzích programoch nieje žiaden problém, avšak ak sa pokúsim nainštalovať najnovší Audacious (repozitár ppa:nilarimogard/webupd8) a program MuseScore (repozitár ppa:mscore-ubuntu/mscore-stable). Prvý poznáte, audioprehrávač, ten druhý slúži na zápis nôt. Problém nastáva ten, že ak nainštalujem Audacious z predvoleného repozitára pre Ubuntu 14.04 LTS (ElemetaryOS Freya je postavený na ňom), tak ten obsahuje verziu 3.4.3. Najnovšia verzia cez pridaný repozitár je ale 3.7.1 - avšak sa nejako bijú balíčky práve s programom MuseScore. Nainštaloval som najprv Audacious 3.7.1, všetko OK. Potom som nainštaloval MuseScore, takisto inštalácia v pohode. Ale iba do najbližšej aktualizácie. Potom mi Audacious odinštalovalo (samo) a pri opätovnom pokuse o inštaláciu mi vypisuje toto:

    kenco@G-FLY:~/Stiahnuté$ sudo apt-get install audacious Načítavajú sa zoznamy balíkov... Hotovo Vytvára sa strom závislostí Načítavajú sa stavové informácie... Hotovo Niektoré balíky sa nedajú nainštalovať. To môže znamenať, že požadujete nemožnú situáciu, alebo ak používate nestabilnú distribúciu, že požadované balíky ešte neboli vytvorené alebo presunuté z fronty Novoprichádzajúcich (Incoming) balíkov. Nasledovné informácie vám možno pomôžu vyriešiť túto situáciu:

    Nasledovné balíky majú nesplnené závislosti: audacious : Závisí na: audacious-plugins (>= 3.7) ale inštalovať sa bude 3.4.3-2 E: Problémy sa nedajú opraviť, niektoré balíky držíte v poškodenom stave.

    Problém ale je v tom, že nedokážem už nainštalovať ani pôvodnú verziu Audacious z repozitára pre ubuntu 14.04. Čo teraz s tým?

    Odpovědi

    6.12.2015 13:20 Brad | skóre: 7
    Rozbalit Rozbalit vše Re: Kolízia balíčkov dvoch súčasne nainštalovaných programov
    Zkus ručně stáhnout a nainstalovat balíček audacious-plugins v požadované verzi (>= 3.7), pak už by si to nemělo stěžovat na nesplněné závislosti a měl by jít Audacious z repozitáře nainstalovat.
    6.12.2015 13:27 kenco
    Rozbalit Rozbalit vše Re: Kolízia balíčkov dvoch súčasne nainštalovaných programov
    O tom som sa už pokúsil, stiahol som všetky štyri súvisiace balíčky z repozitára https://launchpad.net/~nilarimogard/+archive/ubuntu/webupd8

    Konkrétne tieto: https://launchpad.net/~nilarimogard/+archive/ubuntu/webupd8/+files/audacious_3.7-1~webupd8~trusty0_i386.deb https://launchpad.net/~nilarimogard/+archive/ubuntu/webupd8/+files/libaudcore3_3.7-1~webupd8~trusty0_i386.deb https://launchpad.net/~nilarimogard/+archive/ubuntu/webupd8/+files/audacious-plugins-dbg_3.7-1~webupd8~trusty0_i386.deb https://launchpad.net/~nilarimogard/+archive/ubuntu/webupd8/+files/audacious-plugins_3.7-1~webupd8~trusty0_i386.deb

    Ale posledné dva (audacious-plugins) mi nedovolí nainštalovať.
    6.12.2015 13:33 Brad | skóre: 7
    Rozbalit Rozbalit vše Re: Kolízia balíčkov dvoch súčasne nainštalovaných programov
    Ten předposlední balíček zřejmě nemusíš řešit (audacious-plugins-dbg_3.7-1~webupd8~trusty0_i386.deb), to by měl být debug balíček který bys neměl potřebovat, a u toho posledního - co konkrétně mu na něm vadí (co o něm píše při pokusu o instalaci)?

    Nepřidal sis omylem nějaký novější repozitář?
    6.12.2015 13:40 kenco
    Rozbalit Rozbalit vše Re: Kolízia balíčkov dvoch súčasne nainštalovaných programov
    Repozitár som pridal ten, akú mám verziu, takže pre 14.04 Trusty. A keď dám manuálne nainštalovať ten deb súbor, vypíše toto:

    kenco@G-FLY:~$ cd Stiahnuté kenco@G-FLY:~/Stiahnuté$ ls audacious-plugins-dbg_3.7-1-webupd8-trusty0_i386.deb audacious-plugins_3.7-1-webupd8-trusty0_i386.deb audacious_3.7-1-webupd8-trusty0_i386.deb libaudcore3_3.7-1-webupd8-trusty0_i386.deb kenco@G-FLY:~/Stiahnuté$ sudo dpkg -i audacious-plugins_3.7-1-webupd8-trusty0_i386.deb [sudo] password for kenco: dpkg: ohľadom audacious-plugins_3.7-1-webupd8-trusty0_i386.deb obsahujúci audacious-plugins:i386: audacious-plugins:i386 kazí audacious (<< 3.6.99.1) audacious (verzia 3.4.3-1) je prítomná a inštalovaný.

    dpkg: error processing archive audacious-plugins_3.7-1-webupd8-trusty0_i386.deb (--install): nainštalovanie audacious-plugins:i386 by pokazilo audacious a odkonfigurovanie nie je povolené (--auto-deconfigure by mohlo pomôcť) Vyskytli sa chyby počas spracovania: audacious-plugins_3.7-1-webupd8-trusty0_i386.deb
    6.12.2015 13:50 Brad | skóre: 7
    Rozbalit Rozbalit vše Re: Kolízia balíčkov dvoch súčasne nainštalovaných programov
    Tak samozřejmě Audacious ve starší verzi bude napřed nutné ručně kompletně odinstalovat (tj. i se všemi souvisejícími balíčky), poté postup s ruční instalací novějších opakuj. Pokud to neprojde ani tak, zkus mu je vnutit bez kontroly závislostí (pokud to Apt umožňuje, předpokládám že ano). Pokud to nepomůže ani tak, musí pak poradit někdo zkušenější, protože já už nebudu vědět.
    6.12.2015 13:59 kenco
    Rozbalit Rozbalit vše Re: Kolízia balíčkov dvoch súčasne nainštalovaných programov
    Ďakujem za pomoc aj tak - ani ja niesom až taký expert, ak by som bol, tak by som to asi vedel vyriešiť. :) Ide len o to, že tam bude asi nejaká kolízia s balíčkami, ktoré súvisia s programom MuseScore - nakoľko, pokiaľ ten nieje nainštalovaný, tak Audacious 3.7.1 v pohode funguje. Iba keď nainštalujem aj MuseScore, tak sa to pokazí. Už sa mi podarilo nainštalovať pôvodný starší Audacious s predvoleného repozitára, takže mi to funguje - aj keď nie s najnovším dostupným SW, ako by som chcel.
    7.12.2015 08:41 1john2 | skóre: 35 | blog: jo12hn | zlín, brno
    Rozbalit Rozbalit vše Re: Kolízia balíčkov dvoch súčasne nainštalovaných programov
    zasadni otazka - jaka konkretni funkcionalita chybi ve starsi verzi? tj, ma to cele nejaky smysl nebo je to ciste nice to have?

    jinak by bylo fajn vedet:

    jake zavislosti ma audacious( v obou verzich).

    jake zavislosti ma musescore?

    prosim o vlozeni kazdeho vypisu do znacky code, at je to prehlednejsi
    7.12.2015 10:44 Brad | skóre: 7
    Rozbalit Rozbalit vše Re: Kolízia balíčkov dvoch súčasne nainštalovaných programov
    Dobrá snaha, ale vzhledem k tomu že Elementary OS je placený (a patrně to má na nějakém Macu) tak myslím, že je rád že mu to nějak funguje a nebude to dál řešit (potřebuje komponovat a stříhat, ne se hrabat v závislostech).
    7.12.2015 14:09 Ostap Kotab
    Rozbalit Rozbalit vše Re: Kolízia balíčkov dvoch súčasne nainštalovaných programov
    Je to o volbě, nebo ne? Ano, Linux opravdu o volbě často není a brání se jí, tedy každý cizí repo použít nelze. Mě by samotného zajímalo proč když u knihoven je označení o kterou verzi se jedná, že by chyba b. manažeru nebo b. správce?
    12.12.2015 22:21 kenco
    Rozbalit Rozbalit vše Re: Kolízia balíčkov dvoch súčasne nainštalovaných programov
    Takže, musel som sa tu vrátiť, nakoľko to fungovalo iba do reštartu, a opäť to nejde.

    Kvôli čomu najnovší audacious - neviem, čím to je, ale pôvodná 3.4.3 blbne s mojou zvukovkou SoundBlaster Audigy FX - bežne po cca hodinke prehrávania hudby začal vydávať akési pazvuky, prestal prehrávať hudbu, a musel som PC reštartovať. Takisto je tam chaotické zobrazenie adresárov/súborov pri pridávaní hudby z disku. Je normálne, že klasické zobrazenie je - najprv abecedné zoradenie podpriečinkov daného priečinka a pod nimi dole zasa abecedné zoradenie samostatných súborov, ktoré niesú v podpriečinkoch. V 3.4.3 to zoradzuje všetko naraz podľa abecedy, ako podpriečinky, takisto aj samostatné súbory. Jednoducho mi tá verzia príde ako nejaká nedorobená beta.

    Rád by som Ti pridal aj závislosti, ale úprimne, neviem, ako Ti to zistiť. Takže dám iba výpisy, o čom som sa pokúšal, a čo mi vypisuje. Jediné (ak to pomôže) môžem zatiaľ uviesť iba repozitáre, z ktorých dané programy inštalujem.

    Audacious: ppa:nilarimogard/webupd8 MuseScore: ppa:mscore-ubuntu/mscore-stable

    kenco@G-FLY:~$ sudo apt-get install audacious Načítavajú sa zoznamy balíkov... Hotovo Vytvára sa strom závislostí Načítavajú sa stavové informácie... Hotovo Niektoré balíky sa nedajú nainštalovať. To môže znamenať, že požadujete nemožnú situáciu, alebo ak používate nestabilnú distribúciu, že požadované balíky ešte neboli vytvorené alebo presunuté z fronty Novoprichádzajúcich (Incoming) balíkov. Nasledovné informácie vám možno pomôžu vyriešiť túto situáciu:

    Nasledovné balíky majú nesplnené závislosti: audacious : Závisí na: audacious-plugins (>= 3.7) ale sa nebude inštalovať E: Problémy sa nedajú opraviť, niektoré balíky držíte v poškodenom stave. kenco@G-FLY:~$ sudo apt-get install audacious-plugins Načítavajú sa zoznamy balíkov... Hotovo Vytvára sa strom závislostí Načítavajú sa stavové informácie... Hotovo Niektoré balíky sa nedajú nainštalovať. To môže znamenať, že požadujete nemožnú situáciu, alebo ak používate nestabilnú distribúciu, že požadované balíky ešte neboli vytvorené alebo presunuté z fronty Novoprichádzajúcich (Incoming) balíkov. Nasledovné informácie vám možno pomôžu vyriešiť túto situáciu:

    Nasledovné balíky majú nesplnené závislosti: audacious-plugins : Závisí na: libqt5multimedia5 (>= 5.2.0) ale sa nebude inštalovať E: Problémy sa nedajú opraviť, niektoré balíky držíte v poškodenom stave. kenco@G-FLY:~$ sudo apt-get install libqt5multimedia5 Načítavajú sa zoznamy balíkov... Hotovo Vytvára sa strom závislostí Načítavajú sa stavové informácie... Hotovo Niektoré balíky sa nedajú nainštalovať. To môže znamenať, že požadujete nemožnú situáciu, alebo ak používate nestabilnú distribúciu, že požadované balíky ešte neboli vytvorené alebo presunuté z fronty Novoprichádzajúcich (Incoming) balíkov. Nasledovné informácie vám možno pomôžu vyriešiť túto situáciu:

    Nasledovné balíky majú nesplnené závislosti: libqt5multimedia5 : Závisí na: qtbase-abi-5-2-1 E: Problémy sa nedajú opraviť, niektoré balíky držíte v poškodenom stave. kenco@G-FLY:~$ sudo apt-get install qtbase-abi-5-2-1 Načítavajú sa zoznamy balíkov... Hotovo Vytvára sa strom závislostí Načítavajú sa stavové informácie... Hotovo Balík qtbase-abi-5-2-1 je virtuálny balík poskytovaný balíkmi: libqt5core5a 5.2.1+dfsg-1ubuntu14.3 [Nie je kandidátska verzia] libqt5core5a 5.2.1+dfsg-1ubuntu14 [Nie je kandidátska verzia]

    E: Balík „qtbase-abi-5-2-1“ nemá kandidáta na inštaláciu
    12.12.2015 23:24 Brad | skóre: 7
    Rozbalit Rozbalit vše Re: Kolízia balíčkov dvoch súčasne nainštalovaných programov
    To vypadá na klasický dependency hell, snaží se ti to tam ve finále dotáhnout asi půlku KDEčka. Jelikož Freya má jako okenního správce Galu (která je based on Mutter, který je based-on nevím na čem…), tak bych jako řešení viděl pokusit se sehnat balíček vytvořený přímo pro tvůj systém, nebo se pokusit najít nějaký alternativní program se stejnými funkcemi.

    Jinak nedokážu víc poradit, třeba se najde někdo zkušenější.
    13.12.2015 12:39 kenco
    Rozbalit Rozbalit vše Re: Kolízia balíčkov dvoch súčasne nainštalovaných programov
    Nerozumiem dopodrobna, čo si písal, ale niečo na tom bude - už len preto, že MuseScore v tom prostredí vyzerá tak "KDEčkovsky" - proste iný font, iný vzhľad, nezapadá to do systému ako ostatné programy. Najviac ma štve to, že staršia verzia z pôvodného repozitáru 1.3 funguje v pohode, má dokonca aj adekvátny "look" (gnome), ale novovytvorené súbory v 2.0.2 v nej neotvorím. :( Pričom tá novšia verzia má vychytávky, ktoré mi chýbali v pôvodnej staršej verzii (zápis viacerých partov za sebou v jednom súbore a podobne..). No nič, budem čakať, či niekto s niečím príde, snáď to čím skôr aj v oficiálnych repozitároch aktualizujú (Audacious zo včera na dnes zmenil verziu zo 3.4.3 na 3.6.2 v oficiálnom repozitári ubuntu - v podstate má odstránené vyššie uvedené chyby ako mala 3.4.3, takže problém je tak z polovice vyriešený).
    13.12.2015 15:40 distro
    Rozbalit Rozbalit vše Re: Kolízia balíčkov dvoch súčasne nainštalovaných programov
    Přesně tak, ten kdo balík vytvářel používá KDE, tak to zkompiloval s QT nebo i KDE knihovnama. Ale mě knihovny základu pro KDE prostředí nevadí, ale jen dokud to nebude mít taky zavislosti na KDE aplikacích, knihovny se nespouští a v menu se neukazují. SPíš bych řekl, že ty knihovny nejdou nainstalovat z dǔvodu, že nemáš přidané repo které je obsahují.
    13.12.2015 15:48 distro
    Rozbalit Rozbalit vše Re: Kolízia balíčkov dvoch súčasne nainštalovaných programov
    A jinak souhlasím, pokud existuje ppa které nevyžaduje ani QT tak ho zkusit, samozřejmě pokud balík není postavený jen pro KDE a nepracoval by ani jen v příkazovém režimu, tady je to ale vyloučeno.
    14.12.2015 22:46 kenco
    Rozbalit Rozbalit vše Re: Kolízia balíčkov dvoch súčasne nainštalovaných programov
    Ináč, chlapi, taká vec. Trochen sa snažím rozumieť, o čom tu píšete. A nemohol by som to nejako nainštalovať na základe stiahnutých *.deb súborov z tohto repozitára? Proste namiesto tých súborov, ktoré požaduje z KDE, aby fičali na adekvátnych balíčkoch z GNOME? Sorry, že píšem tak laicky, nerozumiem sa tomu, ale predpokladám, že keď verzia 1.3 beží natívne aj pod GNOME (resp. knižnicami s GNOME), tak by s tým nemala mať problém ani verzia 2.0.2, tak?

    Založit nové vláknoNahoru

    Tiskni Sdílej: Linkuj Jaggni to Vybrali.sme.sk Google Del.icio.us Facebook

    ISSN 1214-1267   www.czech-server.cz
    © 1999-2015 Nitemedia s. r. o. Všechna práva vyhrazena.