abclinuxu.cz AbcLinuxu.cz itbiz.cz ITBiz.cz HDmag.cz HDmag.cz abcprace.cz AbcPráce.cz
AbcLinuxu hledá autory!
Inzerujte na AbcPráce.cz od 950 Kč
Rozšířené hledání
×
dnes 11:55 | Komunita

Vývojový tým OpenSSL ve spolupráci s iniciativou Core Infrastructure konsorcia Linux Foundation spustil proces přelicencování této kryptografické knihovny ze současné licence na licenci Apache Licence v 2.0 (ASLv2). Nová licence usnadní začleňování OpenSSL do dalších svobodných a open source projektů. Všichni dosavadní vývojáři OpenSSL (Authors) obdrží v následujících dnech email s prosbou o souhlas se změnou licence.

Ladislav Hagara | Komentářů: 0
dnes 01:11 | Komunita

Před třemi týdny Mozilla.cz představila projekt Photon, jehož cílem je návrh a implementace nového vzhledu Firefoxu. Včera zveřejnila první náhled vzhledu Photon. Práce na projektu Photon jsou rozděleny do pěti týmů, které celkem čítají 19 lidí. Zaměřují se na zlepšení prvního spuštění Firefoxu a zaujetí nových uživatelů, celkovou úpravu vzhledu, zlepšení animací, zrychlení odezvy uživatelského rozhraní a také upravení nabídek. Vývoj lze sledovat v Bugzille.

Ladislav Hagara | Komentářů: 9
včera 20:00 | Komunita

OneDrive pro firmy je již ve webových prohlížečích na Linuxu stejně rychlý jako na Windows. Microsoft opravil chybu z listopadu loňského roku. OneDrive pro firmy běžel na Linuxu mnohem pomaleji než na Windows. V popisu chyby bylo uvedeno, že stačilo v prohlížeči na Linuxu nastavit v user-agentu Windows a vše se zrychlilo. Odpovědí Microsoftu bylo (Internet Archive: Wayback Machine), že Linux není podporován. Po bouřlivých diskusích na redditu i Hacker News byla chyba nalezena a opravena.

Ladislav Hagara | Komentářů: 4
včera 19:00 | Zajímavý projekt

Byla vyhlášena soutěž Hackaday Prize 2017. Soutěž je určena vývojářům open source hardwaru. Pro výherce je připraveno celkově 250 tisíc dolarů. Každý ze 120 finalistů získá tisíc dolarů. Nejlepší pak navíc 50, 30, 20, 15, 10 a 5 tisíc dolarů. Jedná se již o čtvrtý ročník soutěže. V roce 2014 zvítězil projekt globální sítě open source pozemních satelitních stanic SatNOGS. V roce 2015 zvítězil open source systém pro řízení elektrických invalidních vozíků pohybem očí Eyedriveomatic. V roce 2016 zvítězil modulární robot Dtto.

Ladislav Hagara | Komentářů: 0
včera 15:00 | Bezpečnostní upozornění

Byla vydána Samba ve verzích 4.6.1, 4.5.7 a 4.4.12. Řešen je bezpečnostní problém CVE-2017-2619. Pomocí symbolických odkazů a souběhu (symlink race) lze "teoreticky" získat přístup k souborům, které nejsou sdíleny. Linuxové distribuce jsou postupně aktualizovány (Debian).

Ladislav Hagara | Komentářů: 0
včera 07:43 | Nová verze

Na Steamu se objevil port hry Arma: Cold War Assault (Operation Flashpoint) pro Mac a Linux. … více »

creon | Komentářů: 26
včera 05:55 | Nová verze

Po 18 měsících od vydání verze 8.0 byla vydána verze 9.0 open source alternativy GitHubu, tj. softwarového nástroje s webovým rozhraním umožňujícího spolupráci na zdrojových kódech, GitLab. Představení nových vlastností v příspěvku na blogu a na YouTube.

Ladislav Hagara | Komentářů: 0
včera 03:33 | Komunita

Platnost posledního patentu souvisejícího s Dolby Digital (AC-3) vypršela. Po MP3 se tak do Fedory oficiálně dostane také kodek AC-3.

Ladislav Hagara | Komentářů: 5
včera 00:44 | Komunita

Feral Interactive, společnost zabývající se vydáváním počítačových her pro operační systémy macOS a Linux, nabízí své hry na Steamu vývojářům open source 3D grafické knihovny Mesa zdarma. Podmínkou je minimálně 25 commitů za posledních 5 let. Stejnou nabídku dostali vývojáři knihovny Mesa v roce 2015 od Valve. O rok dříve dostali od Valve tuto nabídku vývojáři Debianu a Ubuntu.

Ladislav Hagara | Komentářů: 0
22.3. 23:55 | Nová verze

Opera 44, verze 44.0.2510.857, byla prohlášena za stabilní. Nejnovější verze tohoto webového prohlížeče je postavena na Chromiu 57. Z novinek vývojáři Opery zdůrazňují podporou Touch Baru na nejnovějších MacBoocích Pro (gif). Přehled novinek pro vývojáře na blogu Dev.Opera.

Ladislav Hagara | Komentářů: 1
Jak se stavíte k trendu ztenčování přenosných zařízení (smartphony, notebooky)?
 (14%)
 (2%)
 (72%)
 (3%)
 (10%)
Celkem 924 hlasů
 Komentářů: 72, poslední 1.3. 11:16
    Rozcestník

    Dotaz: OpenWRT wifi client

    25.6.2016 03:38 TiVek
    OpenWRT wifi client
    Přečteno: 405×
    Zdravím,

    doposud jsem bezproblémů používal starší verzi OpenWRT Backfire 10.03.1 na routeru Asus WL-520gu, blblo mi na něm ale načítání dat z meteostanice, tak jsem jej nahradil routerem TP-Link TL-WR842ND, kde mi běhá 12.09 kvůli starým balíkům (zkoušel jsem i 14.07 ale dopadlo to stejně viz. níže)

    problém je následující: TP-Link se musí ve wifi režimu client připojit k domácímu AP. TP-Link má mít pouze jednu IP 192.168.0.131 (v krajním případě může mít i více, ale lepší by byla jedna), nechci aby mezi wlan a eth routoval, nechci dhcp, nepotřebuju firewall, pouze aby se po připojení na wifi bylo možné přes eth rozhraní TP-Linku kabelem připojit k mé domácí síti (DHCP server běží na jiném zařízení mimo zmíněné).

    na Backfire 10.03.1 jsem to řešil tak, že jsem nastavil IP ethernetu tedy na interface eth0 (lan) dále se routerem připojil na domácí AP, pak změnil u WLAN používáný interface na eth0 (lan) (automaticky vytvořený interface pro wifi jsem smazal) a fungovalo to

    bohužel na 12.09 i 14.07 pokud udělám stejný postup tak se mi nepřipojí WIFI tplinku k mému domácímu AP, jediná možnost kdy se připojí je, když má wifi vlastní interface. Zkoušel jsem dělat na jednotlivých interfacech bridge, ale neúspěšně, zkoušel jsem vytvořit další rozhraní BRIDGE, kterému jsem připojil oba interfaci (zde jsem si úspěšně několikrát router odřízl z obou stran)

    různé kombinace už zkouším několik hodin, ale nic uspokojivě nezabralo, je půl čtvrté ráno, furt mi to nejde a už jsem z toho zoufalý :(

    Odpovědi

    25.6.2016 08:06 NN
    Rozbalit Rozbalit vše Re: OpenWRT wifi client
    25.6.2016 11:07 Petr Šobáň | skóre: 79 | blog: soban | Olomouc
    Rozbalit Rozbalit vše Re: OpenWRT wifi client
    Nějak nechápu.

    Proč šachuješ s eth0 atd......

    Většinou stačí nastavit wifi na klient, vypnout DHCP server a je to.

    Pokud chceš WAN konektor připojit k LAN konektorům nastavit parametry integrovaného switchu (vyhodit WAN z jeho VLANU a dát do VLANU kde jsou LAN konektory).

    Asi by to chtělo resetnout do default a jenom nastavit wifi na klient vypnout DHCP a hodit sem konfiguráky aby jsme skoukli co tam máš blbě když to nechce fungovat...

    26.6.2016 13:32 TiVek
    Rozbalit Rozbalit vše Re: OpenWRT wifi client
    Konfiguruju přes luci, pokud se chci připojit k wifi, nutí mě to definovat (docela logicky) Network, v kterém to bezdrátové rozhraní bude provozováno

    v interface by pak mělo dle mě zůstat jen LAN kde je zároveň eth1(lan), wlan(wifi) a případně i eth0(wan)(eth0 pouze pokud chci lokálně použít i fyzický WAN port) a všechno by to pak mělo dostat jen jednu IP - jenomže takhle to nefunguje, pokud to tak nastavím, tak se mi wifi nepřipojí na AP

    původní dotaz jsem možná sepsal dost blbě
    27.6.2016 08:37 Petr Šobáň | skóre: 79 | blog: soban | Olomouc
    Rozbalit Rozbalit vše Re: OpenWRT wifi client
    To že se wifi nepřipojí nemá nic společného s lan, ale třeba zjistit co jsi nastavil blbě.

    Wifi se propojuje většinou do bridge s lan.

    Možná se snažíš použít stejné IP na wan a wifi.

    Jinak těžko ti můžeme poradit jak nedodáš výpisy jak nastavení tak chyby co to vypíše...
    27.6.2016 13:14 TiVek
    Rozbalit Rozbalit vše Re: OpenWRT wifi client
    WAN jsem vůbec nenastavoval (tuším tam je automaticky DHCP client) ani do fyzického portu WAN nemám nic připojeno - rozhraní WAN nemám v plánu používat (pouze možná fyzický WAN port může sloužit stejně jako zbylé LAN - ale není to nutné). Ano docela rozumím, že asociace Wifi s AP nebude souviset s nastavení LAN, ale když mám jen jeden interface pro LAN i WIFI (br-lan - bridge přes rozhraní mám "zapnutý") a tímpádem i jednu IP pro obě fyzická rozhraní, tak se WIFI zkrátka neasociuje. Pokud pro wifi udělám samostatný interface např wlan, tak je asociace okamžitá.

    Na ASUS WL-520gu (OpenWRT 10.03.1) to jelo bezproblémů ihned. Postup nastavení provádím defakto stejný jako níže akorát s rozdílem, že WIFI nejede jako AP ale jako Client : http://root42.blogspot.cz/2014/01/how-to-setup-openwrt-router-as-wifi.html

    Konfiguráky sem rád postnu, ale které přesně? /etc/config/network a /etc/config/wireless ? nebo ještě něco?

    27.6.2016 17:01 TiVek
    Rozbalit Rozbalit vše Re: OpenWRT wifi client
    /etc/config/network

    config interface 'loopback'
    	option ifname 'lo'
    	option proto 'static'
    	option ipaddr '127.0.0.1'
    	option netmask '255.0.0.0'
    
    config globals 'globals'
    	option ula_prefix 'fd32:893b:92d8::/48'
    
    config interface 'lan'
    	option ifname 'eth1'
    	option force_link '1'
    	option type 'bridge'
    	option proto 'static'
    	option netmask '255.255.255.0'
    	option ip6assign '60'
    	option ipaddr '192.168.0.131'
    	option broadcast '192.168.0.1'
    	option dns '192.168.0.1'
    
    config interface 'wan'
    	option ifname 'eth0'
    	option proto 'dhcp'
    
    config interface 'wan6'
    	option ifname '@wan'
    	option proto 'dhcpv6'
    
    config switch
    	option name 'switch0'
    	option reset '1'
    	option enable_vlan '1'
    
    config switch_vlan
    	option device 'switch0'
    	option vlan '1'
    	option ports '0 1 2 3 4'

    /etc/config/wireless
    config wifi-device 'radio0'
    	option type 'mac80211'
    	option channel '11'
    	option hwmode '11g'
    	option path 'platform/ar934x_wmac'
    	option htmode 'HT20'
    	option disabled '0'
    	option txpower '30'
    	option country 'CZ'
    
    config wifi-iface
    	option ssid 'mojewifi'
    	option encryption 'psk2'
    	option device 'radio0'
    	option mode 'sta'
    	option bssid 'C8:3A:35:29:F6:F0'
    	option key 'mojeheslonawifi'
    	option network 'lan'
    27.6.2016 20:08 TiVek
    Rozbalit Rozbalit vše Re: OpenWRT wifi client
    a ještě jedna konfigurace, tentokrát wifi funguje, ale z ethernetu na routeru se nedostanu na svou domácí síť (postupoval jsem dle: https://wiki.openwrt.org/doc/recipes/relayclient )

    /etc/config/network
    config interface 'loopback'
    	option ifname 'lo'
    	option proto 'static'
    	option ipaddr '127.0.0.1'
    	option netmask '255.0.0.0'
    
    config globals 'globals'
    	option ula_prefix 'fd2a:4727:e103::/48'
    
    config interface 'lan'
    	option ifname 'eth1'
    	option force_link '1'
    	option proto 'static'
    	option netmask '255.255.255.0'
    	option ip6assign '60'
    	option ipaddr '192.168.2.1'
    
    config interface 'wan'
    	option ifname 'eth0'
    	option proto 'dhcp'
    
    config interface 'wan6'
    	option ifname '@wan'
    	option proto 'dhcpv6'
    
    config switch
    	option name 'switch0'
    	option reset '1'
    	option enable_vlan '1'
    
    config switch_vlan
    	option device 'switch0'
    	option vlan '1'
    	option ports '0 1 2 3 4'
    
    config interface 'wwan'
    	option _orig_ifname 'wlan0'
    	option _orig_bridge 'false'
    	option proto 'static'
    	option ipaddr '192.168.0.131'
    	option netmask '255.255.255.0'
    	option gateway '192.168.0.1'
    	option dns '192.168.0.1'
    
    config interface 'stabridge'
    	option proto 'relay'
    	option ipaddr '127.0.0.1/8'
    	list network 'lan'
    	list network 'wwan'
    /etc/config/wireless
    config wifi-device 'radio0'
    	option type 'mac80211'
    	option channel '11'
    	option hwmode '11g'
    	option path 'platform/ar934x_wmac'
    	option htmode 'HT20'
    	option disabled '0'
    	option txpower '30'
    	option country 'CZ'
    
    config wifi-iface
    	option network 'wwan'
    	option ssid 'mojewifi'
    	option encryption 'psk2'
    	option device 'radio0'
    	option mode 'sta'
    	option bssid 'C8:3A:35:29:F6:F0'
    	option key 'mojeheslonawifi'
    28.6.2016 06:07 Petr Šobáň | skóre: 79 | blog: soban | Olomouc
    Rozbalit Rozbalit vše Re: OpenWRT wifi client
    Tak nevím skoušel jsem to taky protože jsem ti nevěřil.

    S natem bez problému naklikané a funguje to.

    Bez natu jsem to nerozchodil a to jsem si s tím hrál 4 hodiny tak nevím kde soudruzi z OpenWRT udělaly chybu....

    Nemůžu si pomoct ale mám dojem že v OpenWRT to jde s wifi s kopce.

    Kdysi to nepodporovalo 12 a 13 kanál a byl na to patch a dnes to sice tyto kanály podporuje ale co to nastavuje za výkon nechápu vždyť ten má být uložen v ROM té wifi a s různou verzí OpenWRT to vypisuje různé hodnoty?
    28.6.2016 08:44 rom
    Rozbalit Rozbalit vše Re: OpenWRT wifi client
    Co se týče WIFI klinta s OpenWRT, tak mám úplně stejnou zkušenost jako Petr. S NATem to funguje, ale nastavení bez NATu jsem zkoušel a nic.
    28.6.2016 09:13 TiVek
    Rozbalit Rozbalit vše Re: OpenWRT wifi client
    a přitom ve staré verzi (Backfire) to funguje bezproblémů, ještě jsem včera přišel na jednu zajímavost - pokud udělám obrácený postup tedy připojím router na domácí síť přes ethernet a wifi dám do režimu AP, tak zařízení připojené přes wifi jsou normálně na domácí síti, opačně to ale prostě nejde

    škoda, že to nejde bez natu, ještě se zeptám - je možné to nějak obejít třeba NATem 1:1 ?

    28.6.2016 12:53 Petr Šobáň | skóre: 79 | blog: soban | Olomouc
    Rozbalit Rozbalit vše Re: OpenWRT wifi client
    Ono by to podle mě nějak šlo, ale kdo přijde na to kde je zakopaný pes.

    Skoušel jsem vypínat firewall a nic tak jsem si chtěl vypsat zařízení pomocí ip a zase nic on tam ani ip není tak mi není jasné pomocí čeho to nastavuje zařízení tak jsem si musel ip balíček doinstalovat.....

    Ještě teď mě napadlo zda tam nechybí nějaký balíček pro práci s wifi.

    Osobně bych tam asi nechal starší verzi (Backfire) kde to funguje a máte to ověřené....
    28.6.2016 13:42 TiVek
    Rozbalit Rozbalit vše Re: OpenWRT wifi client
    backfire mám na starém routeru, na tom mi zas dělá problémy metostanice, která je pro mě to hlavní, síť tam byla jen provizorní (ale víte jak to je s provizorními řešeními) holt budu muset dotahnout několik nových kabelů z rozvaděče

    taky si myslím, že problém je řešitelný, bohužel ani jeden návod co jsem našel na internetu nezafungoval, asi tam stejně časem připojím raspberry, které má víc možností (a hlavně víc místa na aplikace) než ten router
    28.6.2016 14:35 Petr Šobáň | skóre: 79 | blog: soban | Olomouc
    Rozbalit Rozbalit vše Re: OpenWRT wifi client
    Ještě mě napadlo skoukni /etc/sysctl.conf

    Já jsem tam teď našel:
    # disable bridge firewalling by default
    net.bridge.bridge-nf-call-arptables=0
    net.bridge.bridge-nf-call-ip6tables=0
    net.bridge.bridge-nf-call-iptables=0
    
    A když bude firewall vypnutý tak zda to neblokuje přenos paketů v bridge nevím jak je to provázané s firewallem nikdy jsem to nepotřeboval.

    Založit nové vláknoNahoru

    Tiskni Sdílej: Linkuj Jaggni to Vybrali.sme.sk Google Del.icio.us Facebook

    ISSN 1214-1267   www.czech-server.cz
    © 1999-2015 Nitemedia s. r. o. Všechna práva vyhrazena.