OpenMandriva ROME, tj. průběžně aktualizovaná (rolling) edice linuxové distribuce OpenMandriva, byla vydána ve verzi 26.09. Vedle Flatpaku také s podporou Snapu.
Edison Design Group po více než 30 letech zveřejnil zdrojový kód svého EDG C/C++ front-endu. Ten proslul širokou podporou standardů C++ a kompatibilitou s dialekty kompilátorů od Microsoftu, GNU, Clangu, Sunu a dokonce i s prehistorickým cfrontem. EDG byl použit například v kompilátoru Intel C++ Classic, kompilátoru NVCC od firmy NVIDIA pro platformu CUDA nebo v našeptávači kódu IntelliSense v produktech společnosti Microsoft. Projekt nyní spravuje organizace The C++ Alliance a kód je dostupný pod licencí Apache 2.0, doplněnou o výjimky projektu LLVM.
Pocket Tank je malé kapesní virtuální akvárium postavené na vývojové desce ESP32-S3-Touch-AMOLED-1.8. Na dvoujádrovém mikrokontroléru ESP32-S3 s 8 MB PSRAM a 16 MB flash paměti běží jak simulace akvária, tak i malý jazykový model určující chování rybiček. Lokální model o velikosti 7,56 MB se 14 miliony parametrů vznikl destilací modelu Gemma 4 26B, tedy učitele s 26 miliardami parametrů. Kromě firmwaru pro skutečný modul s AMOLED
… více »Open-source nástroj Jevstiller vytváří (destiluje) malý lokální model, který se průběžně učí z odpovědí komerční služby Jev. Běžné dotazy vyřizuje přímo na vlastním hardware, čímž může řádově zkrátit čas odezvy a snížit provozní náklady díky menšímu využívání zpoplatněného API. Nejisté požadavky Jevstiller posílá do Jevu, rovněž průběžně kontroluje náhodná dvě procenta dotazů Jevem. Pokud se lokální model začne s Jevem rozcházet,
… více »Konference LinuxDays 2026 proběhne již tento víkend 3. a 4. října v Praze v areálu ČVUT v Dejvicích na FIT. Konference LinuxDays 2026 znamená desítky přednášek a workshopů, zástup zajímavých osobností, místo pro setkání, spoustu nových nápadů a informací a stánky řady různých projektů: Fedora, openSUSE, vpsFree.cz, Mozilla, MacGyver - bastlíři SH, OpenAlt a mnoho dalších. Vstup je volný.
Microsoft oznámil, že WSL kontejnery (WSLC) aneb linuxové kontejnery ve Windows Subsystem for Linux (WSL) jsou již obecně dostupné. Současně popsal jejich architekturu.
openSUSE Leap 16.1 vstoupil do RC fáze. Nově lze instalovat jako standardní systém (Standard) nebo jako neměnný systém s atomickými aktualizacemi (Immutable). Samostatná neměnná distribuce openSUSE Leap Micro končí.
Byl vydán Mozilla Firefox 157.0. S nejvýraznější vizuální proměnou za poslední roky. Přehled novinek v poznámkách k vydání a poznámkách k vydání pro vývojáře. Řešeny jsou rovněž bezpečnostní chyby. Nový Firefox 157 bude brzy k dispozici také na Flathubu a Snapcraftu.
Rodina produktů Raspberry Pi se rozšířila o Raspberry Pi Smart Display Module. Deska pro Raspberry Pi Compute Module 5 se zasouvá přímo do displejů dle specifikace Intel SDM. Cena desky je 30 dolarů.
Byla vydána nová verze 2.56.0 distribuovaného systému správy verzí Git. Přispělo 104 vývojářů, z toho 39 nových. Přehled novinek v příspěvku na blogu GitHubu a v poznámkách k vydání.
ping –c3 tecmint.lan #Domain Name vypíše IP jedno DC $ ping –c3 adc1.tecmint.lan #FQDN vypíše IP adc1 $ ping –c3 adc1 #Host vypíše IP adc1 $ host –t tecmint.lan vypíše IP jedno DC $ host –t adc1.tecmint.lan vypíše IP adc1 $ host –t SRV _kerberos._udp.tecmint.lan # UDP Kerberos SRV record vypise hostname jednotlivých dc ve tvaru adc1.tecmint.lan $ host -t SRV _ldap._tcp.tecmint.lan # TCP LDAP SRV record vypise hostname jednotlivých dc ve tvaru adc1.tecmint.lan host objectGUID._msdcs.tecmint.lan Vypíše IP odpovídajících IP Všechny tyto testy DNS jsem ověřil na jednotlivých DC a všude to funguje
3 - opravil db příkazem:cat /etc/hosts 127.0.0.1 localhost verejnaip dc2.tecmint.lan dc2 verejnaip dc1.tecmint.lan dc1 cat /etc/hostname dc1 cat /etc/resolv.conf cat /etc/resolv.conf domain tecmint.lan search tecmint.lan nameserver verejnaip toho konkretniho DC cat /etc/samba/smb.conf cat /etc/samba/smb.conf # Global parameters [global] netbios name = DC1 realm = TECMINT.LAN workgroup = TECMINT server role = active directory domain controller dns forwarder = 8.8.8.8 log level = 3 [netlogon] path = /var/lib/samba/sysvol/tecmint.lan/scripts read only = No [sysvol] path = /var/lib/samba/sysvol read only = No cat /etc/krb5.conf [libdefaults] default_realm = TECMINT.LAN dns_lookup_realm = false dns_lookup_kdc = true
4 - na DC1, které má všechny role syncl čas ntp.cesnet.cz. Ostatní DC si syncují čas z DC1 5 - z jednoho stroje přehrál tdbbackup -s .bak /var/lib/samba/private/idmap.ldb na ostatní 6- z jednoho stroje rsyncem syncuji sysvol na ostatnisamba-tool dbcheck --cross-ncs --fix
7 - resetoval acl na policies a od té doby příkaz samba-tool ntacl sysvolcheck na žádném DC nic nevypíše takže to je ok. Po té co jsem udělal kroky výše, doména se stala stabilnější, replikace ani na jednom stroji nehlásí errory. Když jedno DC vypnu klienti se připojí na druhé. Ale nepomohlo mně to na opravu GPO, jediné co se tedy opravilo je, že je můžu vytvářet. Ale když dám gpupdate, tak to vypíše:rsync -XAavz --delete-after --progress --stats /var/lib/samba/sysvol/ root@dc2:/usr/local/samba/var/locks/sysvol/
Myslel jsem tedy, že pomůže dát novější sambu. Vzal jsem tedy stroj DC3 se sambou Version 4.5.16-Debian. Připojil do domény, provedl replikaci. Je ještě potřeba něco dělat? Protože když ostatní DC vypnu, tak se ke klientům připojí jen ADMINI, ostatním userům to píše přístup odepřen. Nový stroj jde k novému dc připojit i když vypnu stávajíc dva staré. Replikace ani na jednom ze tří strojů nehlásí chyby. Zkusil jsem i verzi Version 4.9.8-Debian. Stáhl jsem balík někde z netu, tak snad je ok. Ke stroji se normálně připojila, ale samba nenaběhne.Updating Policy... User policy could not be updated successfully. The following errors were encount ered: The processing of Group Policy failed. Windows could not determine if the user a nd computer accounts are in the same forest. Ensure the user domain name matches the name of a trusted domain that resides in the same forest as the computer ac count. Computer Policy update has completed successfully. To diagnose the failure, review the event log or run GPRESULT /H GPReport.html f rom the command line to access information about Group Policy results. C:\GPRESULT /H GPReport.html INFO: The user "TECMINT\Administrator" does not have RSOP data.
Napadá někoho čím by to ještě mohlo být? Dá se nějak nastavení resetovat na defaultní hodnoty? Případně co dál ještě lze udělat?Jun 7 00:32:35 adc1 winbindd[751]: [2019/06/07 00:32:35.669334, 0] ../source3/winbindd/winbindd_cache.c:3160(initialize_winbindd_cache) Jun 7 00:32:35 adc1 winbindd[751]: initialize_winbindd_cache: clearing cache and re-creating with version number 2 Jun 7 00:32:35 adc1 winbindd[751]: [2019/06/07 00:32:35.681141, 0] ../source3/winbindd/winbindd_util.c:131(add_trusted_domain) Jun 7 00:32:35 adc1 winbindd[751]: add_trusted_domain: Got null SID for domain [zakaznici] Jun 7 00:32:35 adc1 winbindd[751]: [2019/06/07 00:32:35.682859, 0] ../source3/winbindd/winbindd_util.c:1245(init_domain_list) Jun 7 00:32:35 adc1 winbindd[751]: init_domain_list: init_domain_list_dc failed Jun 7 00:32:35 adc1 winbindd[751]: [2019/06/07 00:32:35.687269, 0] ../source3/winbindd/winbindd.c:1454(winbindd_register_handlers) Jun 7 00:32:35 adc1 winbindd[751]: unable to initialize domain list Jun 7 00:32:35 adc1 samba: task[winbindd_parent][746]: [2019/06/07 00:32:35.713580, 0] ../source4/winbind/winbindd.c:46(winbindd_done) Jun 7 00:32:35 adc1 samba: task[winbindd_parent][746]: winbindd daemon died with exit status 1 Jun 7 00:32:35 adc1 samba: task[winbindd_parent][746]: [2019/06/07 00:32:35.714446, 0] ../source4/smbd/service_task.c:36(task_server_terminate) Jun 7 00:32:35 adc1 samba: task[winbindd_parent][746]: task_server_terminate: task_server_terminate: [winbindd child process exited]
Je možné vyzálohovat pouze počítače a uživatele a vše obnovit do nového čistého DC?To bude asi nejjednodušší dělat z Windows. Nikdy jsem to netestoval, ale snad by mohlo fungovat tohle: Active Directory user backup and recovery tool.
[2019/06/17 06:25:12.544457, 2] ../source3/winbindd/winbindd_rpc.c:333(rpc_name_to_sid) name_to_sid: failed to lookup name: NT_STATUS_NONE_MAPPED [2019/06/18 16:41:19.417299, 3] ../source4/auth/kerberos/krb5_init_context.c:80(smb_krb5_debug_wrapper) Kerberos: target ^B does not have secrets at this KDC, need to proxy [2019/06/18 16:41:19.417363, 3] ../source4/auth/kerberos/krb5_init_context.c:80(smb_krb5_debug_wrapper) Kerberos: Failed building TGS-REP to ipv4:x.x.x.x:10079 [2019/06/18 16:41:19.417424, 3] ../source4/smbd/service_stream.c:66(stream_terminate_connection) Terminating connection - 'kdc_tcp_call_loop: proxying requested when not RODC' [2019/06/18 16:41:23.777427, 3] ../lib/ldb-samba/ldb_wrap.c:325(ldb_wrap_connect) ldb_wrap open of secrets.ldb
Tiskni
Sdílej: