abclinuxu.cz AbcLinuxu.cz itbiz.cz ITBiz.cz HDmag.cz HDmag.cz abcprace.cz AbcPráce.cz
AbcLinuxu hledá autory!
Inzerujte na AbcPráce.cz od 950 Kč
Rozšířené hledání
×
dnes 13:55 | Nová verze

Byla vydána verze 15.0 na Debianu založené linuxové distribuce Untangle NG Firewall. Přehled novinek v poznámkách k vydání a ve videu na YouTube. Vyzkoušet lze (zatím neaktualizované) demo webového rozhraní.

Ladislav Hagara | Komentářů: 0
dnes 12:11 | Pozvánky

Letošní ročník konference LinuxDays se uskuteční o víkendu 3. a 4. října, opět se potkáme v pražských Dejvicích na FIT ČVUT. Také během devátého ročníku nás budou čekat desítky přednášek, workshopy, stánky a spousta doprovodného programu. Aktuální dění můžete sledovat na Twitteru nebo Facebooku, přidat se můžete také do telegramové diskusní skupiny.

Petr Krčmář | Komentářů: 1
dnes 10:22 | Zajímavý článek

Alexander Popov se v příspěvku na svém blogu podrobně věnuje možnostem zneužití bezpečnostní chyby CVE-2019-18683 v linuxovém podsystému V4L2. Videoukázka eskalace práv na YouTube. Chyba byla v upstreamu opravena v listopadu loňského roku. Alexander Popov se chybě věnoval ve své přednášce (pdf) na konferenci OffensiveCon 2020.

Ladislav Hagara | Komentářů: 0
dnes 06:00 | Nová verze

Byla vydána nová verze 20.02.17 svobodného multiplatformního video editoru Shotcut (Wikipedie). Přehled novinek v oznámení o vydání. Využíván je MLT Multimedia Framework 6.20.0 a WebVfx 1.2.0. Nejnovější Shotcut je k dispozici také ve formátech AppImage, Flatpak i Snap.

Ladislav Hagara | Komentářů: 2
včera 16:22 | IT novinky

Spolkový úřad pro informační bezpečnost (Bundesamt für Sicherheit in der Informationstechnik) schválil používání softwarů Gpg4win a Gpg4KDE, tj. nadstaveb nad GnuPG, pro šifrování a přenos utajovaných informací stupně utajení Vyhrazené (VS-NUR FÜR DEN DIENSTGEBRAUCH (VS-NfD)), EU RESTRICTED a NATO RESTRICTED [reddit].

Ladislav Hagara | Komentářů: 0
včera 12:44 | Humor

Viceprezident společnosti Oracle Matthew O'Keefe napsal na Twitteru: "Kdyby databáze Oracle neexistovala, světová ekonomika by se zastavila. Kdyby většina open source distribuovaných databází neexistovala, byl by svět pro data mnohem bezpečnějším místem". Příspěvek rozpoutal diskusi nejenom na redditu a následně byl z Twitteru smazán (Wayback Machine).

Ladislav Hagara | Komentářů: 17
včera 09:33 | Nová verze

Byla vydána nová verze 1.38 správce síťových připojení ConnMan (Wikipedie). Z novinek lze zdůraznit podporu WireGuardu.

Ladislav Hagara | Komentářů: 0
včera 06:00 | Zajímavý projekt

Byl spuštěn Humble Book Bundle: Cybersecurity 2020 by Wiley. Za 1 euro a více lze koupit 7 elektronických knih, za 7,50 eur a více lze koupit 13 elektronických knih a za 13,50 eur a více lze koupit 20 elektronických knih věnovaných kybernetické bezpečnosti od nakladatelství Wiley. Peníze lze libovolně rozdělit mezi nakladatelství Wiley, Humble Bundle, Electronic Frontier Foundation a Let's Encrypt.

Ladislav Hagara | Komentářů: 0
17.2. 21:55 | Zajímavý článek

Clear Linux je distribuce vyvíjená firmou Intel; vybočuje optimalizací na výkon, pročež se používá např. k běhu benchmarků, ale také pro vývojáře či do cloudu. Recenze na Ars Technica se zaobírá použitím Clear Linuxu jako uživatel: instalace, pozorování rychlosti spouštění Gimpu, správa balíčků a instalace Google Chrome nebo konfigurace OpenZFS. Praktické nasazení mimo specializace, kde je výkon kritický, nakonec nedoporučuje.

Fluttershy, yay! | Komentářů: 5
17.2. 21:44 | Nasazení Linuxu

Jižní Korea se z historických důvodů potýká se silnou závislostí na Microsoftu (konkrétně ActiveX), kterou se snaží postupně odbourat. Na jaře 2019 tamní ministerstvo vnitra oznámilo testování Linuxu na pracovních stanicích. Nyní, po skončení podpory Windows 7, byl přechod potvrzen s cílem omezit závislost na třetí straně a snížit náklady. Do roku 2026 je v plánu, že uživatelé budou používat notebooky s Windows, ale připojovat se na vzdálený linuxový desktop v cloudu. Některá ministerstva již Linux používají.

Fluttershy, yay! | Komentářů: 0
Vydržela vám novoroční předsevzetí?
 (9%)
 (6%)
 (3%)
 (82%)
Celkem 161 hlasů
 Komentářů: 0
Rozcestník

www.AutoDoc.Cz

Dotaz: OpenWRT switched client

3.12.2019 15:37 xtonda
OpenWRT switched client
Přečteno: 298×
Nějak se mi nedaří udělat co mi přijde jako ta nejjednodušší věc. Mám TP-Link Archer C7 s OpenWRT a chci aby se mi připojil jako klient na Wifi AP a spojil wifi do bridge s LAN porty, tedy aby se to chovalo jako switch nebo řekněme media konvertor wifi - ethernet. Nic dalšího, žádný router, žádný firewall, žádné DHCP, DNS a kdoví co dalšího to ještě dělá. Prostě potřebuji připojit 2 PC na AC wifinu s podporou 3x3 MIMO nechci kupovat dva USB adaptéry, s podporou této rychlosti jsou docela drahé. Dá někdo tip jak toho dosáhnout? Díky.

Řešení dotazu:


Odpovědi

3.12.2019 16:22 Jary | skóre: 30 | blog: Jary má blog | Dům
Rozbalit Rozbalit vše Re: OpenWRT switched client
Já myslim, že se to dělá nějak takhle:
# cat /etc/config/network 
8<---8<---8<--- 
config interface 'lan'
	option type 'bridge'
	option proto 'static'
	option netmask '255.255.255.0'
	option bridge_empty '1'  # Tohle nevim proč tam je
	option ipaddr '192.168.5.1'
	option ifname 'lan1 lan2 lan3 lan4 lan5 lan6 lan7 lan8'  # Možná sem budeš muset dát port switche místo jednotlivých portů.
8<---8<---8<---
# cat /etc/config/wireless
8<---8<---8<--- 
config wifi-device 'radio1'
	option type 'mac80211'
	option macaddr 'XX:XX:XX:XX:XX:XX'
	option country 'CZ'
	option legacy_rates '1'
	option channel 'auto'
	option hwmode '11g'

config wifi-iface
	option ssid 'wifina'
	option encryption 'psk2'
	option device 'radio1'
	option key 'SECRET'
	option mode 'ap'
	option network 'lan'  # tohle bude asi důležité
8<---8<---8<--- 
Já jsem to prostě naklikal ve web UI. Vypadá to, že wifiny se musí přidat trochu jiným způsobem, než jiné porty.
.sig virus 3.2_cz: Prosím, okopírujte tento text do vaší patičky. GitHub
3.12.2019 16:24 Jary | skóre: 30 | blog: Jary má blog | Dům
Rozbalit Rozbalit vše Re: OpenWRT switched client
Aha, teď koukám, že jsi chtěl wifi client... no tak to bude podobné, jenom trochu jiné nastavení ve wireless.

Co konkrétně ti nefunguje?
.sig virus 3.2_cz: Prosím, okopírujte tento text do vaší patičky. GitHub
3.12.2019 16:28 xtonda
Rozbalit Rozbalit vše Re: OpenWRT switched client
wifi se tváří jako připojené, ale když zapojím počítač kabelem do LAN TP-Linku, tak se nepřipojí, nedostane IP.
3.12.2019 16:45 Jary | skóre: 30 | blog: Jary má blog | Dům
Rozbalit Rozbalit vše Re: OpenWRT switched client
Tak to bych doporučil oprášit wireshark a/nebo tcpdump. Třeba:
tcpdump -i nějaký_interface port bootpc
by asi mělo pomoct, když na nějakém interface, třeba toho vytvořeného bridge a zjistit, jestli a kam až se to DHCP (bootpc) dostane.

Možná taky může být problém s tím, že můžeš mít dva DHCP servery, co chtějí být autoritativní. Tak zjisti, jestli se tohle neděje.
.sig virus 3.2_cz: Prosím, okopírujte tento text do vaší patičky. GitHub
3.12.2019 21:06 NN
Rozbalit Rozbalit vše Re: OpenWRT switched client
dva DHCP servery, co chtějí být autoritativní
To asi tezko. Maximalne se perou mezi sebou. Kde by se ten druhy vzal? Nicmene souhlasim s tim, ze ping/tcpdump hodne napovi.
3.12.2019 23:26 Jary | skóre: 30 | blog: Jary má blog | Dům
Rozbalit Rozbalit vše Re: OpenWRT switched client
Kdekoliv jinde na broadcast doméně.

Tazatel chce tohle AP připojit jako clienta k jinému AP. Jened DHCP může být tam. Druhý na tomhle AP.
.sig virus 3.2_cz: Prosím, okopírujte tento text do vaší patičky. GitHub
Řešení 1× (xtonda (tazatel))
3.12.2019 21:30 f
Rozbalit Rozbalit vše Re: OpenWRT switched client
Je potreba zapnout WDS: https://openwrt.org/docs/guide-user/network/wifi/atheroswds
3.12.2019 23:41 Jary | skóre: 30 | blog: Jary má blog | Dům
Rozbalit Rozbalit vše Re: OpenWRT switched client
Já myslím, že to nechce. Přeci jenom řekl, že chce to wifi mít v režimu client. WDS se používá, když chci "prodloužit dosah" wifi. WDS bridge je něco jiného, než bridge, co se konfiguruje třeba pomocí brctl. Řekl bych to asi tak, že je to na jiné vrstvě.

V případě WDS, když AP přijme WIFI rámec tak ho musí (často, ne li vždy) zopakovat. To znamená, že propustnosti takové sítě klesne pod polovinu toho, co bez WDS.
.sig virus 3.2_cz: Prosím, okopírujte tento text do vaší patičky. GitHub
Řešení 1× (xtonda (tazatel))
4.12.2019 00:39 xtonda
Rozbalit Rozbalit vše Re: OpenWRT switched client
Ano, dal sem dotaz i přímo na OpenWRT forum a tam mě nakopli směrem k WDS (stejný odkaz) a po chvíli laborování sem to v tomto režimu rozchodil, klíč je totiž zde https://openwrt.org/docs/guide-user/network/wifi/relay_configuration, konkrétně větička Since opensource wireless drivers used in OpenWrt do not support bridging in client mode, the traffic between LAN and the wireless client must be joined by routing it. Takže asi proto mi ty bridge co sem tam různě zkoušel nastavovat nechodily, tedy buď WDS nebo relayd
4.12.2019 01:10 xtonda
Rozbalit Rozbalit vše Re: OpenWRT switched client
To, čeho chci dosáhnout, je dostat pomocí dvou krabic TP-Link Archer C7 LAN z jedné místnosti do druhé kam se mi nechce tahat kabel. Udělat to jako AP - klient je jedna z možností. Můj starší Edimax má režim pojmenovaný AP Bridge Point to Point, který je v manuálu popsaný “AP Bridge Mode” provides the function to bridge more than 2 wired Ethernet networks together by wireless LAN. You can use two access points with “AP Bridge-Point to Point mode” to bridge two wired Ethernet networks together. to by byl ideál.
4.12.2019 00:12 lertimir | skóre: 63 | blog: Par_slov
Rozbalit Rozbalit vše Re: OpenWRT switched client
A jak dopadají postupné kroky? Jde převést C7 do client módu? jde se s ním připojit?

Mám jiný TP-Link s OpenWRT, a připadá mi, že to jde jednoduše naklikat v LUCI: V menu Network/Wireless provedu scan a připojení a v Network/Interfaces provedu bridge mezi eth0.1 wlan0 a wlan1, odeberu jiné interface a v dalších menu vypnu všechny DNS,DHCP nad tímto nabridgovaným interface. A musím si dát pozor a přemýšlet odkud se v jakémkoliv kroku připojuji, abych si neuříznul konektivitu.
4.12.2019 00:43 xtonda
Rozbalit Rozbalit vše Re: OpenWRT switched client
Viz moje předchozí reakce, wlan adaptér jako klient nejde bridgeovat, s WDS to nějak chodí, otázka jestli optimálně, celkem ironicky WDS umí i stock firmware, otázka v jaké kvalitě.
4.12.2019 09:09 Vantomas | skóre: 29 | Praha
Rozbalit Rozbalit vše Re: OpenWRT switched client
WiFi standard nepodporuje bridge na klienské straně. Přes wifi klienta a bridge neprojdou MAC adresy počítačů, které jsou na LAN. Dříve a i dnes se to dá řešit přes ARP proxy, DHCP relay a spoustu jiných obezliček. Ale druhou, lepší možností, je použití WDS. WDS se dá použít k více věcem, ale WDS si mimojiné naváže transportní vrstvu nad klasickým WiFi a je to potom čistá L2 kudy proteče cokoliv, i v klasickým režimu AP-klient.
4.12.2019 11:27 Jary | skóre: 30 | blog: Jary má blog | Dům
Rozbalit Rozbalit vše Re: OpenWRT switched client
Zajímavé. Díky.
.sig virus 3.2_cz: Prosím, okopírujte tento text do vaší patičky. GitHub
14.12.2019 00:34 xtonda
Rozbalit Rozbalit vše Re: OpenWRT switched client
Tak mi to nedalo, nahodil sem zpátky stock firmware a tam to přes WDS chodí taky a navíc o třetinu rychleji. Sice sice na rozdíl od WRT nejde úplně vypnout AP na klientské krabici, ale dá se tomu nastavit jiné SSID a pokud se na to nic nepřipojí, tak k poklesu propustnosti z důvodu retransmise paketů na klientu nedochází. S OpenWRT nestíhal CPU https://forum.openwrt.org/t/switched-client/49654/8?u=xtonda
14.12.2019 12:30 kysučan | skóre: 6
Rozbalit Rozbalit vše Re: OpenWRT switched client
Páni, práve v tomto čase rieším niečo podobné. To s tým WDS mi helflo, ale narazil som na ďalší problém. Mám nejaký starší tplink opakovač s dd-wrt a keď ho nastavím na "wds client", tak všetko facha, ibaže sa nedokážem cez wifi pripojiť na ten opakovač, ani na zariadenia za ním.

Založit nové vláknoNahoru

Tiskni Sdílej: Linkuj Jaggni to Vybrali.sme.sk Google Del.icio.us Facebook

ISSN 1214-1267   www.czech-server.cz
© 1999-2015 Nitemedia s. r. o. Všechna práva vyhrazena.