abclinuxu.cz AbcLinuxu.cz itbiz.cz ITBiz.cz HDmag.cz HDmag.cz abcprace.cz AbcPráce.cz
AbcLinuxu hledá autory!
Inzerujte na AbcPráce.cz od 950 Kč
Rozšířené hledání
×

dnes 19:46 | Nová verze

dnsdist, specializovaný balancer pro DNS provoz, dosáhl stabilní verze 1.2.0. Tento software vyvíjí komunita kolem PowerDNS a neměl by uniknout pozornosti nikomu, kdo provozuje vytíženější rekurzivní DNS servery. Balancer je vhodný k obraně před DDoS útoky, je skriptovatelný v LUA, disponuje konzolovým rozhraním a má spoustu dalších zajímavých vlastností.

… více »
BigWrigley | Komentářů: 0
dnes 15:22 | Nová verze

Byla vydána verze 9.5 open source alternativy GitHubu, tj. softwarového nástroje s webovým rozhraním umožňujícího spolupráci na zdrojových kódech, GitLab (Wikipedie). Představení nových vlastností v příspěvku na blogu. Zdůraznit lze možnost ověřování GPG podpisů u commitů.

Ladislav Hagara | Komentářů: 1
včera 16:22 | Nová verze

Byla vydána verze 0.11.0 softwaru pro statistickou analýzu dat GNU PSPP (Wikipedie), svobodné alternativy k proprietárnímu softwaru IBM SPSS Statistics (Wikipedie). Vedle několika vylepšení a oprav chyb jsou řešeny také 2 bezpečnostní chyby CVE-2017-10791 a CVE-2017-10792. O týden později byla vydána verze 1.0.0 přinášející pouze aktualizaci překladů. Proč verze 1.0.0 a ne například 0.11.1? Dle vývojářů jsou důvody následující:

… více »
Ladislav Hagara | Komentářů: 0
včera 10:35 | Komunita

Na blogu Oracle se objevila zpráva o tom, že plánovaná verze Java EE 8 bude uvolněna jako open source (referenční implementace a compatibility kit). V současné době je uvolněna jen Java SE (standard edition) pod licencí GPLv2 v podobě OpenJDK (Open Java Development Kit), kterou začal v roce 2006 uvolňovat Sun.

Max | Komentářů: 4
21.8. 23:55 | IT novinky

Google na YouTube oficiálně představil Android 8.0 Oreo. Přehled novinek v příspěvku na blogu věnovaném vývojářům.

Ladislav Hagara | Komentářů: 33
21.8. 16:44 | Zajímavý článek

Po téměř 3 měsících od vydání třetího čísla publikoval Michal Špaček na svých stránkách čtvrté číslo newsletteru věnovanému bezpečnosti, bezpečnému vývoji převážně webových aplikací a bezpečnosti uživatelů. Jedná se současně o číslo poslední: "Nepíše se mi to lehce, a trvalo to, než jsem to ze sebe dostal, ale tohle je poslední newsletter v této podobě. Ani jsem ho nestihl pojmenovat a už jsem ho zabil. Nezbývá mi tolik času, abych každou událost, novinku a změnu v prohlížeči detailně popisoval tak, jak bych v newsletteru chtěl, mrzí mě to".

Ladislav Hagara | Komentářů: 2
21.8. 07:00 | Nová verze

Byla vydána diaspora* ve verzi 0.7.0.0. Jedná se o svobodný software, který slouží jako osobní webový server pro poskytování služeb sociální sítě (Wikipedie). Přehled novinek v příspěvku na blogu a na GitHubu. Sociální síť diaspora* byla před pěti lety předána komunitě.

Ladislav Hagara | Komentářů: 0
21.8. 06:00 | IT novinky

Společnost Hardkernel stojící za jednodeskovými počítači ODROID představila na YouTube minipočítač určený pro domácí cloud ODROID-HC1 vycházející z ODROID-XU4. Minipočítač s kovovou krabičkou, do které stačí vložit 2 a půl palcový disk, lze koupit za 49 dolarů. ODROID-HC1 je stohovatelný.

Ladislav Hagara | Komentářů: 39
20.8. 16:22 | Nová verze

Byl vydán DB Browser for SQLite (sqlitebrowser) ve verzi 3.10.0. Nejnovější stabilní verze této grafické nadstavby nad relačním databázovým systémem SQLite (Wikipedie) přináší například integraci s DBHub.io, tj. platformou pro sdílení SQLite databází. Podrobnosti na GitHubu.

Ladislav Hagara | Komentářů: 2
20.8. 08:00 | IT novinky

Andy Rubin, spoluzakladatel společnosti Android, jež byla v roce 2005 koupena Googlem, nyní CEO společnosti Essential Products, oznámil předprodej chytrého telefonu Essential. Telefon se začne rozesílat 1. září. Cena telefonu je 699 dolarů. Cena telefonu současně s 360° kamerou s rozlišením 4K byla stanovena na 749 dolarů. Kameru, v budoucnu i další příslušenství, lze k telefonu připojit pomocí konektoru s magnety.

Ladislav Hagara | Komentářů: 1
Těžíte nějakou kryptoměnu?
 (5%)
 (2%)
 (18%)
 (76%)
Celkem 374 hlasů
 Komentářů: 21, poslední 13.8. 09:57
    Rozcestník

    Dotaz: apt-get -f install problem

    11.9.2004 22:48 jirik
    apt-get -f install problem
    Přečteno: 185×
    Ahoj jsem lamicka Mam nasledujici problem: pouzivam debian, ale jsem zacatecnik. Vzdy bylo pri instalcich vse v poho, az najdenou ted po upgrade distro pres dselect mi to dela toto.

    Co koliv chci nainstalovat, tak mi to rekne, ze mam dat apt-get -f install, zadam to a najednou toto. Vzdy at instaluji cokoli to chce ten libxft-dev. Predem se omlouvam za tapetu, ale nevim co vedet potrebujete a co ne.
    The following extra packages will be installed:
      libxft-dev
    The following packages will be upgraded
      libxft-dev
    1 upgraded, 0 newly installed, 0 to remove and 748 not upgraded.
    112 not fully installed or removed.
    Need to get 0B/60.2kB of archives.
    After unpacking 4096B disk space will be freed.
    Do you want to continue? [Y/n] y
    
    (Reading database ... 117305 files and directories currently installed.)
    
    Preparing to replace libxft-dev 2.1.2-5 (using .../libxft-dev_2.1.2-6_i386.deb)...
    diversion of /usr/X11R6/include/X11/Xft/Xft.h
         to /usr/X11R6/include/X11/Xft/Xft1.h by libxft-dev
    Removing `diversion of /usr/X11R6/include/X11/Xft/Xft.h
         to /usr/X11R6/include/X11/Xft/Xft1.h by libxft-dev'
    dpkg-divert: rename involves overwriting
         `/usr/X11R6/include/X11/Xft/Xft.h' with
      different file `/usr/X11R6/include/X11/Xft/Xft1.h', not allowed
    
    dpkg: error processing /var/cache/apt/archives/libxft-dev_2.1.2-6_i386.deb (--unpack):
     subprocess pre-installation script returned error exit status 2
    Errors were encountered while processing:
     /var/cache/apt/archives/libxft-dev_2.1.2-6_i386.deb
    E: Sub-process /usr/bin/dpkg returned an error code (1)
    
    uz nevim co s tim. Vsem predem dekuji za odpoved.

    Odpovědi

    12.9.2004 08:27 speedo
    Rozbalit Rozbalit vše Re: apt-get -f install problem
    No neco podobneho mi to psalo, kdyz jsem manualne smazal nejaky soubor z nejakeho balicku...musel jsem si pak pohrat se skripty v /var/lib/dpkg/info (presneji se skripty ktere prislusely danemu problemovemu balicku)...to by asi pomohlo v pripade, ze uz by byl ten balicek "libxft-dev" castecne naistalovan...jinak nevim :-)...pripadne dotazy zasilej na martin_konecny@centrum.cz...chodim sem (na ABC) jen jednou tydne...cus bus...;-)
    12.9.2004 09:29 Robert Krátký | skóre: 94 | blog: Robertův bloček
    Rozbalit Rozbalit vše Re: apt-get -f install problem
    pripadne dotazy zasilej na martin_konecny@centrum.cz...chodim sem (na ABC) jen jednou tydne...

    Prosím diskutující, aby nepřenášeli diskuze zde započaté (a nevyřešené) na soukromé maily. Ostatní uživatelé se pak řešení problému nedozví, což je škoda.
    12.9.2004 09:42 Robert Krátký | skóre: 94 | blog: Robertův bloček
    Rozbalit Rozbalit vše Re: apt-get -f install problem
    Tvůj problém byl řešen např. v tomto fóru.

    Nejjednodušší pravděpodobně bude odinstalovat pomocí apt-get --purge remove libxft-dev. Asi to s sebou vezme pár závislostí, což nevadí, mělo by se to omezit na nějaké -dev balíky.

    Pak už jen nainstaluj novou verzi a ty balíky, které jsi odinstaloval společně se starou verzí.
    13.9.2004 12:36 jirik
    Rozbalit Rozbalit vše Re: apt-get -f install problem
    Vsem moc dekuji, vyzkousim, podam zpravu :-))
    13.9.2004 19:05 jirik
    Rozbalit Rozbalit vše Re: apt-get -f install problem
    TAk to nefacha :-((
    root@1[krtek2345]# apt-get --purge remove libxft-dev
    Reading Package Lists... Done
    Building Dependency Tree... Done
    You might want to run 'apt-get -f install' to correct these:
    The following packages have unmet dependencies:
      libqt3-mt-dev: Depends: libxft-dev
    E: Unmet dependencies. Try 'apt-get -f install' with no packages (or specify a solution).
    
    Jsem zkousel i cely nazvy tech balicku, a to zase rika, ze je nema-> E: Couldn't find package libxft-dev_2.1.2-5 hmmm :-(( :-(( tak nevim co s tim.
    13.9.2004 20:12 Robert Krátký | skóre: 94 | blog: Robertův bloček
    Rozbalit Rozbalit vše Re: apt-get -f install problem
    Nechce nic dělat, protože si myslí, že jsi nedokončil poslední instalaci/upgrade (což má pravdu).

    Takže, pomocí apt-get --purge remove odstraň všechny balíčky, které na libxft-dev záleží. Potom je zase všechny nainstaluj zpátky společně s tím novým libxft-dev. Např. takto:

    apt-get --purge remove libqt3-mt-dev [+ další, které na libxft-dev závisí]

    Potom zase všechny odstraněné nainstaluj zpátky.
    17.9.2004 14:14 jirik
    Rozbalit Rozbalit vše Re: apt-get -f install problem
    aha, asi hloupej dotaz, ale jak zjistim ktere balicky na nem zavisi?
    17.9.2004 14:43 Tomáš | skóre: 29 | blog: Tomik
    Rozbalit Rozbalit vše Re: apt-get -f install problem
    V podobne situaci jsem jednou byl a apt-get odmítalo pracovat. Zabere ale

    dpkg -r naázev_balíku

    Pokud na něm něco závisí, tak si zařve. Potom bys musel odinstalovat nejdřív ten závislý balík (platí to i pro další závislé balíky).
    17.9.2004 15:17 pasmen | skóre: 45 | blog: glob | Praha
    Rozbalit Rozbalit vše Re: apt-get -f install problem
    Co na cem zavici zjistit treba pomoci
    apt-cache rdepends --installed
    (myslim ze to je tak, ted nemam moznost to vyzkouset, dyztak man apt-cache).
    18.9.2004 22:14 jirik
    Rozbalit Rozbalit vše Re: apt-get -f install problem
    Vsem moc dekuji za pomoc uz to beha jak ma :-)) Ale v souvislosti by mne jeste zajimalo: Mam rvat do kompu balicky unstable, testing a nebo jen stable. Co by melo byt stabilnejsi :-) (unstable, testing?). a za dalsi, pokud mam nainstalovany z balicku program napriklad Program verze1.deb a novejsi verze je jen ve zdrojaku, musim pred jeho nainstalovanim odinstalovat balicek? pokud ano a zadam apt-get remove program verze1.deb odinstaluji se i balicky, ktere jsou potrebne pro chod te nove verze (asi zavislosti, ze? :-) ? Dekuji
    18.9.2004 22:42 Robert Krátký | skóre: 94 | blog: Robertův bloček
    Rozbalit Rozbalit vše Re: apt-get -f install problem
    ad stabilita: jména jednotlivých větví distribuce myslím říkají vše (stabilní, testovací, nestabilní). To však neznamená, by pro běžnou práci nešlo používat cokoliv jiného než stable. Já mám už pár let pouze unstable a na žádný výraznější problém jsem nenarazil (občas problém se závislostmi, ale řešitelné).

    ad nová verze: nainstaluješ-li program po kompilaci ze zdrojáku, aniž bys předtím odinstaloval balíček se starší verzí, budeš mít v systému dvě verze téhož programu, což nedělá nikdy dobrotu.

    Takže doporučuji program zkompilovat, převést do balíčku pomocí checkinstall a pak tímto vlastnoručně vytvořeným balíčkem upgradovat stávající verzi.
    19.9.2004 11:28 jirik
    Rozbalit Rozbalit vše Re: apt-get -f install problem
    jeste se chci optat: Jak tomu prblemu, ktery jsme mel muzu predejit? Jaky balicek mam nainstalovat pro nvou verzi KDE3.2.3 ? A jestli budu chtit, aby se mi instalovaly napr jen stable balicky tak to udelam tak, ze v apt.conf dam misto unstable->stable, a nebo, ze proste vymazu cesty v source. list? diky
    19.9.2004 12:16 Robert Krátký | skóre: 94 | blog: Robertův bloček
    Rozbalit Rozbalit vše Re: apt-get -f install problem
    Zbytečné opisovat manuál... Přečti si APT-HOWTO.

    Založit nové vláknoNahoru

    Tiskni Sdílej: Linkuj Jaggni to Vybrali.sme.sk Google Del.icio.us Facebook

    ISSN 1214-1267   www.czech-server.cz
    © 1999-2015 Nitemedia s. r. o. Všechna práva vyhrazena.