abclinuxu.cz AbcLinuxu.cz itbiz.cz ITBiz.cz HDmag.cz HDmag.cz abcprace.cz AbcPráce.cz
AbcLinuxu hledá autory!
Inzerujte na AbcPráce.cz od 950 Kč
Rozšířené hledání
×
eParkomat, startup z ČR, postoupil mezi finalisty evropského akcelerátoru ChallengeUp!
Robot na pivo mu otevřel dveře k opravdovému byznysu
Internet věcí: Propojený svět? Už se to blíží...
včera 21:21 | Nová verze Ladislav Hagara | Komentářů: 0
včera 11:44 | Zajímavý projekt

Na Indiegogo byla spuštěna kampaň na podporu herní mini konzole a multimediálního centra RetroEngine Sigma od Doyodo. Předobjednat ji lze již od 49 dolarů. Požadovaná částka 20 000 dolarů byla překonána již 6 krát. Majitelé mini konzole si budou moci zahrát hry pro Atari VCS 2600, Sega Genesis nebo NES. Předinstalováno bude multimediální centrum Kodi.

Ladislav Hagara | Komentářů: 0
včera 00:10 | Nová verze

Byla vydána verze 4.7 redakčního systému WordPress. Kódové označením Vaughan bylo vybráno na počest americké jazzové zpěvačky Sarah "Sassy" Vaughan. Z novinek lze zmínit například novou výchozí šablonu Twenty Seventeen, náhledy pdf souborů nebo WordPress REST API.

Ladislav Hagara | Komentářů: 1
6.12. 12:00 | Zajímavý projekt

Projekt Termbox umožňuje vyzkoušet si linuxové distribuce Ubuntu, Debian, Fedora, CentOS a Arch Linux ve webovém prohlížeči. Řešení je postaveno na projektu HyperContainer. Podrobnosti v často kladených dotazech (FAQ). Zdrojové kódy jsou k dispozici na GitHubu [reddit].

Ladislav Hagara | Komentářů: 24
6.12. 11:00 | Bezpečnostní upozornění

Byly zveřejněny informace o bezpečnostní chybě CVE-2016-8655 v Linuxu zneužitelné k lokální eskalaci práv. Chyba se dostala do linuxového jádra v srpnu 2011. V upstreamu byla opravena minulý týden [Hacker News].

Ladislav Hagara | Komentářů: 2
5.12. 22:00 | Komunita

Přibližně před měsícem bylo oznámeno, že linuxová distribuce SUSE Linux Enterprise Server (SLES) běží nově také Raspberry Pi 3 (dokumentace). Obraz verze 12 SP2 pro Raspberry Pi 3 je ke stažení zdarma. Pro registrované jsou po dobu jednoho roku zdarma také aktualizace. Dnes bylo oznámeno, že pro Raspberry Pi 3 je k dispozici také nové openSUSE Leap 42.2 (zprávička). K dispozici je hned několik obrazů.

Ladislav Hagara | Komentářů: 6
5.12. 06:00 | Zajímavý software

OMG! Ubuntu! představuje emulátor terminálu Hyper (GitHub) postavený na webových technologiích (HTML, CSS a JavaScript). V diskusi k článku je zmíněn podobný emulátor terminálu Black Screen. Hyper i Black Screen používají framework Electron, stejně jako editor Atom nebo vývojové prostředí Visual Studio Code.

Ladislav Hagara | Komentářů: 50
5.12. 06:00 | Zajímavý článek

I letos vychází řada ajťáckých adventních kalendářů. QEMU Advent Calendar 2016 přináší každý den nový obraz disku pro QEMU. Programátoři se mohou potrápit při řešení úloh z kalendáře Advent of Code 2016. Kalendáře Perl Advent Calendar 2016 a Perl 6 Advent Calendar přinášejí každý den zajímavé informace o programovacím jazyce Perl. Stranou nezůstává ani programovací jazyk Go.

Ladislav Hagara | Komentářů: 10
3.12. 16:24 | Nová verze

Byla vydána Mageia 5.1. Jedná se o první opravné vydání verze 5, jež vyšla v červnu loňského roku (zprávička). Uživatelům verze 5 nepřináší opravné vydání nic nového, samozřejmě pokud pravidelně aktualizují. Vydání obsahuje všechny aktualizace za posledního téměř půldruhého roku. Mageia 5.1 obsahuje LibreOffice 4.4.7, Linux 4.4.32, KDE4 4.14.5 nebo GNOME 3.14.3.

Ladislav Hagara | Komentářů: 17
3.12. 13:42 | Pozvánky

V Praze probíhá konference Internet a Technologie 16.2, volné pokračování jarní konference sdružení CZ.NIC. Konferenci lze sledovat online na YouTube. K dispozici je také archiv předchozích konferencí.

Ladislav Hagara | Komentářů: 0
Kolik máte dat ve svém domovském adresáři na svém primárním osobním počítači?
 (32%)
 (24%)
 (29%)
 (8%)
 (5%)
 (3%)
Celkem 785 hlasů
 Komentářů: 50, poslední 29.11. 15:50
Rozcestník
Reklama

Dotaz: Proxim Symphony a jadro 2.4.x

27.6.2002 11:30 miki
Proxim Symphony a jadro 2.4.x
Přečteno: 122×
Podařilo se někomu rozjet tuto kartu pod novým jádrem např. RH7.3 kernel 2.4.18-3 ? Mě se po velkém snažení podařilo zkompilovat modul rlmod, ovladač rl2-1.7.1(při kompilaci vyhazuje plno chyb,které jsem odstranil), ale stejně se mi nepodařilo kartu spustit(systém kartu normálně vidí jak Prox. Symph. na ISA PNP nepomohla ani ruční incializace insmod rlmod io=0x200 irq=5 , adresu i irq jsem různě zkoušel měnit a pořád mi to hlásí konflikt zařízení ..což je blbost ověřil jsem to v /proc). Ve RH7.0 s kernel 2.2.16 jede perfektně. Jestli máte někdo nějaké další zkušenosti tak budu rád za každé nakopnutí správným směrem :o)

Odpovědi

CIJOML avatar 2.9.2002 09:37 CIJOML | skóre: 58 | Praha
Rozbalit Rozbalit vše Proxim Symphony a jadro 2.4.x
Vyhod z konfigurace kernelu ISA PNP support a projdi zdrojaky a includuj misto malloc.h slab.h a potom to pojede.
13.9.2002 09:05 Miroslav Kriho | skóre: 12
Rozbalit Rozbalit vše Proxim Symphony a jadro 2.4.x
Jo dik moc za pomoc. Uz mi to funguje. V nejakem diskuznim foru jsem narazil na info, že u RedHat je treba: 1] v souboru lls.c vsechny radky s endif: #endif LINUX_VERSION_CODE zmenit na #endif /* LINUX_VERSION_CODE */ 2] zmenit malloc.h na slab.h v souboru lls.c 3] ve vzniklem souboru config.mk po configure zmenit radek na LINUXH = /lib/modules/2.4.7-10/build/include nebo 2.4.18-3 podle jadra
7.5.2003 20:22 clusk
Rozbalit Rozbalit vše Proxim Symphony a jadro 2.4.x
Ahoj, tak jsem to zkousel presne tak, jak je zde psano, ale porad mi nejde zavest modul rlmod.o do MDK 9.1 s jadrem 2.4.21-0.13 :-( Pri nabihani systemu to pise "unresolved symbols in rlmod.o", kdyz se pokusim zavest modul rucne "insmod rlmod.o", napise mi, ze je rlmod.o zkompilovan gcc verzi 2 a kernel verzi 3, takze ho taky nezavede. Nakonec jsem zkousel "insmod -f rlmod.o" - nasilne zavedeni, ale to taky zklamalo - vyhodilo mi to par "unresolved symbols" a konec:-( - jedna se o Proxim Symphony do PCI diky za jakoukoliv radu, uz jsem vazne zoufaly
17.5.2003 11:15 Miroslav Kriho | skóre: 12
Rozbalit Rozbalit vše Proxim Symphony a jadro 2.4.x
Chce to po tobě 2.x kompilator. Taky jsem to zkusil na RH8 a neslo mi to,ale je fakt že jsem na tom nebadal dal. Vratil jsem se na routeru k RH7.3 a jadro mam 2.4.20 opatchovane H323, xfs a jede jak z praku. Je fakt že na klientske stanici by bylo hezčí něco modernějšího třeba ta RH9 a nebo Mamdrake 9.1 Jeste s tim zkusim neco udelat pak bych to tu napsal jak jsem dopadnul s novější distribuci.
30.9.2004 15:40 slave
Rozbalit Rozbalit vše Re: Proxim Symphony a jadro 2.4.x
Cau,

mam ManDrake 10.0 Community a nainstaloval sem to s jadrem 2.4.25-2mdk a Proxim Symphony PCI card. Stahl jsem si drivery z odkazu co tady uverejnujete. Podle README (ktery neni az tak pro amatera jako jsem ja)

1. make sure your kernel supports loadable modules (to nevim jak :(
2. install the kernel sources - header files, 'make dep' (taky nevim co to chce)
3. make config (provede se nejaka konfigurace ale chce to veci jako treba toto:
When you execute "make install", the driver modules will be copied here.
The default of "REDHAT" will use redhat default locations whereever possible.
Module location? [REDHAT]:

to mam zadat nejakou cestu? resp. jakou chci? No pak jsem zkusil make modules modules_install a to vypsalo silene moc erroru...

Nenapsal by prosim Vas nekdo presnej postup jak se postupuje v instalaci tohoto modulu v tomto jadre? Nebo nemate nekdo odkaz na takovej postup? (postupy co jsou na netu jsou na me moc slozity)

Pokusim se sehnat nekoho kdo linuxu rozumi, ale nevim, jestli nekoho najdu. Potrebuju tam rozjet internet, bez nej jsem ztracenej. Chci pomalu prestoupit z WinXP na linux. V literature pro zacatecniky toto vubec ale pospany neni. Je jen postup ./configure, make, make install apod...

Diky Slave

31.7.2003 20:42 Martin Dařílek
Rozbalit Rozbalit vše Proxim Symphony a jadro 2.4.x
setkal jsem s úplně stejným problémem. Též používám MDK 9.1 a hlášku o rozdílných verzích dostávám též. Nicméně pomocí "insmod -f rlmod.o" lze ovladač - sice s upozorněními - zavést a zprovoznit. Na diskusním fóru k těmto ovladačům jsem našel tvrzení,že ta hláška o nekompatibilitě kompilátorů je způsobena starou verzí modulu dodávanéno v instalačním balíku, který je zkompilován pod starším jádrem (liblld.a). Bohužel k němu nejsou zdrojáky :-(
31.3.2004 14:23 Milan Dobeš | skóre: 22
Rozbalit Rozbalit vše Re: Proxim Symphony a jadro 2.4.x
Ahoj, zařazuji se do fronty nešťastníků se svým problémem. Instaluji Proxim Symphony na RH9 do 2 počítačů (P2P), jednu mám PCI a druhou ISA. Zatím instaluji ten s ISA kartou. Insmod mi hlásí totéž, -f ho zavedu ale abych to zprovoznil, musel jsem udělat několik akcí kterým nerozumím.
1. V RH9 není isapnptools, musel jsem si jej nainstalovat. To by celkem nevadilo.
2. V /etc/rc.d/rc.sysinit jsem musel upravit podmínku pro spouštění isapnp tak, aby netestovala existenci /proc/isapnp. PROČ??? Nepřehlédl jsem něco???
3. Nedokázal jsem to rozejet přes /etc/modules.conf pravděpodobně kvůli tomu parametru -f a musel jsem to dát do /etc/rc.d/rc.modules kde jsem to dokázal udělat jen jako eth0. Nedá se to udělat nějak lépe? Nepodařilo se Vám to někomu?
Díky předem za info!
31.3.2004 15:33 Honza
Rozbalit Rozbalit vše Re: Proxim Symphony a jadro 2.4.x
S touhle kartou jsem si uzil sve, ale kdyz uz se mi to podarilo rozjet zjistil jsem ze chyba vzdy byla mezi klavesnici a zidli :-(

Takze v prvni rade se podivej na jinou zdejsi diskusi.

A v druhe rade se znova zaber do dokumentace, protoze ty obezlicky co ti tadi radi, opravdu nechapu a to ze jsem to na RH 7.3 rozchazel a provozoval, nez jsem to vymenil za "normalni WiFi", nebot ty Symphony je fakt smejd, ale to je jina...
31.3.2004 15:59 Milan Dobeš | skóre: 22
Rozbalit Rozbalit vše Re: Proxim Symphony a jadro 2.4.x
Díky za odpověď, četl jsem taky! Kdybych si nebyl jistý že je to mezi klávesnicí a židli tak bych s tím neopruzoval. Že je to shid vím, ale potřebuji se spojit přes ulici na cca 20m a karty mi leží ve stole. Jinak jsem už o kousek dál, nainstaloval jsem i druhý stroj s tou PCI kartou a nějak mi nechtějí spolu ...a.t.d. Jinak na obou strojích už mám snad vše funkční, alespoň to nehlásí žádné problémy (mimo ten problematický "insmod -f rlmod"). Pomohla by mi funkční konfigurace master a slave pro P2P. Please nebyla by? (volání proxcfg pro master a pro slave). Díky předem! Jo a ještě jeden dotaz, fungovalo Vám to někomu na stole mezi sebou bez antén, nebo tam musí být něco připojeného?
31.3.2004 17:49 Honza
Rozbalit Rozbalit vše Re: Proxim Symphony a jadro 2.4.x
Uff, tak ted uz tu konfiguraci zrejme nemam - kouknu se doma, ale myslim ze uz je nekde na pravde bozi. Rozhodne to chce postupovat jak jsem psal v minule diskusi a kroky konzultovat s manualem. Podle mne je hloupe ze je v tolika souborech a proto jsem se v tom dost ztracel :(

A co se deje kdyz zkusis modul zavest pomoci modprobe?

Ja jsem to mel jako p2p spoj a pak i vetsi sit asi o 4 stanicich (a to byl hustej bordel :-) ). Kazdopadne podle man proxcfg jsem nejak nastavil kanal, a jmeno_domeny nebo neco v tom smyslu. Moc toho nebylo. Rozhodne u mastera to toho chce nastavit vic nez slave, ale to je jasny. Jo a take nezapomen na heslo ktery potrebujou pro vzajemnou komunikaci. Bez anten. No nevim, ale uz delsi dobu to mam v planu vyzkouset, protoze se mi doma valej dve tyhle karty, ale anteny jsou v prcicich.
1.4.2004 11:24 Honza
Rozbalit Rozbalit vše Re: Proxim Symphony a jadro 2.4.x
Tak ty konfiguraky uz nemam :-(
1.4.2004 11:36 Milan Dobeš | skóre: 22
Rozbalit Rozbalit vše Re: Proxim Symphony a jadro 2.4.x
Tak jsem to včera nakonec rozdejchal, mám to na RH9 se zkompilovaným vanila kernelem 2.4.20 patchnutým ABI knihovnou (ta s tím pochopitelně nesouvisí, potřebuji ji pro jiný SW). Na kompu s ISA kartou jsem musel dokompilovat isapnptools a v /etc/rc.d/rc.sysinit jsem musel upravit podmínku pro spouštění isapnp tak, aby netestovala existenci /proc/isapnp. Jinak se při startu kompu isapnp nespustil. V obou kompech se mi podařilo karty nastartovat pouze s pomocí /etc/rc.d/rc.modules, protože ovladače jsem musel instalovat "ismod -f rlmod ..." a v /etc/modules.conf konfigurace hlásila že karty nejsou přítomny.
Jinak modprobe a insmod normálně hlásí nekompatibilitu kompilátorů (viz výše) a ovladače nezavedou, nicméně insmod -f to jde natáhnout a funguje to.
Konfigurace je na obou strojích stejná, oba se spustí jako možný master a když se spojí, jeden z nich se masterem stane.
Jo a bez antén to "chodí" na přímou viditelnost 10 cm :-)
Díky moc za pomoc!!!

Založit nové vláknoNahoru

Tiskni Sdílej: Linkuj Jaggni to Vybrali.sme.sk Google Del.icio.us Facebook

ISSN 1214-1267   www.czech-server.cz
© 1999-2015 Nitemedia s. r. o. Všechna práva vyhrazena.