abclinuxu.cz AbcLinuxu.cz itbiz.cz ITBiz.cz HDmag.cz HDmag.cz abcprace.cz AbcPráce.cz
AbcLinuxu hledá autory!
Inzerujte na AbcPráce.cz od 950 Kč
Rozšířené hledání
×
    včera 20:22 | Komunita

    Byly zpracovány a na YouTube zveřejněny videozáznamy z konference LinuxDays 2026.

    Ladislav Hagara | Komentářů: 0
    včera 18:44 | Zajímavý software

    Německý startup Aleph Alpha k příležitosti výročí sjednocení Německa zveřejnil open-weight jazykový model Kolibri, vyvíjený s ohledem na unijní pojetí autorského práva, ochranu osobních údajů GDPR a nařízení EU o umělé inteligenci, jehož 'Kodexu správné praxe' je Aleph Alpha signatářem. Výsledkem tohoto přístupu je transparentnější technologie, kterou například budou moci využívat evropské veřejné instituce, ovšem za cenu

    … více »
    AfD 💙 | Komentářů: 1
    včera 18:33 | IT novinky

    Nvidia zveřejnila návrh nové bezpečnostní platformy pro nasazování AI agentů. Jedná se o nasazení AI za použití OpenShell a Sentry, dvou oddělených bezpečnostních vrstev, v nichž může Sentry monitorovat a vyhodnocovat chování AI v OpenShellu tak, že ho v krajním případě až vypne. Mělo by to zabránit dalším únikům AI ze sandboxu.

    vencour | Komentářů: 0
    3.10. 11:33 | Komunita

    Přímý přenos (YouTube) z konference LinuxDays 2026, jež probíhá tento víkend v Praze v prostorách FIT ČVUT. Na programu je spousta zajímavých přednášek.

    Ladislav Hagara | Komentářů: 2
    3.10. 02:44 | Nová verze

    Byla vydána nová verze 0.17.0 programovacího jazyka Zig (Codeberg, Wikipedie). Přispělo 206 vývojářů. Přehled novinek v poznámkách k vydání.

    Ladislav Hagara | Komentářů: 0
    2.10. 21:00 | Zajímavý projekt

    Open-source projekt OpenDLSS-NR je 'bitově přesná reimplementace' neuronové rendrovací sítě DLSS 5 od společnosti NVIDIA, jenže pro grafické API Vulkan (DLSS slouží k vylepšování klasickým způsobem vyrendrovaných snímků pomocí lokálních modelů umělé inteligence, a to v reálném čase). Projekt není nijak spojen se společností NVIDIA, je pouze pro OS Windows a natrénované váhy modelu si uživatelé musí obstarat sami. Zdrojový kód je k dispozici na GitHubu, pod licencí MIT s výjimkou pro komponenty třetích stran.

    AfD 💙 | Komentářů: 0
    2.10. 20:55 | Zajímavý software

    Společnost Cloudflare představila Clef a Clef-Flash, open-source rozhodovací modely určené pro rychlou a konzistentní klasifikaci vstupů. Na rozdíl od klasických LLM vracejí tyto modely deterministické striktně typované strukturované odpovědi s exaktními pravděpodobnostmi, tedy odpovědi ve stylu přelomového modelu Jev.

    … více »
    AfD 💙 | Komentářů: 1
    2.10. 04:44 | Nová verze

    Byla vydána beta verze Ubuntu 26.10 s kódovým názvem Stonking Stingray. Přehled novinek v poznámkách k vydání. Dle plánu by Ubuntu 26.10 mělo vyjít 15. října 2026.

    Ladislav Hagara | Komentářů: 0
    1.10. 22:22 | Nová verze

    Byla vydána verze 1.99.0 programovacího jazyka Rust (Wikipedie). Podrobnosti v poznámkách k vydání. Vyzkoušet Rust lze například na stránce Rust by Example.

    Ladislav Hagara | Komentářů: 5
    1.10. 18:11 | Komunita

    Od 13. do 15. října proběhne v Praze OpenSSL Conference 2026. Na YouTube lze zhlédnout videozáznamy přednášek z loňského roku.

    Ladislav Hagara | Komentářů: 0
    Které desktopové prostředí na Linuxu používáte?
     (9%)
     (7%)
     (4%)
     (21%)
     (29%)
     (8%)
     (5%)
     (2%)
     (14%)
     (20%)
    Celkem 2795 hlasů
     Komentářů: 31, poslední 13.8. 00:27
    Rozcestník

    Dotaz: VSFTPD hlásí could not bind...

    11.1.2005 16:35 Petr Dvořáček
    VSFTPD hlásí could not bind...
    Přečteno: 1901×
    Dobrý den.
    Uměl by někdo pomoci ? Už jsem z toho na budku.

    root@bart ~# ftp
    ftp> open
    (to) 10.10.1.1
    Connected to 10.10.1.1 (10.10.1.1).
    500 OOPS: could not bind listening IPv4 socket
    ftp> bye
    root@bart ~#

    Odpovědi

    11.1.2005 17:31 puco
    Rozbalit Rozbalit vše Re: VSFTPD hlásí could not bind...
    Ukaz aj vsftpd.conf, potom ti bude jednoduchsie pomoct.
    11.1.2005 19:03 Smazáno | skóre: 21 | blog: tezkorict
    Rozbalit Rozbalit vše Re: VSFTPD hlásí could not bind...
    Podle mě to nehlásí vsftpd, ale jen ten klient kterým se připojuješ.

    Obvykle ale takový hlášky vídám, když se coby nerůt snažím spustit něco poslouchajícího na privilegovaným portu.
    12.1.2005 00:40 puco
    Rozbalit Rozbalit vše Re: VSFTPD hlásí could not bind...
    Podla mna to je vsftpd, ten ma pravidelne hlasky typu 500 OOPS. A pripajam sa k tomu nazoru, ktory je trochu nizsie, s tym xinetd. Stale by sa hodilo videt ten vsftpd.conf :-)
    11.1.2005 19:17 Milan Hejpetr | skóre: 25 | blog: poznamky | Plzen
    Rozbalit Rozbalit vše Re: VSFTPD hlásí could not bind...
    Nemate nahodou vsftpd nastavene jako sluzbu inetd (xinetd) a ve vsftpd.conf soucasne s tim nastaveno, ze je vsftpd v rezimu daemon ? Podivejte se do vsftpd.conf a pripradne to opravte, aby to vypadalo takto:

    #enable for standalone mode listen=NO
    11.1.2005 19:19 Milan Hejpetr | skóre: 25 | blog: poznamky | Plzen
    Rozbalit Rozbalit vše Re: VSFTPD hlásí could not bind...
    Omlouvam se za spatne formatovani:
    #enable for standalone mode
    listen=NO
    12.1.2005 10:03 Petr Dvořáček
    Rozbalit Rozbalit vše Re: VSFTPD hlásí could not bind...
    Děkuji Vám Milane. Vaše rada pomohla.
    Teď když dám připojit se k FTP, tak skutečně to už běží.
    Akorát zase řeším problém, co dělám kde špatně, protože když zadám
    své uživatelské jméno a heslo, tak mě to nedovolí se k FTP přihlásit.

    /etc/vsftpd/vsftpd.conf
    ...
    # Uncomment this to allow local users to log in.
    local_enable=YES
    ...

    root@bart ~# ftp
    ftp> open
    (to) localhost
    Connected to localhost (127.0.0.1).
    220 (vsFTPd 1.2.2)
    Name (localhost:root): petr
    331 Please specify the password.
    Password:
    530 Login incorrect.
    Login failed.
    ftp> bye
    221 Goodbye.
    root@bart ~#

    Jsem si jist, že heslo zadávám správně.

    Uživatele jsem vytvářel následovně:
    useradd petr -m -G users,ftp,wheel -s /bin/bash
    passwd petr

    Poradíte mi prosím, co ještě dělám kde špatně ?
    S tímto VSFTPD mám tento problém jenom zde, kde ho volám pomocí xinetd.
    12.1.2005 10:40 Milan Hejpetr | skóre: 25 | blog: poznamky | Plzen
    Rozbalit Rozbalit vše Re: VSFTPD hlásí could not bind...
    Vypisuje to neco do systemoveho logu ? Napr. do /var/log/messages ?
    Mate v poradku PAM ? - napr. /etc/pam.d/vsftpd ?
    Neni uzivatel petr uveden v /etc/vsftpd.ftpusers ?
    Jak mate v konfiguraku nastavenu volbu userlist_deny= ? Je tam YES nebo NO ?
    12.1.2005 11:05 Petr Dvořáček
    Rozbalit Rozbalit vše Re: VSFTPD hlásí could not bind...
    Dobrý den.

    Ve /var/log/messages není o FTP (vsftpd) nic.
    Co se týká instalace VSFTPD, postupoval jsem dle tohoto návodu:
    http://doc.trustix.org/cgi-bin/trustixdoc.cgi?VsFTPd

    v /etc/vsftpd.ftpusers uživatele petr uveden není

    vsftpd.conf

    root@bart ~# cat /etc/vsftpd/vsftpd.conf
    # Example config file /etc/vsftpd/vsftpd.conf
    # # The default compiled in settings are fairly paranoid. This sample file
    # loosens things up a bit, to make the ftp daemon more usable.
    # Please see vsftpd.conf.5 for all compiled in defaults.
    #
    # READ THIS: This example file is NOT an exhaustive list of vsftpd options.
    # Please read the vsftpd.conf.5 manual page to get a full idea of vsftpd's
    # capabilities.
    #
    # Allow anonymous FTP? (Beware - allowed by default if you comment this out).
    anonymous_enable=NO
    #
    # Uncomment this to allow local users to log in.
    local_enable=YES
    #
    # Uncomment this to enable any form of FTP write command.
    #write_enable=YES
    #
    # Default umask for local users is 077. You may wish to change this to 022,
    # if your users expect that (022 is used by most other ftpd's)
    #local_umask=022
    #
    # Uncomment this to allow the anonymous FTP user to upload files. This only
    # has an effect if the above global write enable is activated. Also, you will
    # obviously need to create a directory writable by the FTP user.
    #anon_upload_enable=YES
    #
    # Uncomment this if you want the anonymous FTP user to be able to create
    # new directories.
    #anon_mkdir_write_enable=YES
    #
    # Activate directory messages - messages given to remote users when they
    # go into a certain directory.
    dirmessage_enable=YES
    #
    # Activate logging of uploads/downloads.
    xferlog_enable=YES
    #
    # Make sure PORT transfer connections originate from port 20 (ftp-data).
    connect_from_port_20=YES
    #
    # If you want, you can arrange for uploaded anonymous files to be owned by
    # a different user. Note! Using "root" for uploaded files is not
    # recommended!
    #chown_uploads=YES
    #chown_username=whoever
    #
    # You may override where the log file goes if you like.
    xferlog_file=/var/log/vsftpd
    #
    # If you want, you can have your log file in standard ftpd xferlog format
    xferlog_std_format=YES
    #
    # You may change the default value for timing out an idle session.
    #idle_session_timeout=600
    #
    # You may change the default value for timing out a data connection.
    #data_connection_timeout=120
    #
    # It is recommended that you define on your system a unique user which the
    # ftp server can use as a totally isolated and unprivileged user.
    nopriv_user=ftp
    #
    # Enable this and the server will recognise asynchronous ABOR requests. Not
    # recommended for security (the code is non-trivial). Not enabling it,
    # however, may confuse older FTP clients.
    #async_abor_enable=YES
    #
    # By default the server will pretend to allow ASCII mode but in fact ignore
    # the request. Turn on the below options to have the server actually do ASCII
    # mangling on files when in ASCII mode.
    # Beware that turning on ascii_download_enable enables malicious remote parties
    # to consume your I/O resources, by issuing the command "SIZE /big/file" in
    # ASCII mode.
    # These ASCII options are split into upload and download because you may wish
    # to enable ASCII uploads (to prevent uploaded scripts etc. from breaking),
    # without the DoS risk of SIZE and ASCII downloads. ASCII mangling should be
    # on the client anyway..
    #ascii_upload_enable=YES
    #ascii_download_enable=YES
    #
    # You may fully customise the login banner string:
    #ftpd_banner=Welcome to blah FTP service.
    #
    # You may specify a file of disallowed anonymous e-mail addresses. Apparently
    # useful for combatting certain DoS attacks.
    #deny_email_enable=YES
    # (default follows)
    #banned_email_file=/etc/vsftpd.banned_emails
    #
    # You may specify an explicit list of local users to chroot() to their home
    # directory. If chroot_local_user is YES, then this list becomes a list of
    # users to NOT chroot().
    chroot_local_user=YES
    #chroot_list_enable=YES
    # (default follows)
    #chroot_list_file=/etc/vsftpd.chroot_list
    #
    # You may activate the "-R" option to the builtin ls. This is disabled by
    # default to avoid remote users being able to cause excessive I/O on large
    # sites. However, some broken FTP clients such as "ncftp" and "mirror" assume
    # the presence of the "-R" option, so there is a strong case for enabling it.
    #ls_recurse_enable=YES

    pam_service_name=vsftpd
    userlist_enable=YES
    #enable for standalone mode
    listen=NO
    tcp_wrappers=YES
    # XXX:TSL -- Use /var/lib/vsftp/chroot as secure_chroot_dir.
    secure_chroot_dir=/var/lib/vsftp/chroot
    root@bart ~#
    12.1.2005 11:08 Petr Dvořáček
    Rozbalit Rozbalit vše Re: VSFTPD hlásí could not bind...
    Problém vyřešen.

    pam_service_name=vsftpd

    :-)
    12.1.2005 11:08 Petr Dvořáček
    Rozbalit Rozbalit vše Re: VSFTPD hlásí could not bind...
    Oprava:pam_service_name=ftp

    Založit nové vlákno • Nahoru

    Tiskni Sdílej: Linkuj Jaggni to Vybrali.sme.sk Google Del.icio.us Facebook

    ISSN 1214-1267   www.czech-server.cz
    © 1999-2015 Nitemedia s. r. o. Všechna práva vyhrazena.