abclinuxu.cz AbcLinuxu.cz itbiz.cz ITBiz.cz HDmag.cz HDmag.cz abcprace.cz AbcPráce.cz
AbcLinuxu hledá autory!
Inzerujte na AbcPráce.cz od 950 Kč
Rozšířené hledání
×
dnes 18:11 | Nová verze

Po půl roce vývoje od vydání verze 7.0.0 byla vydána verze 8.0.0 překladačové infrastruktury LLVM (Wikipedie). Přehled novinek v poznámkách k vydání: LLVM, Clang, clang-tools-extra, LLD a Libc++.

Ladislav Hagara | Komentářů: 0
dnes 17:44 | Nová verze

Bylo vydáno Eclipse IDE 2019-03 aneb Eclipse 4.11. Nově vychází toto vývojové prostředí čtvrtletně. Představení novinek na YouTube.

Ladislav Hagara | Komentářů: 0
dnes 01:11 | IT novinky

V říjnu loňského roku společnost Google představila hráčům počítačových her Project Stream umožňující streamování AAA her do webového prohlížeče Chrome. Včera na konferenci GDC 2019 (Game Developers Conference) společnost Google oficiálně představila (YouTube) pokračování projektu – herní platformu Stadia. V Česku a na Slovensku je služba Stadia zatím nedostupná.

Ladislav Hagara | Komentářů: 18
včera 23:11 | Nová verze

Byla vydána Java 12 / JDK 12. Nových vlastností (JEP - JDK Enhancement Proposal) je 8. Nová Java / JDK vychází každých 6 měsíců.

Ladislav Hagara | Komentářů: 1
včera 22:55 | Nová verze

Byla vydána verze 3.13 živé linuxové distribuce Tails (The Amnesic Incognito Live System), jež klade důraz na ochranu soukromí uživatelů a anonymitu. Přehled změn v příslušném seznamu. Řešena je také celá řada bezpečnostních chyb.

Ladislav Hagara | Komentářů: 0
včera 22:11 | Pozvánky

Březnový pražský sraz spolku OpenAlt se koná již tento čtvrtek – 21. 3. 2019 od 18:00 v Šenkýrně Hlubina (Lidická 37, Praha 5). Sejdeme se zase u dobrého piva a popovídáme si o tématech jako umění a technologie, IoT, CNC, svobodný software, hardware a další hračky. Pro zájemce budou tentokrát k dispozici i nějaké samolepky s GNU/Linuxovou tématikou.

xkucf03 | Komentářů: 0
včera 16:44 | Nová verze

Byl vydán Mozilla Firefox 66.0. Přehled novinek v poznámkách k vydání a na stránce věnované vývojářům. Nová verze řeší například problém s poskakováním obsahu, umí zabránit stránkám v automatickém přehrávání zvuků, přináší novou uvítací stránku anonymního prohlížení nebo zobrazuje podrobnější informace o neplatném certifikátu.

Ladislav Hagara | Komentářů: 4
včera 09:22 | IT novinky

Společnost NVIDIA představila (YouTube) jednodeskový počítač Jetson Nano Developer Kit s podporou CUDA. Koupit jej lze za 99 dolarů. Současně byl představen robot JetBot, stačí si jej vytisknout na 3D tiskárně a Jetson Nano do něj vložit.

Ladislav Hagara | Komentářů: 8
včera 01:22 | Nová verze

Po 13 měsících vývoje od vydání verze 1.20 byla vydána nová verze 1.22 grafického prostředí MATE (Wikipedie). Přehled nových vlastností a vylepšení v poznámkách k vydání. Zdůraznit lze podporu Waylandu.

Ladislav Hagara | Komentářů: 2
18.3. 19:55 | Komunita

Neziskové technologické konsorcium Linux Foundation minulý týden rozšířilo seznam svých projektů. Novinkou je CHIPS Alliance a Continuous Delivery Foundation (CDF). Spojením Node.js Foundation a JS Foundation vznikla OpenJS Foundation. Představena byla také platforma CommunityBridge nebo Red Team Project.

Ladislav Hagara | Komentářů: 0
Kolik balíčků (v tisících) máte nainstalovaných na svém systému?
 (4%)
 (13%)
 (34%)
 (30%)
 (19%)
 (3%)
 (2%)
 (1%)
 (3%)
Celkem 215 hlasů
 Komentářů: 19, poslední dnes 12:24
Rozcestník

Dotaz: alsa a zavislosti (gentoo)

16.1.2005 16:57 honza
alsa a zavislosti (gentoo)
Přečteno: 191×
ahoj, mam problem se zavislostmi. Distribuce Gentoo. Chci si do aplikaci zakompilovat podporu pro ALSA, ale alsa ovladace chci pouzivat z vanilla jadra (2.6.10). standartni prikaz: #USE="alsa" emerge -u esound mi vnucuje ovladace z gentoo-sources 2.4.28 (30MB). Chtel bych aby si je pripadne vzalo zdrojaky z std.cesty /usr/src/linux Jde mi o nainstalovani alsa-utils a moznost kompilace aplikace(knihoven,...) proti alsa(e). Jak toho dosahnout? Diky.

Odpovědi

16.1.2005 17:21 nobody
Rozbalit Rozbalit vše Re: alsa a zavislosti(gentoo)
Treba alsa-lib - to nema s jadrom nic spolocne. V 2.6.10 je alsa 1.0.6. V podstate vsetky verzie alsa-lib od 1.0.0 po 1.0.6 by mali ist.
16.1.2005 18:27 8an | skóre: 30
Rozbalit Rozbalit vše Re: alsa a zavislosti(gentoo)
Tohle je docela divný bug, mě to nic takového nedělá. Na kompilaci proti ALSA by měly stačit alsa-headers. Napadá mě, jestli jsi nepřecházel z 2.4 jádra a nemáš linux-headers místo linux26-headers.
If you build an operating system that even an idiot can use, only idiots will use it.
16.1.2005 18:45 honza
Rozbalit Rozbalit vše Re: alsa a zavislosti(gentoo)
No mozna na tom prechodu je, protoze ja jsem instaloval z LiveCD a tam jsem mel 2.4jadro. Hned jak se chrootnul a udelal nutne veci, prekompiloval jsem si kernel-2.6.10.
16.1.2005 18:55 honza
Rozbalit Rozbalit vše Re: alsa a zavislosti(gentoo)
tak jsem se podival a opravdu mam jen linux-headers.
16.1.2005 18:58 honza
Rozbalit Rozbalit vše Re: alsa a zavislosti(gentoo)
Jenze jak to jeste napravit ?
16.1.2005 20:06 Mortal | skóre: 26 | blog: mortals_log
Rozbalit Rozbalit vše Re: alsa a zavislosti(gentoo)
emerge -C linux-headers
emerge linux26-headers
V pekle jsou samé diskety a ďábel je velká disketová mechanika
16.1.2005 21:14 honza
Rozbalit Rozbalit vše Re: alsa a zavislosti(gentoo)
hmm, ale v aktualni portage tree je pro mne - linux26-headers-2.6.8.1-r2. Co vubec ty headers obsahuji? A k cemu vubec jsou ? Nevadi ze jadro mam 2.6.10 nemeli by odpovidat verze ?
16.1.2005 21:42 nobody
Rozbalit Rozbalit vše Re: alsa a zavislosti(gentoo)
Ake headers ??? Headers z jadra su potrebne len pri kompilacii alsa-lib, aj to som si nie isty - myslim si ze ani nie su potrebne. Treba nainstalovat alsa-lib 1.0.6 - a potom uz pojde kompilovat alsa-utils a zvysok.
16.1.2005 21:47 jm
Rozbalit Rozbalit vše Re: alsa a zavislosti(gentoo)
Jsou zejmena ke kompilaci glibc. Po jejich upgradu je vhodne prekompilovat i glibc. Ale hlavne: Ja vam vubec nerozumim, proc se proboha vrtate v nejakych linux26-headers, kdyz jadro 2.6 ma ALSA ovladace primo v sobe!

P.S. Ne, verze linux(26)-headers nemusi souhlasit s verzi jadra.
16.1.2005 22:06 Ctirad Feřtr | skóre: 43 | Praha
Rozbalit Rozbalit vše Re: alsa a zavislosti(gentoo)
Pokud je nainstalované jádro 2.6 a hlavičky od 2.4, tak rozhodně k žádným problémům s alsou nedochází (sám jsem na linux26-headers přecházel teprve před pár dny, kdežto jádro 2.6 používám měsíce).

Spíš se zdá, že jsou tam nějaké zapomenuté alsa-drivers, které se při emerge esound snaží updatovat a jako závislost si vzít (chybějící) kernel 2.4. Kdyby sem tazatel napsal výsledek z "emerge -uvp esound", tak by bylo vidět hned, která bije.
16.1.2005 22:48 honza
Rozbalit Rozbalit vše Re: alsa a zavislosti(gentoo)
Dobre. Sice to neni esound, ale : emerge -uvp xmms a vysledek:
Calculating dependencies ...done!
[ebuild  N    ] media-sound/alsa-headers-1.0.8_rc1  0 kB 
[ebuild  N    ] sys-kernel/gentoo-sources-2.4.28-r5  -build -doc -symlink 31,453 kB 
[ebuild  N    ] media-sound/alsa-driver-1.0.8_rc1  -debug -doc +oss 0 kB 
[ebuild  N    ] media-libs/alsa-lib-1.0.7  -doc -jack -static 660 kB 
[ebuild  N    ] media-libs/libmikmod-3.1.11-r1  +alsa -debug +esd +oss 597 kB 
[ebuild  N    ] media-libs/libogg-1.1.2  410 kB 
[ebuild  N    ] media-libs/libvorbis-1.1.0  -debug 1,281 kB 
[ebuild  N    ] app-arch/unzip-5.50-r2  1,043 kB 
[ebuild  N    ] media-sound/xmms-1.2.10-r5  -3dnow +alsa -cjk -debug -directfb
                +esd +ipv6 +mikmod +mmx +nls +oggvorbis +opengl +oss -xml 2,553 kB 
Total size of downloads: 37,999 kB
1/ nechci stahovat zbytecne novy kernel
2/ chci kompilovat aplikace proti Alsa
3/ chci mit moznost nainstalovat alsa-utils bez bodu 1/ (neumim nastavit v I/O pro zvuky a jejich ztiseni atpod)
16.1.2005 23:45 jt | skóre: 11
Rozbalit Rozbalit vše Re: alsa a zavislosti(gentoo)
Jestli nechces tahat novy kernel tak pridej do /etc/portage/package.mask
 >=sys-kernel/gentoo-sources-2.4.28-r5 
Jinak vrele doporucuji clanek na rootu.
17.1.2005 01:07 Ctirad Feřtr | skóre: 43 | Praha
Rozbalit Rozbalit vše Re: alsa a zavislosti(gentoo)
Aha, tak je to přesně jako jsem říkal. Máš tam úplně zbytečně "alsa-driver", který se týká jenom jádra 2.4 (a tudíž si ho tahá ssebou jako závislost). Unmergni ho a problém je vyřešen.
17.1.2005 02:11 xkesh | skóre: 46 | blog: eXtempore
Rozbalit Rozbalit vše Re: alsa a zavislosti(gentoo)
"If you use a 2.6 kernel, you may use the drivers provided in the kernel, but we still recommend that you use media-sound/alsa-driver as they are more up to date than what is provided in the kernel tree." Gentoo Linux ALSA Guide
17.1.2005 12:41 Ctirad Feřtr | skóre: 43 | Praha
Rozbalit Rozbalit vše Re: alsa a zavislosti(gentoo)
Zjevně pravá ruka neví co dělá levá :/
17.1.2005 19:02 Jan Kundrát (jkt) | skóre: 27 | blog: jkt | Praha - Bohnice
Rozbalit Rozbalit vše Re: alsa a zavislosti(gentoo)
a opravdu je lepsi rekompilovat dalsi package pri kazdym upgradu kernelu? proc? ta wikina je zrala na aktualizaci ;-)
17.1.2005 19:50 honza
Rozbalit Rozbalit vše Re: alsa a zavislosti(gentoo)
Hmm, a jak by jste to resil vy ?
17.1.2005 20:36 Jan Kundrát (jkt) | skóre: 27 | blog: jkt | Praha - Bohnice
Rozbalit Rozbalit vše Re: alsa a zavislosti(gentoo)
pouzival bych driver z vanilla kernelu. vlastne proc kondicional, ja ho taky pouzivam :-). a muzeme si tykat.
17.1.2005 20:50 honza
Rozbalit Rozbalit vše Re: alsa a zavislosti(gentoo)
no ja mam ve svem vanilla kernelu zakompilovanou podporu pro ALSU. Ja tady spis resim to, ze jsou nekde umisteny nejake zvlastni zavislosti.
17.1.2005 21:01 jm
Rozbalit Rozbalit vše Re: alsa a zavislosti(gentoo)
Viz nize ;-)
18.1.2005 00:41 Ctirad Feřtr | skóre: 43 | Praha
Rozbalit Rozbalit vše Re: alsa a zavislosti(gentoo)
Ta wikina nicméně nekecá ( i když je pravda, že dávat externí alsa drivery k jádru 2.6 je asi na nic), teď jsem zkoušel emergnout alsa-driver na instalci s jádrem 2.6 a jednou závislostí jsou alsa-headers. Pokud se tedy něco pokouší instalovat 2.4 kernel, je chyba jinde.
18.1.2005 13:22 honza
Rozbalit Rozbalit vše Re: alsa a zavislosti(gentoo)
Jedine na co jsem prisel, je ze hlavni zavislosti (u .ebuildu) jsou (u DEPEND) jen na alsa-lib. virtual/linux-sources pouziva prave jen alsa-drivers. Koukal jsem se na (alsa-*,...) a nenasel jsem zavislost, ktera by potrebovala zrovna alsa-drivers, ale presto mi to vnucuje.

Nebylo by snad jednodussi dat do USE="-alsa oss" a hotovo, ale neresilo by to tento zvlastni problem.
18.1.2005 13:54 jm
Rozbalit Rozbalit vše Re: alsa a zavislosti(gentoo)
Patrne pouzivate nejaky podivny domrseny profil, protoze nic podobneho to po me rozhodne nechce.
# USE="alsa" emerge -pv esound

These are the packages that I would merge, in order:

Calculating dependencies ...done!
[ebuild  N    ] media-libs/audiofile-0.2.6-r1  365 kB
[ebuild  N    ] media-sound/alsa-headers-1.0.8_rc1  1,843 kB
[ebuild  N    ] media-libs/alsa-lib-1.0.7  -doc -jack -static 660 kB
[ebuild  N    ] media-sound/esound-0.2.34  +alsa -ipv6 +tcpd 310 kB

Total size of downloads: 3,180 kB

# USE="alsa" emerge  --emptytree -pv esound

[ebuild  N    ] sys-kernel/linux26-headers-2.6.8.1-r2  -build 0 kB
...
[ebuild  N    ] sys-kernel/gentoo-dev-sources-2.6.10-r5 
                 -build -doc -symlink (-ultra1) 0 kB
...
[ebuild  N    ] media-sound/alsa-headers-1.0.8_rc1  1,843 kB
[ebuild  N    ] media-libs/alsa-lib-1.0.7  -doc -jack -static 660 kB
[ebuild  N    ] media-sound/esound-0.2.34  +alsa -ipv6 +tcpd 310 kB
Zkuste prikaz regenworld.
17.1.2005 19:41 honza
Rozbalit Rozbalit vše Re: alsa a zavislosti(gentoo)
Omluvte me, ale ja porad nevim jak ten problem vyresit. "Unemergni ho" ? ja jeste vubec nic nemam z tech alsa zavislosti zkompilovane. tudiz # emerge -C alsa-driver mi nepomuze. V systemu zatim toho mam velmi malo.
17.1.2005 20:19 jm
Rozbalit Rozbalit vše Re: alsa a zavislosti(gentoo)
Najdete podle toho vypisu ebuild, ktery misto virtual/alsa zavisi na alsa-driver, a napiste bug report.
17.1.2005 02:02 xkesh | skóre: 46 | blog: eXtempore
Rozbalit Rozbalit vše Re: alsa a zavislosti(gentoo)
emerge si pokud vim bere info o kernelu z /usr/src/linux, zkus pred tim zkontrolovat
ls -l /usr/src/linux
a kdyžtak:
# rm /usr/src/linux 
 
# cd /usr/src 
 
# ln -s linux-pozadovana-verze-jadra linux 
17.1.2005 06:11 honza
Rozbalit Rozbalit vše Re: alsa a zavislosti(gentoo)
mam pouze jedno a symlink mam vytvorenej
17.1.2005 20:41 Cyekona
Rozbalit Rozbalit vše Re: alsa a zavislosti(gentoo)
Ja mam ten samy problem s tim, ze mam alsa v jadre a nektere programy chteji pri kompilaci alsu, ta samozrejme pri snaze kompilace se zhrouti protoze uz je v jadre, parametr --nodeps to neresi, protoze ja chci jenom aby to netahalo alsu, kdyz uz ji mam. Nevedel by nekdo jak na to??
18.1.2005 00:34 Ctirad Feřtr | skóre: 43 | Praha
Rozbalit Rozbalit vše Re: alsa a zavislosti(gentoo)
Pokud je použité jádro 2.6 s jeho alsa drivery, je potřeba mít emergnuté pouze alsa-lib alsa-tools a alsa-utils. Pokud se používají externí alsa drivery (pro 2.4 i 2.6), tak je potřeba ještě alsa-driver a alsa-headers.
18.1.2005 15:30 WerK | skóre: 19 | blog: desktop
Rozbalit Rozbalit vše Re: alsa a zavislosti(gentoo)
jednoduche, mam taky 2.6 kernel a alsa ovladac primo v jadre a treba xmms brecelo ze chce alsa-driver a pritom alsa-driver se nezkompiluje protoze uz je v jadre. Reseni je snadne ... musite gentoo prinutit, aby si myslelo, ze driver uz ma : echo "media-sound/alsa-driver" >> /etc/portage/profile/package.provided A je po problemu :) v starsich verzich portage se to tusim delalo --inject media-sound/alsa-driver ale to uz je deprecadated
18.1.2005 16:09 Jarda Kotěšovec (athli) | skóre: 17 | blog: athli
Rozbalit Rozbalit vše Re: alsa a zavislosti(gentoo)
Ahoj,
ono je to resene tak, ze programy, ktere potrebuji alsu zavisi na virtual/alsa. Jako defaultni se instaluje alsa-drivers (viz /usr/portage/profiles/base/virtuals). Pointa je v tom, ze pokud si nainstalujete pres emerge 2.6 jadro, tak i to splnuje tu zavislost virtual/alsa. Konkretne to muzete vycist v eclassu ke kernelu - /usr/portage/eclass/kernel-2.eclass. Vzhledem k tomu, ze i pres emerge si muzete nainstalovat vanilla jadro, tak je to asi nejlogictejsi pristup. Jinak se da samozrejme vyuzit package.provided, jak pise WerK
18.1.2005 21:18 honza
Rozbalit Rozbalit vše Re: alsa a zavislosti(gentoo)
Problem byl timto vyresen. V podstate mi tato chyba vzniknula, protoze jsem nepouzil emerge pro nainstalovani jadra, ale stahl jsem si ho z meho usbcka, kde jsem ho mel jiz ulozen. Uzivatel byl timto poucen a ...

Diky moc za pomoc.

Založit nové vláknoNahoru

Tiskni Sdílej: Linkuj Jaggni to Vybrali.sme.sk Google Del.icio.us Facebook

ISSN 1214-1267   www.czech-server.cz
© 1999-2015 Nitemedia s. r. o. Všechna práva vyhrazena.