abclinuxu.cz AbcLinuxu.cz itbiz.cz ITBiz.cz HDmag.cz HDmag.cz abcprace.cz AbcPráce.cz
AbcLinuxu hledá autory!
Inzerujte na AbcPráce.cz od 950 Kč
Rozšířené hledání
×
dnes 00:55 | Komunita

Pocket (dříve Read It Later) (Wikipedie) je oblíbená služba umožňující uložit si článek z webu na později. V červnu 2015 s vydáním Firefoxu 38.0.5 se do té doby doplněk Pocket stal integrovanou součásti Firefoxu, a to i přes odpor celé řady uživatelů tohoto webového prohlížeče. Mozilla po měsících ustoupila a z integrované součásti se stal opět doplněk. Včera bylo oznámeno, že Mozilla službu Pocket kupila (Mozilla Blog, Pocket Blog).

Ladislav Hagara | Komentářů: 0
včera 23:55 | Pozvánky

Tentokrát jsme si pro vás připravili neobvyklou akci. Ve středu 1. 3. v 17:30 nás přivítá sdružení CZ.NIC ve svých prostorách v Milešovské ulici číslo 5 na Praze 3, kde si pro nás připravili krátkou prezentaci jejich činnosti. Následně navštívíme jejich datacentrum pod Žižkovskou věží. Provedou nás prostory, které jsou běžnému smrtelníkovi nedostupné!

… více »
xkucf03 | Komentářů: 0
včera 18:30 | Komunita

Jednodeskový počítač Raspberry Pi slaví již 5 let. Prodej byl spuštěn 29. února 2012. O víkendu proběhne v Cambridgi velká narozeninová party. Na YouTube bylo při této příležitosti zveřejněno video představující zajímavé projekty postavené na Raspberry Pi.

Ladislav Hagara | Komentářů: 0
včera 18:30 | Nová verze

Byla vydána verze 2017.1.1 svobodného multiplatformního leteckého simulátoru FlightGear. Kódový název a výchozí letiště této verze je Bergen. Přehled novinek v Changelogu.

Ladislav Hagara | Komentářů: 0
včera 10:50 | Zajímavý software

Mozilla.cz informuje o dvou nových experimentálních funkcích v programu Firefox Test Pilot (zprávička). Snooze Tabs slouží k odkládání panelů na později. Pokud vám někdo pošle odkaz, ale vy nemáte čas si stránku hned přečíst, můžete si naplánovat otevření panelu na později. Stačí kliknout na tlačítko a vybrat, kdy chcete panel otevřít. Firefox panel schová a ve vybraný čas znovu otevře. Pulse umožňuje ohodnotit, jak dobře stránka funguje, např. jak rychle se ve Firefoxu načetla. Podle nasbíraných hodnocení pak bude Mozilla prohlížeč ladit.

Ladislav Hagara | Komentářů: 6
včera 02:00 | IT novinky

V Barceloně probíhá veletrh Mobile World Congress 2017. Nokia na něm například představila (360° video na YouTube) novou Nokii 3310 (YouTube). BlackBerry představilo BlackBerry KEYone (YouTube) s QWERTY klávesnicí. LG představilo LG G6 (YouTube). Huawei HUAWEI P10 a P10 Plus. Samsung představil tablet Galaxy Tab S3.

Ladislav Hagara | Komentářů: 1
26.2. 14:00 | Nová verze

Komunita kolem Linuxu From Scratch (LFS) vydala Linux Linux From Scratch 8.0 a Linux From Scratch 8.0 se systemd. Nové verze knih s návody na instalaci vlastního linuxového systému ze zdrojových kódů přichází především s Glibc 2.25 a GCC 6.3.0. Současně bylo oznámeno vydání verze 8.0 knih Beyond Linux From Scratch (BLFS) a Beyond Linux From Scratch se systemd.

Ladislav Hagara | Komentářů: 0
26.2. 11:11 | Nová verze

Byla vydána verze 0.10.0 webového prohlížeče qutebrowser (Wikipedie). Přehled novinek v příspěvku na blogu. Vývojáři qutebrowseru kladou důraz na ovladatelnost pomocí klávesnice a minimální GUI. Inspirovali se prohlížečem dwb a rozšířeními pro Firefox Vimperator a Pentadactyl. Prohlížeč qutebrowser je naprogramován v Pythonu a využívá PyQt5. Zdrojové kódy jsou k dispozici na GitHubu pod licencí GNU GPL 3.

Ladislav Hagara | Komentářů: 33
25.2. 16:22 | Nová verze

Po pěti měsících od vydání Waylandu a Westonu 1.12.0 oznámil Bryce Harrington (Samsung) vydání Waylandu 1.13.0 a Westonu 2.0.0.

Ladislav Hagara | Komentářů: 6
24.2. 13:37 | Bezpečnostní upozornění

Společnost Cloudflare (Wikipedie) na svém blogu potvrdila bezpečnostní problém s její službou. V požadovaných odpovědích od reverzní proxy byla odesílána také data z neinicializované paměti. Útočník tak mohl získat cookies, autentizační tokeny, data posílaná přes HTTP POST a další citlivé informace. Jednalo se o chybu v parsování HTML. Zneužitelná byla od 22. září 2016 do 18. února 2017. Seznam webů, kterých se bezpečnostní problém potenciálně týká na GitHubu.

Ladislav Hagara | Komentářů: 1
Jak se stavíte k trendu ztenčování přenosných zařízení (smartphony, notebooky)?
 (13%)
 (2%)
 (72%)
 (3%)
 (10%)
Celkem 727 hlasů
 Komentářů: 69, poslední dnes 01:02
    Rozcestník

    Dotaz: dve verce gcc a glibc

    8.5.2005 00:02 psYcOder | skóre: 5
    dve verce gcc a glibc
    Přečteno: 73×
    Zdravim,uz jsem se na neco podobneho ptal,ikdyz diskuze nedosla ke zdarnemu reseni. Ted to mam trochu jinak. Chci vedet zda by mohla fungovat tato teorie: Na systemu(s distribici slack 10.1 => glibc 2.3.4,gcc 3.3.4) jestli je mozne nainstalovat druhou/starsi verzi glibc gcc. System by normalne pouzivat svou novejsi verzi gcc a glibc,ale pri kompilaci jisteho programu musim pouzit starsi verzi gcc i glibc,nicmene pro aktualni system potrebuji novejsi verze. Nainstalovat starsi verzi zpusobem,ze bych udelal skript(neco ve smyslu switchto), ktery by prepsal symlinky bud na starsi/novejsi. Podle me by toteoreticky fungovat mohlo,kdyz by se switchto pouzil pouze na kompilaci programu. Ale nez si rozhrabu totalne system,tak bych se radeji poradil. Eventuelne jestle nekdo resil podobny problem. Predem dekuji

    Odpovědi

    8.5.2005 00:11 VícNežNic | skóre: 42 | blog: Spáleniště | Ne dost daleko
    Rozbalit Rozbalit vše Re: dve verce gcc a glibc
    Manipulovat s glibc je velmi spolehlivá a poměrně rychlá cesta jak zrušit systém :-)
    Copak toho není dost?
    8.5.2005 00:18 Jorgito
    Rozbalit Rozbalit vše Re: dve verce gcc a glibc
    de to, podivej se napriklad na crossgcc.billgatliff.com anebo maillist na redhatu sources.redhat.com/ml/crossgcc

    v zasade jde o to udelat uplne novy toolchain, to znamena binutils+kern.headers+gcc+glibc

    potom kdyz budes prekladat si budes muset davat pozor proti cemu to budes linkovat... ps:dalsi info jak si udelat toolchain muzes najit na lfs (linux from scratch)
    8.5.2005 00:19 Jorgito
    Rozbalit Rozbalit vše Re: dve verce gcc a glibc
    doporucuju delat ten toolchain nekde v /home adresari....kdyz budes potrebovat info tak dej vedet...
    8.5.2005 00:26 VícNežNic | skóre: 42 | blog: Spáleniště | Ne dost daleko
    Rozbalit Rozbalit vše Re: dve verce gcc a glibc
    Já neříkám, že to nejde :-) Já jenom odrazuji od manipulace s tou glibc, která je v /lib a je s ní slinkovaný celý systém.
    Copak toho není dost?
    8.5.2005 00:22 Michal Marek (twofish) | skóre: 55 | blog: { display: blog; } | Praha
    Rozbalit Rozbalit vše Re: dve verce gcc a glibc
    Mít víc verzí gcc je docela běžné, glibc jedině tak nainstalovat do zvláštního adresáře a použít -I/.../include při překladu, -L/.../lib při linkování a LD_LIBRARY_PATH=/.../lib při spouštění programu... což je pořád šílenost (*), takže lepší bude opravit ten program, když od něj jsou zdrojáky.

    (*) problém budou třeba knihovny používané tím programem, které jsou kompilované proti novější glibc, Takže by asi bylo potřeba překompilovat všechno, s čím se ten program linkuje.

    PS: pokud by ses přesto chtěl vrtat v /lib, tak si předem nainstaluj staticky linkovaný busybox ;-)
    8.5.2005 00:27 jorge sanchez | skóre: 4
    Rozbalit Rozbalit vše Re: dve verce gcc a glibc
    Mít víc verzí gcc je docela běžné, glibc jedině tak nainstalovat do zvláštního adresáře a použít -I/.../include při překladu, -L/.../lib při linkování a LD_LIBRARY_PATH=/.../lib při spouštění programu... což je pořád šílenost

    no pokud da LDFLAGS="-all-static" tak uz se mu to linkovat nebude.... (po prekladu to muzes vzdycky zkontrolvat ldd neco)

    pokud se pletu tak se omlouvam...
    8.5.2005 11:11 Michal Marek (twofish) | skóre: 55 | blog: { display: blog; } | Praha
    Rozbalit Rozbalit vše Re: dve verce gcc a glibc
    libnss* věci se normálně nahrávají za běhu dynamicky, takže hrátkám s LD_LIBRARY_PATH se nejspíš nevyhne, kromě toho by si se statickým linkováním jen přidělával práci... Ale zkusit to může :-)

    PS: -all-static je option libtoolu, ne samotného linkeru.
    8.5.2005 00:37 Ondřej Kubečka | skóre: 29 | blog: datlovo | Ulm
    Rozbalit Rozbalit vše Re: dve verce gcc a glibc
    Nejsem si jisty, jak svuj dotaz myslíte, totiž jde-li vám skutečně o jiné verze GCC i glibc nebo jste to jenom spojil v jedno nedopatřením?

    Nicméně, nakolik rozumím vašemu dotazu:

    Je to možné celkem neproblematicky. Osobně kvůli některých starších projektů, které si s GCC3 (4 jsem na ně ani nezkoušel) nerozumí používám na systému i gcc 2.95.3.

    Různí lidé mají různé zvyky, já ho umístil do samostatného stromu v /opt/gcc-2.95.3 a do /etc/ld.so.conf jsem nakonec přidal řádek
       /opt/gcc-2.95.3/lib
    
    Resp. jsem si vyrobil balíček, který se o to postará (případně mohu asi nějak poskytnout).

    A obecně:

    Pokud chcete pouze některé aplikace dynamicky linkovat proti jiné verzi knihovny, kterou umístíte v samostatném stromě a kterou nechcete přidávat do prohledávaných cest dynamického linkování pro celý systém (/etc/ld.so.conf), můžete aplikaci při kompilaci poradit, kde má hledat, a při běhu ji pak cesty k příslušným verzím přídat v "obalovacím" skriptu pomocí proměnné LD_LIBRARY_PATH.

    Snad alespoň něco z toho pomůže. :)
    8.5.2005 00:41 Ondřej Kubečka | skóre: 29 | blog: datlovo | Ulm
    Rozbalit Rozbalit vše Re: dve verce gcc a glibc
    Tak se omlouvám: Koukám, že než to člověk sesmolí, tak je zodpovězeno. :)
    8.5.2005 02:42 psYcOder | skóre: 5
    Rozbalit Rozbalit vše Re: dve verce gcc a glibc
    dekuji,nic mene projekt pouziva pouze 3 knihovny,kde hlavni je Inti,a kvuli ni potrebuji downgrade glibc a downgrade gcc kvuli kompliaci vlastniho projektu, takze risknu cestu instalaci gcc 2.95,kterou potrebuji a prekompilaci onych tri knhoven,za snad ne-naivniho predpokladu,ze nebudu muset prekompilavat nejake systemove knihovny. Jevi se to jako nejefektivnejsi cesta. Vas balicek by mi nejspis byl dost uzitecny,takze Vas o nej zadam,viz zaslany email. Ale naskyta se mi otazka instalace starsi verze,zda mi jeste muzete poradit. Uz ted je jasne ze starsi versi gcc nebud moci instalovat z bin.balicku ale kompilaci ze zdroje. ./configure --prefix- /op/staragcc ...atd ale jestli nebude vadit,kdyzbudu kompilovat gcc 2.95 novejsi/aktualni/ verzi gcc 3.x.? V pondeli se do toho pustim a kdyztak dam jeste echo... Dekuji za navrhy reseni.
    17.12.2005 15:56 maxtractor
    Rozbalit Rozbalit vše Re: dve verce gcc a glibc
    Ahoj,

    mohl bych o tento balicek poprosit? Pouzivam
    Fedora Core 4
    a kvuli programu Network Simulator 2 potrebuji gcc-2.95.3 nainstalovat. Stahl jsem si z ftp://ftp.gnu.org/pub/gnu/gcc/ zdroje gcc-everything-2.95.3.tar.gz, ale nevim presne, jak a co instalovat tak, aby se mi to naistalovalo paralelne se soucasnyma gcc a neznicil jsem si cely linux. Dekuji predem za pripadny balicek ci jakykoliv navod, jak postupovat.

    Petr

    Založit nové vláknoNahoru

    Tiskni Sdílej: Linkuj Jaggni to Vybrali.sme.sk Google Del.icio.us Facebook

    ISSN 1214-1267   www.czech-server.cz
    © 1999-2015 Nitemedia s. r. o. Všechna práva vyhrazena.