abclinuxu.cz AbcLinuxu.cz itbiz.cz ITBiz.cz HDmag.cz HDmag.cz abcprace.cz AbcPráce.cz
AbcLinuxu hledá autory!
Inzerujte na AbcPráce.cz od 950 Kč
Rozšířené hledání
×

dnes 01:00 | Nová verze

Oficiálně bylo vydáno Ubuntu 18.04 LTS s kódovým názvem Bionic Beaver. Tato verze s prodlouženou podporou bude podporována 5 let, tj. do dubna 2023. Přehled novinek a také odkazy na oficiální deriváty v poznámkách k vydání.

Ladislav Hagara | Komentářů: 3
včera 23:00 | Nová verze

Po osmi letech od prvního commitu byla vydána verze 1.0 webového frameworku Flask (Wikipedie) napsaného v Pythonu. Přehled novinek v oznámení o vydání. Instalovat lze z PyPI. Odstraněna byla podpora Pythonu 2.6 a 3.3.

Ladislav Hagara | Komentářů: 0
včera 16:22 | Zajímavý článek

Nadace Raspberry Pi vydala devětašedesáté číslo (pdf) anglicky psaného časopisu MagPi věnovanému Raspberry Pi a projektům postaveným na tomto jednodeskovém počítači a šesté číslo (pdf) časopisu pro kutily HackSpace věnovanému navíc 3D tisku, pájení, řezání nebo i elektronice a IoT.

Ladislav Hagara | Komentářů: 0
včera 14:11 | Komunita

Byl zveřejněn seznam 44 osob přijatých do programu Outreachy od 14. května do 14. srpna 2018. Cílem programu Outreachy je přitáhnout do světa svobodného a otevřeného softwaru lidi ze skupin, jež jsou ve světě svobodného a otevřeného softwaru málo zastoupeny.

Ladislav Hagara | Komentářů: 13
včera 11:44 | Nová verze

Glen MacArthur vydal verzi 2018.4.2 na Debianu založené linuxové distribuce optimalizované pro tvůrce audio a video obsahu AV Linux (Wikipedie). Podrobnosti v oznámení o vydání a v stotřicetistránkovém manuálu (pdf).

Ladislav Hagara | Komentářů: 1
25.4. 23:33 | Nová verze

Byla vydána nová stabilní verze 1.15 (1.15.1147.36) webového prohlížeče Vivaldi (Wikipedie). Z novinek lze zdůraznit možnost nastavení vlastního pozadí okna, přístup k záložkám z hlavního menu, lepší ovládatelnost v režimu celé obrazovky nebo vyřešení problémů se zvukem v HTML5. Nejnovější Vivaldi je postaveno na Chromiu 65.0.3325.183.

Ladislav Hagara | Komentářů: 0
25.4. 17:22 | Nová verze

Node.js Foundation, oficiální projekt konsorcia Linux Foundation, oznámila vydání verze 10.0.0 otevřeného multiplatformního prostředí pro vývoj a běh síťových aplikací napsaných v JavaScriptu Node.js (Wikipedie). Verze 10 se v říjnu stane novou aktivní LTS verzí. Podpora je plánována do dubna 2021.

Ladislav Hagara | Komentářů: 0
25.4. 15:33 | Nová verze

Neal Cardwell ze společnosti Google oznámil zveřejnění verze 2.0 nástroje pro testování síťového stacku packetdrill. Jde o souhrnné vydání změn z interního vývoje od roku 2013.

Michal Kubeček | Komentářů: 0
25.4. 13:22 | Zajímavý software

Microsoft na svém blogu oznámil, že správce knihoven pro C++ Vcpkg (VC++ Packaging Tool) lze nově používat také na Linuxu a macOS. Aktuálně je pro Linux k dispozici více než 350 knihoven [reddit].

Ladislav Hagara | Komentářů: 1
25.4. 12:44 | Komunita

Byly zveřejněny exploity na Nintendo Switch a platformu Tegra X1: Fusée Gelée a ShofEL2. Jejich zneužití nelze zabránit softwarovou aktualizací. Na druhou stranu exploity umožní na Nintendo Switch snadno a rychle nainstalovat Linux, viz. ukázka na YouTube. Jenom je potřeba sáhnout na hardware.

Ladislav Hagara | Komentářů: 0
Používáte na serverech port knocking?
 (3%)
 (7%)
 (47%)
 (26%)
 (18%)
Celkem 388 hlasů
 Komentářů: 29, poslední 5.4. 12:25
    Rozcestník

    Dotaz: Problem pri includovani libwnck ve svem programu

    29.12.2005 09:40 Martin
    Problem pri includovani libwnck ve svem programu
    Přečteno: 137×
    Zdravim, snazim se napsat jednoduchy program pouzivajici libwnck. Normalne jsem si knihovnu stahl, svatou trojici nainstaloval, ale kdyz ji includuju do uplne prazdneho programu (int main(){}), gcc4.0 mi to stejne odmitne zkompilovat a vyhodi furu chyb typu
    /usr/local/include/libwnck-1.0/libwnck/screen.h:123: error: expected constructor, destructor, or type conversion before ‘*’ token
    /usr/local/include/libwnck-1.0/libwnck/screen.h:124: error: expected constructor, destructor, or type conversion before ‘*’ token
    /usr/local/include/libwnck-1.0/libwnck/screen.h:129: error: ‘gboolean’ does not name a type
    /usr/local/include/libwnck-1.0/libwnck/screen.h:131: error: ‘gulong’ does not name a type
    /usr/local/include/libwnck-1.0/libwnck/screen.h:134: error: ‘gboolean’ does not name a type
    /usr/local/include/libwnck-1.0/libwnck/screen.h:136: error: ‘gboolean’ has not been declared
    /usr/local/include/libwnck-1.0/libwnck/screen.h:148: error: ‘G_END_DECLS’ does not name a type
    /usr/local/include/libwnck-1.0/libwnck/application.h:43: error: ‘GObject’ does not name a type
    /usr/local/include/libwnck-1.0/libwnck/application.h:50: error: ‘GObjectClass’ does not name a type
    /usr/local/include/libwnck-1.0/libwnck/application.h:53: error: ‘WnckApplication’ has not been declared
    /usr/local/include/libwnck-1.0/libwnck/application.h:56: error: ‘WnckApplication’ has not been declared
    /usr/local/include/libwnck-1.0/libwnck/application.h:59: error: ‘GType’ does not name a type
    /usr/local/include/libwnck-1.0/libwnck/application.h:61: error: expected constructor, destructor, or type conversion before ‘*’ token
    /usr/local/include/libwnck-1.0/libwnck/application.h:63: error: ‘gulong’ does not name a type
    /usr/local/include/libwnck-1.0/libwnck/application.h:65: error: expected constructor, destructor, or type conversion before ‘*’ token
    /usr/local/include/libwnck-1.0/libwnck/application.h:66: error: ‘WnckApplication’ was not declared in this scope
    /usr/local/include/libwnck-1.0/libwnck/application.h:66: error: ‘app’ was not declared in this scope
    /usr/local/include/libwnck-1.0/libwnck/application.h:73: error: ‘WnckApplication’ was not declared in this scope
    
    (ve skutecnosti je jich asi ctyrikrat vic)

    Zkousel jsem nainstalovat hned nekolik verzi libwnck (predchozi jsem samozrejme odinstalovaval), ale nijak to nepomohlo. Taky jsem zkousel gcc3.2, to taky nepomohlo. BTW, ten includovaci adresar se sice jmenuje vzdycky libwnck-1.0, ale verze co jsem zkousel byly 2.6, 2.10 a 2.13.

    Odpovědi

    Fuky avatar 29.12.2005 17:16 Fuky | skóre: 52 | blog: 4u
    Rozbalit Rozbalit vše Re: Problem pri includovani libwnck ve svem programu

    Myslím, že Ti chybí knihovny, které libwnck využívá.

    #define WNCK_I_KNOW_THIS_IS_UNSTABLE
    
    #include >libwnck/libwnck.h<
    
    int main (void) 
    {
    }
    

    Příkaz pro překlad:

    gcc $(pkg-config --cflags libwnck-1.0) main.c

    Výstup pkg-config --cflags libwnck-1.0:

    -DXTHREADS -I/usr/include/libwnck-1.0 -I/usr/include/gtk-2.0 -I/usr/lib/gtk-2.0/include -I/usr/X11R6/include -I/usr/include/atk-1.0 -I/usr/include/pango-1.0 -I/usr/include/freetype2 -I/usr/include/glib-2.0 -I/usr/lib/glib-2.0/include
    29.12.2005 17:21 zabza | skóre: 52 | blog: Nad_sklenkou_cerveneho
    Rozbalit Rozbalit vše Re: Problem pri includovani libwnck ve svem programu
    Mandriva 2006
    [ivok@zero ~]$ rpm -qa|grep libwnck
    libwnck-1_16-2.10.3-3mdk
    libwnck-1_16-devel-2.10.3-3mdk
    libwnck-2.10.3-3mdk
    [ivok@zero ~]$ cat x.c 
    #include "libwnck/libwnck.h"
    
    int main () {
            return 0;
    }
    [ivok@zero ~]$ gcc x.c `pkg-config --libs --cflags libwnck-1.0`                 In file included from /usr/include/libwnck-1.0/libwnck/libwnck.h:28,
                     from x.c:1:
    /usr/include/libwnck-1.0/libwnck/window.h:26:2: error: #error "libwnck should only be used if you understand that it's subject to frequent change, and is not supported as a fixed API/ABI or as part of the platform"
    [ivok@zero ~]$ gcc x.c `pkg-config --libs --cflags libwnck-1.0` -DWNCK_I_KNOW_THIS_IS_UNSTABLE
    [ivok@zero ~]$ 
    
    2.1.2006 10:17 Martin
    Rozbalit Rozbalit vše Re: Problem pri includovani libwnck ve svem programu
    Hura, ted uz to zkompiluju, diky moc !

    Ovsem kdyz se pokusim pouzit jakoukoliv funkci libwnck, treba wnck_screen_get_active_workspace nebo wnck_screen_get_default, kompilator mi vzdycky hlasi, ze ji nezna :-( :
    /tmp/ccYLqwIy.o(.text+0xd7): In function `main':
    main.cpp: undefined reference to `wnck_screen_get_default'
    /tmp/ccYLqwIy.o(.text+0xe0):main.cpp: undefined reference to `wnck_screen_get_active_workspace'
    /tmp/ccYLqwIy.o(.text+0xf1):main.cpp: undefined reference to `wnck_workspace_get_number'
    collect2: ld returned 1 exit status
    Nebijte mne prosim, jestli je to nejaka blbost, ja se C++ teprve ucim...
    Fuky avatar 2.1.2006 10:58 Fuky | skóre: 52 | blog: 4u
    Rozbalit Rozbalit vše Re: Problem pri includovani libwnck ve svem programu

    $ gcc $(pkg-config --cflags --libs libwnck-1.0) main.c

    Ještě jsem zapomněl přidat flag --libs.

    2.1.2006 11:02 Martin
    Rozbalit Rozbalit vše Re: Problem pri includovani libwnck ve svem programu
    Jo, ted uz se to zkompiluje bez problemu :-). Moc diky !

    Založit nové vláknoNahoru

    Tiskni Sdílej: Linkuj Jaggni to Vybrali.sme.sk Google Del.icio.us Facebook

    ISSN 1214-1267   www.czech-server.cz
    © 1999-2015 Nitemedia s. r. o. Všechna práva vyhrazena.