abclinuxu.cz AbcLinuxu.cz itbiz.cz ITBiz.cz HDmag.cz HDmag.cz abcprace.cz AbcPráce.cz
AbcLinuxu hledá autory!
Inzerujte na AbcPráce.cz od 950 Kč
Rozšířené hledání
×

včera 12:00 | Nová verze

Po cca 3 týdnech od vydání Linux Mintu 18.3 s kódovým jménem Sylvia a prostředími MATE a Cinnamon byla oznámena také vydání s prostředími KDE a Xfce. Podrobnosti v poznámkách k vydání (KDE, Xfce) a v přehledech novinek s náhledy (KDE, Xfce). Linux Mint 18.3 je podporován do roku 2021.

Ladislav Hagara | Komentářů: 6
15.12. 12:55 | Nová verze

Byla vydána verze 17.12.0 KDE Aplikací (KDE Applications). Přehled novinek v kompletním seznamu změn a na stránce s dalšími informacemi. Aplikace, které nebyly dosud portovány na KDE Frameworks 5, byly z KDE Aplikací odstraněny.

Ladislav Hagara | Komentářů: 51
15.12. 03:00 | Komunita

Na Humble Bundle lze získat počítačovou hru Company of Heroes 2 (Wikipedie, YouTube) běžící také v Linuxu zdarma. Speciální akce končí v sobotu v 19:00.

Ladislav Hagara | Komentářů: 0
15.12. 02:00 | Zajímavý software

Christian Kellner představil na svém blogu projekt Bolt řešící bezpečnost rozhraní Thunderbolt 3 na Linuxu. Pomocí příkazu boltctl nebo rozšíření GNOME Shellu lze komunikovat s démonem boltd a například zakázat neznámá zařízení a předejít tak útokům typu Thunderstrike nebo DMA.

Ladislav Hagara | Komentářů: 8
15.12. 01:00 | Nová verze

Po půl roce vývoje od vydání verze 11.0 byla vydána verze 11.1 svobodného softwaru pro vytváření datových úložišť na síti FreeNAS (Wikipedie). Nejnovější FreeNAS je postaven na FreeBSD 11.1. Přehled novinek v příspěvku na blogu. Zdůraznit lze zvýšení výkonu OpenZFS, počáteční podporu Dockeru nebo synchronizaci s cloudovými službami Amazon S3 (Simple Storage Services), Backblaze B2 Cloud, Google Cloud a Microsoft Azure

Ladislav Hagara | Komentářů: 0
14.12. 23:55 | Nová verze

Po dvou měsících vývoje od vydání verze 235 oznámil Lennart Poettering vydání verze 236 správce systému a služeb systemd (GitHub, NEWS).

Ladislav Hagara | Komentářů: 10
14.12. 20:00 | Nová verze Ladislav Hagara | Komentářů: 0
14.12. 19:33 | Pozvánky

Pražská Fedora 27 Release Party, oslava nedávného vydání Fedory 27, se uskuteční 19. prosince od 19:00 v prostorách společnosti Etnetera (Jankovcova 1037/49). Na programu budou přednášky o novinkách, diskuse, neřízený networking atd.

Ladislav Hagara | Komentářů: 0
14.12. 18:11 | Nová verze

Byla vydána verze 2.11.0 QEMU (Wikipedie). Přispělo 165 vývojářů. Provedeno bylo více než 2 000 commitů. Přehled úprav a nových vlastností v seznamu změn.

Ladislav Hagara | Komentářů: 0
14.12. 17:44 | Komunita

Canonical oznámil dostupnost kryptografických balíčků s certifikací FIPS 140-2 úrovně 1 pro Ubuntu 16.04 LTS pro předplatitele podpory Ubuntu Advantage Advanced. Certifikace FIPS (Federal Information Processing Standards) jsou vyžadovány (nejenom) vládními institucemi USA.

Ladislav Hagara | Komentářů: 3
Jak se vás potenciálně dotkne trend odstraňování analogového audio konektoru typu 3,5mm jack z „chytrých telefonů“?
 (8%)
 (0%)
 (1%)
 (1%)
 (76%)
 (14%)
Celkem 1006 hlasů
 Komentářů: 45, poslední 1.12. 19:00
    Rozcestník

    Dotaz: Eclipse a chyba An error has occurred

    25.9.2006 21:14 marau
    Eclipse a chyba An error has occurred
    Přečteno: 415×
    Dobrý den, snažím se rozběhat eclipse (3.2 GTK) na linuxu, ale bohužel marně. Při pokusu spustit eclipse se mi objeví následující chyba:

    An error has occurred. See the log file xxxxx.log

    V error logu je toto:

    !SESSION 2006-09-25 21:05:35.468 ----------------------------------------------- eclipse.buildId=M20060629-1905 java.version=1.5.0_08 java.vendor=Sun Microsystems Inc. BootLoader constants: OS=linux, ARCH=x86, WS=gtk, NL=cs_CZ Command-line arguments: -os linux -ws gtk -arch x86

    !ENTRY org.eclipse.osgi 4 0 2006-09-25 21:05:36.680 !MESSAGE Application error !STACK 1 java.lang.UnsatisfiedLinkError: /mydir/programy/eclipse/configuration/org.eclipse.osgi/bundles/47/1/.cp/libswt-pi-gtk-3232.so: /usr/lib/libcairo.so.2: undefined symbol: FT_GlyphSlot_Embolden at java.lang.ClassLoader$NativeLibrary.load(Native Method) at java.lang.ClassLoader.loadLibrary0(Unknown Source) at java.lang.ClassLoader.loadLibrary(Unknown Source) at java.lang.Runtime.loadLibrary0(Unknown Source) at java.lang.System.loadLibrary(Unknown Source) at org.eclipse.swt.internal.Library.loadLibrary(Library.java:123) at org.eclipse.swt.internal.gtk.OS.(OS.java:22) at org.eclipse.swt.internal.Converter.wcsToMbcs(Converter.java:63) at org.eclipse.swt.internal.Converter.wcsToMbcs(Converter.java:54) at org.eclipse.swt.widgets.Display.(Display.java:126) at org.eclipse.ui.internal.Workbench.createDisplay(Workbench.java:433) at org.eclipse.ui.PlatformUI.createDisplay(PlatformUI.java:161) at org.eclipse.ui.internal.ide.IDEApplication.createDisplay(IDEApplication.java:122) at org.eclipse.ui.internal.ide.IDEApplication.run(IDEApplication.java:75) at org.eclipse.core.internal.runtime.PlatformActivator$1.run(PlatformActivator.java:78) at org.eclipse.core.runtime.internal.adaptor.EclipseAppLauncher.runApplication(EclipseAppLauncher.java:92) at org.eclipse.core.runtime.internal.adaptor.EclipseAppLauncher.start(EclipseAppLauncher.java:68) at org.eclipse.core.runtime.adaptor.EclipseStarter.run(EclipseStarter.java:400) at org.eclipse.core.runtime.adaptor.EclipseStarter.run(EclipseStarter.java:177) at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method) at sun.reflect.NativeMethodAccessorImpl.invoke(Unknown Source) at sun.reflect.DelegatingMethodAccessorImpl.invoke(Unknown Source) at java.lang.reflect.Method.invoke(Unknown Source) at org.eclipse.core.launcher.Main.invokeFramework(Main.java:336) at org.eclipse.core.launcher.Main.basicRun(Main.java:280) at org.eclipse.core.launcher.Main.run(Main.java:977) at org.eclipse.core.launcher.Main.main(Main.java:952)

    pro spuštění eclipse jsem si vytvořil následující script:

    #!/bin/bash export LD_LIBRARY_PATH=/mydir/programy/eclipse/ export PATH=/usr/java/jre1.5.0_08/bin/:/mydir/programy/eclipse/ eclipse

    Eclipse jsem se pokoušel spustit i se starší javou, tedy verze 1.5.0_06 a 1.5.0_04 ale nic se nezměnilo, pořád stejná chyba. Díky za odpovědi.

    Odpovědi

    26.9.2006 08:02 kp
    Rozbalit Rozbalit vše Re: Eclipse a chyba An error has occurred
    Zkuste se podivat na tento prispevek a prislusny thread, treba to pomuze: http://lists.alioth.debian.org/pipermail/pkg-java-maintainers/2005-November/006073.html
    26.9.2006 08:40 rastos | skóre: 60 | blog: rastos
    Rozbalit Rozbalit vše Re: Eclipse a chyba An error has occurred
    Buď jedna z týchto knižníc neexistuje alebo nie je aktuálna, alebo nemá splnené závislosti:
    /mydir/programy/eclipse/configuration/org.eclipse.osgi/bundles/47/1/.cp/libswt-pi-gtk-3232.so: 
    /usr/lib/libcairo.so.2:
    Skús pustiť na ne "ldd", prípadne násť funkciu FT_GlyphSlot_Embolden vo výpise "nm menokniznice". Podľa tej funkcie by som tipoval, že nemáš (aktuálny) freetype2.
    Pavel Stárek avatar 26.9.2006 10:12 Pavel Stárek | skóre: 43 | blog: Tady bloguju já :-) | Kolín
    Rozbalit Rozbalit vše Re: Eclipse a chyba An error has occurred
    Zkusil bych updatovat na poslední (nebo nějakou novější verzi, podle tvojí distribuce) verzi knihovny freetype. Viz tento příspěvek. Nic jiného mě nenapadá.
    Kdo chce, hledá způsob; kdo nechce, hledá důvod.
    26.9.2006 17:26 marau
    Rozbalit Rozbalit vše Re: Eclipse a chyba An error has occurred
    Hmm, tak po aktualizaci knihovny freetype (2.1.10) je situace ještě horší. Při spouštění eclipse tam pouze problikne nějaké okýnko (nestačím to ani přečíst) a v error logu není nic. Tak teď už vážně nevím. Zkoušel jsem tedy překompilovat celé GTK, při kompilaci GTK mi to nahlásilo, že mi chybí balíčky ATK, Pango a Cairo. Zkompiloval jsem je tedy v zapsaném pořadí. Vše proběhlo OK. Při opětné kompilaci GTK mi to nahlásilo nějakou chybu (už si jí nepamatuju), na internetu jsem našel, že Cairo musí být překompilováno před Pango, kompilace Caira proběhla v pořádku ale při opětné kompilaci Pango mi to vyhodí tuto chybu:
    cairoview.c:36:20: error: pixman.h: není souborem ani adresářem
    cairoview.c:38: error: expected ‘=’, ‘,’, ‘;’, ‘asm’ or ‘__attribute__’ before ‘*’ token
    cairoview.c: In function ‘update’:
    cairoview.c:134: error: ‘pixman_box16_t’ undeclared (first use in this function)
    cairoview.c:134: error: (Each undeclared identifier is reported only once
    cairoview.c:134: error: for each function it appears in.)
    cairoview.c:134: error: ‘extents’ undeclared (first use in this function)
    cairoview.c:137: error: ‘rects’ undeclared (first use in this function)
    cairoview.c:142: warning: implicit declaration of function ‘pixman_region_extents’
    cairoview.c:142: error: ‘update_region’ undeclared (first use in this function)
    cairoview.c:164: warning: implicit declaration of function ‘pixman_region_num_rects’
    cairoview.c:165: warning: implicit declaration of function ‘pixman_region_rects’
    cairoview.c:201: warning: implicit declaration of function ‘pixman_region_destroy’
    cairoview.c: In function ‘expose’:
    cairoview.c:208: error: ‘update_region’ undeclared (first use in this function)
    cairoview.c:209: warning: implicit declaration of function ‘pixman_region_create’
    cairoview.c:211: warning: implicit declaration of function ‘pixman_region_union_rect’
    cairoview.c: In function ‘main’:
    cairoview.c:274: error: ‘update_region’ undeclared (first use in this function)
    make[2]: *** [cairoview.o] Error 1
    make[2]: Leaving directory `/root/pango-1.9.1/examples'
    make[1]: *** [all-recursive] Error 1
    make[1]: Leaving directory `/root/pango-1.9.1'
    make: *** [all] Error 2
    
    Co s tím? Díky
    26.9.2006 18:07 marau
    Rozbalit Rozbalit vše Re: Eclipse a chyba An error has occurred
    Tak jsem se pokusil Pango přidat přes yum, vše proběhlo v pořádku ale GTK ho asi nemůže najít, protože mi při ./configure vypíše toto:
    configure: error:
    *** Can't link to Pango. Pango is required to build
    *** GTK+. For more information see http://www.pango.org
    26.9.2006 19:14 abr | skóre: 24 | blog: ab
    Rozbalit Rozbalit vše Re: Eclipse a chyba An error has occurred
    Mas nainstalovane JDK nebo jen JRE? Starsi verze Eclipse ti jely?
    26.9.2006 19:18 marau
    Rozbalit Rozbalit vše Re: Eclipse a chyba An error has occurred
    mám jre v. 1.5.08, starší verze (3.1) mi taky nejdou.
    26.9.2006 20:09 abr | skóre: 24 | blog: ab
    Rozbalit Rozbalit vše Re: Eclipse a chyba An error has occurred
    Tak si zkus odinstalovat JRE a nainstaluj JDK (mam JDK 5.0 Update 8 a Eclipse 3.1)
    26.9.2006 20:16 marau
    Rozbalit Rozbalit vše Re: Eclipse a chyba An error has occurred
    Mno, když jsem jel před rokem na Fedoře 3 a Eclipse 3.1 mi šlo s jre 1.5.04 a teď jedu na SuSE 10.1 a ECLIPSE 3.1 mi na javě 04, 06 i 08 hází úpně stejné chyby, navíc po aktualizaci freetype se konečně něco změnilo (i když k horšímu). Ale ještě jsem zapoměl napsat, že poprvé se mi Eclipse povedlo spustit, pak jsem chvíli dělal něcojiného a pak mi to začalo házet tyto chyby. Podle charakteru těch chyb bych řekl, že je to něco s GTK, ale jistej si samozřejmě nejsem. Ale teď už jsem si téměř jistý, že to javou nebude.

    Založit nové vláknoNahoru

    Tiskni Sdílej: Linkuj Jaggni to Vybrali.sme.sk Google Del.icio.us Facebook

    ISSN 1214-1267   www.czech-server.cz
    © 1999-2015 Nitemedia s. r. o. Všechna práva vyhrazena.