abclinuxu.cz AbcLinuxu.cz itbiz.cz ITBiz.cz HDmag.cz HDmag.cz abcprace.cz AbcPráce.cz
AbcLinuxu hledá autory!
Inzerujte na AbcPráce.cz od 950 Kč
Rozšířené hledání
×
včera 11:55 | Komunita

Vývojový tým OpenSSL ve spolupráci s iniciativou Core Infrastructure konsorcia Linux Foundation spustil proces přelicencování této kryptografické knihovny ze současné licence na licenci Apache Licence v 2.0 (ASLv2). Nová licence usnadní začleňování OpenSSL do dalších svobodných a open source projektů. Všichni dosavadní vývojáři OpenSSL (Authors) obdrží v následujících dnech email s prosbou o souhlas se změnou licence.

Ladislav Hagara | Komentářů: 6
včera 01:11 | Komunita

Před třemi týdny Mozilla.cz představila projekt Photon, jehož cílem je návrh a implementace nového vzhledu Firefoxu. Včera zveřejnila první náhled vzhledu Photon. Práce na projektu Photon jsou rozděleny do pěti týmů, které celkem čítají 19 lidí. Zaměřují se na zlepšení prvního spuštění Firefoxu a zaujetí nových uživatelů, celkovou úpravu vzhledu, zlepšení animací, zrychlení odezvy uživatelského rozhraní a také upravení nabídek. Vývoj lze sledovat v Bugzille.

Ladislav Hagara | Komentářů: 22
23.3. 20:00 | Komunita

OneDrive pro firmy je již ve webových prohlížečích na Linuxu stejně rychlý jako na Windows. Microsoft opravil chybu z listopadu loňského roku. OneDrive pro firmy běžel na Linuxu mnohem pomaleji než na Windows. V popisu chyby bylo uvedeno, že stačilo v prohlížeči na Linuxu nastavit v user-agentu Windows a vše se zrychlilo. Odpovědí Microsoftu bylo (Internet Archive: Wayback Machine), že Linux není podporován. Po bouřlivých diskusích na redditu i Hacker News byla chyba nalezena a opravena.

Ladislav Hagara | Komentářů: 4
23.3. 19:00 | Zajímavý projekt

Byla vyhlášena soutěž Hackaday Prize 2017. Soutěž je určena vývojářům open source hardwaru. Pro výherce je připraveno celkově 250 tisíc dolarů. Každý ze 120 finalistů získá tisíc dolarů. Nejlepší pak navíc 50, 30, 20, 15, 10 a 5 tisíc dolarů. Jedná se již o čtvrtý ročník soutěže. V roce 2014 zvítězil projekt globální sítě open source pozemních satelitních stanic SatNOGS. V roce 2015 zvítězil open source systém pro řízení elektrických invalidních vozíků pohybem očí Eyedriveomatic. V roce 2016 zvítězil modulární robot Dtto.

Ladislav Hagara | Komentářů: 0
23.3. 15:00 | Bezpečnostní upozornění

Byla vydána Samba ve verzích 4.6.1, 4.5.7 a 4.4.12. Řešen je bezpečnostní problém CVE-2017-2619. Pomocí symbolických odkazů a souběhu (symlink race) lze "teoreticky" získat přístup k souborům, které nejsou sdíleny. Linuxové distribuce jsou postupně aktualizovány (Debian).

Ladislav Hagara | Komentářů: 0
23.3. 07:43 | Nová verze

Na Steamu se objevil port hry Arma: Cold War Assault (Operation Flashpoint) pro Mac a Linux. … více »

creon | Komentářů: 29
23.3. 05:55 | Nová verze

Po 18 měsících od vydání verze 8.0 byla vydána verze 9.0 open source alternativy GitHubu, tj. softwarového nástroje s webovým rozhraním umožňujícího spolupráci na zdrojových kódech, GitLab. Představení nových vlastností v příspěvku na blogu a na YouTube.

Ladislav Hagara | Komentářů: 0
23.3. 03:33 | Komunita

Platnost posledního patentu souvisejícího s Dolby Digital (AC-3) vypršela. Po MP3 se tak do Fedory oficiálně dostane také kodek AC-3.

Ladislav Hagara | Komentářů: 5
23.3. 00:44 | Komunita

Feral Interactive, společnost zabývající se vydáváním počítačových her pro operační systémy macOS a Linux, nabízí své hry na Steamu vývojářům open source 3D grafické knihovny Mesa zdarma. Podmínkou je minimálně 25 commitů za posledních 5 let. Stejnou nabídku dostali vývojáři knihovny Mesa v roce 2015 od Valve. O rok dříve dostali od Valve tuto nabídku vývojáři Debianu a Ubuntu.

Ladislav Hagara | Komentářů: 0
22.3. 23:55 | Nová verze

Opera 44, verze 44.0.2510.857, byla prohlášena za stabilní. Nejnovější verze tohoto webového prohlížeče je postavena na Chromiu 57. Z novinek vývojáři Opery zdůrazňují podporou Touch Baru na nejnovějších MacBoocích Pro (gif). Přehled novinek pro vývojáře na blogu Dev.Opera.

Ladislav Hagara | Komentářů: 1
Jak se stavíte k trendu ztenčování přenosných zařízení (smartphony, notebooky)?
 (14%)
 (2%)
 (72%)
 (3%)
 (10%)
Celkem 926 hlasů
 Komentářů: 72, poslední 1.3. 11:16
    Rozcestník

    Dotaz: Vývoj Qt aplikácie

    9.7.2016 12:06 rastos | skóre: 60 | blog: rastos
    Vývoj Qt aplikácie
    Přečteno: 695×

    Prišiel za mnou šéf a chcel vedieť, čo by to obnášalo, keby sme chceli vyvíjať Linux-ovú aplikáciu. (komerčnú, pre malý počet konkrétnych zákazníkov) Povedal som mu, čo som vedel, ale sám som nebol spokojný so svojou odpoveďou tak som začal pátrať po tom, ako urobiť aplikáciu pomocou Qt - a narážam na samé otázky:

    • zdá sa, že Qt Creator nie je súčasťou distribúcie - nie je v mojom Slackware, nie je na Ubuntu 14.04 stroji, ku ktorému mám prístup. Zdá sa, že oficiálne odporúčaný spôsob, ako ho nainštalovať, je pustiť nejaký inštalátor zobratý zo stránok Qt. Je to skutočne tak?
    • Na mojom stroji je KDevelop 4.7.2, ten vygeneruje skeleton nového projektu tak, že sa snaží používať include QGuiApplication. To ale vyzerá byť vec nová pre Qt5 a moje distro je zatiaľ na Qt 4.8.7. Je to tak, že KDevelop 4.7.2 nevie vygenerovať skelet projektu pre Qt4? Je to tak, že QGuiApplication znamená snahu použiť Qt5?
    • Licencovanie Qt - FAQ hovorí, že ak použijem dynamické linkovanie, tak môžem použiť Qt pod LGPL licenciou. Čo presne tu znamená "dynamické linkovanie"? Predpokladám, že ak použijem QtCreator, tak vznikne program, ktorý sa bude odkazovať napr. na libQtCore.so. To je to, čo ja považujem za "dynamické linkovanie". Ale niekto by mohol pod tým rozumieť použitie dlopen()/dlsym(). Ako je to? Predpokladám, že málokto potrebuje zasahovať, do samotného Qt a teda prakticky každému closed-source vývojárovi by mohlo vyhovovať LGPL. Je to tak?

    Řešení dotazu:


    Odpovědi

    9.7.2016 13:46 chrono
    Rozbalit Rozbalit vše Re: Vývoj Qt aplikácie
    Balíček s Qt Creator je aj pre 14.04 a vyzerá to tak, že využíva Qt5.
    9.7.2016 15:19 rastos | skóre: 60 | blog: rastos
    Rozbalit Rozbalit vše Re: Vývoj Qt aplikácie
    Tak prvý bod je mi už jasný. QtCreator balík sa dá priamo v defaultnej inštalácii Ubuntu nainštalovať cez "apt-get install qtcreator". Predtým som to nepozeral správne. Tiež potrebuje ešte doinštalovat Qt verziu 4 alebo 5.
    9.7.2016 16:20 chrono
    Rozbalit Rozbalit vše Re: Vývoj Qt aplikácie
    Inštaláciu potrebných Qt knižníc nerieši správca balíčkov?
    9.7.2016 19:00 MadCatX | skóre: 17
    Rozbalit Rozbalit vše Re: Vývoj Qt aplikácie
    Neřeš a v tomto případě jde o správné chování. QtCreator -devel balíčky pro běh nepotřebuje a vývojových Qt kitů je možné mít nainstalováno najednou libovolné množství. Klidně je možné používat distribuční QtCreator a Qt kity nainstalované Qt instalátorem nebo ručně zkompilované.
    Řešení 1× (rastos (tazatel))
    9.7.2016 18:57 MadCatX | skóre: 17
    Rozbalit Rozbalit vše Re: Vývoj Qt aplikácie
    1. QtCreator součástí distribucí bývá (Arch Linux i Fedora ho rozhodně balíčkují), ovšem člověk je pak závislý na tom, v jaké verzi je pro jeho distro zrovna dostupný. Totéž platí o samotných knihovnách Qt. Pokud člověk potřebuje vyvíjet proti nějaké konkrétní verzi Qt, může opět Qt zabalené distribucí nevyhovovat. Další potenciální problém může tkvět v tom, že některé distribuce si Qt různě modifikují, což může znamenat třeba implicitně nefunkční qDebug.

      Pro „business“ použití bych doporučil nainstalovat Qt pomocí instalátoru od Qt Company. Kromě toho, že dostaneš Qtčka v „čisté“ podobě máš možnost nainstalovat několik verzí Qt vedle sebe a používat tu, kterou potřebuješ. Instalátor dále umožňuje nainstalovat některé proprietární Qt moduly, které linuxové distribuce nebalíčkují a z licenčních důvodů to (nejspíš) ani není možné.

    2. KDevelop jsem nějakou dobu neviděl, ale pokud vím, standardně používá jako build system CMake. QtCreator používá Qtčkový QMake, ačkoliv s CMakem umí pracovat taky. Upravit si předgenerovaný CMakeový skelet tak, aby šel sestavit i proti Qt4 by neměl být takový problém, protože rozdíly jsou v tomto směru malé. Na druhou stranu pro nový projekt bych určitě použil Qt5, nejlépe pak LTSkovou verzi 5.6. QtCreator je mimochodem velmi solidní IDE, zvlášť čtyřková řada s podporou pro statický analyzátor Clangu. Pro Vi(m)aře je k dispozici i FakeVim režim.
    3. Nerad bych zde šířil nějaké bludy, ale fungování LGPL licence chápu takto: Pokud jsou knihovny licencované pod LGPL samostatná binárka, vůči které se můj program dynamicky linkuje, pak může být moje aplikace uzavřená. Jestli prolinkování zařídí linker OS nebo moje aplikace je IMHO technický detail, který ta licence nijak neřeší. Důležité je, že na požádání musím jako autor aplikace poskytnout zdrojové kódy všech knihoven licencovaných pod LGPL, které můj program používá včetně všech úprav, které jsem v těch knihovnách udělal. Ty zdrojáky musím mít „fyzicky“, odkaz na nějaký cizí repozitář nestačí.
    Martin Tůma avatar 9.7.2016 21:26 Martin Tůma | skóre: 38 | blog: RTFM | Praha
    Rozbalit Rozbalit vše Re: Vývoj Qt aplikácie

    Vzhledem k tomu, že zákazníků má být víc, bych rozhodně nedoporučoval vyvíjet pro konkrétní verzi Qt, protože už při dvou zákaznících je téměř jisté, že budou chtít používat různé distribuce... A z bastlu, kterej si nese své vlastní Qt a instaluje se nejlépe z nějakýho *.tar.gz scriptem budou určitě všichni nadšený...

    Při troše snahy není problém psát zároveň pro Qt4 i Qt5 a pomocí OBS nebo nějakýho ekvivalentu pak vytvářet balíčky/repozitoře pro široké spektrum distribucí, které mají široké spektrum Qt knihoven.

    Každý má právo na můj názor!
    9.7.2016 23:22 rastos | skóre: 60 | blog: rastos
    Rozbalit Rozbalit vše Re: Vývoj Qt aplikácie
    V tom konkrétnom prípade, ktorým som začal by išlo o kompletný riadiaci systém pre nejaký technologický proces, kde by sme dodávali všetko vrátane OS a HW, na ktorom to pobeží - takže by sme nad verziami a distribúciami mali kontrolu. Ale díky za info.
    9.7.2016 23:22 rastos | skóre: 60 | blog: rastos
    Rozbalit Rozbalit vše Re: Vývoj Qt aplikácie
    Dobrá odpoveď. Ďakujem.
    10.7.2016 12:54 mimi.vx | skóre: 37 | blog: Mimi.VX | Praha
    Rozbalit Rozbalit vše Re: Vývoj Qt aplikácie

    spis nezapomen na to ze pro komercni pouziti u QT musis zaplatit licenci ..

     

    a na QT4 bych se v tuto dobu fakt vybodl ...uz je davno out of support , spis bych se podival na QT 5.6 / 5.7.

    USE="-gnome -kde";turris
    10.7.2016 13:14 chrono
    Rozbalit Rozbalit vše Re: Vývoj Qt aplikácie

    spis nezapomen na to ze pro komercni pouziti u QT musis zaplatit licenci ..

    To ale nie je pravda.
    10.7.2016 13:25 Jardík
    Rozbalit Rozbalit vše Re: Vývoj Qt aplikácie
    S tou licencí je to trochu složitější, hlavně protože C++ a inlinování. Mají tam ještě nějakou výjimku, že když ta inlinovaná část nepřekročí nějakých X procent, tak je to ok, nebo něco takového tam bývalo.
    10.7.2016 22:34 chrono
    Rozbalit Rozbalit vše Re: Vývoj Qt aplikácie
    Možno niekedy také niečo mali, momentálne je v ich FAQ:
    The LGPL allows you to keep the source code of your application private as long as it is “work that uses” the library. Dynamic linking is usually recommended here.
    10.7.2016 21:32 mimi.vx | skóre: 37 | blog: Mimi.VX | Praha
    Rozbalit Rozbalit vše Re: Vývoj Qt aplikácie

    a to si vzal kde ? QT je a byl;a vzdy dual  licensed -- OSS zdarma , komercni vyvoj -- zaplat

     

    https://www.qt.io/buy-product/?pid=7051 je asi co ? 350USD mesicne na 1 vyvojare jen tak ?

    USE="-gnome -kde";turris
    10.7.2016 22:32 chrono
    Rozbalit Rozbalit vše Re: Vývoj Qt aplikácie
    To je nezmysel. Áno, Qt je aj pod komerčnou licenciou, ale ak vývojárovi stačí LGPL (a nepotrebuje Qt Charts a Qt Data Visualization, pretože tie sú len pod GPL), tak môže použiť aj tú licenciu (so všetkým, čo s tým súvisí, je to popísané napr. aj v ich FAQ). A ak by to bolo inak, tak by porušovali LGPL.
    3.5. Can I use the Community open source version to develop my commercial product?

    It depends on how you license and distribute your product. The open source version of Qt is mainly distributed under the LGPL, version 3 and GPLv2/v3. You will need to fulfill the license obligations for these licenses when using Qt in your product.
    PS: A len tak mimochodom, Qt Script, Qt WebKit a Qt WebEngine sú aj v ich komerčnej verzii pod LGPL licenciou.
    10.7.2016 22:44 mimi.vx | skóre: 37 | blog: Mimi.VX | Praha
    Rozbalit Rozbalit vše Re: Vývoj Qt aplikácie
    It depends on how you license and distribute your product. The open source version of Qt is mainly distributed under the LGPL, version 3 and GPLv2/v3. You will need to fulfill the license obligations for these licenses when using Qt in your product.
    z cehoz plyne ze klientum musi dodat i zdrojove kody .. a nebo si poridit komercni licenci ...
    USE="-gnome -kde";turris
    10.7.2016 22:50 chrono
    Rozbalit Rozbalit vše Re: Vývoj Qt aplikácie
    Ak využijú LGPL licenciu, tak im zdrojové kódy aplikácie dať nemusia (a píše sa to aj v inom bode toho ich FAQ, pripadne na ich stránke https://www.qt.io/qt-licensing-terms/)
    Martin Tůma avatar 11.7.2016 09:22 Martin Tůma | skóre: 38 | blog: RTFM | Praha
    Rozbalit Rozbalit vše Re: Vývoj Qt aplikácie
    ...z cehoz plyne ze klientum musi dodat i zdrojove kody

    Ano, ale zdrojové kódy Qt, pokuď je budou modifikovat. Což není zrovna obvyklý případ.

    Každý má právo na můj názor!
    Martin Tůma avatar 11.7.2016 09:25 Martin Tůma | skóre: 38 | blog: RTFM | Praha
    Rozbalit Rozbalit vše Re: Vývoj Qt aplikácie

    Za předpokladu, že to Qt budou dynamicky linkovat. Pokuď by chtěli statickou binárku, pak tu komerční licenci potřebují. Ale zrovna pro Linux je víc než vhodný linkovat proti systémovému Qt.

    Každý má právo na můj názor!
    Martin Tůma avatar 11.7.2016 09:18 Martin Tůma | skóre: 38 | blog: RTFM | Praha
    Rozbalit Rozbalit vše Re: Vývoj Qt aplikácie

    a na QT4 bych se v tuto dobu fakt vybodl ...uz je davno out of support , spis bych se podival na QT 5.6 / 5.7.

    Například aktuální RHEL/Cent OS Qt5 vůbec neobsahuje. A to je zrovna distribuce, která se komerčně používá skoro nejčastěji, takže vykašlat se na ní (nebo nutit uživatele k používání nějakých 3rd party repozitoří) není obecně z obchodního hlediska zrovna nejšťastnější nápad... Zvlášť v situaci, kdy při troše snahy lze psát aplikaci pro Qt5 i Qt4 zároveň.

    Každý má právo na můj názor!
    11.7.2016 10:58 MadCatX
    Rozbalit Rozbalit vše Re: Vývoj Qt aplikácie
    Lehce mimo téma, ale přijde mi vhodné to zmínit. Psát něco zároveň pro Qt4 a Qt5 není až tak jednoduché. S malými odlišnostmi v API se dá poprat, ale Qt5 se vevnitř chovají jinak, takže aplikace sestavitelná proti oběma verzím by se taky musela nadvakrát testovat.
    11.7.2016 11:16 Zdenek 'Mst. Spider' Sedlak | skóre: 37 | blog: xMstSpider
    Rozbalit Rozbalit vše Re: Vývoj Qt aplikácie
    Kdyz to bude komercni a soupnou Qt5 do /opt spolu s aplikaci, tak to nikoho trapit nebude...
    11.7.2016 11:36 Zdenek 'Mst. Spider' Sedlak | skóre: 37 | blog: xMstSpider
    Rozbalit Rozbalit vše Re: Vývoj Qt aplikácie
    Jinak Qt5 je i v EPELu...
    Martin Tůma avatar 11.7.2016 14:06 Martin Tůma | skóre: 38 | blog: RTFM | Praha
    Rozbalit Rozbalit vše Re: Vývoj Qt aplikácie
    Což je 3rd party repository. Netvrdím, že to nejde, ale pokuď se pak máte starat o stroj, kde se takhle chová každej druhej balíček, že potřebuje dalších X repozitoří, tak jako správce z toho dvakrát nadšenej člověk není...
    Každý má právo na můj názor!
    Martin Tůma avatar 11.7.2016 14:03 Martin Tůma | skóre: 38 | blog: RTFM | Praha
    Rozbalit Rozbalit vše Re: Vývoj Qt aplikácie
    To je asi věc názoru, mě by to třeba vadilo. Navíc to pro vývojáře znamená se starat o aktualizace a sestavení Qt.
    Každý má právo na můj názor!

    Založit nové vláknoNahoru

    Tiskni Sdílej: Linkuj Jaggni to Vybrali.sme.sk Google Del.icio.us Facebook

    ISSN 1214-1267   www.czech-server.cz
    © 1999-2015 Nitemedia s. r. o. Všechna práva vyhrazena.