abclinuxu.cz AbcLinuxu.cz itbiz.cz ITBiz.cz HDmag.cz HDmag.cz abcprace.cz AbcPráce.cz
AbcLinuxu hledá autory!
Inzerujte na AbcPráce.cz od 950 Kč
Rozšířené hledání
×

19.5. 00:33 | Zajímavý článek

Správce nástroje curl Daniel Stenberg na GitHubu průběžně vytváří svou novou knihu Uncurled, v níž shrnuje své dlouhodobé zkušenosti s údržbou open-source projektu: od odpozorovaných pouček po vtipné a ne až tak vtipné příklady e-mailů od uživatelů.

Fluttershy, yay! | Komentářů: 11
19.5. 00:22 | Nová verze

Byla vydána nová major verze 25.0 programovacího jazyka Erlang (Wikipedie) a související platformy OTP (Open Telecom Platform, Wikipedie). Přehled novinek v příspěvku na blogu.

Ladislav Hagara | Komentářů: 3
19.5. 00:11 | Nová verze

Deno (Wikipedie), běhové prostředí (runtime) pro JavaScript a TypeScript, bylo vydáno ve verzi 1.22. Přehled novinek v poznámkách k vydání.

Ladislav Hagara | Komentářů: 0
18.5. 18:22 | Nová verze

Společnost Red Hat oznámila vydání Red Hat Enterprise Linuxu (RHEL) 9.0. Vedle nových vlastností a oprav chyb přináší také aktualizaci ovladačů a předběžné ukázky budoucích technologií. Podrobnosti v poznámkách k vydání.

Ladislav Hagara | Komentářů: 7
18.5. 14:00 | Komunita

Lars Knoll oznámil, že po 25 letech v ekosystému Qt, z toho 22 let pracující pro různé společnosti vlastnící Qt, odchází ze společnosti The Qt Company do malého norského startupu.

Ladislav Hagara | Komentářů: 7
18.5. 13:22 | Zajímavý projekt

Na Kickstarteru běží kampaň na podporu mini ITX desky Turing Pi 2 Cluster Computer. Vložením 4 výpočetních modulů, podporovány jsou Raspberry Pi 4, Turing RK1 a Nvidia Jetson, lze získat 4uzlový cluster. Cena desky je 219 dolarů.

Ladislav Hagara | Komentářů: 2
18.5. 10:00 | Pozvánky

Spolek OpenAlt zve příznivce otevřených řešení a přístupu na 198. brněnský sraz, který proběhne v pátek 20. května tradičně od 18 hodin v Pivovarské restauraci Moravia.

Ladislav Hagara | Komentářů: 2
18.5. 07:00 | Zajímavý software

Byla vydána nová verze 0.25 herního enginu Fyrox, původně rg3d. Přehled novinek s kódy, náhledy i videi v příspěvku na blogu.

Ladislav Hagara | Komentářů: 1
18.5. 00:11 | Nová verze

Multiplatformní audio přehrávač Qmmp (Wikipedie) byl vydán ve verzi 2.1.0. Z novinek lze zmínit například podporu XDG Base Directory Specification.

Ladislav Hagara | Komentářů: 0
17.5. 23:22 | Komunita

Letošní konference LibreOffice proběhne 28. září až 1. října v Bolzanu. The Document Foundation hledá přednášející.

Zdeněk Crhonek | Komentářů: 0
Na sociálních sítích nebo jiných webových diskuzích vystupuji pod
 (60%)
 (16%)
 (24%)
Celkem 294 hlasů
 Komentářů: 26, poslední včera 15:03
Rozcestník


Dotaz: linux mint, xampp pro linux

21.9.2016 14:03 Hoodas | skóre: 10
linux mint, xampp pro linux
Přečteno: 1010×

Potřeoval bych radu ohledně nastavení balíku Xampp pro linux. Xampp download.

Xampp mi není schopen na localhostu spustit můj web, který mám online na svém hostingu (viz obr).
Potřeboal bych poradit, jak správně natavit Xampp tak, aby se mi vče spustilo správně.

web obsahuje .htaccess (je možné, že problém bude v nastavení localhostu - behsen si jistý). Rád bych pro případné pochybující dodal, že Xampp je plně linuxem podporovaný a spolupracuje s lamppem.
Nyní nejsem schopen samostatně lampp nainstalovat, neb mi schází potřebné zkušenosti.

Pro informaci: v linuxu jsem byl relativně zdatný před 5 lety, avšak díky autonehodě před 5 lety jsem ztratil dlouhodobou paměť, takže jsem ten tonoucí, který se stébla chytá.

 

Za odpovědi díky.


Řešení dotazu:


Odpovědi

21.9.2016 16:52 Matlák
Rozbalit Rozbalit vše Re: linux mint, xampp pro linux
Boba jeho už tu psali několikrát ať se na Xampp vykašleš a nainstaluješ si to samotné (php+apache+mysql) třeba na deb distru (brutálně) takhle:
apt-get install php5 php5-common php5-cli libapache2-mod-php5 php5-curl php5-gd php5-gmp php5-intl php5-json php5-ldap php5-mcrypt php5-memcached php5-pgsql php-apc php5-xsl php-soap php-net-socket php-mail php-net-smtp php-xml-serializer php-xml-util php-xml-rpc php-xml-htmlsax3 mysql-server
Problém související s htaccessy je většinou v tom že je zakázaný příslušný modul v apache. V normální instalaci stačí nakouknout do /var/log/apache/error.log ppřípadně do ostatních logů ve /var/log/apache nebo /var/log/apache (nebo /var/log/httpd na jiných distrech). Bude tam jasně řečeno co mu chybí, případně stačí příslušnou chybobou hlášku hodit do Googlu a hned se dozvíš který modul aktivovat .

I když je něco "podporované" neznamená to že je to správná cesta. Správnou cestou je nainstalovat si LAMP tak jak má být a tak jak (konec konců) běží i na tom hostingu.

Nyní nejsem schopen samostatně lampp nainstalovat, neb mi schází potřebné zkušenosti.

To není o zkušenostech, to je o manuálech a návodech (a ochotě číst je). Jsou jich mraky. Ten příkaz výše jsem zkopíroval z jednoho debian stroje co tu mám je to trochu "overkill" s tou hromadou extensions, ale nic tím zkazit nejde. A spousta podobných příkazů se povaluje na internetu na každém druhém serveru co se vývoji na platformě LAMP zabývá. Prostě to spustíš a za pár vteřin už apache běží a vesele kváká "It works!". Pak jen stačí nastavit práva nebo prosymlinkovat, třeba takhle (předpokládám že máš tu webovou app ve svém domovském adresáři v /home/hoodas/web/):
chown :www-data /home/hoodas/web/
chmod g+rx /home/hoodas/web/
chmod -R g+r /home/hoodas/web/
ln -s /home/hoodas/web /var/www/web
a hned to jede na http://127.0.0.1/web/.
Nic na tom není. Složitější asi už bude nahrát data do databází, nastavit hesla atd.. ale to je na zkoumání logů té app a samostatné dotazy. Nečekej že tady řekneš "nejde mi spustit moje (blackbox) app" a dostaneš jasnou radu jak to nakonfigurovat podle hostingového phpinfo() a tím budeš mít hotovo.
22.9.2016 12:34 Hoodas | skóre: 10
Rozbalit Rozbalit vše Re: linux mint, xampp pro linux

Ahoj, díky za odpověď. Při zadání přikazu mi to vypsalo následující:

Je fakt, že mi to trochu rozhodilo plány. Máš tucha, v čem by mohl býr ptoblém? Ještě před započetím instalace xamppu jsem se pokoušel o podobný srandy ale ... nakonec sem nainstaloal xampp.

Načítají se seznamy balíků… Hotovo
Vytváří se strom závislostí
Načítají se stavové informace… Hotovo
Pozn: Vybírám „php-pear“ místo „php-xml-util“
Balík libapache2-mod-php5 není dostupný, ale jiný balík se na něj odkazuje.
To může znamenat že balík chybí, byl zastarán, nebo je dostupný
pouze z jiného zdroje

Balík php5 není dostupný, ale jiný balík se na něj odkazuje.
To může znamenat že balík chybí, byl zastarán, nebo je dostupný
pouze z jiného zdroje

Balík php5-cli není dostupný, ale jiný balík se na něj odkazuje.
To může znamenat že balík chybí, byl zastarán, nebo je dostupný
pouze z jiného zdroje
Nicméně následující balíky jej nahrazují:
php7.0-cli:i386 php7.0-cli

Balík php5-common není dostupný, ale jiný balík se na něj odkazuje.
To může znamenat že balík chybí, byl zastarán, nebo je dostupný
pouze z jiného zdroje

Balík php5-mcrypt není dostupný, ale jiný balík se na něj odkazuje.
To může znamenat že balík chybí, byl zastarán, nebo je dostupný
pouze z jiného zdroje

Balík php5-pgsql není dostupný, ale jiný balík se na něj odkazuje.
To může znamenat že balík chybí, byl zastarán, nebo je dostupný
pouze z jiného zdroje

Balík php5-gd není dostupný, ale jiný balík se na něj odkazuje.
To může znamenat že balík chybí, byl zastarán, nebo je dostupný
pouze z jiného zdroje

Balík php-apc není dostupný, ale jiný balík se na něj odkazuje.
To může znamenat že balík chybí, byl zastarán, nebo je dostupný
pouze z jiného zdroje

E: Balík „php5“ nemá kandidáta pro instalaci
E: Balík „php5-common“ nemá kandidáta pro instalaci
E: Balík „php5-cli“ nemá kandidáta pro instalaci
E: Balík „libapache2-mod-php5“ nemá kandidáta pro instalaci
E: Nelze najít balík php5-curl
E: Balík „php5-gd“ nemá kandidáta pro instalaci
E: Nelze najít balík php5-gmp
E: Nelze najít balík php5-intl
E: Nelze najít balík php5-json
E: Nelze najít balík php5-ldap
E: Balík „php5-mcrypt“ nemá kandidáta pro instalaci
E: Nelze najít balík php5-memcached
E: Balík „php5-pgsql“ nemá kandidáta pro instalaci
E: Balík „php-apc“ nemá kandidáta pro instalaci
E: Nelze najít balík php5-xsl
E: Nelze najít balík php-xml-rpc

 

 

Je fakt, že mi to trochu rozhodilo plány. Máš tucha, v čem by mohl býr ptoblém? Ještě před započetím instalace xamppu jsem se pokoušel o podobný srandy ale ... nakonec sem nainstaloal xampp.

22.9.2016 15:14 Hoodas | skóre: 10
Rozbalit Rozbalit vše Re: linux mint, xampp pro linux

mmj, nainstaloval jsem něco, co mi pořád nevalí, jak bych potřeboval ale .. alespoň křůček dál.
Řídil jsem se tímhle: https://www.pcsteps.com/3152-install-lamp-linux-mint-ubuntu/

22.9.2016 19:14 Matlák
Rozbalit Rozbalit vše Re: linux mint, xampp pro linux
Za to se omlouvám, ten Debian je asi archivní kousek (tuším že je to snad dokonce wheezy) co se balíků týče. Například tady je postup který autor podle všeho otestoval na Mintu 18.

Že některé balíky chybí se stává. Pomáhá napsat
apt-get update
apt-cache search php | less
apt-cache search apache | less
nebo
aptitude update
aptitude search php | less
aptitude search apache | less
což zobrazí i jestli jsou dané balíky nainstalované nebo ne. Aptitude nemusíš mít nainstalovaný, ale dá se snad i na Mintu18 stáhnout pomocí apt-get install aptitude.
Můžeš použít i grafický správce balíčků (synaptic snad? v tom se bohužel nevyznám) a vyhledat a naklikat si to k instalaci to pěkně v GUI.

BTW podle toho návodu co jsi tu nalinkoval to vypadá navíc na to že na Mintu 18 existují i věci jako metabalík lamp-server který vše nainstaluje sám a bez vyjmenovávání názvů. Samozřejmě to chce si potom ověřit (pomocí výše uvedených postupů) jestli se nainstalovaly také všechny extensions, které příslušný web chce, jinak může aplikace vyhazovat příslušné chybové hlášky do prohlížeče a/nebo do logů apache.

Založit nové vláknoNahoru

Tiskni Sdílej: Linkuj Jaggni to Vybrali.sme.sk Google Del.icio.us Facebook

ISSN 1214-1267   www.czech-server.cz
© 1999-2015 Nitemedia s. r. o. Všechna práva vyhrazena.