abclinuxu.cz AbcLinuxu.cz itbiz.cz ITBiz.cz HDmag.cz HDmag.cz abcprace.cz AbcPráce.cz
AbcLinuxu hledá autory!
Inzerujte na AbcPráce.cz od 950 Kč
Rozšířené hledání
×
včera 16:33 | Komunita

Google zveřejnil seznam 200 organizací přijatých do letošního Google Summer of Code (GSoC). Dle plánu se studenti přihlašují od 16. do 31. března. Vydělat si mohou od 3 000 do 6 600 dolarů. V Česku a na Slovensku 3 600 dolarů. Další informace v často kladených otázkách (FAQ). K dispozici jsou také statistiky z minulých let.

Ladislav Hagara | Komentářů: 0
včera 15:55 | IT novinky

Ve věku 74 let zemřel Lawrence Tesler. V 70. letech pracoval v Xerox PARC a posléze odešel do Apple. Zabýval se především zjednodušováním uživatelských rozhraní, byl odpůrcem modality a přispěl k prosazení moderního způsobu označování a kopírování textu – myší a klávesovými zkratkami (kombinace s XCV) – v raných Apple Human Interface Guidelines. Dále se podílel např. na vývoji Smalltalku a souvisejícího přenosného počítače Xerox NoteTaker nebo později PDA Apple Newton.

Fluttershy, yay! | Komentářů: 1
včera 13:11 | Zajímavý článek

Aktuální příspěvek What is Mobile PureOS? na stránkách společnosti Purism je věnován operačnímu systému Mobile PureOS, tj. PureOS pro mobilní zařízení a především pro telefon Librem 5. Víceméně se jedná o stabilní Debian s GNOME doplněný o balíčky phosh, phoc, libhandy, Calls, Chats a další.

Ladislav Hagara | Komentářů: 0
20.2. 19:33 | Zajímavý článek

Jozef Mlich se v příspěvku PinePhone je nové OpenMoko na svém blogu věnuje svému novému linuxovému chytrému telefonu PinePhone v edici BraveHeart: "Momentálně se pocity z tohohle zařízení dají přirovnat k BrokenMoku. Většina věcí prostě nefunguje. Minimálně ne sama od sebe. Začít se dá už u samotného hardware, kde existuje wiki stránka popisující nedostatky".

Ladislav Hagara | Komentářů: 14
20.2. 10:00 | Zajímavý projekt

Justine Haupt aktualizovala svůj open source mobilní telefon s rotační číselnicí a zveřejnila kompletní dokumentaci, vlastní kód, schémata i STL soubory pro 3D tisk. Desku plošných spojů případně i vytištěný obal lze koupit v jejím obchodu.

Ladislav Hagara | Komentářů: 33
20.2. 06:00 | IT novinky

Otevřená certifikační autorita Let's Encrypt v příspěvku na svém blogu informuje, že žádosti o vystavení certifikátů nově validuje z několika míst současně (Multi-Perspective Validation). Další informace v diskusním fóru.

Ladislav Hagara | Komentářů: 10
19.2. 13:55 | Nová verze

Byla vydána verze 15.0 na Debianu založené linuxové distribuce Untangle NG Firewall. Přehled novinek v poznámkách k vydání a ve videu na YouTube. Vyzkoušet lze (zatím neaktualizované) demo webového rozhraní.

Ladislav Hagara | Komentářů: 0
19.2. 12:11 | Pozvánky

Letošní ročník konference LinuxDays se uskuteční o víkendu 3. a 4. října, opět se potkáme v pražských Dejvicích na FIT ČVUT. Také během devátého ročníku nás budou čekat desítky přednášek, workshopy, stánky a spousta doprovodného programu. Aktuální dění můžete sledovat na Twitteru nebo Facebooku, přidat se můžete také do telegramové diskusní skupiny.

Petr Krčmář | Komentářů: 7
19.2. 10:22 | Zajímavý článek

Alexander Popov se v příspěvku na svém blogu podrobně věnuje možnostem zneužití bezpečnostní chyby CVE-2019-18683 v linuxovém podsystému V4L2. Videoukázka eskalace práv na YouTube. Chyba byla v upstreamu opravena v listopadu loňského roku. Alexander Popov se chybě věnoval ve své přednášce (pdf) na konferenci OffensiveCon 2020.

Ladislav Hagara | Komentářů: 0
19.2. 06:00 | Nová verze

Byla vydána nová verze 20.02.17 svobodného multiplatformního video editoru Shotcut (Wikipedie). Přehled novinek v oznámení o vydání. Využíván je MLT Multimedia Framework 6.20.0 a WebVfx 1.2.0. Nejnovější Shotcut je k dispozici také ve formátech AppImage, Flatpak i Snap.

Ladislav Hagara | Komentářů: 2
Vydržela vám novoroční předsevzetí?
 (9%)
 (6%)
 (3%)
 (82%)
Celkem 173 hlasů
 Komentářů: 0
Rozcestník

Turris - současně funkční wifi 5 GHz + 2.4 GHz

22.3.2014 01:56 | Přečteno: 7638× | programování | poslední úprava: 22.3.2014 15:15

Kvůli starším legacy zařízením jako mobil a netbook jsem chtěl mít v Turris routeru funkční dvě AP, jedno v 5 GHz a druhé v 2.4 GHz pásmu. Byla by ale škoda zapojovat přes NAT další router, když stačí přidat další wifi kartu. Malé HOWTO na rozběhnutí dvou wifi karet v Turrisu.

Snad jsme již foris zvládli

Předpokládám, že první čast nastavování už proběhla: proklikat tím prvním nastavovátkem (foris) a zvolit existující miniPCIe wifi kartu třeba na 5 GHz, nastavit WPA PSK heslo, root heslo a povolit LuCi - advanced webové klikátko poslouchající na portu 8080.

Jako další wifi kartu je možno obstarat si buďto miniPCIe kartu, pro kterou je na Turrisu volný slot, nebo nějakou USB wifi. Já zvolil první možnost - další miniPCIe wifi. K miniPCIe wifi si musíte taky obstarat anteny s Hirose HFL konektorem, já je vykuchal z nějakého starého routeru. Je dobré nějak vyvést kablík od anteny ven z routeru, vevnitř kvůli kovovému krytu bude očekávatelně stráta na síle signálu - naměřil jsem kolem 13-15 dB rozdíl. Zde musí být člověk trochu kreativní, já jsem ty kablíky vyvedl vedle USB portů. Možná to nevypadá nejlíp, ale funkcionalita > estetika :-)

Několik užitečných utilit

Není nutné, ale neuškodí podívat se, jestli je karta detekována správně - a nemuset to parsovat z sysfs. S opkg package managerem si nainstalujeme pciutils (a klidně další podstatné věci jako bash a vim) :


opkg update
opkg install pciutils
lspci

Měly by být vidět dvě wifi karty - já vybíral druhou taky Atheros, prý jsou spolehlivější než třeba Broadcomy:


0000:00:00.0 PCI bridge: Freescale Semiconductor Inc P2020E (rev 21)
0000:01:00.0 Network controller: Atheros Communications Inc. AR9300 Wireless LAN adaptor (rev 01)
0001:02:00.0 PCI bridge: Freescale Semiconductor Inc P2020E (rev 21)
0001:03:00.0 Network controller: Atheros Communications Inc. AR9300 Wireless LAN adaptor (rev 01)

Rozchození další wifi síťovky

Tohle možná umí LuCi přímo, ale já jsem se chtěl trocha víc pohrabat v openwrt ekosystému, protože je dost jiný než běžné linuxové distribuce. U většiny zařízení podporovaných od openwrt se musí šetřit místem a RAMkou. Detekce openwrt skripty vypadá následovně:


mv /etc/config/wireless /etc/config/wireless.orig
wifi detect > /etc/config/wireless
# editovat /etc/config/wireless - viz nize
/etc/init.d/network restart

V tomto momentě bychom měli mít v /etc/config/wireless detekovány dvě wifi síťovky. Upravíme config, já sem hodím příklad hotového configu, na který můžete použit copy-pastu a upravit si podle sebe. Ty optiony z configu lze pokud vím rovnou editovat z LuCi, možná taková možnost bude příjemnější. Hlavně nezapomenout nastavit WPA PSK hesla a změnit "disabled" na 0 (a klidně vypnout obstarožní TKIP).


config wifi-device 'radio0'
        option type 'mac80211'
        option path 'ffe09000.pcie/pci0000:00/0000:00:00.0/0000:01:00.0'
        option htmode 'HT20'
        list ht_capab 'LDPC'
        list ht_capab 'SHORT-GI-20'
        list ht_capab 'SHORT-GI-40'
        list ht_capab 'TX-STBC'
        list ht_capab 'RX-STBC1'
        list ht_capab 'DSSS_CCK-40'
        option country 'CZ'
        option disabled '0'
        option hwmode '11na'
        option channel '44'

config wifi-iface
        option device 'radio0'
        option network 'lan'
        option mode 'ap'
        option disabled '0'
        option ssid 'SSID_for_5GHz'
        option hidden '0'
        option encryption 'psk2+tkip+aes'
        option key 'Yeah,right!'

config wifi-device 'radio1'
        option type 'mac80211'
        option hwmode '11ng'
        option path 'ffe0a000.pcie/pci0001:02/0001:02:00.0/0001:03:00.0'
        option htmode 'HT20'
        list ht_capab 'LDPC'
        list ht_capab 'SHORT-GI-20'
        list ht_capab 'SHORT-GI-40'
        list ht_capab 'TX-STBC'
        list ht_capab 'RX-STBC1'
        list ht_capab 'DSSS_CCK-40'
        option country 'CZ'
        option channel '1'
        option txpower '20'

config wifi-iface
        option device 'radio1'
        option network 'lan'
        option mode 'ap'
        option disabled '0'
        option ssid 'SSID_for_24GHz'
        option encryption 'psk2+tkip+aes'
        option key 'Did I say Yeah right?'
        option wmm '0'

Teď by obě wifi AP měly fungovat.

       

Hodnocení: 60 %

        špatnédobré        

Tiskni Sdílej: Linkuj Jaggni to Vybrali.sme.sk Google Del.icio.us Facebook

Komentáře

Vložit další komentář

Petr Tomášek avatar 22.3.2014 09:37 Petr Tomášek | skóre: 38 | blog: Vejšplechty
Rozbalit Rozbalit vše Re: Turris - současně funkční wifi 5 GHz + 2.4 GHz
On se Turris dá už pořídit bez toho spyware od CZNICu?
multicult.fm | monokultura je zlo | welcome refugees!
22.3.2014 11:43 Miriam | skóre: 3 | blog: zivot
Rozbalit Rozbalit vše Re: Turris - současně funkční wifi 5 GHz + 2.4 GHz
+1 CZ NIC to potopí
Jendа avatar 22.3.2014 12:18 Jendа | skóre: 76 | blog: Výlevníček | JO70FB
Rozbalit Rozbalit vše Re: Turris - současně funkční wifi 5 GHz + 2.4 GHz
Ne.

Naštěstí router se 128 MB RAM (samozřejmě to není tolik jako Turris) se už dá sehnat za nějakých 1400.
limit_false avatar 22.3.2014 18:18 limit_false | skóre: 23 | blog: limit_false
Rozbalit Rozbalit vše Re: Turris - současně funkční wifi 5 GHz + 2.4 GHz
Určitě se ptáš jako člověk, který si od svého ISP vyžádal všechny své data retention záznamy, prohlédl je a pak se zamyslel nad definicí spyware. A ještě k tomu něco udělal, aby zde data retention nebylo.

P.S.: nedoporučuji používat DNS, TLD autoritativní servery logují dotazy, ze kterých lze dělat podobnou statistiku
When people want prime order group, give them prime order group.
Petr Tomášek avatar 23.3.2014 02:05 Petr Tomášek | skóre: 38 | blog: Vejšplechty
Rozbalit Rozbalit vše Re: Turris - současně funkční wifi 5 GHz + 2.4 GHz
To, jeslit ISP shromažďují data nebo ne, ještě nedává NICu právo špehovat.
multicult.fm | monokultura je zlo | welcome refugees!
limit_false avatar 23.3.2014 02:50 limit_false | skóre: 23 | blog: limit_false
Rozbalit Rozbalit vše Re: Turris - současně funkční wifi 5 GHz + 2.4 GHz
Data retention není opt-in. Data retention není ani opt-out. U Turrisu máš na výběr (navíc zběr dat je někde jinde než na levelu data retention, goto data).

Story time: všechny routery co jsem koupil, mají známé exploity na roota v originálním firmware. Můj oblíbený je na Linksys WRT120N - nejlepší demonstrace, co znamená "ROP chain" a jak to funguje. Jedinou instrukcí se vynuluje admin password a zbytek článku se řeší jenom "drobnosti" jak vrátit stack do původní formy (obyčený shellcode by byl jednodušší, ale to je nuda).

Ad koupené routery - kde to šlo, jsem je nahradil s openwrt/ddwrt. Populární Asus WL-500g mrznul a přehříval se (nepočítám bug s nafouknutým kondenzátorem v zdroji), když wifi byla nastavena na používaní TKIP a z Windowsů se kopírovalo něco přes SMB (důsledek malých paketů, ale oddebugování byla pruda). WRT-120n nefungoval správně s 802.1an, když se použilo WPA2.

A jinak proč si vůbec myslíš, že když jednou nainstaluješ $SYSTEM (třeba openwrt), tak si automagicky v bezpečí? Jdi se podívat na local kernel exploit PoC, které dělá autor grsecurity jenom z čtení kernel patchů.
When people want prime order group, give them prime order group.
Rezza avatar 24.3.2014 15:45 Rezza | skóre: 25 | blog: rezza | Brno
Rozbalit Rozbalit vše Re: Turris - současně funkční wifi 5 GHz + 2.4 GHz
Ten kdo podepsal smlouvu, ten mu to prava dal. Kdo nechce, nemusi.
limit_false avatar 23.3.2014 02:09 limit_false | skóre: 23 | blog: limit_false
Rozbalit Rozbalit vše Re: Turris - současně funkční wifi 5 GHz + 2.4 GHz
Tady máš něco na čtení, ať přístě neukazuješ svou nevědomost:

A Taxonomy of Botnet Structures

Detecting Hidden Anomalies in DNS Communication

A co třeba rovnou zdrojáky?

git clone https://gitlab.labs.nic.cz/turris/ucollect.git
When people want prime order group, give them prime order group.

Založit nové vláknoNahoru

ISSN 1214-1267   www.czech-server.cz
© 1999-2015 Nitemedia s. r. o. Všechna práva vyhrazena.