abclinuxu.cz AbcLinuxu.cz itbiz.cz ITBiz.cz HDmag.cz HDmag.cz abcprace.cz AbcPráce.cz
AbcLinuxu hledá autory!
Inzerujte na AbcPráce.cz od 950 Kč
Rozšířené hledání
×

dnes 21:44 | Nová verze

Organizace Apache Software Foundation (ASF) na svém blogu slaví páté výročí kancelářského balíku Apache OpenOffice jako jejího Top-Level projektu. Při této příležitosti byl vydán Apache OpenOffice 4.1.4 (AOO 4.1.4). Podrobnosti v poznámkách k vydání. Dlouhé čekání na novou verzi tak skončilo.

Ladislav Hagara | Komentářů: 0
dnes 19:22 | Pozvánky

Již příští týden - 26. a 27. října se v Praze v hotelu Olšanka odehraje OpenWRT Summit. Na webu konference naleznete program a možnost zakoupení lístků - ty stojí 55 dolarů. Čtvrtek bude přednáškový a v pátek se budou odehrávat převážně workshopy a meetingy.

Miška | Komentářů: 0
dnes 13:44 | Nová verze

Bylo vydáno Ubuntu 17.10 s kódovým názvem Artful Aardvark. Ke stažení jsou Ubuntu Desktop a Server, Ubuntu Cloud Images, Ubuntu Netboot, Kubuntu, Lubuntu a Lubuntu Alternate, Lubuntu Next, Ubuntu Budgie, Ubuntu Kylin, Ubuntu MATE, Ubuntu Studio a Xubuntu. Podrobnosti v poznámkách k vydání.

Ladislav Hagara | Komentářů: 2
dnes 13:00 | Komunita

MojeFedora.cz informuje, že Fedora 27 dostane podporu pro AAC. Podpora multimediálních formátů je ve výchozí instalaci Fedory tradičně limitovaná kvůli softwarovým patentům, ale desktopový tým Red Hatu se ji i tak snaží v poslední době co nejvíce rozšířit. Už nějaký čas obsahuje kodeky pro MP3, H.264, AC3 a nyní byl přidán také kodek pro další velmi rozšířený zvukový formát – AAC.

Ladislav Hagara | Komentářů: 2
včera 23:55 | Pozvánky

Spolek OpenAlt zve příznivce otevřených technologií a otevřeného přístupu na 145. brněnský sraz, který proběhne v pátek 20. října od 18:00 hodin v restauraci Time Out na adrese Novoměstská 2 v Řečkovicích. Jedná se o poslední sraz před konferencí OpenAlt 2017, jež proběhne o víkendu 4. a 5. listopadu 2017 na FIT VUT v Brně. Běží registrace účastníků.

Ladislav Hagara | Komentářů: 0
včera 21:44 | Nová verze

Byla vydána verze 5.2.0 multiplatformního virtualizačního nástroje Oracle VM VirtualBox. Jedná se o první stabilní verzi z nové větve 5.2. Z novinek lze zmínit například možnost exportování VM do Oracle Cloudu, bezobslužnou instalaci hostovaného systému nebo vylepšené GUI. Podrobnosti v seznamu změn. Aktualizována byla také dokumentace.

Ladislav Hagara | Komentářů: 1
včera 14:00 | Zajímavý projekt

Byl spuštěn Humble Down Under Bundle. Za vlastní cenu lze koupit multiplatformní hry The Warlock of Firetop Mountain, Screencheat, Hand of Fate a Satellite Reign. Při nadprůměrné platbě (aktuálně 3,63 $) také Hacknet, Hacknet Labyrinths, Crawl a Hurtworld. Při platbě 12 $ a více lze získat navíc Armello.

Ladislav Hagara | Komentářů: 0
včera 13:00 | Nová verze

Google Chrome 62 byl prohlášen za stabilní (YouTube). Nejnovější stabilní verze 62.0.3202.62 tohoto webového prohlížeče přináší řadu oprav a vylepšení. Vylepšeny byly také nástroje pro vývojáře (YouTube). Opraveno bylo 35 bezpečnostních chyb.

Ladislav Hagara | Komentářů: 4
včera 11:00 | Zajímavý článek

Článek (en) na Mozilla.cz je věnován vykreslování stránek ve Firefoxu. V průběhu roku 2018 by se ve Firefoxu měl objevit WebRender, jenž by měl vykreslování stránek urychlit díky využití GPU.

Ladislav Hagara | Komentářů: 5
včera 08:22 | Bezpečnostní upozornění

NÚKIB (Národní úřad pro kybernetickou a informační bezpečnost) informuje o zranitelnosti ROCA v procesu generování RSA klíčů, který se odehrává v softwarové knihovně implementované například v kryptografických čipových kartách, bezpečnostních tokenech a dalších hardwarových čipech vyrobených společností Infineon Technologies AG. Zranitelnost umožňuje praktický faktorizační útok, při kterém útočník dokáže vypočítat

… více »
Ladislav Hagara | Komentářů: 4
Jak se vás potenciálně dotkne trend odstraňování analogového audio konektoru typu 3,5mm jack z „chytrých telefonů“?
 (10%)
 (1%)
 (1%)
 (1%)
 (75%)
 (13%)
Celkem 103 hlasů
 Komentářů: 6, poslední dnes 20:51
    Rozcestník

    Dotaz: Instalace Oracle 10 Instant Client -- skape na linkeru

    18.11.2005 19:09 Spike | skóre: 30 | blog: Communicator | Praha
    Instalace Oracle 10 Instant Client -- skape na linkeru
    Přečteno: 2115×
    Zdravíčko, už se pěkných pár hodin snažím rebuildovat PHP4 v Debian Stable, aby spolupracoval s Oracle 10 Instant client (viz link). Do debian/rules jsem doplnil --with-oci8-instant-client, patch už je v distribuci. Mám sice zkusit -rlink, ale nějak mi není úplně jasné, kam ho mám přidat. Zkoušel jsem i novější versi klienta.

    Na identický problém na jiných distribucích i s jinými versemi PHP narazila řada dalších: http://bugs.php.net/bug.php?id=32089 http://www.orafaq.com/forum/t/47188/0/

    Ocením jakoukoli radu. ^_^
    /usr/bin/ld: warning: libnnz10.so, needed by
    /usr/lib/oracle/10.1.0.4/client/lib/libclntsh.so,
    not found (try using -rpath or -rpath-link)
    /usr/lib/oracle/10.1.0.4/client/lib/libclntsh.so: undefined reference to `nzos_ServiceWriteQueue'
    

    Odpovědi

    18.11.2005 19:25 Libor Klepac | skóre: 45 | Mýto
    Rozbalit Rozbalit vše Re: Instalace Oracle 10 Instant Client -- skape na linkeru
    no ja nainstaloval instantclienta vcetne sdk do /opt/oracle/instatnclient

    pak stahl oci8 zde http://pecl.php.net/package/oci8

    pak jsem nainstaloval dh-make-php (ve stable neni) , tim jsem z peclu udelal normalni src balicek debianu, v debian/rules pridal za ./configure toto

    --with-oci8=instantclient,/opt/oracle/instantclient

    a jelo to ;) (jeste bylo treba udelat nejaky symbolicky link v adresari oracle z libclntsh.so.10.1 na libclntsh.so a vsechno funguje ;)
    Urine should only be green if you're Mr. Spock.
    19.11.2005 06:46 Spike | skóre: 30 | blog: Communicator | Praha
    Rozbalit Rozbalit vše Re: Instalace Oracle 10 Instant Client -- skape na linkeru
    Toho instant clienta (basic + sdk/devel) jsi instaloval ze zipů nebo rpm? (Já alienem rpm zkonvertoval na deb a ty jsem nainstaloval.)

    Co přesně je to OCI8, na které odkazuješ? Čím se liší od toho v PHP (4.3.10 + debianí patche)? Jak tak koukám, ten --with-oci8 přijímá jako parametr instantclient, takže je do něj asi přidaná podpora... Ta cesta by pak měla ukazovat na hlavičky, nebo na ty .so knihovny (první je v /usr/include/oracle... a druhé v /usr/lib/oracle...)?

    Je to produkční server, nerad bych na něj dával něco, co není nutné (kompiluji samozřejmě na své testovací mašině).

    Hlavně aby se s tím pak dalo pracovat jako by to používalo --with-oci8-instant-client... (Kdyby ne, tak by se to někomu nemuselo líbi. ^_^;)
    19.11.2005 14:12 Libor Klepac | skóre: 45 | Mýto
    Rozbalit Rozbalit vše Re: Instalace Oracle 10 Instant Client -- skape na linkeru
    Nevedel jsem, ze je to oci8 primo v php ;) ... kdyz jsem neco hledal, tak v php manualu byl link sem na ten pecl.

    Rozdil nevim jaky je, mozna, ze to casem uplne osamostatni.

    Toho oracle clienta jsem jenom rozbalil, takze asi ze zipu, snazim se na to oracle zase rychle zapomenout ;))

    php5 se zbavis v debian/rules , zrus ty zavislosti na php5 targetech (je to Makefile) , debian/control muzes vyhodit php5-dev z build-dependecies

    A zapnes to presne jak si rikal, extension=oci8.so , mozna ,ze to ten balik zapne sam
    Urine should only be green if you're Mr. Spock.
    19.11.2005 14:59 Spike | skóre: 30 | blog: Communicator | Praha
    Rozbalit Rozbalit vše Re: Instalace Oracle 10 Instant Client -- skape na linkeru
    Jo, tak nějak jsem se toho zbavil, v debian/rules, akorát ne v debian/control, takže mi to vyhodilo i prázdný .deb pro php5. :D

    Jestli jsem to pochopil správně, tak OCI8 z PECL by měli časem začlenit zpátky do PHP4. Co jsem tak hledal, Oracle a Zend pro PHP5 napsali Zend Core s podporou Oracle databází... Prostě bordel. :))
    19.11.2005 08:02 Spike | skóre: 30 | blog: Communicator | Praha
    Rozbalit Rozbalit vše Re: Instalace Oracle 10 Instant Client -- skape na linkeru
    Tak jsem si vyrobil ten paklík (ještě jsem z něj _nějakým_ způsobem potřeboval odstranit build pro php5) z PECL.

    Teď by tedy měla stačit čistá instalace PHP4 + OCI8 z PECL... a vše bude běhat jak má? Jestli jsem hledal správně, tak je do php.ini třeba přidat extension= nebo tak něco...

    Koukal jsem, že ty PECLy se dají zakompilovat do PHP staticky... No ještě uvidím, musel bych ho pak rebuildovat při každém security updatu...

    Založit nové vláknoNahoru

    Tiskni Sdílej: Linkuj Jaggni to Vybrali.sme.sk Google Del.icio.us Facebook

    ISSN 1214-1267   www.czech-server.cz
    © 1999-2015 Nitemedia s. r. o. Všechna práva vyhrazena.