abclinuxu.cz AbcLinuxu.cz itbiz.cz ITBiz.cz HDmag.cz HDmag.cz abcprace.cz AbcPráce.cz
AbcLinuxu hledá autory!
Inzerujte na AbcPráce.cz od 950 Kč
Rozšířené hledání
×

včera 18:55 | Nová verze

Byla vydána nová stabilní verze 1.9 (1.9.818.44) webového prohlížeče Vivaldi (Wikipedie). Z novinek vývojáři zdůrazňují podporu nového vyhledávače Ecosia. Ten z příjmů z reklam podporuje výsadbu stromů po celém světě (YouTube). Nově lze přeskupovat ikonky rozšíření nebo řadit poznámky. Nejnovější Vivaldi je postaveno na Chromiu 58.0.3029.82.

Ladislav Hagara | Komentářů: 2
včera 17:00 | Nová verze

Byla vydána verze 3.7.0 svobodného systému pro správu obsahu (CMS) Joomla!. V oznámení o vydání (YouTube) se píše o 700 vylepšeních. Opraveno bylo také 8 bezpečnostních chyb.

Ladislav Hagara | Komentářů: 0
včera 08:22 | Komunita

Grsecurity (Wikipedie) je sada bezpečnostních patchů pro linuxové jádro (porovnání se SELinuxem, AppArmorem a KSPP). Od září 2015 nejsou stabilní verze těchto patchů volně k dispozici. Dle včerejšího oznámení (FAQ) nejsou s okamžitou platností volně k dispozici už ani jejich testovací verze.

Ladislav Hagara | Komentářů: 31
26.4. 23:33 | Komunita

OpenBSD 6.1 vyšlo již 11. dubna. Po dvou týdnech byla vydána i oficiální píseň. Její název je Winter of 95 a k dispozici je ve formátech MP3 a OGG.

Ladislav Hagara | Komentářů: 0
26.4. 18:55 | Nová verze

Byla vydána verze 2017.1 linuxové distribuce navržené pro digitální forenzní analýzu a penetrační testování Kali Linux. S vydáním verze 2016.1 se Kali Linux stal průběžně aktualizovanou distribucí. Aktualizovat jej lze pomocí příkazů "apt update; apt dist-upgrade; reboot".

Ladislav Hagara | Komentářů: 0
26.4. 18:22 | Nová verze

Po téměř pěti letech od vydání verze 2.00 byla vydána nová stabilní verze 2.02 systémového zavaděče GNU GRUB (GRand Unified Bootloader). Přehled novinek v souboru NEWS.

Ladislav Hagara | Komentářů: 12
26.4. 17:55 | Komunita

Vývojáři Debianu oznámili, že od 1. listopadu letošního roku nebudou jejich archivy dostupné pomocí protokolu FTP. Již v lednu oznámil ukončení podpory FTP kernel.org (The Linux Kernel Archives).

Ladislav Hagara | Komentářů: 22
26.4. 17:00 | Bezpečnostní upozornění

V oblíbeném webmailu postaveném na PHP SquirrelMail (Wikipedie) byla nalezena bezpečnostní chyba CVE-2017-7692, jež může být útočníkem zneužita ke spuštění libovolných příkazů a kompletnímu ovládnutí dotčeného serveru. Zranitelnost se týká pouze instancí, kde je pro transport používán Sendmail.

Ladislav Hagara | Komentářů: 3
26.4. 13:11 | Zajímavý článek

Soudní dvůr Evropské unie rozhodl (tisková zpráva) ve věci C-527/15: Prodej multimediálního přehrávače, který umožňuje zdarma a jednoduše zhlédnout na televizní obrazovce filmy protiprávně zpřístupněné na internetu, může představovat porušení autorského práva.

Ladislav Hagara | Komentářů: 31
25.4. 13:33 | Pozvánky

Byly stanoveny termíny konferencí LinuxDays 2017 a OpenAlt 2017. Letošní LinuxDays proběhne o víkendu 7. a 8. října v Praze v Dejvicích v prostorách FIT ČVUT. Letošní OpenAlt proběhne o víkendu 4. a 5. listopadu na FIT VUT v Brně.

Ladislav Hagara | Komentářů: 0
Chystáte se pořídit CPU AMD Ryzen?
 (4%)
 (35%)
 (1%)
 (6%)
 (45%)
 (9%)
Celkem 327 hlasů
 Komentářů: 50, poslední včera 04:06
    Rozcestník

    Dotaz: gentoo_pouziti USE

    marvis avatar 16.7.2006 11:04 marvis | skóre: 4
    gentoo_pouziti USE
    Přečteno: 44×
    Dobry den, neni mi uplne jasne pouziti USE. Je nutne mit to spravne nastavene jen pri instalaci? napr. instaluju Gnome tak povolim USE="x y z" , instaluju Kde zakazu xyz a povolim (pridam) USE="a b c" a po instalaci zase povolim i ty pro gnome?

    Odpovědi

    16.7.2006 11:27 Ritchie | skóre: 27 | blog: Ritchie's | Berlin
    Rozbalit Rozbalit vše Re: gentoo_pouziti USE
    RTFM!

    Pokud nějaký balíček potřebuje zvláštní nastavení, je tu soubor /etc/portage/package.use.
    16.7.2006 12:11 Filip Jirsák | skóre: 66 | blog: Fa & Bi
    Rozbalit Rozbalit vše Re: gentoo_pouziti USE
    Těžko říct, čemu v Gentoo říkáte instalace. Vždy, když zadáte emerge program, stáhne se zdroják programu (až na pár výjimek, které se instalují rovnou z binárky), program se nakonfiguruje, přeloží a nainstaluje do systému.

    USE se používá především v té části konfigurace programu před kompilací. Většina programů má volitelné součásti – např. si můžete vybrat, zda jako grafický toolkit bude používat Qt (KDE) nebo GTK (Gnome). Nebo si můžete vybrat, zda bude používat databázi MySQL, PostgreSQL nebo Firebird (nebo dvě z nich nebo všechny). Při překladu programu z příkazové řádky se to většinou nastavuje spuštěním skriptu ./configure s příslušnými parametry
    ./configure --with-qt --with-mysql --with-postgresql
    
    Tím se určí, které volitelné části chcete do programu zahrnout a které ne.

    No a emerge používá USE příznaky právě ke konfiguraci těchto voleb. Autor ebuild balíčku ho tedy napíše tag, že pokud máte mezi USE např. qt3, nakofiguruje program s --with-qt.

    Souvisí s tím ještě jedna věc, a to jsou závislosti. Když program používá třeba knihovnu Qt, musí být tato knihovna v systému nainstalovaná. Takže ebuild balíček pokud máte tento USE příznak nastaven ještě řekne emrge systému "potřebuji pro svou funkci balíček x11-libs/qt". Emerge zkontroluje, zda už je v systému nainstalovaný, nebo jej také nainstaluje.

    Abych vám odpověděl: obecně je rozumné mít USE příznaky nastavené na stálo a neměnit je s každou kompilací. Třeba když používáte KDE, dáte si do USE příznaků kde a všechny aplikace, které v sobě mají nějakou podporu KDE se skompilují s touto podporou.

    Pokud chcete nějaký příznak použít u jednoho balíčků, ale ne obecně pro celý systém, použijte konfigurační soubor /etc/portage/package.use. To se hodí třeba v případě, že chci jeden program s podporou databáze MySQL, ale enchci podporu MySQL ve všech programech v systému. Pak si nastavím v globálních USE -mysql, takže všechny aplikace se mi budou do systému instalovat bez podpory MySQL. A u té jedné, kde chci mít podporu MySQL, si to nastavím v /etc/portage/package.use, a ta bude mít podporu MySQL zakomilovanou (samozřejmě se uplatní příslušné závislosti, takže pokud jste předtím MySQL v systému neměl, to se doinstaluje).

    Pokud chcete změnit USE příznaky jen pro jednu konkrétní kompilaci, můžete použít
    USE="…" emerge xyz
    Ale to pouze v případě, že dobře víte, co děláte. Emerge si totiž nebude USE příznak pamatovat a při příštím emerge -a world, kdy bude nová verze i programu xyz se vám tento nainstaluje s USe příznaky jak je máte nastavené v systému.
    marvis avatar 16.7.2006 13:20 marvis | skóre: 4
    Rozbalit Rozbalit vše Re: gentoo_pouziti USE
    .... diky za vysvetleni

    Založit nové vláknoNahoru

    Tiskni Sdílej: Linkuj Jaggni to Vybrali.sme.sk Google Del.icio.us Facebook

    ISSN 1214-1267   www.czech-server.cz
    © 1999-2015 Nitemedia s. r. o. Všechna práva vyhrazena.