abclinuxu.cz AbcLinuxu.cz itbiz.cz ITBiz.cz HDmag.cz HDmag.cz abcprace.cz AbcPráce.cz
AbcLinuxu hledá autory!
Inzerujte na AbcPráce.cz od 950 Kč
Rozšířené hledání
×

dnes 11:33 | IT novinky

Red Hat kupuje společnost Codenvy stojící za stejnojmenným webovým (cloudovým) integrovaným vývojovým prostředím (WIDE) postaveném na Eclipse Che.

Ladislav Hagara | Komentářů: 0
dnes 08:55 | Nová verze

V listopadu 2014 byl představen fork Debianu bez systemd pojmenovaný Devuan. Po dva a půl roce jeho vývojáři oznámili vydání první stabilní verze 1.0. Jedná se o verzi s dlouhodobou podporou (LTS) a její kódové jméno je Jessie, podle planetky s katalogovým číslem 10 464.

Ladislav Hagara | Komentářů: 6
včera 20:22 | Zajímavý článek

Nadace Raspberry Pi vydala již osmapadesáté číslo (pdf) stostránkového anglicky psaného časopisu MagPi věnovanému Raspberry Pi a projektům postaveným na tomto jednodeskovém počítači a druhé číslo (pdf) časopisu Hello World primárně určeného pro učitele informatiky a výpočetní techniky.

Ladislav Hagara | Komentářů: 0
včera 19:55 | Humor

Portál Stack Overflow informuje na svém blogu, že pomohl ukončit editor Vim už více než milionu vývojářů. V loňském roce například hledal odpověď na otázku Jak ukončit editor Vim v průměru 1 z 20 000 návštěvníků.

Ladislav Hagara | Komentářů: 10
včera 19:22 | Nová verze

Po pěti měsících od vydání verze 3.5.0 byla vydána nová stabilní verze 3.6.0, tj. první z nové řady 3.6, minimalistické linuxové distribuce zaměřené na bezpečnost Alpine Linux (Wikipedie). Z novinek lze zmínit například podporu dvou nových 64bitových platforem little-endian POWER machines (ppc64le) a IBM z Systems (s390x) nebo nové balíčky Rust 1.17.0, Cargo 0.18.0, GHC 8.0.2 a Julia 0.5.2.

Ladislav Hagara | Komentářů: 0
24.5. 21:33 | Bezpečnostní upozornění

V Sambě byla nalezena a opravena bezpečnostní chyba CVE-2017-7494. Má-li útočník právo ukládat soubory na vzdálený server, může tam uložit připravenou sdílenou knihovnu a přinutit smbd server k jejímu načtení a tím pádem ke spuštění libovolných příkazů. Chyba je opravena v upstream verzích 4.6.4, 4.5.10 a 4.4.14. Chyba se týká všech verzí Samby od verze 3.5.0 vydané 1. března 2010.

Ladislav Hagara | Komentářů: 5
24.5. 20:44 | Nová verze

Byla vydána nová stabilní verze 4.3.0 integrovaného vývojového prostředí (IDE) Qt Creator. Z novinek lze zmínit například integraci editoru kódu do Qt Quick Designeru.

Ladislav Hagara | Komentářů: 1
24.5. 20:11 | Bezpečnostní upozornění

Společnost Check Point informuje na svém blogu o novém vektoru útoku. Pomocí titulků lze útočit na multimediální přehrávače VLC, Kodi, Popcorn Time, Stremio a pravděpodobně i další. Otevření útočníkem připraveného souboru s titulky v neaktualizovaném multimediálním přehrávači může vést ke spuštění libovolných příkazů pod právy uživatele. Ukázka na YouTube. Chyba je opravena v Kodi 17.2 nebo ve VLC 2.2.6.

Ladislav Hagara | Komentářů: 11
23.5. 15:18 | Zajímavý software

CrossOver, komerční produkt založený na Wine, je dnes (23. 5. 2017) dostupný ve slevě. Roční předplatné linuxové verze vyjde s kódem TWENTYONE na $21, resp. $1 v případě IP z chudších zemí. Firma CodeWeavers, která CrossOver vyvíjí, významně přispívá do Wine. Přidaná hodnota CrossOver spočívá v přívětivějším uživatelském rozhraní, integraci do desktopu a podpoře.

Fluttershy, yay! | Komentářů: 26
23.5. 15:11 | Zajímavý projekt

V únoru loňského roku bylo představeno několik útoků na celou řadu bezdrátových klávesnic a myší s názvem MouseJack. Po více než roce lze chybu opravit, tj. aktualizovat firmware, také z Linuxu. Richardu Hughesovi se podařilo navázat spolupráci se společností Logitech, získat od nich dokumentaci, přesvědčit je, aby firmware poskytovali přímo a ne jako součást .exe souboru, aby mohl být popis začleněn do služby Linux Vendor Firmware Service (LVFS) a aktualizace tak mohla proběhnou přímo z Linuxu pomocí projektu fwupd.

Ladislav Hagara | Komentářů: 2
Chystáte se pořídit CPU AMD Ryzen?
 (6%)
 (32%)
 (1%)
 (8%)
 (44%)
 (9%)
Celkem 620 hlasů
 Komentářů: 62, poslední 19.5. 01:57
    Rozcestník

    Dotaz: php-gtk

    mika-talvinen avatar 10.9.2010 18:54 mika-talvinen | skóre: 23 | Plzeň
    php-gtk
    Přečteno: 204×
    Zdravím, rád bych si nainstaloval php-gtk, ale po instalaci glib (2.24.2), když ve složce php-gtk spustím ./configure, vyhodí to tohle:

    checking for GLIB - version >= 2.6.0...
    *** 'pkg-config --modversion glib-2.0' returned 2.24.2, but GLIB (2.24.1)
    *** was found! If pkg-config was correct, then it is best
    *** to remove the old version of GLib. You may also be able to fix the error
    *** by modifying your LD_LIBRARY_PATH enviroment variable, or by editing
    *** /etc/ld.so.conf. Make sure you have run ldconfig if that is
    *** required on your system.
    *** If pkg-config was wrong, set the environment variable PKG_CONFIG_PATH
    *** to point to the correct configuration files
    no
    configure: error: PHP-GTK 2.x requires GLib 2.6.0 or higher

    Našel jsem 1000 a jeden stejný problém na googlu, ale pořád nic, co tedy s tím?

    Odpovědi

    10.9.2010 19:16 chrono
    Rozbalit Rozbalit vše Re: php-gtk
    Tú verziu 2.24.2 si inštaloval ako? (pretože tam máš pravdepodobne verzie dve, alebo máš devel balík pre nesprávnu verziu)
    mika-talvinen avatar 10.9.2010 19:23 mika-talvinen | skóre: 23 | Plzeň
    Rozbalit Rozbalit vše Re: php-gtk
    Stáhnul jsem archiv tar.gz, rozbalil, ./buildconf, ./configure, make, make install
    10.9.2010 20:09 chrono
    Rozbalit Rozbalit vše Re: php-gtk
    V tom prípade tam asi máš nainštalovanú aj systémovú verziu Glib. Asi by bolo najlepšie odinštalovať tú Glib knižnicu, ktorú si skompiloval a nainštalovať z repozitára devel balíček Glib.
    mika-talvinen avatar 10.9.2010 20:40 mika-talvinen | skóre: 23 | Plzeň
    Rozbalit Rozbalit vše Re: php-gtk
    Tak jsem to nainstaloval a teď to hází:
    checking for libsexy support... no
    checking for GtkMozEmbed support... no
    checking for scintilla support... no
    checking for sourceview support... no
    checking for spell support... no
    creating main/php_gtk_ext.c
    ./configure: line 11641: LTOPTIONS_VERSION: command not found
    ./configure: line 11642: LTSUGAR_VERSION: command not found
    ./configure: line 11643: LTVERSION_VERSION: command not found
    ./configure: line 11644: LTOBSOLETE_VERSION: command not found
    checking for a sed that does not truncate output... (cached) /bin/sed
    ./configure: line 11719: syntax error near unexpected token `lt_decl_varnames,'
    ./configure: line 11719: `lt_if_append_uniq(lt_decl_varnames, SED, , ,'


    10.9.2010 21:56 chrono
    Rozbalit Rozbalit vše Re: php-gtk
    Pravdepodobne ti chýba libtool.
    mika-talvinen avatar 11.9.2010 01:43 mika-talvinen | skóre: 23 | Plzeň
    Rozbalit Rozbalit vše Re: php-gtk
    nn, taky mam: sudo apt-get install libtool
    libtool je již nejnovější verze
    libtool nastaven jako instalovaný ručně (?)
    poky74 avatar 10.9.2010 21:17 poky74 | skóre: 36 | blog: Zápisník | Vrchlabí
    Rozbalit Rozbalit vše Re: php-gtk

    aptitude install libgtk2.0-dev

    Chcete Linuxové samolepky nebo Tuxe na klíče? ->
    mika-talvinen avatar 10.9.2010 21:27 mika-talvinen | skóre: 23 | Plzeň
    Rozbalit Rozbalit vše Re: php-gtk
    mam nainstalováno

    Založit nové vláknoNahoru

    Tiskni Sdílej: Linkuj Jaggni to Vybrali.sme.sk Google Del.icio.us Facebook

    ISSN 1214-1267   www.czech-server.cz
    © 1999-2015 Nitemedia s. r. o. Všechna práva vyhrazena.