abclinuxu.cz AbcLinuxu.cz itbiz.cz ITBiz.cz HDmag.cz HDmag.cz abcprace.cz AbcPráce.cz
AbcLinuxu hledá autory!
Inzerujte na AbcPráce.cz od 950 Kč
Rozšířené hledání
×
dnes 17:53 | Bezpečnostní upozornění

Google na svém blogu věnovaném počítačové bezpečnost informuje o nalezení "reálného" způsobu generování kolizí hašovací funkce SHA-1. Podrobnosti a zdrojové kódy budou zveřejněny do 90 dnů. Již dnes lze ale na stránce SHAttered nalézt 2 pdf soubory, jejichž obsah se liší a SHA-1 otisk je stejný (infografika).

Ladislav Hagara | Komentářů: 1
dnes 17:51 | Nová verze

Vyšla nová verzia open source software na správu a automatizáciu cloudových datacentier Danube Cloud 2.4. Danube Cloud je riešenie postavené na SmartOS, ZFS, KVM a zónach. Obsahuje vlastnosti ako integrovaný monitoring, DNS manažment, zálohy, a samozrejme rozsiahlu dokumentáciu.

dano | Komentářů: 0
dnes 17:46 | Pozvánky

V Plzni se 3. až 5. března 2017 uskuteční AIMTEChackathon. Je to akce pro vývojáře, grafiky, webdesignéry i veřejnost. Akci provází zajímavé přednášky IT odborníků. Více o programu a možnosti přihlášení na stránkách akce.

cuba | Komentářů: 0
dnes 01:00 | Nová verze

Známý šifrovaný komunikátor Signal od verze 3.30.0 již nevyžaduje Google Play Services. Autoři tak po letech vyslyšeli volání komunity, která dala vzniknout Google-free forku LibreSignal (dnes již neudržovaný). Oficiální binárky jsou stále distribuované pouze přes Google Play, ale lze použít neoficiální F-Droid repozitář fdroid.eutopia.cz s nezávislými buildy Signalu nebo oficiální binárku stáhnout z Google Play i bez Google účtu

… více »
xm | Komentářů: 5
včera 23:14 | Nová verze

Po třech týdnech od vydání první RC verze byla vydána první stabilní verze 17.01.0 linuxové distribuce pro routery a vestavěné systémy LEDE (Linux Embedded Development Environment), forku linuxové distribuce OpenWrt. Přehled novinek v poznámkách k vydání. Dotazy v diskusním fóru.

Ladislav Hagara | Komentářů: 6
včera 17:28 | Bezpečnostní upozornění

Byly zveřejněny informace o bezpečnostní chybě CVE-2017-6074 v Linuxu zneužitelné k lokální eskalaci práv. Jde o chybu v podpoře DCCP (Datagram Congestion Control Protocol). Do linuxového jádra se dostala v říjnu 2005. V upstreamu byla opravena 17. února (commit). Bezpečnostní chyba byla nalezena pomocí nástroje syzkaller [Hacker News].

Ladislav Hagara | Komentářů: 11
včera 15:00 | Zajímavý software

Společnost Valve vydala novou beta verzi SteamVR. Z novinek lze zdůraznit oficiální podporu Linuxu. Další informace o podpoře této platformy pro vývoj virtuální reality v Linuxu v diskusním fóru. Hlášení chyb na GitHubu.

Ladislav Hagara | Komentářů: 0
včera 06:00 | Nová verze

Po necelém roce od vydání verze 0.67 byla vydána verze 0.68 populárního telnet a ssh klienta PuTTY. Podrobnosti v přehledu změn. Řešeny jsou také bezpečnostní chyby.

Ladislav Hagara | Komentářů: 0
21.2. 21:32 | Nasazení Linuxu

Canonical představuje nejnovější verzi chytré helmy DAQRI s Ubuntu pro rozšířenou realitu. K vidění bude příští týden v Barceloně na veletrhu Mobile World Congress 2017.

Ladislav Hagara | Komentářů: 0
21.2. 21:31 | Pozvánky

Pro zájemce o hlubší znalosti fungování operačních systémů připravila MFF UK nový předmět Pokročilé operační systémy, v rámci něhož se vystřídají přednášející nejen z řad pracovníků fakulty, ale dorazí také odborníci ze společností AVAST, Oracle, Red Hat a SUSE. Tento předmět volně navazuje na kurz Operační systémy ze zimního semestru, ale pokud máte praktické zkušenosti odjinud (například z přispívání do jádra Linuxu) a chcete si

… více »
Martin Děcký | Komentářů: 6
Jak se stavíte k trendu ztenčování přenosných zařízení (smartphony, notebooky)?
 (13%)
 (2%)
 (71%)
 (3%)
 (10%)
Celkem 691 hlasů
 Komentářů: 66, poslední včera 18:57
    Rozcestník

    Dotaz: Fedora a Amavis

    13.2.2004 12:03 kama
    Fedora a Amavis
    Přečteno: 808×
    Zdravím. Nedaří se mi nainstalovat Amavis-new20030616-3.p6.rhfc1.rpm na Fedoru.Stále píše spoustu perlovských modulů, které chybí. Na CD nejsou a když jsem je stáhnul buď nejdou nainstalovat, nebo se naistaluji a presto pri instalaci amavis zahlasi, ze je nema.Zkousel jsem perlovske moduly jak v rpm, tak v tar.gz.Apropo, co znamená v názvu "p6" Dík Kama

    Odpovědi

    13.2.2004 15:50 unchallenger | skóre: 69 | blog: unchallenger
    Rozbalit Rozbalit vše Fedora a Amavis
    Kdes vzal to rpm, co za moduly chybí, moduly jsi zkoušel instalovat z CPANu, rpm, ...? Je pátek třináctého a křišťálové koule nefungují.
    15.2.2004 13:35 Kama
    Rozbalit Rozbalit vše Fedora a Amavis
    Bylo třeba nainstalovat dle návodu na http://www.abclinuxu.cz/clanky/ViewRelation?rid=50909:

    perl-Archive-Tar perl-Archive-Zip perl-Compress-Zlib perl-Convert-TNEF perl-Convert-UUlib perl-IO-stringy perl-libnet perl-MailTools perl-MIME-Base64 perl-MIME-tools perl-Unix-Syslog perl-Net-Server perl-Time-HiRes perl-Digest-MD5 perl-Digest-SHA1 perl-Digest-HMAC perl-Net-DNS arc nomarch bzip2 file lha ncompress unarj unrar zoo

    Některé moduly jako arc jsem nenašel ani na inst.CD ani jinde. Všechny perlovské moduly jsem stáhnul z http://www.cpan.org/modules/01modules.index.html. Jejich kompilace proběhlá zdánlivě bez problémů (z CPAn *.tar.gz ...makefile.pl,make,make install), Při instalaci amavisu, (verze jsou níže), napsal hlášku, že nemá nainstalovány perlovské moduly, jejichž instalace proběhla zdánlivě vpořádku. Z amavisu jsem zkoušel jednak amavisd-new-20030616-p7.tar.gz na adrese http://www.ijs.si/software/amavisd/#download a pak i amavis-ng_0.1.6.4.orig.tar.gz

    Budu muset zkusit opět RH 7.3. Je spousta www stránek, která popisuje instalaci amavisu do RH7.3 a nabízí přímo pro tuto distribuci perlovské moduly. Je možné, že pro Fedoru nefungují... tak to by byla smůla. Fakt nevím. Kama
    15.2.2004 13:37 kama
    Rozbalit Rozbalit vše Fedora a Amavis
    Tak arc.rpm jsem našel, problém ale přetrvává.Kama
    15.2.2004 13:44 unchallenger | skóre: 69 | blog: unchallenger
    Rozbalit Rozbalit vše Fedora a Amavis
    Když něco nainstaluješ ručně z CPANu, tak o těch modulech samozřejmě neví rpm, takže si při instalaci něčeho, co na nich závisí, stěžuje. Z tohoto důvodu dělám ze všech perlových modulů balíčky pomocí Perl2RPM.

    Nebo můžeš nainstalovat ručně (a ne z balíčku) i amavis...

    Poslední možnost je --nodeps, když jsi si jist, že tam ty moduly máš, ale to moc nedoporučuji.
    16.2.2004 14:56 Dušan Hokův | skóre: 43 | blog: Fedora a další...
    Rozbalit Rozbalit vše Fedora a Amavis
    nefunguji... rh9 ma perl 5.8.0, fedora 5.8.1; je treba pouzit src.rpm baliky a prelozit si je pro fedoru
    16.2.2004 15:09 unchallenger | skóre: 69 | blog: unchallenger
    Rozbalit Rozbalit vše Fedora a Amavis
    To by tam ti tataři museli nějaká .src.rpm mít...

    Ale balíčky pro 5.8.0 (tj. RH9) by nevadily, když se na FC1 podíváš do @INC, zjistíš, že z důvodu zpětné kompatibility tam jsou cesty jak 5.8.1 tak s 5.8.0.

    Jinak řadu těch modulů mám zRPMovaných přímo pro FC1 i na svých stránkách (stačí hledat, např. Google: Fedora Core 1 "MIME-tools" rpm), zbytek by snad zvládl Perl2RPM...
    18.2.2004 13:49 kama
    Rozbalit Rozbalit vše Fedora a Amavis
    Je zde někdo, kdo rozchodil Avavis nad Fedorou Core 1? Nemůžu pořád sehnat následující balíčky.: Perl-Archive-Tar.rpm Perl-convert-TNEF.rpm Perl-MIME Entity.rpm Perl-MIME-Parser.rpm Perl-MIME-Words.rpm Perl-Mail-Address.rpm ncompres.rpm unarj.rpm Co znamená, balik.src.rpm. Co znamena SRC? Ještě jednou dík Kama
    18.2.2004 14:03 unchallenger | skóre: 69 | blog: unchallenger
    Rozbalit Rozbalit vše Fedora a Amavis
    src.rpm jsou zdrojáky. normální balíček z nich získáš rpmbuildem. je to tu furt dokola...

    použij Perl2RPM a vyrob si balíčky sám. kromě toho existuje rpmpan, kde jsou rpm od kompletního CPANu, akorát už nevím, pro co...
    18.2.2004 17:13 kama
    Rozbalit Rozbalit vše Fedora a Amavis
    perl2rpm mi hází chyby. Configured : _sourcedir=/usr/src/redhat/SOURCES Cannon determine the value of `%{?skeldir}' from `rpm --showrc' Compilation failed failed in require at usr/lib/perl5/vendor_perl/5.8.1/RPM/Perl2RPM.pam line 26 Begin failed--compilation aborted at usr/lib/perl5/vendor_perl/5.8.1/RPM/Perl2RPM.pam line 26 Už se s tím drbu týden. A nejsem schopnej na Fedoře nainstalovat jenom perl. .Asi to zabalim. Vracim se k RH 7.3. Dik ya rady
    18.2.2004 18:06 unchallenger | skóre: 69 | blog: unchallenger
    Rozbalit Rozbalit vše Fedora a Amavis
    Sorry, to bude moje chyba. Vydal jsem Perl2RPM-1.3.1.
    18.2.2004 18:12 kama
    Rozbalit Rozbalit vše Fedora a Amavis
    Takže začít znova??? :-) Dnes už neeeeeeeee. Zítra stáhnu Z Tvých stránek perl2RPM znovu. Snad tam budeš mít nějakou jinou vezri. Dík Kama
    18.2.2004 18:22 unchallenger | skóre: 69 | blog: unchallenger
    Rozbalit Rozbalit vše Fedora a Amavis
    Však už tam je 1.3.1 s opravou...

    Byla tam blbá chyba, takže to fungovalo lidem, kteří používali perl2rpm už dřív, ale čerstvé instalace chcípaly...

    Já bych ti v podstatě ty balíčky pro FC1 mohl udělat, ale když už jsem jednou napsal program, který to automatizuje... ;-)
    19.2.2004 08:46 kama
    Rozbalit Rozbalit vše Fedora a Amavis
    Pozn. Budou platit ty balíčky ,které doufám vyrobím,i pro RH 9.0? Kama
    19.2.2004 08:50 unchallenger | skóre: 69 | blog: unchallenger
    Rozbalit Rozbalit vše Fedora a Amavis
    Ne, naopak. Viz můj příspěvek z 16.2.2004 15:09.
    19.2.2004 08:59 kama
    Rozbalit Rozbalit vše Fedora a Amavis
    Šel bys raději do Fedory,nebo RH9.0 Shrike? Už jsem to totiž přeinstaloval na RH.9.0 v domění, že amavis rozjedu....:-) Mám raději nainstalovat ypět Fedoru? Kama
    19.2.2004 09:06 unchallenger | skóre: 69 | blog: unchallenger
    Rozbalit Rozbalit vše Fedora a Amavis
    Já bych nainstaloval Fedoru, jenže já mám výrobu perlových rpm balíčků dobře zvládnutou, takže si potřebné rpm vyrobím na cokoli (co používá rpm)...
    19.2.2004 09:12 kama
    Rozbalit Rozbalit vše Fedora a Amavis
    OOK. Přeinstaluju to zpět na FEDORU A budutě otravovat dál :-) Dík. Zatím
    19.2.2004 17:52 kama
    Rozbalit Rozbalit vše Fedora a Amavis
    Vím, že je to trapny.ale Nainstaloval jsem perl-perl2rpm-1.3-1.noarch.rpm (48.9 kB) Když napíšu: perl2rpm archive-Tar-0.22.tar.gz Pořád mi to hází stejnou chybu. (Fedora) Ještě jednou Dík PS: Na http://dag.wieers.com/packages/ není zdaleka vše pro fedoru.
    19.2.2004 18:32 unchallenger | skóre: 69 | blog: unchallenger
    Rozbalit Rozbalit vše Fedora a Amavis
    1.3 je buggy

    1.3.1 je opravený

    Po 1.3 už tam není den ani stopy, kde ho bereš?

    Krom toho balíčky pro RH9 jsou OK, pokud někde jsou (jak jsem psal výše).
    19.2.2004 18:42 unchallenger | skóre: 69 | blog: unchallenger
    Rozbalit Rozbalit vše Fedora a Amavis
    Teď jsem zkusil Perl2RPM-1.3.1 bootstrapnout (vyrobit rpm z Perl2RPM pomocí Perl2RPM) na panenském počítači a jede mi to.

    Pokud je to opravdu 1.3.1, tak by mě zajímal podrobnější bugreport.
    19.2.2004 22:16 kama
    Rozbalit Rozbalit vše Fedora a Amavis
    Tak si představ, že proxyna v práci měla Tvou stránku v cashce a ukazovala mi v práci pouze staré stránky.... Z domu je vidět zcela něco jiného, než z práce.... Já se na to vyprdnu. To je materiál.....Ze sebe dělám blbce. Dík, zítra dám vědět co a jak dopadlo. Snad to klapne...Kama
    19.2.2004 09:12 David Luftner
    Rozbalit Rozbalit vše Fedora a Amavis
    Na adrese http://dag.wieers.com/packages/ najdete všechny balíčky amavisd-new včetně balíčků, které nejsou součástí instalace (moduly perlu rozbalovače a pod).
    Vřele doporučuji.
    19.2.2004 18:23 kam
    Rozbalit Rozbalit vše Fedora a Amavis
    Vím, že je to trapny.ale Nainstaloval jsem perl-perl2rpm-1.3-1.noarch.rpm (48.9 kB) Když napíšu: perl2rpm archive-Tar-0.22.tar.gz Pořád mi to hází stejnou chybu. (Fedora) Ještě jednou Dík PS: Na http://dag.wieers.com/packages/ není zdaleka vše pro fedoru.
    20.2.2004 10:11 kama
    Rozbalit Rozbalit vše Fedora a Amavis
    Tak nevim. 1) stáhnul jsem perl-perl2rpm-1.3.2-1.noarch.rpm 2) rpm -i perl-perl2rpm-1.3.2-1.noarch.rpm 3) perl2rpm-cpan Archive-Tar-0.22.tar.gz 4) vyběhne hláška rpm --showrc Configured : _sourcedir=/usr/src/redhat/SOURCES

    Cannot determine the value of `%{_skeldir}' from `rpm --showrc'

    Compilation failed in require at usr/lib/perl5/site_perl/5.8.1/RPM/Perl2RPM.pm line 26

    Begin failed--compilation aborted at usr/lib/perl5/site_perl/5.8.1/RPM/Perl2RPM.pm line 26

    Compilation failed in require at usr/bin/perl2rpm-cpan line 34

    Compilation faild--compilation aborted at /usr/bin/perl2rpm-cpan line 34

    fakt me to s...
    20.2.2004 13:45 unchallenger | skóre: 69 | blog: unchallenger
    Rozbalit Rozbalit vše Fedora a Amavis
    To jsem blázen... Kdyby ti to napsalo ,Cannot read /home/kama/.cpan/MyConfig.pm`, tak bych chápal, že nemáš rozchozený perl-CPAN modul umožňující automatické stahování přímo z CPANu (a v tom případě nepoužívej perl2rpm-cpan Archive::Tar ale perl2rpm Archive-Tar-něco.tar.gz).

    Určitě se nespouští stará verze? which perl2rpm a podívej se, co je přiřazeno do ,my $VERSION = ...`.

    Já ti ta rpm tedy vyrobím, když mi sem dáš seznam, co ještě chybí (perl-Archive-Tar je např. přímo ve Fedoře, takže ho není zapotřebí vyrábět), ale rád bych zjistil, proč ti to nefunguje.
    20.2.2004 14:09 kama
    Rozbalit Rozbalit vše Fedora a Amavis
    OK.

    Dnes jsem nainstaloval perl2rpm 1.3.2.1.rpm, předtím jsem odinstaloval perl2rpm 1.3.1...rpm.

    Pak jsem spustil perl2rpm archive-Tar...tar.gz a nic to neudělalo.

    Stahnul jsem tedy perl2rpm-1.3.2.tar.gz, rozbalil, perl Makefile.PL, make,make test, (test proběhl OK), make install. Vše OK. Pak jsem znovu napsal: perl2rpm archive-Tar.tar.gz

    Proběhlo spostu řádků....snad na 2 opbrazovky. Zůstalo to viset, asi ve "VIMu" Mám pocit, že i když to stopnu, tak proces jede dál. V /usr/src/redhat/SOURCES je !Archive-Tar.tar.gz červeně. Pokud mi napíšeš, kam to loguje, pošlu log soubor.

    Pokud všemu rozumím, měl by se do Adresare /usr/src/redhat/Sources/RPMS vytvořit automaticky rpm balíček Archive-Tar.rpm a to po zadání perl2rpm Archive-Tar.tar.gz

    Je tak?
    20.2.2004 14:53 unchallenger | skóre: 69 | blog: unchallenger
    Rozbalit Rozbalit vše Fedora a Amavis
    Jo; argument je prostě tarball s modulem.

    Editor se spustí, abys mohl napsat nějaký rozumný popis balíčku, pokud chceš (popis se bohužel neumí napsat sám...). Zkouší to spustit postupně $VISUAL, $EDITOR a vi (podobně jako crontab, cvs, ...). Nepodaří-li se nic z toho, tak to asi chcípne. Pokud chceš zcela neinteraktivní build, tak to spouštěj

    VISUAL=/bin/cat perl2rpm Archive-Tar-0.22.tar.gz

    Červeně, to asi myslíš link na neexistující soubor. To by mělo nastat jedině v případě, pokud jsi tomu dal jako argument neexistující soubor (tarball).

    Log je to, co to vypisuje na obrazovku ;-) takže případně &>perl2rpm.log

    Sakra, rpm od Archive::Tar už mám vyrobené na všech počítačích, kde mám účet ;-) ale všude to funguje.
    23.2.2004 10:12 David Luftner
    Rozbalit Rozbalit vše Fedora a Amavis
    Ja nasel na DAG vse abych to nainstaloval co nemuzete najit?
    BALIČEKZDROJ
    amavisd-new-20030616-3.p6.rhfc1.dag.i386.rpmDAG
    arc-5.21e-0.rhfc1.dag.i386.rpmDAG
    nomarch-1.3-1.rhfc1.dag.i686.rpmDAG
    perl-Archive-Zip-1.05-1.rhfc1.dag.noarch.rpmDAG
    perl-Compress-Zlib-1.22-0.rhfc1.dag.i386.rpmDAG
    perl-Convert-TNEF-0.17-2.rhfc1.dag.noarch.rpmDAG
    perl-Convert-UUlib-0.31-0.rhfc1.dag.i386.rpmDAG
    perl-Digest-HMAC-1.01-1.rhfc1.dag.noarch.rpmDAG
    perl-Digest-SHA1-2.03-0.rhfc1.dag.i386.rpmDAG
    perl-IO-stringy-2.108-4.rhfc1.dag.noarch.rpmDAG
    perl-MIME-tools-5.411-2.rhfc1.dag.noarch.rpmDAG
    perl-Net-DNS-0.38-0.rhfc1.dag.noarch.rpmDAG
    perl-Net-Server-0.86-0.rhfc1.dag.noarch.rpmDAG
    perl-Unix-Syslog-0.100-0.rhfc1.dag.i386.rpmDAG
    perl-MailTools-1.60-0.rhfc1.dag.noarch.rpmDAG
    unrar-2.71-0.rhfc1.dag.i686.rpmDAG
    zoo-2.10-1.rhfc1.dag.i686.rpmDAG
    ncompress-4.2.4-34.i386.rpmCD Fedora
    perl-Archive-Tar-0.22-29.noarch.rpm)CD Fedora
    spamassassin-2.60-2.i386.rpmCD Fedora
    perl-HTML-Parser-3.26-18.i386.rpmCD Fedora
    perl-HTML-Tagset-3.03-28.noarch.rpmCD Fedora
    perl-TimeDate-1.1301-5.noarch.rpmCD Fedora
    perl-Time-HiRes-1.38-4.i386.rpmCD Fedora
    unarj-2.63a-4.i386.rpmCD Fedora
    23.2.2004 11:12 Kamorek | skóre: 33 | blog: předvolební mazec | VB
    Rozbalit Rozbalit vše Fedora a Amavis
    Např. když dám prom -i perl-Archive-Tar*.rpm chybí MailTools.rpm Když dám rpm -i perl-Mailtools*.rpm, tak zahlásí, že mu ještě chybí perl:(Date::Format) a perl(Date::parse). A takové závislosti mi hlásí téměř u každého rpm balíčku.. Asi zešedivím.

    PS: Pro Yetiho: MÁM POCIT, ŽE MI ZAMRZÁ PRÁVĚ "vi". když ho spustím, nejde z něj vyskočit a chová se podivně.Nicméně jsem s ním nikdy neměl co do činění, takže nevím.Ale sakra instaloval jsem Fedoru už 2x a mašina je téměř nová. Dík Kama
    Taky si udělám nějakou studii.
    23.2.2004 11:18 David Luftner
    Rozbalit Rozbalit vše Fedora a Amavis
    Stahnul jsem všechno co jsem uedl a instaloval jsem to najednou:
    rpm -i baliček1 baliček2 baliček3 ...
    Myslím, že se tam někde i kříží závislosti tak to je jediná šance.
    Teď jsem to projistotu zkusil na nově nainstalované Fedore a instalace proběhne OK.
    23.2.2004 11:27 Kamorek | skóre: 33 | blog: předvolební mazec | VB
    Rozbalit Rozbalit vše Fedora a Amavis
    Že už se tak blbě ptám: je správný zápis:

    rpm -i arc*.rpm perl-Mime-Tools*.rpm perl-mailTools*.rpm......?

    každopádně Amavis instalujete jako poslední. Když dám rpm -i amavis*.rpm tak mi nyní vypíše, že chybí: Perl: Archive::tar, Convert::TNEFF:, MIME::Entity, MIME:Parser, MIME::TOOLS, MIME:Words, Mail::Adress, Mailtools, unarj Jakmile ale dám nainstalovat některý z balíčků, vypíše další závislosti...

    Zkusím tedy nainstalovat Fedoru naposled. Nechám ji nainstalovat komplet celou. Pak zkusím Váš postup. Dík Kamil
    Taky si udělám nějakou studii.
    23.2.2004 11:33 David Luftner
    Rozbalit Rozbalit vše Fedora a Amavis
    Zapis je tak jak pisete.
    Na poradi balicku v zapise nezalezi amavis muze byt klidne i na prvnim miste.
    Jenom nepouzivam hvezdicky, ale to je asi jedno.
    Instalaci jsem delal na minimalni instalaci Fedory (Jen textovy rezim).

    Založit nové vláknoNahoru

    Tiskni Sdílej: Linkuj Jaggni to Vybrali.sme.sk Google Del.icio.us Facebook

    ISSN 1214-1267   www.czech-server.cz
    © 1999-2015 Nitemedia s. r. o. Všechna práva vyhrazena.