abclinuxu.cz AbcLinuxu.cz itbiz.cz ITBiz.cz HDmag.cz HDmag.cz abcprace.cz AbcPráce.cz
AbcLinuxu hledá autory!
Inzerujte na AbcPráce.cz od 950 Kč
Rozšířené hledání
×
25.3. 22:00 | Komunita

Portál Stack Overflow po roce opět vyzpovídal své uživatele, jedná se především o vývojáře softwaru, a zveřejnil (podcast) detailní výsledky průzkumu. Průzkumu se letos zúčastnilo více než 64 tisíc vývojářů. Jejich nejmilovanější platformou je linuxový desktop. Ten je také druhou nejpoužívanější platformou vývojářů.

Ladislav Hagara | Komentářů: 3
24.3. 11:55 | Komunita

Vývojový tým OpenSSL ve spolupráci s iniciativou Core Infrastructure konsorcia Linux Foundation spustil proces přelicencování této kryptografické knihovny ze současné licence na licenci Apache Licence v 2.0 (ASLv2). Nová licence usnadní začleňování OpenSSL do dalších svobodných a open source projektů. Všichni dosavadní vývojáři OpenSSL (Authors) obdrží v následujících dnech email s prosbou o souhlas se změnou licence.

Ladislav Hagara | Komentářů: 24
24.3. 01:11 | Komunita

Před třemi týdny Mozilla.cz představila projekt Photon, jehož cílem je návrh a implementace nového vzhledu Firefoxu. Včera zveřejnila první náhled vzhledu Photon. Práce na projektu Photon jsou rozděleny do pěti týmů, které celkem čítají 19 lidí. Zaměřují se na zlepšení prvního spuštění Firefoxu a zaujetí nových uživatelů, celkovou úpravu vzhledu, zlepšení animací, zrychlení odezvy uživatelského rozhraní a také upravení nabídek. Vývoj lze sledovat v Bugzille.

Ladislav Hagara | Komentářů: 44
23.3. 20:00 | Komunita

OneDrive pro firmy je již ve webových prohlížečích na Linuxu stejně rychlý jako na Windows. Microsoft opravil chybu z listopadu loňského roku. OneDrive pro firmy běžel na Linuxu mnohem pomaleji než na Windows. V popisu chyby bylo uvedeno, že stačilo v prohlížeči na Linuxu nastavit v user-agentu Windows a vše se zrychlilo. Odpovědí Microsoftu bylo (Internet Archive: Wayback Machine), že Linux není podporován. Po bouřlivých diskusích na redditu i Hacker News byla chyba nalezena a opravena.

Ladislav Hagara | Komentářů: 6
23.3. 19:00 | Zajímavý projekt

Byla vyhlášena soutěž Hackaday Prize 2017. Soutěž je určena vývojářům open source hardwaru. Pro výherce je připraveno celkově 250 tisíc dolarů. Každý ze 120 finalistů získá tisíc dolarů. Nejlepší pak navíc 50, 30, 20, 15, 10 a 5 tisíc dolarů. Jedná se již o čtvrtý ročník soutěže. V roce 2014 zvítězil projekt globální sítě open source pozemních satelitních stanic SatNOGS. V roce 2015 zvítězil open source systém pro řízení elektrických invalidních vozíků pohybem očí Eyedriveomatic. V roce 2016 zvítězil modulární robot Dtto.

Ladislav Hagara | Komentářů: 0
23.3. 15:00 | Bezpečnostní upozornění

Byla vydána Samba ve verzích 4.6.1, 4.5.7 a 4.4.12. Řešen je bezpečnostní problém CVE-2017-2619. Pomocí symbolických odkazů a souběhu (symlink race) lze "teoreticky" získat přístup k souborům, které nejsou sdíleny. Linuxové distribuce jsou postupně aktualizovány (Debian).

Ladislav Hagara | Komentářů: 0
23.3. 07:43 | Nová verze

Na Steamu se objevil port hry Arma: Cold War Assault (Operation Flashpoint) pro Mac a Linux. … více »

creon | Komentářů: 30
23.3. 05:55 | Nová verze

Po 18 měsících od vydání verze 8.0 byla vydána verze 9.0 open source alternativy GitHubu, tj. softwarového nástroje s webovým rozhraním umožňujícího spolupráci na zdrojových kódech, GitLab. Představení nových vlastností v příspěvku na blogu a na YouTube.

Ladislav Hagara | Komentářů: 0
23.3. 03:33 | Komunita

Platnost posledního patentu souvisejícího s Dolby Digital (AC-3) vypršela. Po MP3 se tak do Fedory oficiálně dostane také kodek AC-3.

Ladislav Hagara | Komentářů: 5
23.3. 00:44 | Komunita

Feral Interactive, společnost zabývající se vydáváním počítačových her pro operační systémy macOS a Linux, nabízí své hry na Steamu vývojářům open source 3D grafické knihovny Mesa zdarma. Podmínkou je minimálně 25 commitů za posledních 5 let. Stejnou nabídku dostali vývojáři knihovny Mesa v roce 2015 od Valve. O rok dříve dostali od Valve tuto nabídku vývojáři Debianu a Ubuntu.

Ladislav Hagara | Komentářů: 0
Jak se stavíte k trendu ztenčování přenosných zařízení (smartphony, notebooky)?
 (14%)
 (2%)
 (71%)
 (3%)
 (10%)
Celkem 940 hlasů
 Komentářů: 72, poslední 1.3. 11:16
    Rozcestník

    Dotaz: quagga - jak zabezpecit default routy smerem k iGW

    7.10.2004 13:40 Zdeněk Štěpánek | skóre: 57 | blog: uz_mam_taky_blog | varnsdorf
    quagga - jak zabezpecit default routy smerem k iGW
    Přečteno: 365×
    Zdravim

    Rozjel jsem v siti quaggu 0.96.5. Routovani vnitrni site jede jak ma, ale mam problem s internetem.

    Konfigy a schema site naleznete zde:
    http://gavanet.arachne.cz/quagga/

    Problem je v tom ze quagga na igw nejak spatne roztrubuje je je pro celou sit defaultni brana do internetu. Ostatni routery pak netusi kam posilat cokoliv co neni 10.0.0.0/8. Problem se vyskytuje vpodstate jenom na router_spicak. Proste se rozhodne a nastavi default branu na router_hradek, takze to pak cykluje mezi spicakem a hradkem. Potreboval bych neco jako aby na igw bylo nastaveno ze je default brana pro cely area 0.

    Moc diky vsem kdo aspon trochu poradi, docela me to stve.

    Zdenek
    www.pirati.cz - s piráty do parlamentu i jinam www.gavanet.org - czfree varnsdorf

    Odpovědi

    7.10.2004 21:54 Zdeněk Štěpánek | skóre: 57 | blog: uz_mam_taky_blog | varnsdorf
    Rozbalit Rozbalit vše Re: quagga - jak zabezpecit default routy smerem k iGW
    Zdravim

    Pridam dalsi informace. Vypozoroval jsem ze router_spicak se tak 3krat za den rozhodne a na kratkou chvili (3-5 minut) nastavi default routu na router_hradek, to jest na jinej, slepej, konec site nez je iGW. Topologie site se od zapnuti cele zebry vubec nezmenila, vubec nic, proste to je z niceho nic. Nevidim duvod proc by zebra na staticke siti mela nejak oscilovat se svym nastavenim, takze jedine co me napada je nekvalitni linka spicak -> studanka (to jeste smer na igw). Chvilku je proste vyssi ruseni, nebo tam proletelo hejno holubu a tak quagga tu linku vyhodnoti jako nefunkcni. Za chvilku zase funguje a tak se to sroutuje spravne.

    Takze me napadlo toto:

    interface eth0
    description "linka_eth0"
    ip ospf cost 100
    ip ospf dead-interval 40
    ip ospf hello-interval 10

    Potreboval bych vedet jake hodnoty dead-interval a hello-interval mate osvedcene pro wifi spoje.

    Diky
    Zdenek
    www.pirati.cz - s piráty do parlamentu i jinam www.gavanet.org - czfree varnsdorf
    7.10.2004 22:44 Zdeněk Štěpánek | skóre: 57 | blog: uz_mam_taky_blog | varnsdorf
    Rozbalit Rozbalit vše Re: quagga - jak zabezpecit default routy smerem k iGW
    Zdravim

    Tak doplnujici informace jeste jednou. Treti zajimavou polozkou je "ip ospf retransmit-interval".

    Hral jsme si s "dead-interval", nastavil jsme 240 a routery se mi nespojily. Nevim jestli ten cas neplati i pro prechod z nefunkcniho do funkcniho stavu. Proste se mi to nespojilo, jakmile jsem ho zakomentoval, routery se spojily hned.

    Zdenek
    www.pirati.cz - s piráty do parlamentu i jinam www.gavanet.org - czfree varnsdorf
    7.10.2004 23:36 Ctirad Feřtr | skóre: 43 | Praha
    Rozbalit Rozbalit vše Re: quagga - jak zabezpecit default routy smerem k iGW
    Pokud je v routeru několik interfaců (jakože v routeru asi jo ;), tak ty intervaly musí být na všech stejné, jinak to nefunguje.
    7.10.2004 23:33 Ctirad Feřtr | skóre: 43 | Praha
    Rozbalit Rozbalit vše Re: quagga - jak zabezpecit default routy smerem k iGW
    Já to mám na každém routeru staticky (řádek "ip route 0.0.0.0/0 10.x.y.z" v zebra.conf) , ale před časem jsem to zkoušel šířit přes ospf takto:

    default-information originate metric X metric-type 1

    a fungovalo to uspokojivě. Ale má to smysl jenom v případě, že má člověk záložní gw někde úplně jinde, na kterou se v případě výpadku nějakého spoje má routa v odříznuté oblasti otočit.
    8.10.2004 08:08 Zdeněk Štěpánek | skóre: 57 | blog: uz_mam_taky_blog | varnsdorf
    Rozbalit Rozbalit vše Re: quagga - jak zabezpecit default routy smerem k iGW
    Zdravim

    Presne to me zajima. Budu mit v siti druhou igw a nechci tam davat staticky routy, coz navic zhavaruje kdyz spadne linka na kterou vede staticka routa a jina obchvatna treba bezi. Davat jich tam vic s ruznejma metrikama nechci, to uz to rovnou muzu delat cely staticky.

    Zajimavy ale je ze kamos mi tvrdil ze "default-information originate metric X metric-type 1" NESMIM mit nikde jinde nez na iGW, tak si nejsem jistej. Ted to mam jenom na iGW (presneji jenom "default-information originate metric-type 1"). Je to logicky, prece nemuzu mit vsechny routery nakonfigurovany stejne, jak pak quagga vi kterej z nich je iGW?

    Zdenek
    www.pirati.cz - s piráty do parlamentu i jinam www.gavanet.org - czfree varnsdorf
    8.10.2004 10:09 Ctirad Feřtr | skóre: 43 | Praha
    Rozbalit Rozbalit vše Re: quagga - jak zabezpecit default routy smerem k iGW
    Davat jich tam vic s ruznejma metrikama nechci, to uz to rovnou muzu delat cely staticky.

    Cože ?

    Zajimavy ale je ze kamos mi tvrdil ze "default-information originate metric X metric-type 1" NESMIM mit nikde jinde nez na iGW, tak si nejsem jistej.

    Kámoš má pravdu. Tohle nastavujete jenom na jediném routeru, úplně "na konci" cesty té default routy (tudíž v tomto případě iGW respektive u jedné každé iGW, pokud jich máte víc a chete, aby se mezi nimi automaticky přepínalo dle dostupnosti/metriky) a nikde jinde. Pochopitelně to funguje jenom v rámci jedné ospf oblasti. Takže třeba v czfree.net, kde se uvnitř cloudů používá ospf a mezi nimi BGP, to funguje jenom uvniř cloudů a pokud je iGW v sousedním cloudu, musí to originate být jednak na hraničním BGP routeru, co do té vedlejší oblasti směřuje a pak ještě jednou na té iGW.
    8.10.2004 12:28 Zdeněk Štěpánek | skóre: 57 | blog: uz_mam_taky_blog | varnsdorf
    Rozbalit Rozbalit vše Re: quagga - jak zabezpecit default routy smerem k iGW
    Zdravim

    Diky za radu, zacinam se cim dal tim vic ujistovat ze to mam nakonfigurovany spravne a ze je nejspis problem v kvalite linky a nevhodnych defaultnich parametrech dead-interval. Chapu to spravne tak ze v ramci jednoho routeru musi byt vsechny linky nastavene stejne a zaroven i druhy konec linky stejne -> na cele siti (v cele area) u vsech interfacu musi byt stejny dead-interval?

    Ja mam celou sit v area 0 a uvnitr site BGP nepouzivam, bude casem asi jenom na iGW v ramci tunelo do prazske czfree. Jinak co ja vim (je to starsi informace) cela prazska czfree ma area 0.

    Zdenek
    www.pirati.cz - s piráty do parlamentu i jinam www.gavanet.org - czfree varnsdorf
    8.10.2004 13:51 Ctirad Feřtr | skóre: 43 | Praha
    Rozbalit Rozbalit vše Re: quagga - jak zabezpecit default routy smerem k iGW
    Pokud se normální routy šíří korektně, tak problém ve kvalitě linky ani těch dead-interval/retransmitech nebude. BTW, ty interfacy v zebra.conf by tam měly být alespoň vyjmenované i když jim tam žádné ip nepřiřazujete (což byste v zájmu konzistence a přehlednosti asi měl).

    Jak je to přesně s těmi hodnotami dead interval a retransmit by bylo asi nejlepší nastudovat z manuálu. Podle mých zkušeností se musí nastavit stejné hodnoty na všech interfacech v jednom routeru, jinak to nechodí. Naopak, když dám jinou hodnotu na jeden konec linky než na druhý, tak se to spojí, ale tuším jsou v logu nějaké nadávky.

    BTW, pražská czfree je rozsekaná na cloudy uvnitř kterých se routuje pomocí ospf a mezi nimi pomocí bgp.
    8.10.2004 17:28 Zdeněk Štěpánek | skóre: 57 | blog: uz_mam_taky_blog | varnsdorf
    Rozbalit Rozbalit vše VYRESENO - doufam
    Zdravim

    Tak se stalo presne to co jsme cekal a co jsem nechtel, nasel jsme absolutne trapny chyby v konfigach routeru. Samozrejme ze jsme mel "default-information originate metric-type 1" i na dalsich routerech, je to tim ze jsme to psal nadvakrat, nejdriv jednu cast site (spravne) a pak druhou cast (tam jsem udelal 2 routery blbe). Byl jsem si jistej ze jsem to psal spravne...

    Sypu si popel na hlavu a omlouvam se vsem kdo hledali problem tam kde nebyl. Jmenovite gulimu kterej nad tim stravil skoro cely dopoledne a stejne si toho nevsiml.

    Vyskytl se ovsem problem popisovany zde: http://www.abclinuxu.cz/forum/show/62554 V siti nebyla jedina default routa. To jsem vyresil nasledujici upravou konfiguraku na igw. Verejne IP se mi ale dovnitr site nedostavaji, pravdepodobne za to muze ten access-list na konci. Predchozi verzi je zakomentovana.
    router ospf
     ospf router-id 10.193.120.26
     redistribute connected metric-type 1
     redistribute static metric-type 1
     passive-interface wlan0
     network 10.193.120.240/28 area 0
     network 10.193.120.24/29 area 0
     network 10.193.120.48/29 area 0
     network 10.193.121.128/27 area 0
     network 213.180.37.72/30 area 0
    ! network 213.180.37.72/30 area 255 !predchozi verze
     default-information originate always metric-type 1
    ! area 255 range 213.180.37.72/30 not-advertise !predchozi verze
    !
    distribute-list confil out connected
    access-list confil permit 10.0.0.0/8
    access-list confil deny any
    
    Zdenek
    www.pirati.cz - s piráty do parlamentu i jinam www.gavanet.org - czfree varnsdorf

    Založit nové vláknoNahoru

    Tiskni Sdílej: Linkuj Jaggni to Vybrali.sme.sk Google Del.icio.us Facebook

    ISSN 1214-1267   www.czech-server.cz
    © 1999-2015 Nitemedia s. r. o. Všechna práva vyhrazena.