abclinuxu.cz AbcLinuxu.cz itbiz.cz ITBiz.cz HDmag.cz HDmag.cz abcprace.cz AbcPráce.cz
AbcLinuxu hledá autory!
Inzerujte na AbcPráce.cz od 950 Kč
Rozšířené hledání
×
dnes 02:00 | IT novinky

V Barceloně probíhá veletrh Mobile World Congress 2017. Nokia na něm například představila (360° video na YouTube) novou Nokii 3310 (YouTube). BlackBerry představilo BlackBerry KEYone (YouTube) s QWERTY klávesnicí. LG představilo LG G6 (YouTube). Huawei HUAWEI P10 a P10 Plus. Samsung představil tablet Galaxy Tab S3.

Ladislav Hagara | Komentářů: 0
včera 14:00 | Nová verze

Komunita kolem Linuxu From Scratch (LFS) vydala Linux Linux From Scratch 8.0 a Linux From Scratch 8.0 se systemd. Nové verze knih s návody na instalaci vlastního linuxového systému ze zdrojových kódů přichází především s Glibc 2.25 a GCC 6.3.0. Současně bylo oznámeno vydání verze 8.0 knih Beyond Linux From Scratch (BLFS) a Beyond Linux From Scratch se systemd.

Ladislav Hagara | Komentářů: 0
včera 11:11 | Nová verze

Byla vydána verze 0.10.0 webového prohlížeče qutebrowser (Wikipedie). Přehled novinek v příspěvku na blogu. Vývojáři qutebrowseru kladou důraz na ovladatelnost pomocí klávesnice a minimální GUI. Inspirovali se prohlížečem dwb a rozšířeními pro Firefox Vimperator a Pentadactyl. Prohlížeč qutebrowser je naprogramován v Pythonu a využívá PyQt5. Zdrojové kódy jsou k dispozici na GitHubu pod licencí GNU GPL 3.

Ladislav Hagara | Komentářů: 10
25.2. 16:22 | Nová verze

Po pěti měsících od vydání Waylandu a Westonu 1.12.0 oznámil Bryce Harrington (Samsung) vydání Waylandu 1.13.0 a Westonu 2.0.0.

Ladislav Hagara | Komentářů: 1
24.2. 13:37 | Bezpečnostní upozornění

Společnost Cloudflare (Wikipedie) na svém blogu potvrdila bezpečnostní problém s její službou. V požadovaných odpovědích od reverzní proxy byla odesílána také data z neinicializované paměti. Útočník tak mohl získat cookies, autentizační tokeny, data posílaná přes HTTP POST a další citlivé informace. Jednalo se o chybu v parsování HTML. Zneužitelná byla od 22. září 2016 do 18. února 2017. Seznam webů, kterých se bezpečnostní problém potenciálně týká na GitHubu.

Ladislav Hagara | Komentářů: 1
24.2. 08:22 | Nová verze

Byla vydána první beta verze Ubuntu 17.04 s kódovým názvem Zesty Zapus. Ke stažení jsou obrazy Kubuntu, Lubuntu, Ubuntu Budgie, Ubuntu GNOME, Ubuntu Kylin, Ubuntu Studio a Xubuntu. Dle plánu by Ubuntu 17.04 mělo vyjít 13. dubna 2017.

Ladislav Hagara | Komentářů: 55
23.2. 17:53 | Bezpečnostní upozornění

Google na svém blogu věnovaném počítačové bezpečnost informuje o nalezení "reálného" způsobu generování kolizí hašovací funkce SHA-1. Podrobnosti a zdrojové kódy budou zveřejněny do 90 dnů. Již dnes lze ale na stránce SHAttered nalézt 2 pdf soubory, jejichž obsah se liší a SHA-1 otisk je stejný (infografika).

Ladislav Hagara | Komentářů: 40
23.2. 17:51 | Nová verze

Vyšla nová verzia open source software na správu a automatizáciu cloudových datacentier Danube Cloud 2.4. Danube Cloud je riešenie postavené na SmartOS, ZFS, KVM a zónach. Obsahuje vlastnosti ako integrovaný monitoring, DNS manažment, zálohy, a samozrejme rozsiahlu dokumentáciu.

dano | Komentářů: 12
23.2. 17:46 | Pozvánky

V Plzni se 3. až 5. března 2017 uskuteční AIMTEChackathon. Je to akce pro vývojáře, grafiky, webdesignéry i veřejnost. Akci provází zajímavé přednášky IT odborníků. Více o programu a možnosti přihlášení na stránkách akce.

cuba | Komentářů: 0
23.2. 01:00 | Nová verze

Známý šifrovaný komunikátor Signal od verze 3.30.0 již nevyžaduje Google Play Services. Autoři tak po letech vyslyšeli volání komunity, která dala vzniknout Google-free forku LibreSignal (dnes již neudržovaný). Oficiální binárky jsou stále distribuované pouze přes Google Play, ale lze použít neoficiální F-Droid repozitář fdroid.eutopia.cz s nezávislými buildy Signalu nebo oficiální binárku stáhnout z Google Play i bez Google účtu

… více »
xm | Komentářů: 8
Jak se stavíte k trendu ztenčování přenosných zařízení (smartphony, notebooky)?
 (13%)
 (2%)
 (72%)
 (3%)
 (10%)
Celkem 721 hlasů
 Komentářů: 67, poslední dnes 01:12
    Rozcestník

    Dotaz: Java, Netbeans

    29.12.2007 19:28 Marta | skóre: 3
    Java, Netbeans
    Přečteno: 2059×
    Do Suse 10.3 s prostředím KDE jsem se rozhodla nainstalovat NetBeans IDE 6.0. Instalátor po mně chtěl JDK, tak jsem ho nainstalovala, zbytek instalace Netbeans proběhl vpořádku. Ale bohužel, to bylo všechno. Nepodařilo se mi ho spustit, chvíli dělá, že se spouští, ale nespustí se. Zkusila jsem spustit jen samotnou javu, a tady možná bude ten problém, nechce se mnou komunikovat, taktéž se nespustí.

    Nemám s vývojovými programy zatím vůbec žádné zkušenosti.

    Díky za rady.

    Odpovědi

    29.12.2007 19:31 dementni.lojzik | skóre: 19 | blog: ze zivota na vsi
    Rozbalit Rozbalit vše Re: Java, Netbeans
    a co presne znamena, ze se nespusti java?
    29.12.2007 19:34 Marta | skóre: 3
    Rozbalit Rozbalit vše Re: Java, Netbeans
    Žádná Java aplikace, nic.
    29.12.2007 19:57 dementni.lojzik | skóre: 19 | blog: ze zivota na vsi
    Rozbalit Rozbalit vše Re: Java, Netbeans
    tak nainstaluj JDK :-) Pak je v netbeans potreba nastavit cestu k tomuto JDK (pta se na ni tusim uz instalator) Tools->Java Platform Manager. Pak by to melo chodit (... co se JRE, obvykle byva soucasti JDK)
    29.12.2007 20:10 Lukáš Kotek | skóre: 15
    Rozbalit Rozbalit vše Re: Java, Netbeans
    Jakým způsobem ty aplikace spouštíš? Napadá mě, jestli máš tebou nainstalovanou javu přidanou v systémové proměnné PATH?
    Lidstvo vydává obrovské prostředky na ochranu sebe sama před sebou samým. Znáte lepší definici šílenství?
    mess avatar 29.12.2007 19:48 mess | skóre: 43 | blog: bordel | Háj ve Slezsku - Smolkov
    Rozbalit Rozbalit vše Re: Java, Netbeans
    Zkus nainstalovat ještě JRE. Teda, pokud ho ještě nemáš.
    Cez párne mesiace zošíváš vaginy, cez neparne montuješ hajzle.
    29.12.2007 21:06 h/atack | skóre: 4
    Rozbalit Rozbalit vše Re: Java, Netbeans
    A co se vypise, kdyz v prikazovem radku spustite:

    java -version

    ?

    Pripadne opet z prikazoveho radku spustit NetBeans, dle toho, kam se to nainstalovalo, napr.:

    netbeans-6.0/bin/netbeans

    Nenapise to neco uzitecneho?
    kouzer avatar 30.12.2007 09:23 kouzer | skóre: 11 | Mladá Boleslav
    Rozbalit Rozbalit vše Re: Java, Netbeans
    Zkus Netbenas spustit i s cestou k Javě. Něco ve smyslu /usr/java/jre/bin/java -jar netbeans.jar. Třeba to půjde.
    Linux user #448944.
    30.12.2007 14:43 tv
    Rozbalit Rozbalit vše Re: Java, Netbeans
    Mozna je to problem s libX11, verze 1.1.x dela jave (ale i dalsim) problemy. Je na to workaround , kdy se meni neco v jave a nebo downgrade libX11. Ja v FC8 pouzivam libX11.1.0.3.

    http://www.linuxquestions.org/questions/fedora-35/fedora-8-java-error-solved-xlib.lock-problem-605099/
    30.12.2007 19:07 Marta | skóre: 3
    Rozbalit Rozbalit vše Re: Java, Netbeans
    Trochu jsem si pohrála a NetBeans se spustil. Doinstalovala jsem JRE a pár dalších všemožných věciček, něco někam pode vygooglených návodů dopsala a nakonec jsem do /etc/X11/xinit/xinitrc přidala řádek

    "export LIBXCB_ALLOW_SLOPPY_LOCK=1".

    Když jsem začátkem prosince instalovala NetBeans na druhém počítači (SuSE 10.3, Gnome), dostala jsem se až k přímému spuštění programu, ale pak se objevila chyba

    The application <unknown> has crashed. Information about the crash has been successfully collected. This application is not known to bug-buddy, therefore the bug report cannot be sent to the GNOME Bugzilla. Please save the bug to a text file and report it to the appropriate bug tracker for this application.

    Zatím jsem ji nevyřešila, Linux na tomto PC od té doby neběžel, ale sama na řešení asi nepřijdu.

    A nakonec - nedaří se mi spustit žádný *.jar soubor, nevím, jestli něco dělám špatně já, nebo ještě nemám všechno úplně vyladěný.
    30.12.2007 19:39 Michal Vyskočil | skóre: 60 | blog: miblog | Praha
    Rozbalit Rozbalit vše Re: Java, Netbeans
    ad /etc/X11/xinit/xinitrc
    cat /etc/alternatives/jre_sun/bin/java
    #!/bin/bash
    # This wrapper script solves the problem that graphical java programs won't work with the newest X server
    export LIBXCB_ALLOW_SLOPPY_LOCK=1
    exec -a `readlink -f $0` `readlink -f $0`.bin ${1+"$@"}
    
    ;-)

    Jinak k problému s jary - pokud ti funguje příkaz java, tak jar se spustí příkazem java -jar soubor.jar. Případně je možné ještě jaru přidat práva na spustitelnost, pomocí /etc/init.d/java.binfmt_misc zaregistrovat spouštění misc binárek a potom jary spouštět jako jakýkoli jiný program ./soubor.jar.
    When your hammer is C++, everything begins to look like a thumb.
    1.1.2008 14:25 Marta | skóre: 3
    Rozbalit Rozbalit vše Re: Java, Netbeans
    Jary mi spouštět nejdou.

    java -jar JavaApplication1.jar

    Exception in thread "main" java.lang.UnsupportedClassVersionError: Bad version number in .class file

    at java.lang.ClassLoader.defineClass2(Native Method)

    at java.lang.ClassLoader.defineClass(ClassLoader.java:719)

    at java.security.SecureClassLoader.defineClass(SecureClassLoader.java:160)

    at java.net.URLClassLoader.defineClass(URLClassLoader.java:254)

    at java.net.URLClassLoader.access$100(URLClassLoader.java:56)

    at java.net.URLClassLoader$1.run(URLClassLoader.java:195)

    at java.security.AccessController.doPrivileged(Native Method)

    at java.net.URLClassLoader.findClass(URLClassLoader.java:188)

    at java.lang.ClassLoader.loadClass(ClassLoader.java:306)

    at sun.misc.Launcher$AppClassLoader.loadClass(Launcher.java:268)

    at java.lang.ClassLoader.loadClass(ClassLoader.java:251)

    at java.lang.ClassLoader.loadClassInternal(ClassLoader.java:319)

    A nejenom u této aplikace, nespustím žádnou.

    A potom se mi v netbeans nezobrazuje nic v palette, což mi poměrně hodně vadí. Nepodařilo se mi nic kloudného vygooglit. nevíte někdo co s tím?
    Daniel Kvasnička ml. avatar 1.1.2008 15:42 Daniel Kvasnička ml. | skóre: 52 | blog: The Joys and Sorrows of Being an IT Freak | Ostrava
    Rozbalit Rozbalit vše Re: Java, Netbeans
    Znamena to, ze mas starsi JDK, nez pro ktere jsou programy vyhazujici tuto vyjimku napsane.

    Pokud ti to delaji vsechny java aplikace, tak je to ale trosku podezrele. Jsi si urcite jista, ze JDK i JRE mas primo od Sunu a ne nejakou jinou implementaci? Pokud jsi to instalovala z balicku, je dost mozne, ze ti instalator podstrcil nejake GCJ nebo neco podobneho...

    (btw: pokud mas JDK, nemelo by byt vubec potreba doinstalovavat JRE -- pokud jde o stejnou verzi)
    FSF: “screw you for not wanting the stuff we produce”, People: “screw you for not producing the stuff we want."
    8.1.2008 20:07 Marta | skóre: 3
    Rozbalit Rozbalit vše Re: Java, Netbeans
    Píší mi to dvě java aplikace, třetí, co mám, napíše:

    Exception in thread "main" java.lang.NoClassDefFoundError: javax/swing/GroupLayout$Group

    Zkusila jsem Netbeans odinstalovat a nainstalovala jsem netbeans + JDK v jednom. Stejně to nepomohlo a zdá se mi dost divné, že i teď nejdou jary spouštět. Vždyť JDK bylo přímo k tomuto NetBeans.

    A potom s NetBeans palette - zkoušela jsem toto: http://www.nabble.com/Palette-Empty-to13296094.html i toto: http://wiki.netbeans.info/wiki/view/FaqFormRestoringPalette a nepomohlo ani jedno. Je pořád prázdná a nemám ideu, co s tím. Doufala jsem, že znovunainstalování netbeans pomůže, ale nepomohlo vůbec v ničem.
    Prom avatar 22.1.2008 14:41 Prom | skóre: 10 | Praha 5
    Rozbalit Rozbalit vše Re: Java, Netbeans
    mozna je to uplne strela mimo, ale velkou spoustu chyb souvisejich s javou (OOo, Eclipse atd.) mi zavinila nedostatecna pamet, po upgradu z 1GB an 2GB jsem se jich zbavil jako zazrakem...
    slax - nový pohled na svět...
    22.1.2008 20:13 Marta | skóre: 3
    Rozbalit Rozbalit vše Re: Java, Netbeans
    No tak to by bylo docela dost možný, nedávno jsem upgradovala ze dvou nespolupracujících 128 na dvě 250, ale je to možná ještě pořád málo, ale nelíbí se mi, že by kvůli paměti neměly fungovat některé programy. Já jedu na hodně starým stroji, sestaveným ze starých částí (CPU Celeron 600 MHz,...) a nevidím v dohlednu nějaký větší upgrade, natož dokupování pamětí. Tohle schroustá i pitomej windows, tak nevim, proč by linux ne. Na windows mi všechno (i když nepočítatelně pomaleji a se silným rachtáním) běží, včetně javy.

    Už mi běhá vpořádku NetBeans, jenom pořád nejdou spouštět jary.
    okbob avatar 30.12.2007 19:03 okbob | skóre: 30 | blog: systemakuv_blog | Benešov
    Rozbalit Rozbalit vše Re: Java, Netbeans
    Zkuste spustit NetBeans z prikazove radky. Melo by Vam to neco vypsat na terminal.

    Java je pouze runtime, kdyz ji spustite vypise neco na output a skonci

    [pavel@localhost bin]$ java -showversion java version "1.7.0" IcedTea Runtime Environment (build 1.7.0-b21) IcedTea Client VM (build 1.7.0-b21, mixed mode)
    30.4.2008 13:29 Marta | skóre: 3
    Rozbalit Rozbalit vše Re: Java, Netbeans
    Problém s javou jsem sice nevyřešila, ale snad pomůže plánovaná celková reinstalace Linuxu. NetBeans se mi podařilo nainstalovat přidáním správného repozitáře a následném nainstalováním přes Yast.

    Díky za rady, M.
    14.7.2008 17:07 Marta | skóre: 3
    Rozbalit Rozbalit vše Re: Java, Netbeans

    Jestli se ještě objeví nějaký "šikulka", kterému se v konsoli na klasický příkaz

    java -jar aplikace.jar
    bude zobrazovat jenom chybový výpis tohoto typu, už mám řešení. Tedy alespoň v mém případě se toto řešení ujalo.

    marta # java -jar JavaApplication1.jar
    Exception in thread "main" java.lang.UnsupportedClassVersionError: Bad version number in .class file
    at java.lang.ClassLoader.defineClass2(Native Method)
    at java.lang.ClassLoader.defineClass(ClassLoader.java:719)
    at java.security.SecureClassLoader.defineClass(SecureClassLoader.java:160)
    at java.net.URLClassLoader.defineClass(URLClassLoader.java:254)
    at java.net.URLClassLoader.access$100(URLClassLoader.java:56)
    at java.net.URLClassLoader$1.run(URLClassLoader.java:195)
    at java.security.AccessController.doPrivileged(Native Method)
    at java.net.URLClassLoader.findClass(URLClassLoader.java:188)
    at java.lang.ClassLoader.loadClass(ClassLoader.java:306)
    at sun.misc.Launcher$AppClassLoader.loadClass(Launcher.java:268)
    at java.lang.ClassLoader.loadClass(ClassLoader.java:251)
    at java.lang.ClassLoader.loadClassInternal(ClassLoader.java:319) 

    Pravděpodobně bude chyba způsobena tím, že je nainstalováno několik verzí javy. V mém případě se jednalo o verze 5 a 6. Takže se vyskytla hned 2 řešení, jak jar spustit správně. Buď jednu verzi odinstalovat, nebo jar spustit s úplnou cestou k javě, aby jar věděl, ve které se má spustit.

    Třeba to někomu pomůže. M.

    finc avatar 2.8.2008 22:36 finc | skóre: 8 | blog: Finc | Kolín
    Rozbalit Rozbalit vše Re: Java, Netbeans
    I kdyz bude mit clovek nainstalovano nekolik verzi Javy, nicemu to nevadi.

    Vetsinou staci nastavit globalni promenou JAVA_HOME.

    O tom, odkud se mi spousti vychozi JRE, staci v konsoli napsat 'which java'.

    Pokud dane verze Javy nejsou smichany v jednom adresari, tak dany classloader spustene JVM nebude o jine verzi nic vedet. Jedine, ze by aplikace meli nastaveny nejaky vlastni, sileny path do odlisne verze, nez pod kterou jsem aplikaci spustil.
    Kdo Vam dal pravo ty lidi urazet? A kdo ti dal pravo cumet z okna, ty kr.vo!

    Založit nové vláknoNahoru

    Tiskni Sdílej: Linkuj Jaggni to Vybrali.sme.sk Google Del.icio.us Facebook

    ISSN 1214-1267   www.czech-server.cz
    © 1999-2015 Nitemedia s. r. o. Všechna práva vyhrazena.