Po osmi letech od vydání verze 2.0 byla vydána nová major verze 3.0 multiplatformního editoru tagů MusicBrainz Picard (Wikipedie). Přehled novinek, vylepšení a oprav v changelogu.
Mezinárodní federace hudebního průmyslu (International Federation of the Phonographic Industry) navrhla Evropské komisi zařazení populárního open-source nástroje yt-dlp na evropský seznam 'padělků a pirátství' (EU Counterfeit and Piracy Watch List) pro rok 2027 (plné znění žádosti IFPI). IFPI ve svém podání označuje tento aktivně vyvíjený a o rozličné funkce bohatší fork youtube-dl za 'závažný problém' pro hudební průmysl, v
… více »Byla vydána nová verze 7.4 linuxové distribuce Parrot OS (Wikipedie). Jedná se o linuxovou distribuci založenou na Debianu a zaměřenou na penetrační testování, digitální forenzní analýzu, reverzní inženýrství, hacking, anonymitu nebo kryptografii. Přehled novinek v příspěvku na blogu.
Dnes startuje desátý ročník oblíbené kyberbezpečnostní soutěže The Catch organizované Forenzní laboratoří CESNETu. Letos zavede soutěžící do světa národních výzkumných a vzdělávacích sítí (NREN). Čekají na vás tematické úlohy založené na principu Capture the Flag (CTF), hledání ukrytých flagů i zajímavé ceny. Otestujte své schopnosti a vyrazte na lov flagů.
Byly zpracovány a na YouTube zveřejněny videozáznamy z konference LinuxDays 2026.
Německý startup Aleph Alpha k příležitosti výročí sjednocení Německa zveřejnil open-weight jazykový model Kolibri, vyvíjený s ohledem na unijní pojetí autorského práva, ochranu osobních údajů GDPR a nařízení EU o umělé inteligenci, jehož 'Kodexu správné praxe' je Aleph Alpha signatářem. Výsledkem tohoto přístupu je transparentnější technologie, kterou například budou moci využívat evropské veřejné instituce, ovšem za cenu
… více »Nvidia zveřejnila návrh nové bezpečnostní platformy pro nasazování AI agentů. Jedná se o nasazení AI za použití OpenShell a Sentry, dvou oddělených bezpečnostních vrstev, v nichž může Sentry monitorovat a vyhodnocovat chování AI v OpenShellu tak, že ho v krajním případě až vypne. Mělo by to zabránit dalším únikům AI ze sandboxu.
Přímý přenos (YouTube) z konference LinuxDays 2026, jež probíhá tento víkend v Praze v prostorách FIT ČVUT. Na programu je spousta zajímavých přednášek.
Byla vydána nová verze 0.17.0 programovacího jazyka Zig (Codeberg, Wikipedie). Přispělo 206 vývojářů. Přehled novinek v poznámkách k vydání.
Open-source projekt OpenDLSS-NR je 'bitově přesná reimplementace' neuronové rendrovací sítě DLSS 5 od společnosti NVIDIA, jenže pro grafické API Vulkan (DLSS slouží k vylepšování klasickým způsobem vyrendrovaných snímků pomocí lokálních modelů umělé inteligence, a to v reálném čase). Projekt není nijak spojen se společností NVIDIA, je pouze pro OS Windows a natrénované váhy modelu si uživatelé musí obstarat sami. Zdrojový kód je k dispozici na GitHubu, pod licencí MIT s výjimkou pro komponenty třetích stran.
procmailu - v souboru .procmailrc v home toho uživatele (je nutné mít procmail nastavený), nebo přímo filtry v Postfixu (nevím, jestli je to možné, používám Exim).
V Eximu se tahle funkce jmenuje Vacation a nastavuje se pro každého uživatele zvlášť v souboru ~/.vacation.msg a ~/.forward.
Pozor na automatické odpovědi na různé mail-listy a podobně (obecně se automatické odpovědi moc nedoporučují). Vacation to řeší tak, že si vede databázi adres, na které už byla automatická odpověď poslána a při další příchozí zprávě z takové adresy odpoví až po nastaveném čase (třeba týden).
Ve výsledku tedy na každou adresu pošle maximálně jednu opověď za týden.
Jinak procmail mam uz z drivejska nainstalovany (i kdyz si nepamatuju ze bych s nim kdykoliv co delal :D)
aptitude search procmail i procmail - Versatile e-mail processor p procmail-lib - A library of useful procmail recipesv nastaveni postfixu jsem nasel zakomentovany radek s procmail - http://pastebin.com/m12b8e390 ps: prosim nekamentujte me za ten konfigurak, leppil jsem to nekolik tydnu asi z 50ti navodu :D a za pomoci asi 5ti lidi
apt-get install libmldbm-perl libio-lockedfile-perl libnet-perl libcarp-clan-perl libdbi-perl libdbd-mysql-perl libnet-server-perl libio-stringy-perl
# ./yaa.pl --action=start Unable to create daemon version of Yaa object: Unable to load protocol driver (require() failed).
# telnet localhost 40000 Trying 127.0.0.1... telnet: Unable to connect to remote host: Connection refused
# apt-get install libmldbm-perl libio-lockedfile-perl libnet-perl libcarp-clan-perl libdbi-perl libdbd-mysql-perl libnet-server-perl libio-stringy-perl Čtu seznamy balíků... Hotovo Vytvářím strom závislostí Čtu stavové informace... Hotovo Balík libnet-perl je virtuální balík poskytovaný: perl-modules 5.10.0-11 Měli byste explicitně vybrat jeden k instalaci. E: Balík libnet-perl nemá kandidáta pro instalaci
# apt-get install perl-modules 5.10.0-11 Čtu seznamy balíků... Hotovo Vytvářím strom závislostí Čtu stavové informace... Hotovo perl-modules je již nejnovější verze. E: Nemohu najít balík 5.10.0-11
# apt-get install libmldbm-perl libio-lockedfile-perl libcarp-clan-perl libdbi-perl libdbd-mysql-perl libnet-server-perl libio-stringy-perl Čtu seznamy balíků... Hotovo Vytvářím strom závislostí Čtu stavové informace... Hotovo libdbi-perl je již nejnovější verze. libdbi-perl nastaven jako instalovaný ručně. libdbd-mysql-perl je již nejnovější verze. libdbd-mysql-perl nastaven jako instalovaný ručně. libnet-server-perl je již nejnovější verze. Následující extra balíky budou instalovány: libfreezethaw-perl Následující NOVÉ balíky budou nainstalovány: libcarp-clan-perl libfreezethaw-perl libio-lockedfile-perl libmldbm-perl Následující balíky budou aktualizovány: libio-stringy-perl 1 aktualizováno, 4 nově instalováno, 0 k odstranění a 91 neaktualizováno. 1 instalováno nebo odstraněno pouze částečně. Potřebuji stáhnout 168kB archivů. Po této operaci bude na disku použito dalších 352kB. Chcete pokračovat [Y/n]? y Mám:1 http://ftp.cz.debian.org sid/main libcarp-clan-perl 6.00-1 [14,8kB] Mám:2 http://ftp.cz.debian.org sid/main libfreezethaw-perl 0.43-4 [16,7kB] Mám:3 http://ftp.cz.debian.org etch/main libio-lockedfile-perl 0.23+d030220-1 [17,8kB] Mám:4 http://ftp.cz.debian.org sid/main libio-stringy-perl 2.110-4 [99,7kB] Mám:5 http://ftp.cz.debian.org sid/main libmldbm-perl 2.01-2 [18,7kB] Staženo 168kB za 0s (385kB/s) Instaluji balík libcarp-clan-perl. (Čtu databázi ... nyní je nainstalováno 46448 souborů a adresářů.) Rozbaluji libcarp-clan-perl (z .../libcarp-clan-perl_6.00-1_all.deb) ... Instaluji balík libfreezethaw-perl. Rozbaluji libfreezethaw-perl (z .../libfreezethaw-perl_0.43-4_all.deb) ... Instaluji balík libio-lockedfile-perl. Rozbaluji libio-lockedfile-perl (z .../libio-lockedfile-perl_0.23+d030220-1_all.deb) ... Připravuji nahrazení libio-stringy-perl 2.110-3 (pomocí .../libio-stringy-perl_2.110-4_all.deb) ... Rozbaluji náhradu libio-stringy-perl ... Instaluji balík libmldbm-perl. Rozbaluji libmldbm-perl (z .../libmldbm-perl_2.01-2_all.deb) ... Zpracování spouštěčů pro balík man-db ... Nastavuji balík gforge-ldap-openldap (4.5.14-22etch8) ... dpkg: chyba při zpracovávání gforge-ldap-openldap (--configure): podproces post-installation script vrátil chybový status 10 Nastavuji balík libcarp-clan-perl (6.00-1) ... Nastavuji balík libfreezethaw-perl (0.43-4) ... Nastavuji balík libio-lockedfile-perl (0.23+d030220-1) ... Nastavuji balík libio-stringy-perl (2.110-4) ... Nastavuji balík libmldbm-perl (2.01-2) ... Při zpracování nastaly chyby: gforge-ldap-openldap E: Sub-process /usr/bin/dpkg returned an error code (1)
# ./yaa.pl --action=startUnable to create daemon version of Yaa object: Unable to load protocol driver (require() failed).
# apt-get install libmldbm-perl libio-lockedfile-perl libcarp-clan-perl libdbi-perl libdbd-mysql-perl libnet-server-perl libio-stringy-perl Čtu seznamy balíků... Hotovo Vytvářím strom závislostí Čtu stavové informace... Hotovo libmldbm-perl je již nejnovější verze. libio-lockedfile-perl je již nejnovější verze. libcarp-clan-perl je již nejnovější verze. libdbi-perl je již nejnovější verze. libdbi-perl nastaven jako instalovaný ručně. libdbd-mysql-perl je již nejnovější verze. libdbd-mysql-perl nastaven jako instalovaný ručně. libnet-server-perl je již nejnovější verze. libio-stringy-perl je již nejnovější verze. 0 aktualizováno, 0 nově instalováno, 0 k odstranění a 91 neaktualizováno. 1 instalováno nebo odstraněno pouze částečně. Po této operaci bude na disku použito dalších 0B. Nastavuji balík gforge-ldap-openldap (4.5.14-22etch8) ... dpkg: chyba při zpracovávání gforge-ldap-openldap (--configure): podproces post-installation script vrátil chybový status 10 Při zpracování nastaly chyby: gforge-ldap-openldap E: Sub-process /usr/bin/dpkg returned an error code (1)nic se nedari
Pro postfixadmin existuje primo implementace vacation. Jeji plus je, ze si do databaze postfixadmina uklada, komu uz poslal mail a neposle v ramci jedne dovolene jedne adrese vic mailu. Nevyhoda je, ze je to naprogramovane uplne blbeja bych potreboval aby posilal mail i kdyz se odesilatel opakuje.... kurna ze bych zkusil neco jako wine outlook? :D :D - samozrejme to je jen narazka na mou neznalost :D
vacation:*:65501:65501::0:0:Virtual Vacation:/nonexistent:/sbin/nologin#/etc/group
vacation:*:65501:
mkdir /var/spool/vacation- user vacation tam ma pristup + nakopal jsem tam vacation.pl a udelal ho +x #/etc/postfix/master.cf:
vacation unix - n n - - pipe
flags=Rq user=vacation argv=/var/spool/vacation/vacation.pl -f ${sender} -- $$
#/etc/postfix/main.cf:
transport_maps = hash:/etc/postfix/transportvytvoreni: #/etc/postfix/transport
autoreply.mojedomena.cz(v tom je jen tato veta)
postmap /etc/postfix/transport /etc/init.d/postfix restarttabulka se mi vytvorila automaticky, do tabulky vacation jsem vlozil novy zaznam, jako prvni ja@mojedomena.cz , pak subject pak body, cache jsem vynechal, domain jsem dal mojedomena.cz, created je defaultne 0000-00-00 00:00:00, active 1 pak jsem v postfixadmin config.inc.php zmenil:
$CONF['vacation'] = 'YES'; // This is the autoreply domain that you will need to set in your Postfix // transport maps to handle virtual vacations. It does not need to be a // real domain (i.e. you don't need to setup DNS for it). $CONF['vacation_domain'] = 'autoreply.mojedomena.cz';vacation.pl - dal jsem spravneho usera, jmeno db a pass + dal logy vacation.log, jeste jednou ress postfixe, a nic... zadna zmana a logy jsem nikde na disku nenasel (ani ve /var/log/ zkousel jsem posilat mail na ja@mojedomena.cz - mail normal dojde, zadna autoreply.... kde delam chybu? dik za pomoc
Takze to zkusim motivacni cestou, pokud vite jak na to (at uz pres roundcube nebo postfixadmin nebo jinak), pak se mi prosim ozvete na icq 454104749.
co potrebuji: potrebuji abych si mohl jednoduse nastavit autoreply na KAZDY mail co mi prijde - pouzivam dovecot s mysql, postfix s mysql, amavis (musel jsem ho vypnout kvuli tomu ze "se to pokazilo") a spamassassin.
Odmena - financni nebo naturalni, dle Vasi nabidky
, ja to proste sam nedam
- uz mi kvuli temto pokusum nekolik dni mail nejel a ja o tom ani nevedel (rozhasil jsem si to)
Dekuji
transport_maps = hash:/etc/postfix/transport.
Mělo by tam být něco takového:
virtual_transport_maps = mysql:/etc/postfix/nazevsouboru_s_mapou_pro_mysql
Dále v tabulce nemůže být mojedomena.cz ale autoreply.mojedomena.cz. Potom si v tabulce domain do řádku goto vedle mojedomena.cz přidáte autoreply.mojedomena.cz (toto platí samozřejmě pokud máte postfix nastavený s tabulkami postfixadmina). A je to.
Tiskni
Sdílej: