abclinuxu.cz AbcLinuxu.cz itbiz.cz ITBiz.cz HDmag.cz HDmag.cz abcprace.cz AbcPráce.cz
AbcLinuxu hledá autory!
Inzerujte na AbcPráce.cz od 950 Kč
Rozšířené hledání
×
    dnes 02:00 | Zajímavý článek

    Jiří Eischmann se v příspěvku Fiasko jménem W Social na svém blogu věnuje evropské sociální síti W: "W Social je příkladem toho, že se problémy sociální sítí nedají řešit od exekutivního stolu. Když na začátku tohoto roku v Davosu oznámili vznik nové sociální sítě W Social, politici se mohli přetrhnout ve chvalozpěvech. Konečně evropská sociální síť a ještě s ověřením identity. … Jak se ukázalo, když v Davosu W Social oznamovali, neměli kromě

    … více »
    Ladislav Hagara | Komentářů: 11
    včera 18:00 | Bezpečnostní upozornění

    Výrobce hardwarových kryptoměnových peněženek Trezor upozorňuje na bezpečnostní incident u společnosti Brevo, kterou využívá k odesílání newsletterů. Útočník na e-mailové adresy odeslal phishingový e-mail.

    Ladislav Hagara | Komentářů: 1
    včera 14:33 | Komunita

    Clement "Clem" Lefebvre publikoval souhrn dění v Linux Mintu za srpen 2026. Aplikace XApp mají vlastní webovou stránku xapp-project.org. Představena byl čtečka EPUB s názvem Xepub a kalendář Clockenstein.

    Ladislav Hagara | Komentářů: 0
    včera 11:44 | Nová verze

    Byla vydána nová verze 3.2.6 svobodné aplikace pro úpravu a vytváření rastrové grafiky GIMP (GNU Image Manipulation Program). Přehled novinek v oznámení o vydání a v souboru NEWS na GitLabu. Nový GIMP je již k dispozici také na Flathubu.

    Ladislav Hagara | Komentářů: 0
    včera 11:33 | Nová verze

    Bylo vydáno Ubuntu 24.04.5 LTS, tj. páté opravné vydání Ubuntu 24.04 LTS s kódovým názvem Noble Numbat. Přehled novinek a oprav na poznámkách k vydání.

    Ladislav Hagara | Komentářů: 0
    včera 04:33 | Komunita

    Švýcarsko testuje přechod z Microsoft 365 na FOSS, konkrétně balík openDesk (Wikipedie) od německé státní společnosti ZenDiS (Wikipedie), s cílem posílit digitální suverenitu.

    Ladislav Hagara | Komentářů: 9
    včera 04:22 | Komunita

    V italském městě Pordenone probíhá LibreOffice Conference 2026. Zúčastnit se lze i online.

    Ladislav Hagara | Komentářů: 0
    10.9. 18:33 | Nová verze

    Svobodný (GPLv3) šachový engine Stockfish (Wikipedie) byl vydán ve verzi 19 (𝕏). Přehled novinek v příspěvku na blogu. Stockfish 19 je o 44 Elo silnější než Stockfish 18.

    Ladislav Hagara | Komentářů: 0
    10.9. 12:33 | Nová verze

    Byla vydána nová verze 1.13.0 dynamického programovacího jazyka Julia (Wikipedie) určeného zejména pro vědecké výpočty. Přehled novinek v příspěvku na blogu a v poznámkách k vydání. Aktualizována byla také dokumentace.

    Ladislav Hagara | Komentářů: 0
    10.9. 11:11 | Pozvánky

    Organizátoři konference LinuxDays zveřejnili program letošního ročníku a spustili registraci návštěvníků. LinuxDays 2026 se uskuteční 3. a 4. října v areálu ČVUT v pražských Dejvicích, na Fakultě informačních technologií. Těšit se můžete na 70 přednášek a workshopů od 66 přednášejících. Konference bude rozdělena do pěti sálů s různou kapacitou. Vstup na LinuxDays je jako obvykle zdarma, stačí včas vyplnit registrační formulář. Opět je možné si na akci zakoupit oběd, ale je třeba to udělat předem, na místě už to nebude možné.

    Petr Krčmář | Komentářů: 1
    Které desktopové prostředí na Linuxu používáte?
     (10%)
     (7%)
     (4%)
     (21%)
     (29%)
     (7%)
     (5%)
     (2%)
     (14%)
     (21%)
    Celkem 2651 hlasů
     Komentářů: 31, poslední 13.8. 00:27
    Rozcestník

    Dotaz: Nestartuje LDAP

    15.6.2009 08:52 jan.rok | skóre: 21
    Nestartuje LDAP
    Přečteno: 496×

    Dobrý den,

    na SLES10 mi přestal startoval LDAP server: hlásí chybu:

     supr nscd: nss_ldap: could not search LDAP server - Server is unavailable

    Konfigurace se snad nezměnila. Kde bych měl hledat chybu? Následkem toho pak nejde ani pošta, Samba, nic co se přes LDAP ověřuje.

    Podle jednoho doporučení jsem zkusil:


    netstat -plutn | grep slapd

    ale nevypsalo to nic.

    Děkuji za jakékoliv postrčení. Škola nám stojí... :-(
     

     


    Řešení dotazu:


    Odpovědi

    15.6.2009 09:13 Milan Uhrák | skóre: 31 | blog: milan_at_ABC
    Rozbalit Rozbalit vše Re: Nestartuje LDAP

    Váš popis je velmi strohý ... jste začátečnik ?   SLES jsem tedy nikdy nepoužíval, ale snad každé distro má logy (to moje ve /var/log/ ). zde lze snadno - dělám to pomocí midnight commanderu (esc -> ? tuším) prohledat soubory na výskyt slova slapd a tím se dopracovat k lepšímu popisu chyby.

    Také lze (u mne) spustit slapd z konzole a sledovat co se bude dít. množství vypisovaných informací lze řídit buď z /etc/ldap/slapd.conf (u mne) nebo z příkazové řádky ( u mne spuštěním "slapd -d 16383" - to číslo udává, co vše se má vylogovat a myslím, že s tímto číslem jsem dostal tak 5 obrazovek hlášek). Více je v man slapd.conf (u mne).

    Jak říkám, Vaše distro neznám, ale snad nebude tak moc odlišné.

    Jen doufám, že jste si "nehrál" s nastavením, kterému nerozumíte a řešení brzy naleznete.

    S pozdravem

    Uhrák

    15.6.2009 09:40 jan.rok | skóre: 21
    Rozbalit Rozbalit vše Re: Nestartuje LDAP

    Ano jsem začátečník.S konfigurací nikdo nic nedělal.

    Dále je v logu toto:

     supr slapd[12136]: bdb_db_open: Database cannot be opened, err -30974. Restore from backup!
    Jun 15 09:31:24 supr slapd[12136]: ====> bdb_cache_release_all
    Jun 15 09:31:24 supr slapd[12136]: bdb(dc=domena,dc=cz): DB_ENV->lock_id_free interface requires an environment configured for the locking subsystem
    Jun 15 09:31:24 supr slapd[12136]: bdb(dc=domena,dc=cz): txn_checkpoint interface requires an environment configured for the transaction subsystem
    Jun 15 09:31:24 supr slapd[12136]: bdb_db_close: txn_checkpoint failed: Invalid argument (22)
    Jun 15 09:31:24 supr slapd[12136]: backend_startup_one: bi_db_open failed! (-30974)
    Jun 15 09:31:24 supr slapd[12136]: slapd shutdown: initiated
    Jun 15 09:31:24 supr slapd[12136]: ====> bdb_cache_release_all
    Jun 15 09:31:24 supr slapd[12136]: bdb_db_close: alock_close failed
    Jun 15 09:31:24 supr slapd[12136]: slapd destroy: freeing system resources.
    Jun 15 09:31:24 supr slapd[12136]: slapd stopped.
    Jun 15 09:31:24 supr slapd[12136]: connections_destroy: nothing to destroy.
    supr:/var/lib/ldap #
     

    To vypadá na poškozenou databázi LDAP?

    Řešení 1× (timeos)
    15.6.2009 11:41 timeos | skóre: 32
    Rozbalit Rozbalit vše Re: Nestartuje LDAP

    Ano, pravdepodobne poskodena databaza (vypadok elektriky?) . LDAP vacsinou pouziva standardne databazu berkeley-db (BDB), ktora je sice fajn, ale lahko sa poskodi vplvyom napr zleho vypnutia. Je preto dolezite robit pravidelne zalohy (dumpy) databazy v pripade ze by takato situacia nastala. Pokial ziadna zaloha nie je, je mozne existujucu databazu este skusit opravit pomocou "dbX" utilit (kde X je verzia pouzivanej BDB)... konkretne pomocou dbX_recover (alebo mozno aj rovno db_recover, treba zistit). Zo slapd.conf si zistite, kde je presne ulozena databaza (direktiva "directory") a pouzite nasledujuci prikaz:

    db_recover -h /cesta/k/databaze 

    Prikaz by nemal vypisat nic a po jeho dokonceni mozte skusit nastartovat LDAP cez init skript. Ak tato recovery nepomoze, skuste pouzit este catastrophic recovery (ten isty prikaz s parametrom -c):

    db_recover -c -h /cesta/k/databaze 

    drzim palce.

    15.6.2009 13:03 jan.rok | skóre: 21
    Rozbalit Rozbalit vše Re: Nestartuje LDAP

    Ani nevíte, jak jste mi pomohl, díky moc. Zabrala až ta druhá možnost, poprvé se zobrazila chyba

    db_recover: unable to join the environment
     

    A o té druhé možnosti jsem nevěděl.

    Výslechy bylo zjištěno, že skutečně došlo k výpadku napájení, bohužel jistá osoba vytáhla nesprávný kabel z UPS.
    Děkuju všem za rychlé reakce. JR

    15.6.2009 09:25 Filip Jirsák | skóre: 67 | blog: Fa & Bi
    Rozbalit Rozbalit vše Re: Nestartuje LDAP
    supr nscd: nss_ldap: could not search LDAP server - Server is unavailable
    Tohle není chyba LDAP serveru, ale LDAP klienta NSS (tj. správa a ověřování unixových účtů v LDAPu). Pokud tohle skutečně najdete v logu LDAP serveru, znamená to, že ke startu LDAP serveru potřebujete účty, které jsou v LDAPu – což by byl poněkud problém. Účty potřebné pro start LDAPu musíte mít v lokální databázi (/etc/passwd a /etc/groups) a NSS musíte mít nastavené tak, aby nejprve zkoušel soubory a pak až LDAP, nebo aby při nedostupnosti LDAPu pokračoval v ověřování dál přes soubory.
    15.6.2009 09:49 jan.rok | skóre: 21
    Rozbalit Rozbalit vše Re: Nestartuje LDAP

    Dobrý den,

    mám to chápat tak, že pokud mám v slapd.conf:

    database bdb
    suffix "dc=domena,dc=cz"
    rootdn "cn=Administrator,dc=domena,dc=cz"
    rootpw "{ssha}A55YdUvtLY5v/6phETq5INaLlLpYWlpTTA=="
     

    tak to znamená, že LDAP server vyžaduje pro svůj start účet administrator a tento účet musí být také v /etc/passwd?

    15.6.2009 10:13 Filip Jirsák | skóre: 67 | blog: Fa & Bi
    Rozbalit Rozbalit vše Re: Nestartuje LDAP
    Ne, tohle je účet v LDAPu. Ale třeba můžete mít nastavené, že se server spouští pod unixovým uživatelem ldap (pod rootem asi neběží, resp. po startu a zahájení naslouchání se asi práv roota zbaví), tj. vlastníkem datových souborů je uživatel ldap apod. Uživatele ldap pak musí být nutné ověřit i bez běžícího LDAP serveru – tj. uživatel musí být v lokální databázi (v souboru /etc/passwd) a tato databáze se musí prohledávat i při nedostupnosti LDAP serveru (nejlepší je, když se soubory prohledávají jako první – zpravidla jsou tam systémové účty, a nejspíš chcete, aby nebylo možné ani omylem tyto účty v LDAPu předefinovat).

    Založit nové vláknoNahoru

    Tiskni Sdílej: Linkuj Jaggni to Vybrali.sme.sk Google Del.icio.us Facebook

    ISSN 1214-1267   www.czech-server.cz
    © 1999-2015 Nitemedia s. r. o. Všechna práva vyhrazena.