abclinuxu.cz AbcLinuxu.cz itbiz.cz ITBiz.cz HDmag.cz HDmag.cz abcprace.cz AbcPráce.cz
AbcLinuxu hledá autory!
Inzerujte na AbcPráce.cz od 950 Kč
Rozšířené hledání
×
    dnes 13:44 | Zajímavý projekt

    Hra Factorio dorazila na Printables. Hned teď si můžete stáhnout 65 různých modelů a nechat celou mimozemskou planetu oživnout na svém stole.

    Ladislav Hagara | Komentářů: 1
    včera 19:22 | Nová verze

    GNU Project Debugger aneb GDB byl vydán ve verzi 18.1. Podrobný přehled novinek v souboru NEWS.

    Ladislav Hagara | Komentářů: 0
    25.9. 23:33 | Humor

    Prezident USA Donald Trump během svého projevu na valném shromáždění OSN 22. září 2026 prohlásil, že umělá inteligence 'bude dále oficiálně nazývána superinteligencí', zkráceně SI. Svůj návrh zdůvodnil takto: 'Použití slova artificial činí inteligenci falešnou. Ona falešná není, ve skutečnosti je úžasná'. Zároveň ve svém proslovu prohlásil, že Spojené státy kategoricky odmítají jakékoliv pokusy o vytvoření 'globalistického

    … více »
    AfD 💙 | Komentářů: 13
    25.9. 23:22 | Nová verze

    Čínská technologická firma Xiaomi představila novou verzi 2.6 svého modelu MiMo, váhy modelů MiMo‑V2.6‑Pro‑RL a MiMo‑V2.6‑Flash‑RL jsou dostupné na HuggingFace pod licencí MIT. Výkonnější varianta Pro má přes bilion parametrů, z toho 42 miliard aktivních, úspornější Flash 309 miliard parametrů, z nichž se při generování aktivuje přibližně 15 miliard. Oba modely mají délku kontextového okna milion tokenů. Tyto MoE modely zvládají

    … více »
    AfD 💙 | Komentářů: 0
    25.9. 03:33 | Komunita

    Proběhl Snapdragon Summit 2026. Společnost Qualcomm se mimo jiné pochlubila během Linuxu na čipech Snapdragon X2. Zatím pouze v ranní verzi vhodné pro vývojáře linuxových distribucí a přispěvatele do jádra Linux.

    Ladislav Hagara | Komentářů: 0
    24.9. 21:11 | Nová verze

    Byla vydána nová verze 2.0 klienta F-Droid určeného pro instalaci bezplatných a otevřených mobilních aplikací do Androidu ze softwarového repozitáře F-Droid (Wikipedie). Jedná se o alternativu k Google Play.

    Ladislav Hagara | Komentářů: 7
    24.9. 12:11 | Komunita

    Debian Inference Portal nabízí vývojářům Debianu bezplatný přístup ke službám AI/LLM. Sponzorem je společnost Scaleway.

    Ladislav Hagara | Komentářů: 0
    24.9. 11:44 | Bezpečnostní upozornění

    Robert Ressl nalezl ve WordPressu kritickou zranitelnost CVE-2026-87902 s CVSS 9.2. Útočníkům umožňuje neoprávněný přístup k souborům a vzdálené spuštění kódu (RCE). Opravena je ve verzích 7.1.2, 7.0.6, 6.9.9…

    Ladislav Hagara | Komentářů: 0
    24.9. 03:33 | IT novinky

    Společnost Meta na dvoudenní konferenci Meta Connect 2026 představuje své novinky. Vypíchnout lze lehké brýle s funkci VR Meta VR Glasses. Do prodeje půjdou na jaře 2027 za cenu 1299,99 dolarů.

    Ladislav Hagara | Komentářů: 0
    23.9. 14:44 | Nová verze

    Google Chrome 154 byl prohlášen za stabilní. Nejnovější stabilní verze 154.0.8037.57 přináší řadu novinek. Podrobný přehled v poznámkách k vydání. Opraveno bylo 108 bezpečnostních chyb. Vylepšeny byly také nástroje pro vývojáře.

    Ladislav Hagara | Komentářů: 12
    Které desktopové prostředí na Linuxu používáte?
     (9%)
     (7%)
     (4%)
     (21%)
     (29%)
     (8%)
     (5%)
     (2%)
     (14%)
     (20%)
    Celkem 2739 hlasů
     Komentářů: 31, poslední 13.8. 00:27
    Rozcestník

    Dotaz: Nestartuje LDAP

    15.6.2009 08:52 jan.rok | skóre: 21
    Nestartuje LDAP
    Přečteno: 512×

    Dobrý den,

    na SLES10 mi přestal startoval LDAP server: hlásí chybu:

     supr nscd: nss_ldap: could not search LDAP server - Server is unavailable

    Konfigurace se snad nezměnila. Kde bych měl hledat chybu? Následkem toho pak nejde ani pošta, Samba, nic co se přes LDAP ověřuje.

    Podle jednoho doporučení jsem zkusil:


    netstat -plutn | grep slapd

    ale nevypsalo to nic.

    Děkuji za jakékoliv postrčení. Škola nám stojí... :-(
     

     


    Řešení dotazu:


    Odpovědi

    15.6.2009 09:13 Milan Uhrák | skóre: 31 | blog: milan_at_ABC
    Rozbalit Rozbalit vše Re: Nestartuje LDAP

    Váš popis je velmi strohý ... jste začátečnik ?   SLES jsem tedy nikdy nepoužíval, ale snad každé distro má logy (to moje ve /var/log/ ). zde lze snadno - dělám to pomocí midnight commanderu (esc -> ? tuším) prohledat soubory na výskyt slova slapd a tím se dopracovat k lepšímu popisu chyby.

    Také lze (u mne) spustit slapd z konzole a sledovat co se bude dít. množství vypisovaných informací lze řídit buď z /etc/ldap/slapd.conf (u mne) nebo z příkazové řádky ( u mne spuštěním "slapd -d 16383" - to číslo udává, co vše se má vylogovat a myslím, že s tímto číslem jsem dostal tak 5 obrazovek hlášek). Více je v man slapd.conf (u mne).

    Jak říkám, Vaše distro neznám, ale snad nebude tak moc odlišné.

    Jen doufám, že jste si "nehrál" s nastavením, kterému nerozumíte a řešení brzy naleznete.

    S pozdravem

    Uhrák

    15.6.2009 09:40 jan.rok | skóre: 21
    Rozbalit Rozbalit vše Re: Nestartuje LDAP

    Ano jsem začátečník.S konfigurací nikdo nic nedělal.

    Dále je v logu toto:

     supr slapd[12136]: bdb_db_open: Database cannot be opened, err -30974. Restore from backup!
    Jun 15 09:31:24 supr slapd[12136]: ====> bdb_cache_release_all
    Jun 15 09:31:24 supr slapd[12136]: bdb(dc=domena,dc=cz): DB_ENV->lock_id_free interface requires an environment configured for the locking subsystem
    Jun 15 09:31:24 supr slapd[12136]: bdb(dc=domena,dc=cz): txn_checkpoint interface requires an environment configured for the transaction subsystem
    Jun 15 09:31:24 supr slapd[12136]: bdb_db_close: txn_checkpoint failed: Invalid argument (22)
    Jun 15 09:31:24 supr slapd[12136]: backend_startup_one: bi_db_open failed! (-30974)
    Jun 15 09:31:24 supr slapd[12136]: slapd shutdown: initiated
    Jun 15 09:31:24 supr slapd[12136]: ====> bdb_cache_release_all
    Jun 15 09:31:24 supr slapd[12136]: bdb_db_close: alock_close failed
    Jun 15 09:31:24 supr slapd[12136]: slapd destroy: freeing system resources.
    Jun 15 09:31:24 supr slapd[12136]: slapd stopped.
    Jun 15 09:31:24 supr slapd[12136]: connections_destroy: nothing to destroy.
    supr:/var/lib/ldap #
     

    To vypadá na poškozenou databázi LDAP?

    Řešení 1× (timeos)
    15.6.2009 11:41 timeos | skóre: 32
    Rozbalit Rozbalit vše Re: Nestartuje LDAP

    Ano, pravdepodobne poskodena databaza (vypadok elektriky?) . LDAP vacsinou pouziva standardne databazu berkeley-db (BDB), ktora je sice fajn, ale lahko sa poskodi vplvyom napr zleho vypnutia. Je preto dolezite robit pravidelne zalohy (dumpy) databazy v pripade ze by takato situacia nastala. Pokial ziadna zaloha nie je, je mozne existujucu databazu este skusit opravit pomocou "dbX" utilit (kde X je verzia pouzivanej BDB)... konkretne pomocou dbX_recover (alebo mozno aj rovno db_recover, treba zistit). Zo slapd.conf si zistite, kde je presne ulozena databaza (direktiva "directory") a pouzite nasledujuci prikaz:

    db_recover -h /cesta/k/databaze 

    Prikaz by nemal vypisat nic a po jeho dokonceni mozte skusit nastartovat LDAP cez init skript. Ak tato recovery nepomoze, skuste pouzit este catastrophic recovery (ten isty prikaz s parametrom -c):

    db_recover -c -h /cesta/k/databaze 

    drzim palce.

    15.6.2009 13:03 jan.rok | skóre: 21
    Rozbalit Rozbalit vše Re: Nestartuje LDAP

    Ani nevíte, jak jste mi pomohl, díky moc. Zabrala až ta druhá možnost, poprvé se zobrazila chyba

    db_recover: unable to join the environment
     

    A o té druhé možnosti jsem nevěděl.

    Výslechy bylo zjištěno, že skutečně došlo k výpadku napájení, bohužel jistá osoba vytáhla nesprávný kabel z UPS.
    Děkuju všem za rychlé reakce. JR

    15.6.2009 09:25 Filip Jirsák | skóre: 67 | blog: Fa & Bi
    Rozbalit Rozbalit vše Re: Nestartuje LDAP
    supr nscd: nss_ldap: could not search LDAP server - Server is unavailable
    Tohle není chyba LDAP serveru, ale LDAP klienta NSS (tj. správa a ověřování unixových účtů v LDAPu). Pokud tohle skutečně najdete v logu LDAP serveru, znamená to, že ke startu LDAP serveru potřebujete účty, které jsou v LDAPu – což by byl poněkud problém. Účty potřebné pro start LDAPu musíte mít v lokální databázi (/etc/passwd a /etc/groups) a NSS musíte mít nastavené tak, aby nejprve zkoušel soubory a pak až LDAP, nebo aby při nedostupnosti LDAPu pokračoval v ověřování dál přes soubory.
    15.6.2009 09:49 jan.rok | skóre: 21
    Rozbalit Rozbalit vše Re: Nestartuje LDAP

    Dobrý den,

    mám to chápat tak, že pokud mám v slapd.conf:

    database bdb
    suffix "dc=domena,dc=cz"
    rootdn "cn=Administrator,dc=domena,dc=cz"
    rootpw "{ssha}A55YdUvtLY5v/6phETq5INaLlLpYWlpTTA=="
     

    tak to znamená, že LDAP server vyžaduje pro svůj start účet administrator a tento účet musí být také v /etc/passwd?

    15.6.2009 10:13 Filip Jirsák | skóre: 67 | blog: Fa & Bi
    Rozbalit Rozbalit vše Re: Nestartuje LDAP
    Ne, tohle je účet v LDAPu. Ale třeba můžete mít nastavené, že se server spouští pod unixovým uživatelem ldap (pod rootem asi neběží, resp. po startu a zahájení naslouchání se asi práv roota zbaví), tj. vlastníkem datových souborů je uživatel ldap apod. Uživatele ldap pak musí být nutné ověřit i bez běžícího LDAP serveru – tj. uživatel musí být v lokální databázi (v souboru /etc/passwd) a tato databáze se musí prohledávat i při nedostupnosti LDAP serveru (nejlepší je, když se soubory prohledávají jako první – zpravidla jsou tam systémové účty, a nejspíš chcete, aby nebylo možné ani omylem tyto účty v LDAPu předefinovat).

    Založit nové vlákno • Nahoru

    Tiskni Sdílej: Linkuj Jaggni to Vybrali.sme.sk Google Del.icio.us Facebook

    ISSN 1214-1267   www.czech-server.cz
    © 1999-2015 Nitemedia s. r. o. Všechna práva vyhrazena.