abclinuxu.cz AbcLinuxu.cz itbiz.cz ITBiz.cz HDmag.cz HDmag.cz abcprace.cz AbcPráce.cz
AbcLinuxu hledá autory!
Inzerujte na AbcPráce.cz od 950 Kč
Rozšířené hledání
×
    dnes 02:11 | IT novinky

    Byla oznámena beta verze nového video kodeku Pyrowave pro streamování her v Steam Remote Play. S vysokou propustností a nízkou latencí. S podporou HDR a YUV 4:4:4.

    Ladislav Hagara | Komentářů: 0
    dnes 01:11 | Nová verze

    Byl vydán Sublime Text 4 Build 4213. Sublime Text (Wikipedie) je proprietární multiplatformní editor textových souborů a zdrojových kódů. Ke stažení a k vyzkoušení je zdarma. Pro další používání je nutná licence v ceně 99 dolarů. Spolu se Sublime Merge je cena 168 dolarů.

    Ladislav Hagara | Komentářů: 0
    včera 21:55 | Zajímavý článek

    Firma Anthropic, tvůrce AI modelu Claude, začala v oblasti Sanfranciského zálivu v tichosti provozovat vlastní biotechnologickou laboratoř. Anthropic prý chce pomocí AI urychlit hledání léků na nemoci, jimž farmaceutický průmysl dle názoru firmy věnuje příliš málo pozornosti. Firma tvrdí, že laboratoř se zatím soustředí především na základní biologii, nikoli přímo na vývoj léčiv. Farmaceutický výzkum je pro generálního ředitele Daria Amodeie velice osobní téma, jeho otec zemřel na hepatitidu C několik málo let před objevením účinné léčby.

    AfD 💙 | Komentářů: 3
    včera 21:44 | Humor

    Vědci z Googlu dokončili mapu všech neuronových spojení v mozku (tzv. konektom) samečka mušky octomilky obecné (drosophila melanogaster), hlavním cílem je komparativní analýza s již zmapovaným mozkem samičky. S tímto veřejně dostupným modelem, čítajícím přibližně 160 000 neuronů, se začali bavit nadšenci. Mozek mouchy pohání experimentálního kryptoburzovního bota Stonkfly, případně si zahrál počítačové hry Beat Saber, Mario64 a samozřejmě DOOM (gameplay videa). Ani mozek samičky nezůstal stranou, vyzkoušel si Minecraft.

    AfD 💙 | Komentářů: 0
    včera 16:22 | Nová verze

    Alibaba Cloud je dalším sponzorem nadace Omacom Foundation stojící za linuxovou distribucí Omarchy. Přislíbená částka je 3 miliony dolarů, tj. 1 milion dolarů ročně po dobu tří let. Stejná částka jako u DigitalOcean.

    Ladislav Hagara | Komentářů: 4
    včera 16:11 | Nová verze

    Byla vydána nová verze 262 správce systému a služeb systemd (Wikipedie, GitHub).

    Ladislav Hagara | Komentářů: 0
    včera 02:33 | IT novinky

    Canonical oznámil vydání Zephyr 26.04 LTS. Jedná se o komerční distribuci operačního systému pro mikrokontroléry Zephyr (Wikipedie) s podporou až 15 let.

    Ladislav Hagara | Komentářů: 0
    včera 02:00 | Zajímavý projekt

    Gravity Linux je linuxová distribuce určená pro Apple Silicon s čipy M4 a novějšími. Vydána byla alfa verze pro M4 Mac mini. Gravity Linux je fork Asahi Linuxu.

    Ladislav Hagara | Komentářů: 0
    21.9. 22:22 | Zajímavý projekt

    Hister je osobní soukromý vyhledávač, který lze provozovat na vlastním stroji. Umí prohledávat lokální soubory, importovat historii a záložky z webových prohlížečů, procházet vybrané weby a pomocí rozšíření pro Firefox a Chrome indexovat obsah právě navštívených stránek. Nad vytvořeným indexem pak nabízí vyhledávání prostřednictvím webového rozhraní, příkazové řádky a díky podpoře MCP i nástrojům umělé inteligence. Tento

    … více »
    AfD 💙 | Komentářů: 9
    21.9. 13:33 | IT novinky

    Ministerstvo dopravy uznalo prozatímní schválení asistenčního systému Tesla FSD Supervised vydané nizozemským schvalovacím orgánem RDW. Připojilo se tak k Nizozemsku a dalším pěti evropským státům. Systém je díky tomuto rozhodnutí možné používat za podmínek prozatímního schválení také na území České republiky. Tesla FSD Supervised je asistenčním systémem úrovně 2 podle klasifikace SAE (částečná automatizace řízení). Řidič se

    … více »
    Ladislav Hagara | Komentářů: 22
    Které desktopové prostředí na Linuxu používáte?
     (9%)
     (7%)
     (4%)
     (21%)
     (29%)
     (8%)
     (5%)
     (2%)
     (14%)
     (21%)
    Celkem 2718 hlasů
     Komentářů: 31, poslední 13.8. 00:27
    Rozcestník

    Dotaz: Freeradius - ERROR

    7.3.2010 17:57 detektiv | skóre: 3
    Freeradius - ERROR
    Přečteno: 627×

    Zdravím, nainstaloval jsem si na Debian lenny freeradius. Díval jsem se na návody a diskuze

    .

    Mám tento problém. Když spustím freeradius -X

    tak nakonci se zobrazí hlášení:

    ERROR: Failed to open socket: cannot bind socket: Address already in use /etc/freeradius/radiusd[210]: Error binding to port for 0.0.0.0 port 1812

    Jedná se o sekci Listen, je zde 2x: Kdyz ji zakomentuji tak žádný error se neukáže a pokud zakomentuji jednu část listen tak proběhne error. zkousel jsem zadávat aj ručně IP a port

    #listen {

    # IP address on which to listen.

    # Allowed values are:

    # dotted quad (1.2.3.4)

    # hostname (radius.example.com)

    # wildcard (*)

    # ipaddr = *

    # Port on which to listen.

    # Allowed values are:

    # integer port number (1812)

    # 0 means "use /etc/services for the proper port"

    # port = 0

    # Type of packets to listen for.

    # Allowed values are:

    # auth listen for authentication packets

    # acct listen for accounting packets

    #

    # type = auth

    #}

    Koukal jsem co beží na portech. Instalace serveru je čistá, nainstalované: apache2, openssh-server,mysql-server, mc,phpmyadmin a freeradius

    Kde dělám chybu? Děkuji za rady.

    Odpovědi

    7.3.2010 23:40 NN
    Rozbalit Rozbalit vše Re: Freeradius - ERROR
    Bud si pustil vice instanci, nebo ti na tom portu uz neco posloucha..

    NN
    8.3.2010 00:43 houska
    Rozbalit Rozbalit vše Re: Freeradius - ERROR
    Dve sekce jsou tam proto, ze se pouzivaji dva porty:

    UDP port 1812 - RADIUS Authentication

    UDP port 1813 - RADIUS Accounting

    Byt vami, tak doplnim ip adresy a cisla portu misto hvezdicek a nul.
    8.3.2010 11:28 detektiv | skóre: 3
    Rozbalit Rozbalit vše Re: Freeradius - ERROR

    Tak vypadá že freeradius naslouchá:

    Musel jsem použít freeradius stop a killall radius.

    Teď se zobrazuje:

    Listening on authentication address 10.1.0.16 port 1812
    Listening on accounting address 10.1.0.16 port 1813
    Listening on proxy address 10.1.0.16 port 1814

    Dále bych měl ještě jeden dotaz: Nainstaloval jsem podporu pro mysql podle návodu:

    http://www.kiv.zcu.cz/~simekm/vyuka/pd/zapocty-2004/radius_mysql-mikolasek/

    Když se notebookem připojím do wifi, chce po mě ověření, po zadání me freeradius vypíše:

    ( předpokládám že funguje komunikace, ale uživatele neověří )

    Ready to process requests.
    rad_recv: Access-Request packet from host 10.1.0.31 port 1239, id=16, length=131
    User-Name = "vasek"
    NAS-IP-Address = 10.1.0.31
    NAS-Port = 0
    Called-Station-Id = "00-06-25-53-C4-44"
    Calling-Station-Id = "00-15-AF-39-16-4C"
    NAS-Identifier = "DWL-900AP+"
    Framed-MTU = 1380
    NAS-Port-Type = Wireless-802.11
    EAP-Message = 0x0201000a01766173656b
    Message-Authenticator = 0xfa8d65a922bc9127efde4c0cb9ecb460
    +- entering group authorize
    ++[preprocess] returns ok
    ++[chap] returns noop
    ++[mschap] returns noop
    rlm_realm: No '@' in User-Name = "vasek", looking up realm NULL
    rlm_realm: No such realm "NULL"
    ++[suffix] returns noop
    rlm_eap: EAP packet type response id 1 length 10
    rlm_eap: No EAP Start, assuming it's an on-going EAP conversation
    ++[eap] returns updated
    ++[unix] returns notfound
    users: Matched entry DEFAULT at line 59
    ++[files] returns ok
    ++[expiration] returns noop
    ++[logintime] returns noop
    rlm_pap: Found existing Auth-Type, not changing it.
    ++[pap] returns noop
    rad_check_password:  Found Auth-Type Reject
    rad_check_password: Auth-Type = Reject, rejecting user
    auth: Failed to validate the user.
    Login incorrect: [vasek/<via Auth-Type = Reject>] (from client default port 0 cli 00-15-AF-39-16-4C)
    Found Post-Auth-Type Reject
    +- entering group REJECT
    expand: %{User-Name} -> vasek
    attr_filter: Matched entry DEFAULT at line 11
    ++[attr_filter.access_reject] returns updated
    Delaying reject of request 0 for 1 seconds
    Going to the next request
    Waking up in 0.9 seconds.
    Sending delayed reject for request 0
    Sending Access-Reject of id 16 to 10.1.0.31 port 1239
    Reply-Message = "I hear you knocking, but you cant come in"
    Waking up in 4.9 seconds.
    Cleaning up request 0 ID 16 with timestamp +142
    Ready to process requests.

    V radius.conf jsem nechal vše stejný po instalaci, jen mám povolený include modul sql.

    A ostatní jsem nastavil zvlášť v adresáři sites-enabled souborech

    V eap.conf nastavený default_eap_type = md5

    v souboru : default

    preacct {      
    acct_unique
    preprocess
    suffix
    #files
    }

    accounting {
    detail
    #unix
    sql
    #radutmp
    #sradutmp
    }

    v souboru: inner-tunnel

    authenticate {
    authtype PAP {
    pap
    }
    authtype CHAP {
    chap
    }
    authtype MS-CHAP{
    mschap
    }
    #digest
    #pam
    #unix
    #authtype LDAP {
    #       ldap
    #}

    }

    Díky za ochotu a pomoc

    8.3.2010 16:12 FF
    Rozbalit Rozbalit vše Re: Freeradius - ERROR
    Bohuzel primo neporadim, ale posilam link na stranky co jsem jednou delal do skoly s ukazkovou konfiguraci overeni wifi clienta pres radius http://homel.vsb.cz/~fra186/radius/ . Snad pomuze.
    9.3.2010 18:26 detektiv | skóre: 3
    Rozbalit Rozbalit vše Re: Freeradius - ERROR
    Díky, mám takovou otázku, tak jsem nějak ten Freeradius rozchodil.

    Když zasám vše na localhostu, tak mě uživatele ověří. Pokud se připojím notebookem do wifi sítě, tak mě to neověří. Není potřeba někde ještě něco nainstalovat či nastavit, aby ověřoval ze sítě. Notebook má win.

    Ve vašem článku jsem četl o wpa_supplicant ale to je potřeba jen pro linux.

    Založit nové vláknoNahoru

    Tiskni Sdílej: Linkuj Jaggni to Vybrali.sme.sk Google Del.icio.us Facebook

    ISSN 1214-1267   www.czech-server.cz
    © 1999-2015 Nitemedia s. r. o. Všechna práva vyhrazena.