abclinuxu.cz AbcLinuxu.cz itbiz.cz ITBiz.cz HDmag.cz HDmag.cz abcprace.cz AbcPráce.cz
AbcLinuxu hledá autory!
Inzerujte na AbcPráce.cz od 950 Kč
Rozšířené hledání
×
    včera 22:44 | Nová verze

    Programovací jazyk Python byl vydán v nové major verzi 3.15.0. Podrobný přehled novinek v aktualizované dokumentaci.

    Ladislav Hagara | Komentářů: 0
    včera 22:33 | Zajímavý projekt

    BIGWORDS.PAGE je open-source webová aplikace, která po otevření odkazu v prohlížeči vykreslí přes celou obrazovku jednoduché informační sdělení. Zpráva i její nastavení jsou uložené v části URL za znakem #, například odkaz https://bigwords.page/#abclinuxu zobrazí jako velký bílý nápis 'abclinuxu' na černém pozadí. Obsah odkazu lze upravovat i vestavěným editorem, ten umožňuje nastavovat formátování a vizuální efekty textu, časovače, QR kódy a obrázky. Zdrojový kód je dostupný pod licencí MIT na GitHubu.

    ❗Červivý Hřib krade❗ | Komentářů: 7
    včera 11:55 | Upozornění

    V neděli 11. října proběhne rotace klíče kořenové zóny. Podruhé v historii. Ondřej Filip na blogu CZ.NIC: "Pokud je pro Vás DNS protokol spíše výzva, ale přesto spravujete nějakou síť či DNS resolver, zkuste si jednoduchý test, který připravila firma Cloudflare na této adrese. Obzvláště zbystřit byste měli, pokud uvidíte nějaká červená políčka."

    Ladislav Hagara | Komentářů: 12
    včera 09:55 | IT novinky

    Vláda Spojených států se rozhodla vyřadit americkou softwarovou společnost Microsoft a několik dalších velkých technologických podniků z programu, který umožňuje kvalifikovaným zahraničním pracovníkům získat povolení k trvalému pobytu. Oznámila to včera administrativa amerického prezidenta Donalda Trumpa. Opatření zdůvodnila rozsáhlým zneužíváním programu, který je dlouhodobě terčem kritiky ze strany Trumpových příznivců, neboť prý znevýhodňuje americké pracovníky.

    Ladislav Hagara | Komentářů: 11
    včera 09:44 | IT novinky

    Datové centrum největší ruské technologické společnosti Jandex v Rjazaňské oblasti se stalo cílem dronového útoku a zastavilo provoz. Jandexu se někdy přezdívá „ruský Google“. Provozuje nejoblíbenější internetový vyhledávač v Rusku nebo aplikace pro objednávky jídla a taxi. Využívají jej desítky milionů lidí v rusky mluvících zemích.

    Ladislav Hagara | Komentářů: 11
    včera 09:33 | Nová verze

    Francouzská společnost Mistral AI představila Mistral Large 4 (interně přezdívaný 'le Chonk', volně přeloženo 'pořádný macek'), 'open-weight multimodální hybridní instruct-and-reasoning model s architekturou granulárního MoE, nativně podporující více jak 160 jazyků'. Model má přes jeden bilión parametrů, z nichž při práci využívá 49 miliard, kontextové okno o délce milion tokenů a obrazový enkodér o 1,6 miliardách parametrů.

    … více »
    ❗Červivý Hřib krade❗ | Komentářů: 2
    včera 03:22 | Nová verze

    Svobodný multiplatformní herní engine Bevy napsaný v Rustu byl vydán ve verzi 0.20. Díky 227 přispěvatelům.

    Ladislav Hagara | Komentářů: 0
    včera 03:11 | Komunita

    Simon Long oznámil Raspberry Pi Desktop pro PC a Mac s Intelem postavený na aktualizovaném Debianu 13 Trixie. S klientem Raspberry Pi Connect pro vzdálenou správu. Ke stažení je vedle Raspberry Pi OS pro Raspberry Pi.

    Ladislav Hagara | Komentářů: 1
    8.10. 21:33 | Zajímavý projekt

    ESP32-C3 adblock přemění lacinou vývojovou desku ESP32‑C3 na samostatný DNS blokovač nejenom reklamních domén, minimalistickou alternativu k populárnímu Pi-hole. ESP32-C3 adblock místo objemných názvů domén ukládá jejich 40-bitové FNV-1a hashe do flash paměti, které pak binárně prohledává, kontrola jedné domény trvá přibližně 10 milisekund. Blocklist pojme až 537 tisíc domén a lze jej spravovat přes webové rozhraní. Projekt zatím

    … více »
    ❗Červivý Hřib krade❗ | Komentářů: 0
    8.10. 21:00 | Zajímavý software

    ArtCraft je sada open source aplikací pro práci s obrázky a videi "inspirovaných" aplikacemi od Adobe. Napsaných v Rustu. Pro MacOS, Windows i Linux. Běží také ve webovém prohlížeči. Aktuálně se jedná o 7 aplikací: PhotoCraft (Photoshop), VectorCraft (Illustrator), FilmCraft (Premiere Pro), LightCraft (Lightroom), PdfCraft (Acrobat), EffectCraft (After Effects) a DesignCraft (InDesign). Zdrojové kódy jsou k dispozici na GitHubu.

    Ladislav Hagara | Komentářů: 9
    Které desktopové prostředí na Linuxu používáte?
     (9%)
     (7%)
     (4%)
     (21%)
     (29%)
     (8%)
     (5%)
     (2%)
     (14%)
     (20%)
    Celkem 2822 hlasů
     Komentářů: 31, poslední 13.8. 00:27
    Rozcestník

    Dotaz: Problémy s Kmail

    30.12.2010 21:13 Luigi | skóre: 10
    Problémy s Kmail
    Přečteno: 639×
    Mám opakovaný problém na svém Gentoo s aplikací Kmail. Už dříve, když jsem měl verzi KDE 4.3.něco, tak se mi Kmail po svém startu zavíral s ohlášením chyby Akonadi-selftestu. Chyby to byly různé, jakože existuje log z předchozího startu něčeho s nějakou chybou. Nic konkrétního, nebo zjevné nepravdy. Hledal jsem docela bez úspěchu, nakonec to řešilo promazání profilu Akonadi. Teď se mi po upgradu na KDE 4.5.4 ten problém vrátil, smazání profilu jsem zkusil, nepomohlo. Hledal jsem, ale našel jen nářky ohledně přechodu z mysql na sqlite, nářky nad Akonadi, vše tak nějak bez řešení. Kmail jsem teď upgradoval na 4.4.9, mimo jiné není lokalizovaný, narozdíl od všech ostatních aplikací. K češtine jsem žádné komentáře nenašel, jestli to je nebo není chyba... Celkově mě to dění kolem Kmailu tak nějak přijde podivné. Používal jsem ho rád. Máte s Kmailem někdo taky podobné problémy? Systém je konzistentní z pohledu rebuildu revdepem, projevuje se to i na nové instalaci na jiném stroji, který je narozdíl od mého architektura x86 -tedy soudím že platformě závislé trable to nejsou.

    Odpovědi

    7.1.2011 01:37 Luigi | skóre: 10
    Rozbalit Rozbalit vše Re: Problémy s Kmail
    nikdo nic? ani se nikdo nepřidá v brečení :-)
    7.1.2011 05:01 marek_hb
    Rozbalit Rozbalit vše Re: Problémy s Kmail
    kmail mě donutil přejít na gmail ...
    rADOn avatar 7.1.2011 17:11 rADOn | skóre: 44 | blog: bloK | Praha
    Rozbalit Rozbalit vše Re: Problémy s Kmail
    Mam kmail 4.4.9 na gentoo, zadnej problem.
    "2^24 comments ought to be enough for anyone" -- CmdrTaco
    Pavel Čejka avatar 27.4.2011 23:03 Pavel Čejka | skóre: 28 | blog: tosinezaslouzijmeno
    Rozbalit Rozbalit vše Re: Problémy s Kmail
    Příloha:

    Mám velice podobný problém. Po aktualizaci z KDE 4.1.x na 4.4.9 se KMail spustí, ale slítne po pár vteřinách nečinnosti.

    • kde-base/kmail-4.4.9
    • app-office/akonadi-server-1.3.1
    • kde-base/kontact-4.4.9
    • dev-libs/dbus-glib-0.92
    • dev-python/dbus-python-0.83.2
    • sys-apps/dbus-1.4.1
    • x11-libs/qt-dbus-4.6.3
    • víceméně aktuální Gentoo ...
    USE="3dnow 3dnowext X a52 aac acpi alsa apm audacious cairo cdparanoia
         colordiff cpudetection css ctype cupsddk dbus dga dts dv dvd dvdnav ebook
         encode exif extras ffmpeg flac foomaticdb fuse gd gimp glut gphoto2 gs
         gzip hal hpcups hpijs icu idn ieee1394 inkjar jpeg kde lame lm_sensors
         madwifi matroska mikmod mmx mmxext mng mp3 mpeg mplayer multitarget nfs
         nfsv3 nfsv4 nsplugin nvidia ogg openal opencore-amr opengl pdf png
         powersave ppds pulseaudio qt3support qt4 rdesktop rdp reiserfs samba
         scanner sdl sdl-image sdl-sound sdlaudio semantic-desktop sensord sftp
         sid slang sql sqlite sse sse2 ssh svg svgz theora truetype urandom usb
         v4l v4l2 vdpau vorbis webkit wifi win32codecs wxwidgets xanim xinerama
         xml xmlreader xmlwriter xpdf-headers xprint xrandr zip -branding -esd
         -gnome -handbook -kontact -mysql -plasma"
    

    Chybová hláška ...

    Akonadi Server Self-Test Report
    ===============================
    
    Test 1:  SUCCESS
    --------
    
    Database driver found.
    Details: The QtSQL driver 'QSQLITE' is required by your current Akonadi server configuration and was found on your system.
    
    File content of '/home/cygnus/.config/akonadi/akonadiserverrc':
    [%General]
    Driver=QSQLITE
    SizeThreshold=4096
    ExternalPayload=false
    
    [QSQLITE]
    Name=/home/cygnus/.local/share/akonadi/akonadi.db
    Host=
    User=
    Password=
    Options=
    StartServer=false
    
    
    Test 2:  SKIP
    --------
    
    MySQL server executable not tested.
    Details: The current configuration does not require an internal MySQL server.
    
    Test 3:  SKIP
    --------
    
    MySQL server error log not tested.
    Details: The current configuration does not require an internal MySQL server.
    
    Test 4:  SKIP
    --------
    
    MySQL server configuration not tested.
    Details: The current configuration does not require an internal MySQL server.
    
    Test 5:  SUCCESS
    --------
    
    akonadictl found and usable
    Details: The program '/usr/bin/akonadictl' to control the Akonadi server was found and could be executed successfully.
    Result:
    Akonadi 1.3.1
    
    
    Test 6:  ERROR
    --------
    
    Akonadi control process not registered at D-Bus.
    Details: The Akonadi control process is not registered at D-Bus which typically means it was not started or encountered a fatal error during startup.
    
    Test 7:  ERROR
    --------
    
    Akonadi server process not registered at D-Bus.
    Details: The Akonadi server process is not registered at D-Bus which typically means it was not started or encountered a fatal error during startup.
    
    Test 8:  ERROR
    --------
    
    Nepomuk search service not registered at D-Bus.
    Details: The Nepomuk search service is not registered at D-Bus which typically means it was not started or encountered a fatal error during startup.
    
    Test 9:  SKIP
    --------
    
    Protocol version check not possible.
    Details: Without a connection to the server it is not possible to check if the protocol version meets the requirements.
    
    Test 10:  ERROR
    --------
    
    No resource agents found.
    Details: No resource agents have been found, Akonadi is not usable without at least one. This usually means that no resource agents are installed or that there is a setup problem. The following paths have been searched: '/usr/share/akonadi/agents /usr/share/akonadi/agents'. The XDG_DATA_DIRS environment variable is set to '/usr/share:/usr/local/share:/usr/share', make sure this includes all paths where Akonadi agents are installed to.
    
    Directory listing of '/usr/share/akonadi/agents':
    birthdaysresource.desktop
    contactsresource.desktop
    icalresource.desktop
    imapresource.desktop
    kabcresource.desktop
    kcalresource.desktop
    knutresource.desktop
    kolabproxyresource.desktop
    localbookmarksresource.desktop
    maildirresource.desktop
    maildispatcheragent.desktop
    mboxresource.desktop
    microblog.desktop
    mtdummyresource.desktop
    nepomukcalendarfeeder.desktop
    nepomukcontactfeeder.desktop
    nepomuktagresource.desktop
    nntpresource.desktop
    notesresource.desktop
    pop3resource.desktop
    vcarddirresource.desktop
    vcardresource.desktop
    Directory listing of '/usr/share/akonadi/agents':
    birthdaysresource.desktop
    contactsresource.desktop
    icalresource.desktop
    imapresource.desktop
    kabcresource.desktop
    kcalresource.desktop
    knutresource.desktop
    kolabproxyresource.desktop
    localbookmarksresource.desktop
    maildirresource.desktop
    maildispatcheragent.desktop
    mboxresource.desktop
    microblog.desktop
    mtdummyresource.desktop
    nepomukcalendarfeeder.desktop
    nepomukcontactfeeder.desktop
    nepomuktagresource.desktop
    nntpresource.desktop
    notesresource.desktop
    pop3resource.desktop
    vcarddirresource.desktop
    vcardresource.desktop
    
    Environment variable XDG_DATA_DIRS is set to '/usr/share:/usr/local/share:/usr/share'
    
    Test 11:  ERROR
    --------
    
    Current Akonadi server error log found.
    Details: The Akonadi server did report error during startup into /home/cygnus/.local/share/akonadi/akonadiserver.error.
    
    File content of '/home/cygnus/.local/share/akonadi/akonadiserver.error':
    "Unable to add initial data to table 'ResourceTable'.
    Query error: 'no such column: true Unable to execute statement'
    Query was: INSERT INTO ResourceTable (name,isVirtual) VALUES ('akonadi_search_resource',true)" 
    Unable to initialize database. 
    "[
    0: akonadiserver(_Z11akBacktracev+0x35) [0x80528c5]
    1: akonadiserver() [0x8052e4c]
    2: [0xb775d400]
    3: [0xb775d424]
    4: /lib/libc.so.6(gsignal+0x50) [0xb7029670]
    5: /lib/libc.so.6(abort+0x183) [0xb702ae73]
    6: /usr/lib/qt4/libQtCore.so.4(_Z17qt_message_output9QtMsgTypePKc+0x9d) [0xb73c930d]
    ]
    " 
    
    
    Test 12:  ERROR
    --------
    
    Previous Akonadi server error log found.
    Details: The Akonadi server did report error during its previous startup into /home/cygnus/.local/share/akonadi/akonadiserver.error.old.
    
    File content of '/home/cygnus/.local/share/akonadi/akonadiserver.error.old':
    "Unable to add initial data to table 'ResourceTable'.
    Query error: 'no such column: true Unable to execute statement'
    Query was: INSERT INTO ResourceTable (name,isVirtual) VALUES ('akonadi_search_resource',true)" 
    Unable to initialize database. 
    "[
    0: akonadiserver(_Z11akBacktracev+0x35) [0x80528c5]
    1: akonadiserver() [0x8052e4c]
    2: [0xb7703400]
    3: [0xb7703424]
    4: /lib/libc.so.6(gsignal+0x50) [0xb6fcf670]
    5: /lib/libc.so.6(abort+0x183) [0xb6fd0e73]
    6: /usr/lib/qt4/libQtCore.so.4(_Z17qt_message_output9QtMsgTypePKc+0x9d) [0xb736f30d]
    ]
    " 
    
    
    Test 13:  SUCCESS
    --------
    
    No current Akonadi control error log found.
    Details: The Akonadi control process did not report any errors during its current startup.
    
    Test 14:  SUCCESS
    --------
    
    No previous Akonadi control error log found.
    Details: The Akonadi control process did not report any errors during its previous startup.
    

    Chybové hlášení cháp tak, že se Akonadi nespustí, protože se nespojí s DBusem, který ale běží. Otázkou je proč? Kde pátrat?

    Upřímně, dost silně váhám, jestli se na KMail, který jsem měl v minulosti velmi rád nevykašlat a nenahradit ho Thunderbirdem, se kterým jsem spokojen jinde. Už jen pokusy používat MySQL prostým mailerem mne dost odrazují, zdá se to být čím dál víc hnusným bloatwarem (nemluvě o takových perlách KDE, jako je ksysguard, který vytíží CPU na cca 5% sám o sobě .... to je normální měřič zatížení!?!).

    Takže ještě jednou - kde hledat při problémech KMailu s DBusem a spouštěním Akonadi?

    Založit nové vlákno • Nahoru

    Tiskni Sdílej: Linkuj Jaggni to Vybrali.sme.sk Google Del.icio.us Facebook

    ISSN 1214-1267   www.czech-server.cz
    © 1999-2015 Nitemedia s. r. o. Všechna práva vyhrazena.