abclinuxu.cz AbcLinuxu.cz itbiz.cz ITBiz.cz HDmag.cz HDmag.cz abcprace.cz AbcPráce.cz
AbcLinuxu hledá autory!
Inzerujte na AbcPráce.cz od 950 Kč
Rozšířené hledání
×
dnes 06:00 | IT novinky

Na Indiegogo byla spuštěna kampaň na podporu chytrého telefonu a kapesního počítače Astro Slide 5G Transformer od společnosti Planet Computers. Požadovaná částka 180 000 eur byla vybrána během 4 hodin. Stejně jako u předchozích zařízení Gemini PDA a Cosmo Communicator od této společnosti je slíbená podpora Linuxu.

Ladislav Hagara | Komentářů: 0
včera 19:22 | Zajímavý software

CryptPad je svobodný online kancelářský balík. Zdrojové kódy jsou k dispozici na GitHubu pod licencí AGPL-3.0. Oficiální instance nově nabízí 1 GB prostoru. Mozilla Foundation tento týden věnovala projektu 10 000 $.

Ladislav Hagara | Komentářů: 0
včera 18:22 | Nová verze

Byla vydána finální beta verze Ubuntu 20.04 LTS s kódovým názvem Focal Fossa. Přehled novinek v poznámkách k vydání. Dle plánu by Ubuntu 20.04 mělo vyjít 23. dubna 2020.

Ladislav Hagara | Komentářů: 1
včera 17:22 | Nová verze

Vyšel XCP-ng 8.1 (seznam změn), alternativní sestavení Citrix Hypervisor (dříve XenServer), tedy serverová distribuce hypervizoru Xen (4.13), toolstacku XAPI a systému CentOS v privilegované doméně. XCP-ng na rozdíl od bezplatné verze Citrix Hypervisoru nemá četná omezení funkcionality, vývojáři ale nabízejí i komerční podporu. Novinkou (zatím) pouze v XCP-ng je možnost zálohovat VM včetně aktuálního stavu jejich paměti; funkce je integrována také v administračním nástroji Xen Orchestra.

Fluttershy, yay! | Komentářů: 0
2.4. 17:55 | Nová verze

Byl vydán LineageOS ve verzi 17.1. LineageOS (Wikipedie) je svobodný operační systém pro chytré telefony, tablety a set-top boxy založený na Androidu. Jedná se o nástupce CyanogenModu. LineageOS 17.1 je založený na Androidu 10.

Ladislav Hagara | Komentářů: 9
2.4. 17:22 | Zajímavý projekt

Lukasz Erecinski na blogu Pine64 oznámil možnost předobjednání telefonu PinePhone v edici UBports Community Edition. Telefon bude mít speciální kryt s logem a nápisem UBports Edition. Základní deska bude podle nového schématu (v1.2) vylepšená podle zpětné vazby od majitelů BraveHeart edice. Bude mít FCC i CE certifikace.

joejoe | Komentářů: 3
2.4. 15:33 | IT novinky

Společnost Cloudflare před dvěma lety spustila DNS resolver 1.1.1.1. Včera spustila 1.1.1.1 pro rodiny aneb nové resolvery 1.1.1.2 (2606:4700:4700::1112) a 1.1.1.3 (2606:4700:4700::1113) blokující stránky s malwarem a obsahem pro dospělé. Dnes se omluvila, že nechtěně blokovala také LGBTQIA+ stránky.

Ladislav Hagara | Komentářů: 31
2.4. 14:55 | Nová verze

Společnost Red Hat oznámila vydání Red Hat Enterprise Linuxu 7.8, který přináší vedle nových vlastností a oprav chyb také aktualizaci ovladačů a předběžné ukázky budoucích technologií. Podrobnosti v poznámkách k vydání.

Ladislav Hagara | Komentářů: 0
2.4. 14:33 | Nová verze

V pondělí vyšel Linux 5.6. Dnes vyšla jeho 2. opravná verze 5.6.2 (git). Opravena byla mimo jiné diskutovaná chyba v ovladači iwlwifi.

Ladislav Hagara | Komentářů: 0
1.4. 19:55 | Nová verze

Po dvou letech od vydání verze 3.0 byla vydána nová major verze 4.0 nástrojů LXC, LXD a LXCFS pro kontejnerovou virtualizaci LXC (LinuX Containers). Jedná se o verzi s dlouhodobou podporou (LTS). Ta končí v červnu 2025. Přehled novinek v jednotlivých oznámeních o vydání: LXC, LXD a LXCFS.

Ladislav Hagara | Komentářů: 4
Chodíte do práce?
 (26%)
 (2%)
 (6%)
 (1%)
 (46%)
 (14%)
 (5%)
Celkem 87 hlasů
 Komentářů: 4, poslední 2.4. 14:20
Rozcestník

www.AutoDoc.Cz

Dotaz: Nesplněné závislosti po upgradu Debianu na vyšší verzi

24.11.2019 10:52 David
Nesplněné závislosti po upgradu Debianu na vyšší verzi
Přečteno: 741×
Dobrý den, už si nevím rady, tak se obracím na vás. Upgradoval jsem Debian na verzi 10 (Buster) a se všemi problémy jsem se vypořádal. Až na zlobivý balík asterisk:
Job for asterisk.service failed because a timeout was exceeded.
See "systemctl status asterisk.service" and "journalctl -xe" for details.
invoke-rc.d: initscript asterisk, action "restart" failed.
● asterisk.service - Asterisk PBX
   Loaded: loaded (/lib/systemd/system/asterisk.service; enabled; vendor preset: enabled)
   Active: activating (auto-restart) (Result: timeout) since Sun 2019-11-24 10:47:59 CET; 215ms ago
     Docs: man:asterisk(8)
  Process: 13947 ExecStart=/usr/sbin/asterisk -g -f -p -U asterisk (code=killed, signal=KILL)
 Main PID: 13947 (code=killed, signal=KILL)

lis 24 10:47:59 server systemd[1]: asterisk.service: State 'stop-sigterm' timed out. Killing.
lis 24 10:47:59 server systemd[1]: asterisk.service: Killing process 13947 (asterisk) with signal SIGKILL.
lis 24 10:47:59 server systemd[1]: asterisk.service: Main process exited, code=killed, status=9/KILL
lis 24 10:47:59 server systemd[1]: asterisk.service: Failed with result 'timeout'.
lis 24 10:47:59 server systemd[1]: Failed to start Asterisk PBX.
lis 24 10:48:00 server systemd[1]: asterisk.service: Service RestartSec=1s expired, scheduling restart.
lis 24 10:48:00 server systemd[1]: asterisk.service: Scheduled restart job, restart counter is at 1.
lis 24 10:48:00 server systemd[1]: Stopped Asterisk PBX.
lis 24 10:48:00 server systemd[1]: Starting Asterisk PBX...
dpkg: chyba při zpracovávání balíku asterisk (--configure):
 installed asterisk package post-installation script subprocess returned error exit status 1
dpkg: nesplněné závislosti zamezily konfiguraci balíku asterisk-voicemail:
 asterisk-voicemail závisí na asterisk (= 1:16.2.1~dfsg-1+deb10u1); avšak:
  Balík asterisk zatím není zkonfigurován.

dpkg: chyba při zpracovávání balíku asterisk-voicemail (--configure):
 problém se závislostmi - nechávám nezkonfigurované
Zpracovávají se spouštěče pro balík systemd (241-7~deb10u2) …
Zpracovávají se spouštěče pro balík man-db (2.8.5-2) …
Zpracovávají se spouštěče pro balík libc-bin (2.28-10) …
Při zpracování nastaly chyby:
 asterisk
 asterisk-voicemail
E: Sub-process /usr/bin/dpkg returned an error code (1)
Vždycky se zaseknu na to, že balík asterisk nemohl být zkonfigurován (timeout) a tím pádem se nenainstaluje asterisk-voicemail, který na něm závisí. Poradíte mi prosím?

Řešení dotazu:


Odpovědi

24.11.2019 14:00 NN
Rozbalit Rozbalit vše Re: Nesplněné závislosti po upgradu Debianu na vyšší verzi
dpkg-reconfigure asterisk
24.11.2019 14:24 David
Rozbalit Rozbalit vše Re: Nesplněné závislosti po upgradu Debianu na vyšší verzi
Bohužel to končí na
server:/etc/pam.d# dpkg-reconfigure asterisk
/usr/sbin/dpkg-reconfigure: asterisk is broken or not fully instal
Tady je celá instalace, která končí na timeoutu
server:/etc/pam.d# dpkg-reconfigure asterisk
/usr/sbin/dpkg-reconfigure: asterisk is broken or not fully installed
server:/etc/pam.d# 
server:/etc/pam.d# apt install asterisk
Načítají se seznamy balíků… Hotovo
Vytváří se strom závislostí       
Načítají se stavové informace… Hotovo
Následující dodatečné balíky budou instalovány:
  asterisk-voicemail
Navrhované balíky:
  asterisk-dahdi asterisk-doc asterisk-ooh323 asterisk-opus asterisk-vpb
Následující NOVÉ balíky budou nainstalovány:
  asterisk asterisk-voicemail
0 aktualizováno, 2 nově instalováno, 0 k odstranění a 0 neaktualizováno.
Nutno stáhnout 3 495 kB archivů.
Po této operaci bude na disku použito dalších 8 809 kB.
Chcete pokračovat? [Y/n]

Stahuje se:1 http://ftp.cz.debian.org/debian buster/main amd64 asterisk amd64 1:16.2.1~dfsg-1+deb10u1 [2 287 kB]
Stahuje se:2 http://ftp.cz.debian.org/debian buster/main amd64 asterisk-voicemail amd64 1:16.2.1~dfsg-1+deb10u1 [1 208 kB]
Staženo 3 495 kB za 1s (6 135 kB/s)             
Vybírá se dosud nevybraný balík asterisk.
(Načítá se databáze … nyní je nainstalováno 235182 souborů a adresářů.)
Připravuje se nahrazení …/asterisk_1%3a16.2.1~dfsg-1+deb10u1_amd64.deb …
Rozbaluje se asterisk (1:16.2.1~dfsg-1+deb10u1) …
Vybírá se dosud nevybraný balík asterisk-voicemail.
Připravuje se nahrazení …/asterisk-voicemail_1%3a16.2.1~dfsg-1+deb10u1_amd64.deb …
Rozbaluje se asterisk-voicemail (1:16.2.1~dfsg-1+deb10u1) …
Nastavuje se balík asterisk (1:16.2.1~dfsg-1+deb10u1) …

Konfigurační soubor „/etc/default/asterisk“
 ==> Soubor v systému byl vytvořen vámi nebo skriptem.
 ==> Tento soubor se také nachází v balíku.
   Co s tím chcete udělat ? Možné volby jsou:
    Y nebo I : nainstalovat verzi z balíku
    N nebo O : ponechat současnou verzi
        D    : zobrazit rozdíl mezi verzemi
        Z    : spustit shell a prozkoumat situaci
 Výchozí akcí je ponechání současné verze.
*** asterisk (Y/I/N/O/D/Z) [předvoleno=N] ? Y
Instaluje se nová verze konfiguračního souboru /etc/default/asterisk 

Job for asterisk.service failed because a timeout was exceeded.
See "systemctl status asterisk.service" and "journalctl -xe" for details.
invoke-rc.d: initscript asterisk, action "restart" failed.
● asterisk.service - Asterisk PBX
   Loaded: loaded (/lib/systemd/system/asterisk.service; enabled; vendor preset: enabled)
   Active: activating (start) since Sun 2019-11-24 14:19:51 CET; 1s ago
     Docs: man:asterisk(8)
 Main PID: 20248 (asterisk)
    Tasks: 1 (limit: 4915)
   Memory: 1.1M
   CGroup: /system.slice/asterisk.service
           └─20248 /usr/sbin/asterisk -g -f -p -U asterisk

lis 24 14:19:51 server systemd[1]: Stopped Asterisk PBX.
lis 24 14:19:51 server systemd[1]: Starting Asterisk PBX...
lis 24 14:19:57 server asterisk[20248]: PBX UUID: 8a98c0a7-212c-462f-976b-395fd9b6078a
lis 24 14:19:57 server asterisk[20248]: [Nov 24 14:19:57] NOTICE[20248]: loader.c:2230 load_modules: 320 modules will be loaded.
dpkg: chyba při zpracovávání balíku asterisk (--configure):
 installed asterisk package post-installation script subprocess returned error exit status 1
dpkg: nesplněné závislosti zamezily konfiguraci balíku asterisk-voicemail:
 asterisk-voicemail závisí na asterisk (= 1:16.2.1~dfsg-1+deb10u1); avšak:
  Balík asterisk zatím není zkonfigurován.

dpkg: chyba při zpracovávání balíku asterisk-voicemail (--configure):
 problém se závislostmi - nechávám nezkonfigurované
Zpracovávají se spouštěče pro balík systemd (241-7~deb10u2) …
Zpracovávají se spouštěče pro balík man-db (2.8.5-2) …
Zpracovávají se spouštěče pro balík libc-bin (2.28-10) …
Při zpracování nastaly chyby:
 asterisk
 asterisk-voicemail

Chyba: Časový limit vypršel
E: Sub-process /usr/bin/dpkg returned an error code (1)
24.11.2019 15:17 ...
Rozbalit Rozbalit vše Re: Nesplněné závislosti po upgradu Debianu na vyšší verzi
A co zkusit nejdrive purge kdyz pise co pise a pak znova instalovat, pripadne zkontrolovat checksum stazeneho baliku, jestli neni poskozeny?
24.11.2019 15:20 David
Rozbalit Rozbalit vše Re: Nesplněné závislosti po upgradu Debianu na vyšší verzi
Purge jsem také zkoušel, potom i odinstalaci přes dpkg. Jenže při instalaci to zůstane na něčem viset a nedokončí se konfigurace kvůli timeoutu. Balík je ok.
24.11.2019 15:22 NN
Rozbalit Rozbalit vše Re: Nesplněné závislosti po upgradu Debianu na vyšší verzi
Nejake detaily v :
See "systemctl status asterisk.service" and "journalctl -xe" for details.
Ten puvodni asterisk funguje?
24.11.2019 15:40 David
Rozbalit Rozbalit vše Re: Nesplněné závislosti po upgradu Debianu na vyšší verzi
Nic víc tam není. Jaký původní?
Pavel 'TIGER' Růžička avatar 24.11.2019 17:10 Pavel 'TIGER' Růžička | skóre: 49
Rozbalit Rozbalit vše Re: Nesplněné závislosti po upgradu Debianu na vyšší verzi
sudo apt-get update --fix-missing také nepomůže?
24.11.2019 18:59 David
Rozbalit Rozbalit vše Re: Nesplněné závislosti po upgradu Debianu na vyšší verzi
ne :(
server:/# apt-get update --fix-missing
Mám:1 http://ftp.cz.debian.org/debian buster InRelease
Mám:2 http://security.debian.org buster/updates InRelease                                                                                                               
Mám:3 http://ftp.debian.org/debian buster-backports InRelease                                                                                                           
Mám:4 http://www.deb-multimedia.org buster InRelease                                                                                                                    
Mám:5 http://ppa.launchpad.net/webupd8team/java/ubuntu xenial InRelease                                                                                        
Mám:6 https://download.docker.com/linux/debian buster InRelease                                                                       
Ign:7 http://download.webmin.com/download/repository sarge InRelease               
Mám:8 http://download.webmin.com/download/repository sarge Release
Načítají se seznamy balíků… Hotovo
server:/# apt-get install asterisk
Načítají se seznamy balíků… Hotovo
Vytváří se strom závislostí       
Načítají se stavové informace… Hotovo
asterisk je již nejnovější verze (1:16.2.1~dfsg-1+deb10u1).
0 aktualizováno, 0 nově instalováno, 0 k odstranění a 0 neaktualizováno.
2 instalováno nebo odstraněno pouze částečně.
Po této operaci bude na disku použito dalších 0 B.
Chcete pokračovat? [Y/n] y
Nastavuje se balík asterisk (1:16.2.1~dfsg-1+deb10u1) …
Job for asterisk.service failed because the control process exited with error code.
See "systemctl status asterisk.service" and "journalctl -xe" for details.
invoke-rc.d: initscript asterisk, action "restart" failed.
● asterisk.service - Asterisk PBX
   Loaded: loaded (/lib/systemd/system/asterisk.service; enabled; vendor preset: enabled)
   Active: activating (auto-restart) (Result: exit-code) since Sun 2019-11-24 18:58:48 CET; 16ms ago
     Docs: man:asterisk(8)
  Process: 22383 ExecStart=/usr/sbin/asterisk -g -f -p -U asterisk (code=exited, status=203/EXEC)
 Main PID: 22383 (code=exited, status=203/EXEC)

lis 24 18:58:48 server systemd[1]: asterisk.service: Main process exited, code=exited, status=203/EXEC
lis 24 18:58:48 server systemd[1]: asterisk.service: Failed with result 'exit-code'.
lis 24 18:58:48 server systemd[1]: Failed to start Asterisk PBX.
dpkg: chyba při zpracovávání balíku asterisk (--configure):
 installed asterisk package post-installation script subprocess returned error exit status 1
dpkg: nesplněné závislosti zamezily konfiguraci balíku asterisk-voicemail:
 asterisk-voicemail závisí na asterisk (= 1:16.2.1~dfsg-1+deb10u1); avšak:
  Balík asterisk zatím není zkonfigurován.

dpkg: chyba při zpracovávání balíku asterisk-voicemail (--configure):
 problém se závislostmi - nechávám nezkonfigurované
Zpracovávají se spouštěče pro balík libc-bin (2.28-10) …
Při zpracování nastaly chyby:
 asterisk
 asterisk-voicemail
E: Sub-process /usr/bin/dpkg returned an error code (1)
24.11.2019 19:29 ...
Rozbalit Rozbalit vše Re: Nesplněné závislosti po upgradu Debianu na vyšší verzi
Mas verzi Debian 10 nebo uz 10.02, jinak, kde se lecos vychytavalo? Aniy bych teda vedel jestli to necemu pomuze ;-)
24.11.2019 19:54 David
Rozbalit Rozbalit vše Re: Nesplněné závislosti po upgradu Debianu na vyšší verzi
Distributor ID:	Debian
Description:	Debian GNU/Linux 10 (buster)
Release:	10
Codename:	buster
Je to čerstvě po kompletním upgradu z netu, takže by to měla být poslední verze (i když to ukazuje 10)
24.11.2019 20:13 ...
Rozbalit Rozbalit vše Re: Nesplněné závislosti po upgradu Debianu na vyšší verzi
Uz to vidim dole Asterisk 16.2.1~dfsg-1+deb10u1 posledni verze baliku.
24.11.2019 19:52 David
Rozbalit Rozbalit vše Re: Nesplněné závislosti po upgradu Debianu na vyšší verzi
Záhadou je, že ten asterisk běží.. tak nějak napůl
server:/usr/sbin# ps aux | grep asterisk
asterisk  1414  1.6  0.7 2238160 62908 ?       Ssl  19:45   0:02 /usr/sbin/asterisk -g -f -p -U asterisk
root      2127  0.0  0.0   8756   824 pts/3    S+   19:48   0:00 grep asterisk
server:/usr/sbin# 
server:/usr/sbin# asterisk -vvvvr
Asterisk 16.2.1~dfsg-1+deb10u1, Copyright (C) 1999 - 2018, Digium, Inc. and others.
Created by Mark Spencer markster@digium.com
Asterisk comes with ABSOLUTELY NO WARRANTY; type 'core show warranty' for details.
This is free software, with components licensed under the GNU General Public
License version 2 and other licenses; you are welcome to redistribute it under
certain conditions. Type 'core show license' for details.
=========================================================================
Connected to Asterisk 16.2.1~dfsg-1+deb10u1 currently running on server (pid = 1414)
server*CLI> 
25.11.2019 07:33 Peter Golis | skóre: 60 | blog: Bežné záležitosti | Bratislava
Rozbalit Rozbalit vše Re: Nesplněné závislosti po upgradu Debianu na vyšší verzi
Len pre info, neostalo rc service pre artesisk z pred upgrade? Možno sa to len štartuje 2x.
25.11.2019 00:58 GeorgeWH | skóre: 39
Rozbalit Rozbalit vše Re: Nesplněné závislosti po upgradu Debianu na vyšší verzi
Ak to spravne chapem, tak to skonci na tom, ze nestartne asterisk. Skus cez policy-rc.d zakazat startovanie sluzieb po instalacii balikov a znova nainstaluj asterisk.

https://people.debian.org/~hmh/invokerc.d-policyrc.d-specification.txt
25.11.2019 11:50 David
Rozbalit Rozbalit vše Re: Nesplněné závislosti po upgradu Debianu na vyšší verzi
Odstranil jsem balík přímo přes dpkg -r a --purge. Asterisk již v PC není (takže se už ani nespouští). Přesto při instalaci (apt) končím na tom samém. Timeoutu a nesplněné závislostech spojené s asterisk-voicemail. Nevím, ale možná je v Busteru rozbitého něco obecně, ale podobný problém jsem nikde popsaný nenašel.
25.11.2019 13:44 GeorgeWH | skóre: 39
Rozbalit Rozbalit vše Re: Nesplněné závislosti po upgradu Debianu na vyšší verzi
A zakazal si to spustanie sluzieb hned po instalacii?
25.11.2019 13:57 David
Rozbalit Rozbalit vše Re: Nesplněné závislosti po upgradu Debianu na vyšší verzi
Aha, promiň. Teď mi tvá rada teprve docvakla:) Vyzkouším a dám vědět.
25.11.2019 16:43 David
Rozbalit Rozbalit vše Re: Nesplněné závislosti po upgradu Debianu na vyšší verzi
Paráda, asterisk nainstalovaný (zákaz spouštění při instalaci https://major.io/2016/05/05/preventing-ubuntu-16-04-starting-daemons-package-installed/). Spuštění trvalo skoro 5 min a:

● asterisk.service - Asterisk PBX
   Loaded: loaded (/lib/systemd/system/asterisk.service; enabled; vendor preset: enabled)
   Active: activating (start) since Mon 2019-11-25 16:42:09 CET; 15s ago
     Docs: man:asterisk(8)
 Main PID: 19454 (asterisk)
    Tasks: 46 (limit: 4915)
   Memory: 33.4M
   CGroup: /system.slice/asterisk.service
           ├─19454 /usr/sbin/asterisk -g -f -p -U asterisk
           └─19455 astcanary /var/run/asterisk/alt.asterisk.canary.tweet.tweet.tweet 19454

lis 25 16:42:11 server asterisk[19454]: ALSA lib pcm.c:2565:(snd_pcm_open_noupdate) Unknown PCM cards.pcm.surround50
lis 25 16:42:11 server asterisk[19454]: ALSA lib pcm.c:2565:(snd_pcm_open_noupdate) Unknown PCM cards.pcm.surround51
lis 25 16:42:11 server asterisk[19454]: ALSA lib pcm.c:2565:(snd_pcm_open_noupdate) Unknown PCM cards.pcm.surround71
lis 25 16:42:11 server asterisk[19454]: ALSA lib pcm.c:2565:(snd_pcm_open_noupdate) Unknown PCM cards.pcm.iec958
lis 25 16:42:11 server asterisk[19454]: ALSA lib pcm.c:2565:(snd_pcm_open_noupdate) Unknown PCM cards.pcm.modem
lis 25 16:42:11 server asterisk[19454]: ALSA lib pcm.c:2565:(snd_pcm_open_noupdate) Unknown PCM cards.pcm.phoneline
lis 25 16:42:11 server asterisk[19454]: ALSA lib pcm.c:2565:(snd_pcm_open_noupdate) Unknown PCM cards.pcm.phoneline
lis 25 16:42:11 server asterisk[19454]: Cannot connect to server socket err = No such file or directory
lis 25 16:42:11 server asterisk[19454]: Cannot connect to server request channel
lis 25 16:42:11 server asterisk[19454]: jack server is not running or cannot be started
Jdu tedy pátrat dál.. dobrý posun, díky:)
25.11.2019 18:32 David
Rozbalit Rozbalit vše Re: Nesplněné závislosti po upgradu Debianu na vyšší verzi
Tak když pustím asterisk ručně
server:/etc/default# /usr/sbin/asterisk -g -f -p -U asterisk
PBX UUID: 8a98c0a7-212c-462f-976b-395fd9b6078a
[Nov 25 18:28:55] NOTICE[9224]: loader.c:2230 load_modules: 320 modules will be loaded.
[Nov 25 18:28:55] NOTICE[9224]: cdr.c:4485 cdr_toggle_runtime_options: CDR simple logging enabled.
[Nov 25 18:28:55] WARNING[9224]: acl.c:614 ast_append_ha: Invalid IP address: all
[Nov 25 18:28:55] ERROR[9224]: manager.c:9359 __init_manager: Invalid ACL 'all' for manager user 'watcher' on line 26. Deleting user
[Nov 25 18:28:55] WARNING[9224]: res_phoneprov.c:1230 get_defaults: Unable to find a valid server address or name.
ALSA lib conf.c:3558:(snd_config_hooks_call) Cannot open shared library (null) ((null): /usr/lib/asterisk/modules/res_odbc_transaction.so: undefined symbol: ast_odbc_class_get_isolation)
ALSA lib conf.c:4026:(snd_config_update_r) hooks failed, removing configuration
ALSA lib pcm.c:2565:(snd_pcm_open_noupdate) Unknown PCM cards.pcm.front
ALSA lib pcm.c:2565:(snd_pcm_open_noupdate) Unknown PCM cards.pcm.rear
ALSA lib pcm.c:2565:(snd_pcm_open_noupdate) Unknown PCM cards.pcm.center_lfe
ALSA lib pcm.c:2565:(snd_pcm_open_noupdate) Unknown PCM cards.pcm.side
ALSA lib pcm.c:2565:(snd_pcm_open_noupdate) Unknown PCM cards.pcm.surround21
ALSA lib pcm.c:2565:(snd_pcm_open_noupdate) Unknown PCM cards.pcm.surround21
ALSA lib pcm.c:2565:(snd_pcm_open_noupdate) Unknown PCM cards.pcm.surround40
ALSA lib pcm.c:2565:(snd_pcm_open_noupdate) Unknown PCM cards.pcm.surround41
ALSA lib pcm.c:2565:(snd_pcm_open_noupdate) Unknown PCM cards.pcm.surround50
ALSA lib pcm.c:2565:(snd_pcm_open_noupdate) Unknown PCM cards.pcm.surround51
ALSA lib pcm.c:2565:(snd_pcm_open_noupdate) Unknown PCM cards.pcm.surround71
ALSA lib pcm.c:2565:(snd_pcm_open_noupdate) Unknown PCM cards.pcm.iec958
ALSA lib pcm.c:2565:(snd_pcm_open_noupdate) Unknown PCM cards.pcm.iec958
ALSA lib pcm.c:2565:(snd_pcm_open_noupdate) Unknown PCM cards.pcm.iec958
ALSA lib pcm.c:2565:(snd_pcm_open_noupdate) Unknown PCM cards.pcm.modem
ALSA lib pcm.c:2565:(snd_pcm_open_noupdate) Unknown PCM cards.pcm.modem
ALSA lib pcm.c:2565:(snd_pcm_open_noupdate) Unknown PCM cards.pcm.phoneline
ALSA lib pcm.c:2565:(snd_pcm_open_noupdate) Unknown PCM cards.pcm.phoneline
Cannot connect to server socket err = No such file or directory
Cannot connect to server request channel
jack server is not running or cannot be started
Na tom jack server is not running or cannot be started to zůstane viset.. Zatím jsem nenašel řešení
25.11.2019 20:34 GeorgeWH | skóre: 39
Rozbalit Rozbalit vše Re: Nesplněné závislosti po upgradu Debianu na vyšší verzi
Mozno by stacilo zakazat jack modul v asteriskovi (pokial tam taky je, ale predpokladam, ze ano, lebo skoro vsetko su moduly).
25.11.2019 20:51 David
Rozbalit Rozbalit vše Re: Nesplněné závislosti po upgradu Debianu na vyšší verzi
Nevěděl jsem, jestli je tam potřeba... ale jo, disabloval jsem app_jack, s stejně končím na
lis 25 20:49:51 server asterisk[25389]: Cannot connect to server socket err = No such file or directory
lis 25 20:49:51 server asterisk[25389]: Cannot connect to server request channel
25.11.2019 20:54 David
Rozbalit Rozbalit vše Re: Nesplněné závislosti po upgradu Debianu na vyšší verzi
tak beru zpět.. noload => app_jack.so nezabralo
lis 25 20:49:51 server asterisk[25389]: jack server is not running or cannot be started
25.11.2019 21:08 ...
Rozbalit Rozbalit vše Re: Nesplněné závislosti po upgradu Debianu na vyšší verzi
Tohle by mohlo zabrat viz cp
25.11.2019 21:11 ...
Rozbalit Rozbalit vše Re: Nesplněné závislosti po upgradu Debianu na vyšší verzi
Takze asi jen spustit druhou sluzbu v tvem pripade.
25.11.2019 21:43 David
Rozbalit Rozbalit vše Re: Nesplněné závislosti po upgradu Debianu na vyšší verzi
Tak už je to o něco lepší.. ale stejně.. asterisk.service: Start operation timed out. Terminating. :)
server:/etc/asterisk# systemctl status asterisk
● asterisk.service - Asterisk PBX and telephony daemon.
   Loaded: loaded (/lib/systemd/system/asterisk.service; enabled; vendor preset: enabled)
   Active: deactivating (stop-sigterm) (Result: timeout)
 Main PID: 1316 (asterisk)
    Tasks: 33 (limit: 4915)
   Memory: 55.1M
   CGroup: /system.slice/asterisk.service
           └─1316 /usr/sbin/asterisk -mqf -C /etc/asterisk/asterisk.conf

lis 25 21:38:28 server systemd[1]: Starting Asterisk PBX and telephony daemon....
lis 25 21:39:59 server systemd[1]: asterisk.service: Start operation timed out. Terminating.

server:/etc/asterisk# tail -f /var/log/asterisk/
tail: chyba při čtení '/var/log/asterisk/': je adresářem
tail: /var/log/asterisk/: nelze sledovat konec souboru tohoto typu, sledování tohoto názvu ukončeno
tail: již nezbývají žádné soubory
server:/etc/asterisk# tail -f /var/log/asterisk/messages 
[Nov 25 21:39:44] NOTICE[1316] cdr.c: CDR simple logging enabled.
[Nov 25 21:39:46] WARNING[1316] acl.c: Invalid IP address: all
[Nov 25 21:39:46] ERROR[1316] manager.c: Invalid ACL 'all' for manager user 'watcher' on line 26. Deleting user
[Nov 25 21:39:48] WARNING[1316] res_phoneprov.c: Unable to find a valid server address or name.
[Nov 25 21:41:34] Asterisk 16.2.1~dfsg-1+deb10u1 built by nobody @ buildd.debian.org on a unknown running Linux on 2019-08-20 20:31:36 UTC
[Nov 25 21:41:34] NOTICE[4032] loader.c: 319 modules will be loaded.
[Nov 25 21:41:34] NOTICE[4032] cdr.c: CDR simple logging enabled.
[Nov 25 21:41:34] WARNING[4032] acl.c: Invalid IP address: all
[Nov 25 21:41:34] ERROR[4032] manager.c: Invalid ACL 'all' for manager user 'watcher' on line 26. Deleting user
[Nov 25 21:41:35] WARNING[4032] res_phoneprov.c: Unable to find a valid server address or name.
pepe_ avatar 26.11.2019 15:25 pepe_ | skóre: 48
Rozbalit Rozbalit vše Re: Nesplněné závislosti po upgradu Debianu na vyšší verzi

Stále chyba    Invalid ACL 'all' for manager user 'watcher' on line 26. Deleting user

 

26.11.2019 17:09 debian+
Rozbalit Rozbalit vše Re: Nesplněné závislosti po upgradu Debianu na vyšší verzi
Tak daj tu cast konfigu, kt. sa mu nepaci.
26.11.2019 17:32 David
Rozbalit Rozbalit vše Re: Nesplněné závislosti po upgradu Debianu na vyšší verzi
To už jsem taky vyhodil.. stejně to končí na timeoutu..
26.11.2019 18:35 debian+
Rozbalit Rozbalit vše Re: Nesplněné závislosti po upgradu Debianu na vyšší verzi
prepis .service nema nahodou bezat tento deamon nostop, ak sluzi na spravu? (moze aj ina cast, tak si zisti)?

Napadlo ma nova instalaca, lez kvoli datam to asi nie je vzdy mozne.
26.11.2019 19:21 David
Rozbalit Rozbalit vše Re: Nesplněné závislosti po upgradu Debianu na vyšší verzi
prepis .service nema nahodou bezat tento deamon nostop, ak sluzi na spravu? (moze aj ina cast, tak si zisti)?
Teď nějak nerozumím, co přesně myslíš..
server:~# systemctl status asterisk.service
● asterisk.service - Asterisk PBX and telephony daemon.
   Loaded: loaded (/lib/systemd/system/asterisk.service; enabled; vendor preset: enabled)
   Active: activating (start) since Tue 2019-11-26 19:13:35 CET; 38s ago
 Main PID: 3552 (asterisk)
    Tasks: 39 (limit: 4915)
   Memory: 33.1M
   CGroup: /system.slice/asterisk.service
           └─3552 /usr/sbin/asterisk -gf -C /etc/asterisk/asterisk.conf

lis 26 19:13:35 server systemd[1]: Starting Asterisk PBX and telephony daemon....

server:~# systemctl status asterisk-cli.socket
● asterisk-cli.socket - Asterisk Command-line Interface Socket
   Loaded: loaded (/lib/systemd/system/asterisk-cli.socket; enabled; vendor preset: enabled)
   Active: active (listening) since Tue 2019-11-26 19:16:09 CET; 5s ago
   Listen: /var/run/asterisk/asterisk.ctl (Stream)
    Tasks: 0 (limit: 4915)
   Memory: 56.0K
   CGroup: /system.slice/asterisk-cli.socket

lis 26 19:16:09 server systemd[1]: Starting Asterisk Command-line Interface Socket.
lis 26 19:16:09 server systemd[1]: Listening on Asterisk Command-line Interface Socket.

server:~# tail -f /var/log/asterisk/messages 
[Nov 26 19:10:31] Asterisk 16.2.1~dfsg-1+deb10u1 built by nobody @ buildd.debian.org on a unknown running Linux on 2019-08-20 20:31:36 UTC
[Nov 26 19:10:32] NOTICE[3046] loader.c: 319 modules will be loaded.
[Nov 26 19:10:46] NOTICE[3046] cdr.c: CDR simple logging enabled.
[Nov 26 19:10:47] WARNING[3046] res_phoneprov.c: Unable to find a valid server address or name.
Tohle je aktuální stav.
26.11.2019 19:28 David
Rozbalit Rozbalit vše Re: Nesplněné závislosti po upgradu Debianu na vyšší verzi
Ještě jsem objevil tuhle hlášku
lis 26 19:27:29 server kernel: x86/PAT: asterisk:5864 map pfn RAM range req uncached-minus for [mem 0x35900000-0x3591ffff], got write-combining
Řešení 1× (Aleš Kapica)
29.11.2019 08:07 David
Rozbalit Rozbalit vše Re: Nesplněné závislosti po upgradu Debianu na vyšší verzi
Po zdlouhavém martyriu konečně vyřešeno. Nakonec jsem se odhodlal všechno odinstalovat přes purge. Po čisté instalaci Asterisk naběhl a já postupně začal kopírovat konfigy. Ve chvíli, co jsem překopčil i moduly, Asterisk opět přestal startovat. V tu chvíli mi došlo, že mám několik telefonů Cisco a modul sccp, který není v základní instalaci. Postupně mi docvaklo, že jsem tenhle modul kompiloval. A jasně, když jsem ho odstranil, Asterisk startoval korektně. Znovu jsem zkompiloval a všechno jede. Věc měla v podstatě jednoduché řešení, ale když v logách nebyla žádná zmínka... Takže děkuji všem zúčastněným a přeji hezký den:)

Založit nové vláknoNahoru

Tiskni Sdílej: Linkuj Jaggni to Vybrali.sme.sk Google Del.icio.us Facebook

ISSN 1214-1267   www.czech-server.cz
© 1999-2015 Nitemedia s. r. o. Všechna práva vyhrazena.