abclinuxu.cz AbcLinuxu.cz itbiz.cz ITBiz.cz HDmag.cz HDmag.cz abcprace.cz AbcPráce.cz
Inzerujte na AbcPráce.cz od 950 Kč
Rozšířené hledání
×
    dnes 00:33 | Zajímavý software

    Byl představen Stremio OS pro Raspberry Pi 5 a 4, tj. operační systém postavený nad LineageOS 21 s multimediálním centrem Stremio. Stremio lze instalovat také z Flathubu.

    Ladislav Hagara | Komentářů: 0
    včera 16:33 | Nová verze

    Po půl roce od vydání verze 2.39 byla vydána nová verze 2.40 knihovny glibc (GNU C Library). Přehled novinek v poznámkách k vydání a v souboru NEWS. Opraveno bylo 5 zranitelností (CVE).

    Ladislav Hagara | Komentářů: 0
    včera 15:33 | Pozvánky

    GNU Tools Cauldron 2024 proběhne v Praze na Univerzitě Karlově od 14. do 16. září 2024.

    Ladislav Hagara | Komentářů: 0
    21.7. 05:00 | Nová verze

    OpenMandriva ROME, tj. průběžně aktualizovaná (rolling) edice linuxové distribuce OpenMandriva, byla vydána ve verzi 24.07. S KDE Plasma 6 a spiny LXQt (2.0.0 Qt6) a GNOME (46.3). Vydáno bylo také ROME Plasma6 Wayland ISO. Vývojáři ale nepovažují Wayland za dostatečně vyspělý, aby mohl nahradit X11 pro většinu uživatelů. Linux byl povýšen na verzi 6.10. Přeložen je Clangem.

    Ladislav Hagara | Komentářů: 11
    21.7. 01:00 | Komunita

    Na čem aktuálně pracují vývojáři GNOME a KDE? Pravidelný přehled novinek v Týden v GNOME a Týden v KDE.

    Ladislav Hagara | Komentářů: 0
    19.7. 10:49 | IT novinky

    Světem se valí vlna BSOD počítačů s operačním systémem Windows v kombinaci s bezpečnostním agentem CrowdStrike. Částečně jsou ochromeny letiště, banky, burzy, Microsoft Cloud apod. Zatím je znám jen workaround v podobě nabootování do recovery režimu a smazání jednoho souboru.

    karkar | Komentářů: 125
    18.7. 23:44 | Komunita

    Nezisková organizace Apache Software Foundation (ASF) oznámila, že se částečně přestane dopouštět kulturní apropriace a změní své logo a brand. Minimálně z loga odstraní indiánské pírko. Nové logo a brand představí na své konferenci Community Over Code v říjnu letošního roku. Ta byla ještě nedávno známá jako ApacheCon.

    Ladislav Hagara | Komentářů: 68
    18.7. 19:00 | Nová verze

    Sound Open Firmware, projekt Linux Foundation, open source audio DSP firmware a SDK, byl vydán ve verzi 2.10.0. Podrobný přehled novinek na GitHubu.

    Ladislav Hagara | Komentářů: 1
    18.7. 10:33 | Komunita

    Společnost Nvidia na svém technickém blogu informuje o přechodu na open source moduly jádra pro GPU (představila je v květnu 2022). Na nejnovějších platformách Grace Hopper nebo Blackwell lze používat pouze open source moduly. Pro Turing, Ampere, Ada Lovelace nebo Hopper se doporučuje přejít na open source moduly, v oficiálním instalátoru si lze vybrat mezi proprietárním a open source modulem. Nejstarší Maxwell, Pascal nebo Volta vyžadují proprietární ovladače.

    Ladislav Hagara | Komentářů: 0
    18.7. 00:11 | Zajímavý článek

    Příspěvek na blogu společnosti Wiz se podrobně věnuje dnes již opraveným zranitelnostem v SAP AI. Útočník si mohl změnit své UID na UID firewallu, tj. 1337, a tím obejít firewall, …

    Ladislav Hagara | Komentářů: 0
    Rozcestník

    Dotaz: mikrotik wireguard site to site

    18.6. 10:25 jhrasko
    mikrotik wireguard site to site
    Přečteno: 582×
    Příloha:
    Zdravim,
    skusam sa trocha hrat s WireGuardom.

    Prvy pokus(na jednej strane DEBIAN a druha strana Android telefon) bol podla navodu na https://ubuntu.com/server/docs/wireguard-on-an-internal-system a fungovalo to bez problemov.

    Teraz som sa dostal k dvom Mikrotik routerom RB750Gr3 a chcel som skusit aj spojenie site to site podla navodu priamo na strankach Mikrotiku https://help.mikrotik.com/docs/display/ROS/WireGuard.

    Situacia je trocha odlisna(priloha wireguard.png), na vstupe su routre od ISP. Na jednom som nastavil port forward 13231/UDP na 192.168.0.2 na druhom na 192.168.1.2.

    Nastavenia MT routerov su nasledovne:

    ***** Mikrotik Router 1 *****
    
    /interface/wireguard
    add listen-port=13231 name=wireguard1
    
    /interface/wireguard/peers
    add allowed-address=192.168.1.0/24 endpoint-address=200.200.200.200 endpoint-port=13231 interface=wireguard1 public-key="public-key Mikrotik Router 2"
    
    /ip/address
    add address=10.200.0.1/30 interface=wireguard1
    
    /ip/route
    add dst-address=192.168.1.0/24 gateway=wireguard1
    
    /ip/firewall/filter
    add action=accept chain=input dst-port=13231 protocol=udp src-address=200.200.200.200 place-before=1
    add action=accept chain=forward dst-address=192.168.0.0/24 src-address=192.168.1.0/24 place-before=1
    add action=accept chain=forward dst-address=192.168.1.0/24 src-address=192.168.0.0/24 place-before=1
    
    ***** Mikrotik Router 2 *****
    
    /interface/wireguard
    add listen-port=13231 name=wireguard1
    
    /interface/wireguard/peers
    add allowed-address=192.168.0.0/24 endpoint-address=100.100.100.100 endpoint-port=13231 interface=wireguard1 public-key="public-key Mikrotik Router 1"
    
    /ip/address
    add address=10.200.0.2/30 interface=wireguard1
    
    /ip/route
    add dst-address=192.168.0.0/24 gateway=wireguard1
    
    /ip/firewall/filter
    add action=accept chain=input dst-port=13231 protocol=udp src-address=100.100.100.100 place-before=1
    add action=accept chain=forward dst-address=192.168.1.0/24 src-address=192.168.0.0/24 place-before=1
    add action=accept chain=forward dst-address=192.168.0.0/24 src-address=192.168.1.0/24 place-before=1
    

    Kde robim chybu, resp. co este treba nastavit, lebo to vyzera ze sa ani nevytvori WG tunel?

    Vdaka za kazdu dobru radu.

    Odpovědi

    18.6. 11:34 X
    Rozbalit Rozbalit vše Re: mikrotik wireguard site to site
    Vidim nekolik veci.
    /ip/address add address=10.200.0.1/30 interface=wireguard1
    Podle navodu neni IP adresa ktera se pridava verejna, ale lokalni(192.168.0.2). V navodu je hadam chyba a misto 10.255.255.1/30 ma byt 10.1.202.1/30.
    Příloha: wireguard.png (35362 bytů)
    Podle obrazku, bude mit PC/Sever vychozi branu na routeru od ISP => na mikrotik se provoz nikdy nedostane => musis pridat statickou cestu do 192.168.1.0/24 pres 192.168.0.2 a stejne i na druhe strane.
    Příloha: wireguard.png (35362 bytů)
    V obrazku je chyba. Wireguard nevytvari samostatnou tunelovanou sit(OpenVPN) => vnejsi "obal" tunelu nebude 10.200.0.x, ale verejna cast ISP ie. peer1/peer2.

    50c
    18.6. 15:58 X
    Rozbalit Rozbalit vše Re: mikrotik wireguard site to site
    Beru zpet. Adresa rozhrani wireguard slouzi jako identifikace zdroje. Takze to prvni a posledni je blbost. Nicmene prostredek plati.
    18.6. 12:04 vex21
    Rozbalit Rozbalit vše Re: mikrotik wireguard site to site
    Ten návod na stránkách Mikrotiku je určitě k věci, ale nakonec se mi site to site podařilo úspěšně nastavit dle tohoto návodu: https://www.youtube.com/watch?v=P6f8Qc4EItc

    Normálně bych asi dal přednost psané dokumentaci, ale musím uznat, že v tomto případě to autor vysvětluje velice dobře. Třeba se to bude hodit.
    18.6. 13:12 jhrasko
    Rozbalit Rozbalit vše Re: mikrotik wireguard site to site
    Velka vdaka, idem si to pozriet.
    18.6. 12:34 MP
    Rozbalit Rozbalit vše Re: mikrotik wireguard site to site
    Tady treba psany navod, nezkouseno.

    https://www.kvalitninavody.cz/wireguard-na-mikrotiku-site-to-site/
    18.6. 13:11 jhrasko
    Rozbalit Rozbalit vše Re: mikrotik wireguard site to site
    Dakujem, tento navod poznam. Je +- rovnaky ako navod priamo na strankach MTikroTiku.
    4.7. 20:33 Petr
    Rozbalit Rozbalit vše Re: mikrotik wireguard site to site
    Dnes jsem řešil to samé. Tady rychle, stručně, funkčně.

    Založit nové vláknoNahoru

    Tiskni Sdílej: Linkuj Jaggni to Vybrali.sme.sk Google Del.icio.us Facebook

    ISSN 1214-1267   www.czech-server.cz
    © 1999-2015 Nitemedia s. r. o. Všechna práva vyhrazena.