abclinuxu.cz AbcLinuxu.cz itbiz.cz ITBiz.cz HDmag.cz HDmag.cz abcprace.cz AbcPráce.cz
AbcLinuxu hledá autory!
Inzerujte na AbcPráce.cz od 950 Kč
Rozšířené hledání
×
    dnes 04:33 | IT novinky

    Microsoft oznámil, že WSL kontejnery (WSLC) aneb linuxové kontejnery ve Windows Subsystem for Linux (WSL) jsou již obecně dostupné. Současně popsal jejich architekturu.

    Ladislav Hagara | Komentářů: 0
    včera 23:22 | Komunita

    openSUSE Leap 16.1 vstoupil do RC fáze. Nově lze instalovat jako standardní systém (Standard) nebo jako neměnný systém s atomickými aktualizacemi (Immutable). Samostatná neměnná distribuce openSUSE Leap Micro končí.

    Ladislav Hagara | Komentářů: 0
    včera 22:22 | Nová verze

    Byl vydán Mozilla Firefox 157.0. S nejvýraznější vizuální proměnou za poslední roky. Přehled novinek v poznámkách k vydání a poznámkách k vydání pro vývojáře. Řešeny jsou rovněž bezpečnostní chyby. Nový Firefox 157 bude brzy k dispozici také na Flathubu a Snapcraftu.

    Ladislav Hagara | Komentářů: 0
    včera 10:33 | IT novinky

    Rodina produktů Raspberry Pi se rozšířila o Raspberry Pi Smart Display Module. Deska pro Raspberry Pi Compute Module 5 se zasouvá přímo do displejů dle specifikace Intel SDM. Cena desky je 30 dolarů.

    Ladislav Hagara | Komentářů: 0
    28.9. 23:44 | Nová verze

    Byla vydána nová verze 2.56.0 distribuovaného systému správy verzí Git. Přispělo 104 vývojářů, z toho 39 nových. Přehled novinek v příspěvku na blogu GitHubu a v poznámkách k vydání.

    Ladislav Hagara | Komentářů: 0
    28.9. 21:22 | Bezpečnostní upozornění

    Hackerská skupina ShinyHunters oznámila průnik do informačních systémů FBI, prostřednictvím zero-day zranitelnosti v platformě Oracle PeopleSoft, kterou úřad využívá mimo jiné pro náborový portál FBIJobs.gov. Útočníci tvrdí, že získali až 3 TB dat o současných i bývalých zaměstnancích a uchazečích o práci. Jako důkaz zveřejnili vzorek přibližně 5 000 záznamů obsahující jména, adresy, telefonní čísla, data narození, čísla

    … více »
    AfD 💙 | Komentářů: 1
    28.9. 21:11 | Zajímavý článek

    Doba kompilace linuxového jádra se díky rychlejšímu hardwaru a optimalizacím kbuildu snižuje k deseti sekundám. Nejnovější patche Lorenza Stoakse (vznikají i s pomocí SI) zkrátily na testovacím stroji dobu sestavení z dlouhých 22 vteřin na pouhých 15, a to bez použití RAMdisku. Testovací systém tvořily dva procesory AMD EPYC 9575F (oba dohromady poskytují celkem 128 jader a 256 vláken), čtyřiadvacet 64GB DDR5-6400 paměťových modulů a

    … více »
    AfD 💙 | Komentářů: 13
    28.9. 01:33 | Komunita

    Před rokem a půl vývojáři postmarketOS informovali, že pro projekt hledají nové jméno. Včera bylo oznámeno: postmarketOS se nově jmenuje Nura.

    Ladislav Hagara | Komentářů: 8
    27.9. 13:44 | Zajímavý projekt

    Hra Factorio dorazila na Printables. Hned teď si můžete stáhnout 65 různých modelů a nechat celou mimozemskou planetu oživnout na svém stole.

    Ladislav Hagara | Komentářů: 13
    26.9. 19:22 | Nová verze

    GNU Project Debugger aneb GDB byl vydán ve verzi 18.1. Podrobný přehled novinek v souboru NEWS.

    Ladislav Hagara | Komentářů: 0
    Které desktopové prostředí na Linuxu používáte?
     (9%)
     (7%)
     (4%)
     (21%)
     (29%)
     (8%)
     (5%)
     (2%)
     (14%)
     (20%)
    Celkem 2752 hlasů
     Komentářů: 31, poslední 13.8. 00:27
    Rozcestník

    Dotaz: Autofs CIFS mount zlyháva

    15.2. 19:39 Vlado99 | skóre: 14 | blog: vlado99
    Autofs CIFS mount zlyháva
    Přečteno: 2339×
    Ahoj.

    Používam autofs na Debian 12 na pripojenie 2 share z Windows storage. Niekedy úspešne pripojí obe a po čase jedno pripojenie blbne, alebo hneď na začiatku pripojí len jedno, prípadne žiadne. Hlási, že adresár (ten mountpoint) neexistuje, v logoch sa objavuje Permission denied. Na CentOS Stream 9 identická konfigurácia funguje bez problémov.

    Ten Windows storage má 2 IP adresy. Keď si na Debiane vynútim použitie len jednej z nich (tak, že urobím záznam v /etc/hosts), problémy zmiznú. Chcel by som ale mať k dispozícii obe adresy, kvôli HA. V čom je problém?

    Podrobnosti - čo je identické pre Debian aj CentOS:
    1. host winshr vracia 2 IP adresy.
    2. Konfigurácia autofs je
      /share1   -rw,fstype=cifs,cred=somefile,uid=user1,gid=group1,dir_mode=0775,file_mode=0644,echo_interval=10,handletimeout=30,handlecache,vers=3.1.1,sec=ntlmssp,nosharesock  ://winshr/Share1
      , detto pre Share2, súbor s credentials bol prekopírovaný z CentOSu na Debian rsyncom, credentials nie sú doménové, ale lokálne pre to úložisko
    Čím sa líši CentOS od Debian:
    1. Je to fyzický stroj, Debian je VM pod Hyper-V.
    2. CentOS má 4 fyzické sieťovky spojené do teamu nad ktorým je VLAN pre dátové pripojenie. Debian má jednu sieťovku, VLAN je nastavený na úrovni Hyper-V.
    V journali to vyzerá takto (share2, ktorý sa nepodaril):
    automount[30662]: do_mount: //winshr/Share2 /share2 type cifs options rw,cred=somefile,uid=user1,gid=group1,dir_mode=0750,file_mode=0600,echo_interval=10,handletimeout=30,handlecache,vers=3.1.1,sec=ntlmssp,nosharesock using module generic
    automount[30662]: mount_mount: mount(generic): calling mkdir_path /share2
    automount[30662]: mount(generic): calling mount -t cifs -o rw,cred=somefile,uid=user1,gid=group1,dir_mode=0750,file_mode=0600,echo_interval=10,handletimeout=30,handlecache,vers=3.1.1,sec=ntlmssp,nosharesock //winshr/Share2 /share2
    automount[30662]: >> mount.cifs kernel mount options: ip=10.x.y.z,unc=\\winshr\Share2,dir_mode=0750,file_mode=0600,echo_interval=10,handletimeout=30,handlecache,vers=3.1.1,sec=ntlmssp,nosharesock,uid=1002,gid=1002,user=svc_smbshare,pass=********
    kernel: CIFS: enabling forceuid mount option implicitly because uid= option is specified
    kernel: CIFS: enabling forcegid mount option implicitly because gid= option is specified
    kernel: CIFS: Attempting to mount \\winshr\Share2
    automount[30662]: >> mount error(13): Permission denied
    automount[30662]: >> Refer to the mount.cifs(8) manual page (e.g. man mount.cifs) and kernel log messages (dmesg)
    automount[30662]: mount(generic): failed to mount //winshr/Share2 (type cifs) on /share2
    automount[30662]: dev_ioctl_send_fail: token = 19
    automount[30662]: failed to mount /share2
    automount[30662]: handle_packet: type = 5
    automount[30662]: handle_packet_missing_direct: token 20, name /share2, request pid 30673
    automount[30662]: dev_ioctl_send_fail: token = 20
    kernel: CIFS: VFS: cifs_mount failed w/return code = -13
    

    Odpovědi

    15.2. 21:57 X
    Rozbalit Rozbalit vše Re: Autofs CIFS mount zlyháva
    Neresi to konkretne tvuj problem, ale nejprve bych otestoval pripojeni na obe IP manualne, zda tam neni skutecne nejaky sitovy problem a pak bych zauvazoval nad vymenou autofs za systemd-automount.
    20.2. 00:13 GeorgeWH | skóre: 42
    Rozbalit Rozbalit vše Re: Autofs CIFS mount zlyháva
    pak bych zauvazoval nad vymenou autofs za systemd-automount.
    Programator ma problem. Rozhodol sa ho riesit v Perle. Programator ma uz dva problemy... (nic proti perlu :))
    18.2. 10:30 Bugsa
    Rozbalit Rozbalit vše Re: Autofs CIFS mount zlyháva
    Za prvé bych mount zkusil udělat přímo na IP, ne hostname. Za druhé mount bez parametrů jako jsou nosharesock, handlecache, echo_interval a handletimeout
    Max avatar 19.2. 16:04 Max | skóre: 73 | blog: Max_Devaine
    Rozbalit Rozbalit vše Re: Autofs CIFS mount zlyháva
    Pokud ten windows storage je v AD a má ho zabezpečen, tak by nemělo jít se připojit přes IP, ale jen přes hostname / fqdn.
    Nicméně je to asi zbytečná poznámka, jelikož jsem se nesetkal s nikým, kdo by to měl správně zabezpečený.
    Zdar Max
    Měl jsem sen ... :(
    24.2. 20:51 Radek
    Rozbalit Rozbalit vše Re: Autofs CIFS mount zlyháva
    Ntlm mame zakázany a zakazany smb1/2. Je to tak v pořádku? :-=
    Max avatar 25.2. 08:34 Max | skóre: 73 | blog: Max_Devaine
    Rozbalit Rozbalit vše Re: Autofs CIFS mount zlyháva
    Ne tak docela. Ještě je nutné vypnout anonymous enumeration sam účtů a sdílení.
    Zdar Max
    Měl jsem sen ... :(

    Založit nové vlákno • Nahoru

    Tiskni Sdílej: Linkuj Jaggni to Vybrali.sme.sk Google Del.icio.us Facebook

    ISSN 1214-1267   www.czech-server.cz
    © 1999-2015 Nitemedia s. r. o. Všechna práva vyhrazena.