abclinuxu.cz AbcLinuxu.cz itbiz.cz ITBiz.cz HDmag.cz HDmag.cz abcprace.cz AbcPráce.cz
AbcLinuxu hledá autory!
Inzerujte na AbcPráce.cz od 950 Kč
Rozšířené hledání
×
    včera 21:00 | Nová verze

    Byla vydána Jakarta EE 10. Jakarta EE (Wikipedie), dříve Java EE (Java Platform, Enterprise Edition) a ještě dříve J2EE (Java 2 Platform, Enterprise Edition), je součást platformy Java určená pro vývoj a provoz podnikových aplikací a informačních systémů.

    Ladislav Hagara | Komentářů: 0
    24.9. 23:33 | Nová verze

    Byla vydána nová stabilní verze 3.2.0 svobodného multiplatformního softwaru pro editování a nahrávání zvukových souborů Audacity (Wikipedie). Přehled nových vlastností ve videu na YouTube. Zdůraznit lze podporu VST3 pluginů, realtimové efekty nebo sdílení audio souborů na Audio.com. Audacity lze instalovat také z Flathubu a Snapcraftu.

    Ladislav Hagara | Komentářů: 0
    24.9. 20:44 | Komunita

    Asahi Lina píše v Rustu ovladač pro Linux pro Apple M1 GPU. Aktuální verze už umí točící se kostku (YouTube, Twitter).

    Ladislav Hagara | Komentářů: 11
    24.9. 00:44 | Humor

    Obrázek, na kterém je zobrazen jeho MD5 hash [Hacker News].

    Ladislav Hagara | Komentářů: 10
    23.9. 10:00 | Humor

    Sitcom The IT Crowd, v Česku vysílaný jako Ajťáci a Partička IT, měl být natočen také v německé a americké verzi. Němci natočili 6 dílů. Američané pouze pilot. Velký špatný.

    Ladislav Hagara | Komentářů: 31
    23.9. 09:00 | Nová verze

    Byla vydána verze 10.0.0 interpretu PostScriptu (PS) a Portable Document Formatu (PDF) Ghostscript (Wikipedie). Nedávno byl interpret PDF přepsán z PostScriptu do C. Původní interpret lze použít s volbou -dNEWPDF=false. S verzí 10.01.0 na jaře 2023 bude tato možnost odstraněna.

    Ladislav Hagara | Komentářů: 0
    23.9. 08:00 | Nová verze

    Weston, referenční implementace kompozitoru pro Wayland, byl vydán ve verzi 11.0.0. Přehled novinek v oznámení.

    Ladislav Hagara | Komentářů: 2
    22.9. 20:11 | Nová verze

    Byla vydána verze 1.64.0 programovacího jazyka Rust (Wikipedie). Podrobnosti v poznámkách k vydání. Vyzkoušet Rust lze například na stránce Rust by Example.

    Ladislav Hagara | Komentářů: 0
    22.9. 12:33 | Nová verze

    Byl vydán Debian Installer Bookworm Alpha 1, tj. první alfa verze instalátoru Debianu 12 s kódovým názvem Bookworm.

    Ladislav Hagara | Komentářů: 0
    22.9. 12:11 | IT novinky

    Microsoft a Canonical společně oznámili podporu systemd ve Windows Subsystem for Linux (WSL).

    Ladislav Hagara | Komentářů: 25
    Bavíte se s chatboty na webových stránkách e-shopů, bank, mobilních operátorů atd.?
     (23%)
     (5%)
     (47%)
     (25%)
    Celkem 262 hlasů
     Komentářů: 0
    Rozcestník


    Dotaz: Chyba pri kompilaci GTK 2.2.x a novejsich

    12.2.2004 17:38 Petr Motejlek
    Chyba pri kompilaci GTK 2.2.x a novejsich
    Přečteno: 45×
    Ahoj, marne se pokousim (uz tyden) rozchodit Downloader For X, ten ovsem ke svemu chodu potrebuje knihovnu gtk 2.2.0 nebo novejsi. Kompilaci provadim standartnim zpusobem, tzn ./configure --dalsi-parametry, make all a make install. Distribuce, kterou mam je Debian 3.0 r2. Zarazejici je to, ze kompilace starsich verzi gtk (ty nizsi nez 2.2.0) dopadnou velmi dobre a gtk je nahrane. Ale v pripade, ze se pokousim nainstalovat gtk novejsi, tak dostanu nasledujici chybovou hlasku: (po make all)
    ../../gdk/.libs/libgdk-x11-2.0.so: undefined reference to 'g_fprintf'
    ../../gdk/.libs/libgdk-x11-2.0.so: undefined reference to 'g_get_application_name'
    ../../gtk/.libs/libgtk-x11-2.0.so: undefined reference to 'g_sprintf'
    collect2: ld returned 1 exit status
    make[3]: *** [gtk-demo] Error 1
    make[3]: Leaving directory '/usr/src/Gtk/gtk+2.2.0/demos/gtk-demo'
    make]2]: *** [all-recursive] Error 1
    make[2]: Leaving directory '/usr/src/Gtk/gtk+2.2.0/demos'
    make[1]: *** [all-recursive] Error 1
    make[1]: Leaving directory '/usr/src/Gtk/gtk+2.2.0'
    make: *** [all-recursive-am] Error 2
    Diky moc vsem za pomoc... a kdybyste potrebovali jeste nejake dalsi informace, jen si napiste ... Diky moc

    Odpovědi

    12.2.2004 17:53 unchallenger | skóre: 69 | blog: unchallenger
    Rozbalit Rozbalit vše Chyba pri kompilaci GTK 2.2.x a novejsich
    Zřejmě máš starou GLib -- divím se tedy, že ./configure neřve, že chce novější GLib... ale nainstaluj nejprve verzi GLib, která odpovídá Gtk+, které chceš kompilovat (možná i Atk a Pango, ale s těmi to třeba projde). Jinak neinstaluj 2.2.0, když existuje 2.2.4 (a podívej se do backportů, IMHO tam novější Gtk+2 někde je).
    13.2.2004 00:25 Petr Motejlek
    Rozbalit Rozbalit vše Chyba pri kompilaci GTK 2.2.x a novejsich
    Dikes za odpoved, chyba je ale v tom, ze i kdyz nainstaluju novy glib spravne, tak mi pak prikaz

    glib-config --version stejne hodi nejakou starou 1.2.13 (nebo tak).... netusim jak se to ma debianu rict... skoda ze to gtk pri ty kompilaci nema jako moznost u configure, dat mu adresar kde je nakrany to novy glib a aby proste nepouzival to stary, ale to asi nejde, co ?
    13.2.2004 00:47 unchallenger | skóre: 69 | blog: unchallenger
    Rozbalit Rozbalit vše Chyba pri kompilaci GTK 2.2.x a novejsich
    Žádná g*-2.0 věc už nemá vlastní g*-config, všecho jede přes pkg-config. Ostatně pochybuji, že ti ./configure od Gtk+2 spouští nějaký glib-config, protože v 1.2 by mu byla na dvě věci...

    Spíš, jestli jsi neprohledal backporty a nenainstaloval všechno z balíčků a máš to ručně zkompilované v /usr/local, tak není glib-2.0.pc v PKG_CONFIG_PATH...
    15.2.2004 14:44 Petr Motejlek
    Rozbalit Rozbalit vše Chyba pri kompilaci GTK 2.2.x a novejsich
    Diky moc. Uz to funguje

    Založit nové vláknoNahoru

    Tiskni Sdílej: Linkuj Jaggni to Vybrali.sme.sk Google Del.icio.us Facebook

    ISSN 1214-1267   www.czech-server.cz
    © 1999-2015 Nitemedia s. r. o. Všechna práva vyhrazena.