abclinuxu.cz AbcLinuxu.cz itbiz.cz ITBiz.cz HDmag.cz HDmag.cz abcprace.cz AbcPráce.cz
AbcLinuxu hledá autory!
Inzerujte na AbcPráce.cz od 950 Kč
Rozšířené hledání
×
včera 22:33 | Zajímavý projekt

Na Humble Bundle byla spuštěna akce Humble Book Bundle: Hacking for the Holidays by No Starch Press. Za 1 dolar a více lze koupit 5 elektronických knih, za 8 dolarů a více lze koupit 10 elektronických knih a za 15 dolarů a více lze koupit 15 elektronických knih věnovaných počítačové bezpečnosti, penetračnímu testování, forenzní analýze nebo kryptografii od nakladatelství No Starch Press. Nákupem lze podpořit organizaci Electronic Frontier Foundation (EFF).

Ladislav Hagara | Komentářů: 0
včera 20:11 | Nová verze

Po devíti měsících od vydání verze 5.4 byla vydána verze 5.5 svobodného multiplatformního softwaru pro konverzi a zpracování digitálních fotografií primárně ve formátů RAW RawTherapee (Wikipedie). Nová verze RawTherapee je k dispozici také jako balíček ve formátu AppImage. Stačí jej stáhnout, nastavit právo ke spuštění a spustit.

Ladislav Hagara | Komentářů: 0
včera 15:44 | Upozornění

Národní úřad pro kybernetickou a informační bezpečnost (NÚKIB) vydal varování (pdf) před používáním softwaru i hardwaru společností Huawei Technologies Co., Ltd., a ZTE Corporation. Používání těchto prostředků představuje bezpečnostní hrozbu.

Ladislav Hagara | Komentářů: 42
včera 13:33 | Pozvánky

Spolek OpenAlt zve příznivce otevřených řešení a přístupu na 159. brněnský sraz, který proběhne v pátek 21. prosince od 18:00 v restauraci Na blbým místě na adrese Pellicova 5b.

Ladislav Hagara | Komentářů: 1
včera 12:55 | Bezpečnostní upozornění

V relačním databázovém systému SQLite (Wikipedie) byla nalezena bezpečnostní chyba pojmenovaná Magellan. Chyba se týká také webových prohlížečů postavených na Chromiu podporujících WebSQL API (POC). Bezpečnostní chyba byla opravena v SQLite 3.26.0 a v Chromiu 71.0.3578.80.

Ladislav Hagara | Komentářů: 0
včera 12:11 | Nová verze

WinBtrfs, open source systémový ovladač pro systémy Microsoft Windows umožňující přístup k linuxovému souborovému systému Btrfs, byl vydán ve verzi 1.1. Přináší podporu komprese zstd (Zstandard). WinBtrfs je používán například v operačním systému ReactOS.

Ladislav Hagara | Komentářů: 0
16.12. 12:44 | Komunita

Nadace Cloud Native Computing Foundation (CNCF), jejíž cílem je usnadnit spolupráci při vývoji a zavádění nových cloudových technologií, projekt konsorcia Linux Foundation, organizovala od 10. do 13. prosince v Seattlu konferenci KubeCon + CloudNativeCon North America 2018. Shrnutí dění na konferenci v příspěvku na blogu. V úvodu konference společnost Red Hat věnovala této nadaci distribuovanou key-value databázi etcd. Jedná se o

… více »
Ladislav Hagara | Komentářů: 0
14.12. 14:33 | Nová verze

Byla vydána nová verze 1.30 editoru zdrojových kódů Visual Studio Code (Wikipedie). Přehled novinek i s náhledy a animovanými gify v poznámkách k vydání.

Ladislav Hagara | Komentářů: 2
14.12. 14:22 | Nová verze

Deset dnů po představení beta verze byla vydána stabilní verze Steam Linku pro Raspberry Pi umožňující streamovat hry ve službě Steam z počítače na televizní obrazovku.

Ladislav Hagara | Komentářů: 9
13.12. 20:00 | Nová verze

Byla vydána (YouTube) verze 2018.3 multiplatformního herního enginu Unity (Wikipedie). Přehled novinek i s videoukázkami v příspěvku na blogu a v poznámkách k vydání.

Ladislav Hagara | Komentářů: 0
Chystáte se přejít na Wayland na „desktopu“?
 (25%)
 (9%)
 (11%)
 (31%)
 (24%)
Celkem 147 hlasů
 Komentářů: 19, poslední 14.12. 18:37
Rozcestník

Dotaz: Jak dohledat knihovnu a hlavičkový soubor k gdbm

3.3. 20:28 Nezmar23 | skóre: 2
Jak dohledat knihovnu a hlavičkový soubor k gdbm
Přečteno: 279×
Učím se nějaké scriptiky v Céčku a používám k tomuto účelu Termux. Teď jsem narazil na problém s využitím databáze gdbm. V učebnici je popsáno použití knihoven ndbm.h a gdbm-ndbm.h a bohužel ty se mi do etc/include nepřidaly. Mám jen knihovnu gdbm.h . Zkoušelel jsem si prohlídnout i můj linux Kubuntu 14.04 LTS a tam jsem nas tom stejně. Snažil jsem se googlil, ale nenašel jsem nic co by mi fungovalo. Goglem jsem ztratil hromadu času a nenašel nic.Poslední dobou je vůbec problém použít nejen google jako vyhledávač na cokoli jiného než na nákupy. . .

Něco jsem nakonec ztáhnul z githubu, ale to nefungovalo. Nenašel jsem ani jakým způsobem vlastně najít potřebnou knihovnu. Obecný popis nic. Poradíte někdo, stačí obecně, jak, v případě že potřebuji přidat nějakou knihovnu a hlavičkový soubor,najdu jakého balíčku jsou součástí? Je nějaký zdroj ověřených a funkčních knihoven? Vůbec by se mi hodil nějaký seznam knihoven, programů a utilit k Linuxu s jednoduchými popisy.

Řešení dotazu:


Odpovědi

3.3. 20:57 Petr
Rozbalit Rozbalit vše Re: Jak dohledat knihovnu a hlavičkový soubor k gdbm
libgdbm-dev nainstalovano mas?
3.3. 21:26 Nezmar23 | skóre: 2
Rozbalit Rozbalit vše Re: Jak dohledat knihovnu a hlavičkový soubor k gdbm
ano..
3.3. 22:01 Nezmar23 | skóre: 2
Rozbalit Rozbalit vše Re: Jak dohledat knihovnu a hlavičkový soubor k gdbm
tak v termuxu se mi to přiadlo s knihovnou libdb-dev. Ale je to řešení má to db instaluju nepřidalo gdbm-ndbm.h odinstaluju... . Řešení do budoucna naprd...... . Otázka trvá jak správně dohledávat potřebné knihovny?
3.3. 21:42 NN
Rozbalit Rozbalit vše Re: Jak dohledat knihovnu a hlavičkový soubor k gdbm
V Debian baliku jsou a v Ubuntu baliku taky..
6.3. 02:58 Nezmar
Rozbalit Rozbalit vše Re: Jak dohledat knihovnu a hlavičkový soubor k gdbm
Nemuzu to furt dat dohromady. Pridal se mi jen hlavickovy soubor, ale stejne to nemohu skompilovat, protoze nemam dve knihovny maj bejt tady
/usr/lib/x86_64-linux-gnu/libgdbm_compat.a
/usr/lib/x86_64-linux-gnu/libgdbm_compat.so
a ja to mam taklenc
/usr/lib/libgdbm.a
/usr/lib/libgdbm.so 
Kde ty dve potrebny knihovny sezenu??? Uz jsem na tom zase sest hodin podlejham flustraci.
gcc -I/data/data/com.termux/files/usr/include -L/data/data/com.termux/files/usr/lib dbm1.c -o spust -lgdbm_compat -lgdbm
S parametrem -lgdbm_compat to hlasi
/data/data/com.termux/files/usr/bin/ld: cannot find -lgdbm_compat
clang-5.0: error: linker command failed with exit code 1 (use -v to see invocation)
co mam delat. Daji se ty knihovnz jakkoli stahnout. JE MOZNOST JAKKOLI ZJISTIT KTEREHO BALIKU JSOU SOUCASTI? je sice hezke videt na starnkach ubuntu, ze tam maji byt. To je mi ale prd platy kdyz tam nejsou. VSECHNO co ma v nazvu gdb nebo dbm nebo nb a pak i db jsem nainstaloval. A s nicim se mi nepridali. Tady ve 20. pisou
https://www.gnu.org.ua/software/gdbm/manual/gdbm.html#Compatibility
ze se ma gdbm nainstalovat s parametry --enable-libgdbm-compat ale at jsem to psal jak jsem to psal at jsem hledal jak se v apt pridavaji parametry instalace nic se nepovedlo...... .

Proc je ak slozity pridat blbou knihovnu :o(((

JAK SE TO DELA??????????????????? JAK ZJISTIM POTREBNY BALICEK KE KNIHOVNE????????????

POMOOOOOOOCCCCC PROSIIIIIIIIIIIIIIIIIIIM .

6.3. 07:59 petr_p | skóre: 59 | blog: pb
Rozbalit Rozbalit vše Re: Jak dohledat knihovnu a hlavičkový soubor k gdbm
Ještě ses nedopracoval k apt-file search /usr/lib/libgdbm.so?
6.3. 13:33 Nezmar23 | skóre: 2
Rozbalit Rozbalit vše Re: Jak dohledat knihovnu a hlavičkový soubor k gdbm
Já ty soubopry v počítači nemám... Potřebuju je tam dostat .
6.3. 14:39 rastos | skóre: 61 | blog: rastos
Rozbalit Rozbalit vše Re: Jak dohledat knihovnu a hlavičkový soubor k gdbm
# apt-get update
Ign http://archive.ubuntu.com trusty InRelease
Get:1 http://archive.ubuntu.com trusty-updates InRelease [65.9 kB]
Get:2 http://archive.ubuntu.com trusty-backports InRelease [65.9 kB]       
Get:3 http://security.ubuntu.com trusty-security InRelease [65.9 kB]           
Get:4 http://archive.ubuntu.com trusty Release.gpg [933 B]
Get:5 http://archive.ubuntu.com trusty-updates/universe Sources [249 kB]
Get:6 http://security.ubuntu.com trusty-security/universe Sources [83.2 kB]
Get:7 http://archive.ubuntu.com trusty-updates/main amd64 Packages [1320 kB]
Get:8 http://security.ubuntu.com trusty-security/main amd64 Packages [896 kB]  
Get:9 http://archive.ubuntu.com trusty-updates/restricted amd64 Packages [21.4 kB]
Get:10 http://archive.ubuntu.com trusty-updates/universe amd64 Packages [576 kB]
Get:11 http://security.ubuntu.com trusty-security/restricted amd64 Packages [18.1 kB]
Get:12 http://archive.ubuntu.com trusty-updates/multiverse amd64 Packages [16.0 kB]
Get:13 http://security.ubuntu.com trusty-security/universe amd64 Packages [267 kB]
Get:14 http://archive.ubuntu.com trusty-backports/main amd64 Packages [14.7 kB]
Get:15 http://archive.ubuntu.com trusty-backports/restricted amd64 Packages [40 B]
Get:16 http://archive.ubuntu.com trusty-backports/universe amd64 Packages [52.5 kB]
Get:17 http://archive.ubuntu.com trusty-backports/multiverse amd64 Packages [1392 B]
Get:18 http://archive.ubuntu.com trusty Release [58.5 kB]                  
Get:19 http://security.ubuntu.com trusty-security/multiverse amd64 Packages [4723 B]
Get:20 http://archive.ubuntu.com trusty/universe Sources [7926 kB]   
Get:21 http://archive.ubuntu.com trusty/main amd64 Packages [1743 kB]          
Get:22 http://archive.ubuntu.com trusty/restricted amd64 Packages [16.0 kB]    
Get:23 http://archive.ubuntu.com trusty/universe amd64 Packages [7589 kB]      
Get:24 http://archive.ubuntu.com trusty/multiverse amd64 Packages [169 kB]     
Fetched 21.2 MB in 13s (1597 kB/s)                                             
Reading package lists... Done
# apt-get install libgdbm-dev 
Reading package lists... Done
Building dependency tree       
Reading state information... Done
The following extra packages will be installed:
  binutils cpp cpp-4.8 gcc gcc-4.8 gcc-4.8-base libasan0 libatomic1
  libc-dev-bin libc6-dev libcloog-isl4 libgcc-4.8-dev libgmp10 libgomp1
  libisl10 libitm1 libmpc3 libmpfr4 libquadmath0 libstdc++6 libtsan0
  linux-libc-dev manpages manpages-dev
Suggested packages:
  binutils-doc cpp-doc gcc-4.8-locales gcc-multilib make autoconf automake1.9
  libtool flex bison gdb gcc-doc gcc-4.8-multilib gcc-4.8-doc libgcc1-dbg
  libgomp1-dbg libitm1-dbg libatomic1-dbg libasan0-dbg libtsan0-dbg
  libquadmath0-dbg glibc-doc man-browser
The following NEW packages will be installed:
  binutils cpp cpp-4.8 gcc gcc-4.8 libasan0 libatomic1 libc-dev-bin libc6-dev
  libcloog-isl4 libgcc-4.8-dev libgdbm-dev libgmp10 libgomp1 libisl10 libitm1
  libmpc3 libmpfr4 libquadmath0 libtsan0 linux-libc-dev manpages manpages-dev
The following packages will be upgraded:
  gcc-4.8-base libstdc++6
2 upgraded, 23 newly installed, 0 to remove and 7 not upgraded.
Need to get 20.1 MB of archives.
After this operation, 71.8 MB of additional disk space will be used.
Do you want to continue? [Y/n] 
Get:1 http://archive.ubuntu.com/ubuntu/ trusty-updates/main gcc-4.8-base amd64 4.8.4-2ubuntu1~14.04.4 [16.7 kB]
Get:2 http://archive.ubuntu.com/ubuntu/ trusty-updates/main libstdc++6 amd64 4.8.4-2ubuntu1~14.04.4 [260 kB]
Get:3 http://archive.ubuntu.com/ubuntu/ trusty-updates/main libasan0 amd64 4.8.4-2ubuntu1~14.04.4 [63.1 kB]
Get:4 http://archive.ubuntu.com/ubuntu/ trusty-updates/main libatomic1 amd64 4.8.4-2ubuntu1~14.04.4 [8630 B]
Get:5 http://archive.ubuntu.com/ubuntu/ trusty/main libgmp10 amd64 2:5.1.3+dfsg-1ubuntu1 [218 kB]
Get:6 http://archive.ubuntu.com/ubuntu/ trusty/main libisl10 amd64 0.12.2-1 [419 kB]
Get:7 http://archive.ubuntu.com/ubuntu/ trusty/main libcloog-isl4 amd64 0.18.2-1 [57.5 kB]
Get:8 http://archive.ubuntu.com/ubuntu/ trusty-updates/main libgomp1 amd64 4.8.4-2ubuntu1~14.04.4 [23.1 kB]
Get:9 http://archive.ubuntu.com/ubuntu/ trusty-updates/main libitm1 amd64 4.8.4-2ubuntu1~14.04.4 [28.6 kB]
Get:10 http://archive.ubuntu.com/ubuntu/ trusty/main libmpfr4 amd64 3.1.2-1 [203 kB]
Get:11 http://archive.ubuntu.com/ubuntu/ trusty-updates/main libquadmath0 amd64 4.8.4-2ubuntu1~14.04.4 [126 kB]
Get:12 http://archive.ubuntu.com/ubuntu/ trusty-updates/main libtsan0 amd64 4.8.4-2ubuntu1~14.04.4 [94.8 kB]
Get:13 http://archive.ubuntu.com/ubuntu/ trusty/main libmpc3 amd64 1.0.1-1ubuntu1 [38.4 kB]
Get:14 http://archive.ubuntu.com/ubuntu/ trusty/main manpages all 3.54-1ubuntu1 [627 kB]
Get:15 http://archive.ubuntu.com/ubuntu/ trusty-updates/main binutils amd64 2.24-5ubuntu14.2 [2076 kB]
Get:16 http://archive.ubuntu.com/ubuntu/ trusty-updates/main cpp-4.8 amd64 4.8.4-2ubuntu1~14.04.4 [4452 kB]
Get:17 http://archive.ubuntu.com/ubuntu/ trusty/main cpp amd64 4:4.8.2-1ubuntu6 [27.5 kB]
Get:18 http://archive.ubuntu.com/ubuntu/ trusty-updates/main libgcc-4.8-dev amd64 4.8.4-2ubuntu1~14.04.4 [1688 kB]
Get:19 http://archive.ubuntu.com/ubuntu/ trusty-updates/main gcc-4.8 amd64 4.8.4-2ubuntu1~14.04.4 [5040 kB]
Get:20 http://archive.ubuntu.com/ubuntu/ trusty/main gcc amd64 4:4.8.2-1ubuntu6 [5098 B]
Get:21 http://archive.ubuntu.com/ubuntu/ trusty-updates/main libc-dev-bin amd64 2.19-0ubuntu6.14 [69.0 kB]
Get:22 http://archive.ubuntu.com/ubuntu/ trusty-updates/main linux-libc-dev amd64 3.13.0-142.191 [770 kB]
Get:23 http://archive.ubuntu.com/ubuntu/ trusty-updates/main libc6-dev amd64 2.19-0ubuntu6.14 [1913 kB]
Get:24 http://archive.ubuntu.com/ubuntu/ trusty/main libgdbm-dev amd64 1.8.3-12build1 [24.9 kB]
Get:25 http://archive.ubuntu.com/ubuntu/ trusty/main manpages-dev all 3.54-1ubuntu1 [1820 kB]
Fetched 20.1 MB in 15s (1311 kB/s)                                             
(Reading database ... 11571 files and directories currently installed.)
Preparing to unpack .../gcc-4.8-base_4.8.4-2ubuntu1~14.04.4_amd64.deb ...
Unpacking gcc-4.8-base:amd64 (4.8.4-2ubuntu1~14.04.4) over (4.8.4-2ubuntu1~14.04.3) ...
Setting up gcc-4.8-base:amd64 (4.8.4-2ubuntu1~14.04.4) ...
(Reading database ... 11571 files and directories currently installed.)
Preparing to unpack .../libstdc++6_4.8.4-2ubuntu1~14.04.4_amd64.deb ...
Unpacking libstdc++6:amd64 (4.8.4-2ubuntu1~14.04.4) over (4.8.4-2ubuntu1~14.04.3) ...
Setting up libstdc++6:amd64 (4.8.4-2ubuntu1~14.04.4) ...
Processing triggers for libc-bin (2.19-0ubuntu6.14) ...
Selecting previously unselected package libasan0:amd64.
(Reading database ... 11571 files and directories currently installed.)
Preparing to unpack .../libasan0_4.8.4-2ubuntu1~14.04.4_amd64.deb ...
Unpacking libasan0:amd64 (4.8.4-2ubuntu1~14.04.4) ...
Selecting previously unselected package libatomic1:amd64.
Preparing to unpack .../libatomic1_4.8.4-2ubuntu1~14.04.4_amd64.deb ...
Unpacking libatomic1:amd64 (4.8.4-2ubuntu1~14.04.4) ...
Selecting previously unselected package libgmp10:amd64.
Preparing to unpack .../libgmp10_2%3a5.1.3+dfsg-1ubuntu1_amd64.deb ...
Unpacking libgmp10:amd64 (2:5.1.3+dfsg-1ubuntu1) ...
Selecting previously unselected package libisl10:amd64.
Preparing to unpack .../libisl10_0.12.2-1_amd64.deb ...
Unpacking libisl10:amd64 (0.12.2-1) ...
Selecting previously unselected package libcloog-isl4:amd64.
Preparing to unpack .../libcloog-isl4_0.18.2-1_amd64.deb ...
Unpacking libcloog-isl4:amd64 (0.18.2-1) ...
Selecting previously unselected package libgomp1:amd64.
Preparing to unpack .../libgomp1_4.8.4-2ubuntu1~14.04.4_amd64.deb ...
Unpacking libgomp1:amd64 (4.8.4-2ubuntu1~14.04.4) ...
Selecting previously unselected package libitm1:amd64.
Preparing to unpack .../libitm1_4.8.4-2ubuntu1~14.04.4_amd64.deb ...
Unpacking libitm1:amd64 (4.8.4-2ubuntu1~14.04.4) ...
Selecting previously unselected package libmpfr4:amd64.
Preparing to unpack .../libmpfr4_3.1.2-1_amd64.deb ...
Unpacking libmpfr4:amd64 (3.1.2-1) ...
Selecting previously unselected package libquadmath0:amd64.
Preparing to unpack .../libquadmath0_4.8.4-2ubuntu1~14.04.4_amd64.deb ...
Unpacking libquadmath0:amd64 (4.8.4-2ubuntu1~14.04.4) ...
Selecting previously unselected package libtsan0:amd64.
Preparing to unpack .../libtsan0_4.8.4-2ubuntu1~14.04.4_amd64.deb ...
Unpacking libtsan0:amd64 (4.8.4-2ubuntu1~14.04.4) ...
Selecting previously unselected package libmpc3:amd64.
Preparing to unpack .../libmpc3_1.0.1-1ubuntu1_amd64.deb ...
Unpacking libmpc3:amd64 (1.0.1-1ubuntu1) ...
Selecting previously unselected package manpages.
Preparing to unpack .../manpages_3.54-1ubuntu1_all.deb ...
Unpacking manpages (3.54-1ubuntu1) ...
Selecting previously unselected package binutils.
Preparing to unpack .../binutils_2.24-5ubuntu14.2_amd64.deb ...
Unpacking binutils (2.24-5ubuntu14.2) ...
Selecting previously unselected package cpp-4.8.
Preparing to unpack .../cpp-4.8_4.8.4-2ubuntu1~14.04.4_amd64.deb ...
Unpacking cpp-4.8 (4.8.4-2ubuntu1~14.04.4) ...
Selecting previously unselected package cpp.
Preparing to unpack .../cpp_4%3a4.8.2-1ubuntu6_amd64.deb ...
Unpacking cpp (4:4.8.2-1ubuntu6) ...
Selecting previously unselected package libgcc-4.8-dev:amd64.
Preparing to unpack .../libgcc-4.8-dev_4.8.4-2ubuntu1~14.04.4_amd64.deb ...
Unpacking libgcc-4.8-dev:amd64 (4.8.4-2ubuntu1~14.04.4) ...
Selecting previously unselected package gcc-4.8.
Preparing to unpack .../gcc-4.8_4.8.4-2ubuntu1~14.04.4_amd64.deb ...
Unpacking gcc-4.8 (4.8.4-2ubuntu1~14.04.4) ...
Selecting previously unselected package gcc.
Preparing to unpack .../gcc_4%3a4.8.2-1ubuntu6_amd64.deb ...
Unpacking gcc (4:4.8.2-1ubuntu6) ...
Selecting previously unselected package libc-dev-bin.
Preparing to unpack .../libc-dev-bin_2.19-0ubuntu6.14_amd64.deb ...
Unpacking libc-dev-bin (2.19-0ubuntu6.14) ...
Selecting previously unselected package linux-libc-dev:amd64.
Preparing to unpack .../linux-libc-dev_3.13.0-142.191_amd64.deb ...
Unpacking linux-libc-dev:amd64 (3.13.0-142.191) ...
Selecting previously unselected package libc6-dev:amd64.
Preparing to unpack .../libc6-dev_2.19-0ubuntu6.14_amd64.deb ...
Unpacking libc6-dev:amd64 (2.19-0ubuntu6.14) ...
Selecting previously unselected package libgdbm-dev.
Preparing to unpack .../libgdbm-dev_1.8.3-12build1_amd64.deb ...
Unpacking libgdbm-dev (1.8.3-12build1) ...
Selecting previously unselected package manpages-dev.
Preparing to unpack .../manpages-dev_3.54-1ubuntu1_all.deb ...
Unpacking manpages-dev (3.54-1ubuntu1) ...
Setting up libasan0:amd64 (4.8.4-2ubuntu1~14.04.4) ...
Setting up libatomic1:amd64 (4.8.4-2ubuntu1~14.04.4) ...
Setting up libgmp10:amd64 (2:5.1.3+dfsg-1ubuntu1) ...
Setting up libisl10:amd64 (0.12.2-1) ...
Setting up libcloog-isl4:amd64 (0.18.2-1) ...
Setting up libgomp1:amd64 (4.8.4-2ubuntu1~14.04.4) ...
Setting up libitm1:amd64 (4.8.4-2ubuntu1~14.04.4) ...
Setting up libmpfr4:amd64 (3.1.2-1) ...
Setting up libquadmath0:amd64 (4.8.4-2ubuntu1~14.04.4) ...
Setting up libtsan0:amd64 (4.8.4-2ubuntu1~14.04.4) ...
Setting up libmpc3:amd64 (1.0.1-1ubuntu1) ...
Setting up manpages (3.54-1ubuntu1) ...
Setting up binutils (2.24-5ubuntu14.2) ...
Setting up cpp-4.8 (4.8.4-2ubuntu1~14.04.4) ...
Setting up cpp (4:4.8.2-1ubuntu6) ...
Setting up libgcc-4.8-dev:amd64 (4.8.4-2ubuntu1~14.04.4) ...
Setting up gcc-4.8 (4.8.4-2ubuntu1~14.04.4) ...
Setting up gcc (4:4.8.2-1ubuntu6) ...
Setting up libc-dev-bin (2.19-0ubuntu6.14) ...
Setting up linux-libc-dev:amd64 (3.13.0-142.191) ...
Setting up libc6-dev:amd64 (2.19-0ubuntu6.14) ...
Setting up libgdbm-dev (1.8.3-12build1) ...
Setting up manpages-dev (3.54-1ubuntu1) ...
Processing triggers for libc-bin (2.19-0ubuntu6.14) ...
# dpkg -L libgdbm-dev |grep include
/usr/include
/usr/include/dbm.h
/usr/include/gdbm.h
/usr/include/gdbm-ndbm.h
# ls -l /usr/include/dbm.h /usr/include/gdbm.h  /usr/include/gdbm-ndbm.h
-rw-r--r-- 1 root root 1563 Aug  2  2013 /usr/include/dbm.h
-rw-r--r-- 1 root root 2003 Aug  2  2013 /usr/include/gdbm-ndbm.h
-rw-r--r-- 1 root root 4744 Aug  2  2013 /usr/include/gdbm.h
Napadá mi jediný vinník: Termux. Čo to vlastne je? Odkiaľ to berie balíčky? Na akom HW to vlastne bežíš?
6.3. 15:19 Nezmar23 | skóre: 2
Rozbalit Rozbalit vše Re: Jak dohledat knihovnu a hlavičkový soubor k gdbm
Termux je apka do tableta. používám ji na učení, ale ale zkouším to i na Kubuntu 14.04.LTS. Hlavičkovej soubor mám v obou zařízeních, co mi chybí je knihovna libgdm_compatible.so abych při kompilaci scriptu používající soubor gdbm-ndbm.h mohl zadat volbu -lgdbm_comatible.

Možná to nejde nainstalovat pomocí apt zkusím to stáhnout ze stránek jako tar.gz a tam už je možnost to instalovat s parametry.
6.3. 19:57 rastos | skóre: 61 | blog: rastos
Rozbalit Rozbalit vše Re: Jak dohledat knihovnu a hlavičkový soubor k gdbm
"libgdbm_compat". Nie "libgdm_compatible".
# dpkg -L libgdbm-dev  | grep /lib/
/usr/lib/x86_64-linux-gnu
/usr/lib/x86_64-linux-gnu/libgdbm_compat.a
/usr/lib/x86_64-linux-gnu/libgdbm.a
/usr/lib/x86_64-linux-gnu/libgdbm.so
/usr/lib/x86_64-linux-gnu/libgdbm_compat.so
# ls -l /usr/lib/x86_64-linux-gnu/libgdbm*
-rw-r--r-- 1 root root 47452 Aug  2  2013 /usr/lib/x86_64-linux-gnu/libgdbm.a
lrwxrwxrwx 1 root root    16 Aug  2  2013 /usr/lib/x86_64-linux-gnu/libgdbm.so -> libgdbm.so.3.0.0
lrwxrwxrwx 1 root root    16 Aug  2  2013 /usr/lib/x86_64-linux-gnu/libgdbm.so.3 -> libgdbm.so.3.0.0
-rw-r--r-- 1 root root 22600 Aug  2  2013 /usr/lib/x86_64-linux-gnu/libgdbm.so.3.0.0
-rw-r--r-- 1 root root 23202 Aug  2  2013 /usr/lib/x86_64-linux-gnu/libgdbm_compat.a
lrwxrwxrwx 1 root root    23 Aug  2  2013 /usr/lib/x86_64-linux-gnu/libgdbm_compat.so -> libgdbm_compat.so.3.0.0
lrwxrwxrwx 1 root root    23 Aug  2  2013 /usr/lib/x86_64-linux-gnu/libgdbm_compat.so.3 -> libgdbm_compat.so.3.0.0
-rw-r--r-- 1 root root 10112 Aug  2  2013 /usr/lib/x86_64-linux-gnu/libgdbm_compat.so.3.0.0 
7.3. 06:34 Nezmar23 | skóre: 2
Rozbalit Rozbalit vše Re: Jak dohledat knihovnu a hlavičkový soubor k gdbm
Já topsal z hlavy. Vyhledával jsem compat.
6.3. 18:57 petr_p | skóre: 59 | blog: pb
Rozbalit Rozbalit vše Re: Jak dohledat knihovnu a hlavičkový soubor k gdbm
A právě apt-file prohledává v metadatach povolených repozitářů. Tedy i v balicích, které nainstalované nejsou. Zeptáte se na soubor a apt-file vrátí název balíčku, který jej obsahuje. Pak si daný balíček nainstalujete, a tím získáte soubor na svůj systém.
Řešení 1× (Nezmar23 (tazatel))
7.3. 06:45 Nezmar23 | skóre: 2
Rozbalit Rozbalit vše Re: Jak dohledat knihovnu a hlavičkový soubor k gdbm
Aha proto jsem si myslel, že to vyhledává jen v kompu. Nemám přidaný potřebný repozitář. Ale každopádně tenhle příkaz si píšu do poznámek. Nakonec, ale nebudu používat databázi dbm ani její novější verze ndbm,gdbm. Objevil jsem jednoduchou databázy sqlite. Běží bez problémů na Termuxu i v Kubuntu a má syntaxy sql. Což je na učení pro mě lepší. Sice neumí fungovat jako server a je lepší, když k ní přistupuje jen jeden uživatel. Ale jak jsem už napsal pro moje učení a primitivní scripty je dost dostačující. Děkuji všem za rady. Sice jsem nerozchodil gdbm, ale zase jsem se naučil kam se ukládaj knihovny, sdílené knihovny, hlavičkové soubory, ale hlavně že když to nejde kudy chci, je určitě jiná a lepší možnost.
4.3. 12:19 petr_p | skóre: 59 | blog: pb
Rozbalit Rozbalit vše Re: Jak dohledat knihovnu a hlavičkový soubor k gdbm

Obecná odpověď je vyhledat potřebný soubor ve správci balíčků mezi všemi existujícími (tedy ne jen nainstalovanými) balíky.

Například Google na dotaz „ubuntu what package provides a file“ mi vrátí hned jako první správnou odpověď.

4.3. 18:54 Nezmar23 | skóre: 2
Rozbalit Rozbalit vše Re: Jak dohledat knihovnu a hlavičkový soubor k gdbm
Dyž právě to je muj dost velkej problém, Anglicky jakžtakž čtu.... někdy blbě. Zformulovat anglicky otázku do googlu tak abych něco našel je pro mě dost mizerný. Dřív by stačilao napsat "gdbm libary for linux" a v prvních odkazech bych se už chytil..... . Navíc, že jednou něco na googlu najdu, nemusim to už najít podruhý. Zajímá mě spíš jestli jsou nějaké stránky s přehledm programů, scriptů..... (Nejlépe řazené podle toho co umí s krátkkým popisem v náhledu :o)) . prostě jak to řešit jinak, než pomocí googlu. Tak dlouho jsem hledal knihovnu pro microchip I2C.h I2C.c až jsem se na to vyprd a napsal si jí raději sám což mi zabralo asi polovinu času a navíc mě to bavilo a něco jsem se naučil.

4.3. 20:14 petr_p | skóre: 59 | blog: pb
Rozbalit Rozbalit vše Re: Jak dohledat knihovnu a hlavičkový soubor k gdbm

Každá distribuce má pro každý balíček popis. Můžete si je nechat všechny vypsat. Příklad v Gentoo:

$ qsearch --all | head
app-accessibility/accerciser Interactive Python accessibility explorer
app-accessibility/at-spi2-atk Gtk module for bridging AT-SPI to Atk
app-accessibility/at-spi2-core D-Bus accessibility specifications and registration daemon
app-accessibility/brltty Daemon that provides access to the Linux/Unix console for a blind person
app-accessibility/caribou Input assistive technology intended for switch and pointer users
app-accessibility/edbrowse editor, browser, and mail client using the /bin/ed interface
app-accessibility/eflite A speech server that allows screen readers to interact with festival lite
app-accessibility/emacspeak the emacspeak audio desktop
app-accessibility/emacspeak-ss adds support for several speech synthesizers to emacspeak
app-accessibility/epos language independent text-to-speech system

Asi přes dvacet tisíc balíků.

Dobře udělaný software má ke každému programu manuálovou stránku. Mezi instalovanými se dá hledat příkazem apropos, který jako argument bere regulární výraz. Takže:

$ apropos . | head
$HOME/.odbc.ini [odbc] (5)  - unixODBC data sources configuration
*l [dialog]          (3)  - widgets and utilities for the *p program
*n [xterm]           (1)  - terminal emulator for X
*p [dialog]          (1)  - display dialog boxes from shell scripts
. [builtins]         (1)  - bash built-in commands, see bash(1)
.P Disclaimer: The functionality of this program is now available in the ntpd program. See the -q command line option in the ntpd [ntpdate] (8)  - Network Time Protocol (NTP) daemon page. After a suitable period of mourning, the ntpdate program is to be retired from this distribution
.P Disclaimer: This program has known bugs and deficiencies and nobody has volunteered to fix them in a long time. The good news is the functionality originally intended for this program is available in the ntpd and sntp programs. See the Deprecating ntpdate topic in the NTP Support wiki for a thorough discussion and analysis of the issues. See the -q command line option in the ntpd [ntpdate] (8)  - Network Time Protocol (NTP) daemon page and/or the sntp - Simple Network Time Protocol (SNTP) Client page. After a suitable period of mourning, the ntpdate program will be retired from this distribution
.ad l posix_trace_attr_getinherited [posix_trace_attr_getinherited] (3p)  - retrieve and set the behavior of a trace stream (TRACING) .ad b
.ad l posix_trace_attr_getlogsize [posix_trace_attr_getlogsize] (3p)  - retrieve and set trace stream size attributes (TRACING) .ad b
.ad l posix_trace_eventset_add [posix_trace_eventset_add] (3p)  - manipulate trace event type sets (TRACING) .ad b

Vypíše všechny. Ale jak vidíte, je trochu tupý, protože bere hned první řádek, co není v manuálové stránce komentář. Problém totiž je, že manuálové stránky jsou v podstatě volný text a tak se špatně strojově zpracovávají.

Existují i webové archivy manuálových stránek, například https://linux.die.net/man/ nebo https://www.mankier.com/. Ale z principu nemohou obsahovat všechno.

4.3. 22:40 Nezmar23 | skóre: 2
Rozbalit Rozbalit vše Re: Jak dohledat knihovnu a hlavičkový soubor k gdbm
Manuálové stránky používám, ale ty jsou již pro nainstalovaný softwear. Když hledám nějaký program a vím jaký používám apt search ale moment........
apt search gdbm | grep -C2 gdbm 
.
.
.
.

libgdbm-dev/trusty 1.8.3-12build1 amd64
  GNU dbm database routines (development files)

libgdbm-gst/trusty 3.2.4-2 amd64
  GDBM bindings for GNU Smalltalk

libgdbm3/trusty,now 1.8.3-12build1 amd64 [installed]
  GNU dbm database routines (runtime version)
.
.

no tak takhle by to šlo.... já vůl........ :o)))) dík za nakopnutí
6.3. 06:26 Nezmar23 | skóre: 2
Rozbalit Rozbalit vše Re: Jak dohledat knihovnu a hlavičkový soubor k gdbm
Seznam balíků je mi naprd já potřebuju vědět co mám nainstalovat, abych měl v systému hlavičkový soubor a všechny potřebné knihovny. Tedy gdbm-ndbm.h a libgdm_compat.so

Založit nové vláknoNahoru

Tiskni Sdílej: Linkuj Jaggni to Vybrali.sme.sk Google Del.icio.us Facebook

ISSN 1214-1267   www.czech-server.cz
© 1999-2015 Nitemedia s. r. o. Všechna práva vyhrazena.