abclinuxu.cz AbcLinuxu.cz itbiz.cz ITBiz.cz HDmag.cz HDmag.cz abcprace.cz AbcPráce.cz
AbcLinuxu hledá autory!
Inzerujte na AbcPráce.cz od 950 Kč
Rozšířené hledání
×
    dnes 16:33 | Nová verze

    Google Chrome 155 byl prohlášen za stabilní. Přináší podporu JPEG XL (.jxl). Opraveno bylo 247 bezpečnostních chyb.

    Ladislav Hagara | Komentářů: 0
    dnes 16:00 | Komunita

    Konference OpenAlt 2026 hledá přednášející. Přihlásit přednášky lze do neděle 11. října. Konference proběhne o víkendu 7. a 8. listopadu na půdě Fakulty informačních technologií VUT v Brně. Témata konference jsou: Otevřený a svobodný software, IoT a Hnutí tvůrců, Vzdělávání, Bezpečnost a soukromí, Otevřená společnost, komunity a data, OpenMobility a další.

    Ladislav Hagara | Komentářů: 0
    dnes 13:22 | Nová verze

    Byla vydána nová verze 10.6 sady aplikací pro SSH komunikaci OpenSSH. Přináší řadu důležitých bezpečnostních oprav, vylepšení funkcí a oprav chyb. Povoluje hybridní postkvantový podpisový algoritmus ssh-mldsa44-ed25519.

    Ladislav Hagara | Komentářů: 0
    dnes 04:00 | Zajímavý software

    Americká společnost Reflection AI světu představila Beam, open-weight model s 501 miliardami parametrů (z toho 23 miliard aktivních), určený především pro programování a práci autonomních agentů. Podle autorů jejich model nabízí výkon srovnatelný s většími modely při výrazně nižších nárocích na výpočetní výkon. Beam nyní ještě prochází závěrečným testováním, na stránkách Reflection AI se však lze zaregistrovat a získat předběžný přístup. Váhy modelu, dokumentace a nástroje pro vývojáře mají být zveřejněny v průběhu tohoto měsíce.

    AfD 💙 | Komentářů: 0
    dnes 02:00 | Komunita

    OpenCourant je komunitní fork OpenRadioss, tj. open source softwaru pro simulace havárií, nárazů a vysoce nelineárních dynamických dějů metodou konečných prvků. Společnost Siemens v loňském roce dokončila akvizici společnosti Altair Engineering, jež před čtyřmi lety uvolnila open source verzi OpenRadioss svého proprietárního softwaru Radioss. Minulý týden Siemens OpenRadioss pohřbil. Integroval jej do svého softwaru Simcenter, webovou stránku OpenRadioss přesměroval na Simcenter a repozitář OpenRadioss na GitHubu odstranil.

    Ladislav Hagara | Komentářů: 0
    dnes 00:22 | Pozvánky

    Pořadatelé devátého ročníku komunitního setkání správců nejen českých a slovenských sítí – CSNOG 2027, které se uskuteční 20. a 21. ledna, vyhlásili Call for Abstracts. Náměty na vystoupení mohou zájemci přihlašovat do 31. října na webu akce a vybírat mohou ze tří sekcí – správa sítí, legislativa a regulace a akademické projekty. Zveřejněny byly také Call of Partners určené sponzorům a partnerům setkání, kteří by například chtěli mít na

    … více »
    VSladek | Komentářů: 0
    včera 16:11 | Zajímavý software

    Strata je open-source inferenční engine, který umožňuje lokálně provozovat rozsáhlý čínský model Qwen3.8-Flash-Next, který by jinak nejspíše vyžadoval serverovou infrastrukturu, na běžném herním počítači s alespoň 12 GB VRAM, 32 GB RAM a dostatkem místa na SSD. Nároky na paměť a rychlost generování se liší s použitou variantou modelu Qwen. Zdrojový kód je dostupný na GitHubu, pod licencí MIT.

    AfD 💙 | Komentářů: 2
    včera 15:11 | Humor

    Americký prezident Donald Trump oznámil vznik federální Jednotky pro superinteligenci (Super Intelligence Force), která má koordinovat postup vlády, technologických firem, náboženských organizací a dalších institucí v oblasti rychle se rozvíjející umělé inteligence (Trumpem oficiálně nazývanou superinteligencí). SIF, podřízená přímo Trumpovi, má pomoci Spojeným státům udržet v oblasti SI technologický náskok nad světem a

    … více »
    AfD 💙 | Komentářů: 4
    včera 13:11 | Zajímavý software

    Klient je e-mailový klient pro GNOME s nativní podporou Proton Mailu, PGP a spamfiltrem řízeným AI. Napsaný je v Go s GTK4 a libadwaita. Připojuje se přímo k Proton Mailu (bez Proton Bridge), ke Gmailu, k Seznam.cz a k libovolné schránce IMAP/SMTP. Každou novou zprávu nejdřív posoudí spamfiltr a teprve potom ji ukáže a ohlásí. Rozhraní je česky a anglicky.

    Ladislav Hagara | Komentářů: 5
    včera 10:44 | Humor

    Hra Doom nově běží také v SQL databázi CedarDB. Představen byl SQLDoom. Vyzkoušet lze online demo. Zdrojové kódy jsou k dispozici na GitHubu.

    Ladislav Hagara | Komentářů: 0
    Které desktopové prostředí na Linuxu používáte?
     (9%)
     (7%)
     (4%)
     (21%)
     (29%)
     (8%)
     (5%)
     (2%)
     (14%)
     (20%)
    Celkem 2812 hlasů
     Komentářů: 31, poslední 13.8. 00:27
    Rozcestník

    Dotaz: Nefunkcny systemd po instalacii balika

    20.2.2020 20:42 GeorgeWH | skóre: 42
    Nefunkcny systemd po instalacii balika
    Přečteno: 661×
    CentOS 7.5 (kvm VM), po nainstalovani balika certbot (+ jeho zavislosti a automatickom update 4 balikov libsepol, libselinux, audit-libs a libsemanage) ostal system v podstate nefunkcny.
    # systemctl status httpd.service
    Failed to get D-Bus connection: Connection refused
    Log po installacii:
    Feb 20 19:40:47 server systemd: Started Cleanup of Temporary Directories.                                                                                         
    Feb 20 20:07:38 server systemd: Reexecuting.                                                                                                                      
    Feb 20 20:07:38 server systemd: systemd 219 running in system mode. (+PAM +AUDIT +SELINUX +IMA -APPARMOR +SMACK +SYSVINIT +UTMP +LIBCRYPTSETUP +GCRYPT +GNUTLS +ACL +XZ +LZ4 -SECCOMP +BLKID +ELFUTILS +KMOD +IDN)
    Feb 20 20:07:38 server systemd: Detected virtualization kvm.
    Feb 20 20:07:38 server systemd: Detected architecture x86-64.
    Feb 20 20:07:38 server systemd: Failed to connect to system bus: Connection refused
    Feb 20 20:07:38 server systemd: Failed to initialize D-Bus connection: Connection refused
    Feb 20 20:07:38 server yum[3477]: Updated: libsepol-2.5-10.el7.x86_64
    Feb 20 20:07:38 server yum[3477]: Updated: libselinux-2.5-14.1.el7.x86_64
    Feb 20 20:07:38 server yum[3477]: Installed: python2-pyasn1-0.1.9-7.el7.noarch
    Feb 20 20:07:38 server yum[3477]: Installed: python-ipaddress-1.0.16-2.el7.noarch
    ...
    Feb 20 20:07:42 server yum[3477]: Installed: python-IPy-0.75-6.el7.noarch
    Feb 20 20:07:42 server yum[3477]: Installed: checkpolicy-2.5-8.el7.x86_64
    Feb 20 20:07:42 server dbus[456]: [system] Reloaded configuration
    Feb 20 20:07:42 server yum[3477]: Installed: policycoreutils-python-2.5-33.el7.x86_64
    Feb 20 20:07:42 server yum[3477]: Installed: python2-mock-1.0.1-10.el7.noarch
    ...
    Feb 20 20:07:43 server yum[3477]: Installed: python2-certbot-1.0.0-1.el7.noarch
    Feb 20 20:07:43 server yum[3477]: Installed: certbot-1.0.0-1.el7.noarch
    Feb 20 20:16:38 server systemd: Started /dev/initctl Compatibility Daemon.
    Feb 20 20:16:38 server systemd: Starting /dev/initctl Compatibility Daemon...
    Feb 20 20:16:38 server systemd-initctl: Failed to get D-Bus connection: Connection refused
    Feb 20 20:16:38 server systemd: systemd-initctl.service: main process exited, code=exited, status=1/FAILURE
    Feb 20 20:16:38 server systemd: Unit systemd-initctl.service entered failed state.
    Feb 20 20:16:38 server systemd: systemd-initctl.service failed.
    Feb 20 20:16:38 server systemd: Started /dev/initctl Compatibility Daemon.
    Feb 20 20:16:38 server systemd: Starting /dev/initctl Compatibility Daemon...
    Feb 20 20:16:38 server systemd-initctl: Failed to get D-Bus connection: Connection refused
    Feb 20 20:16:38 server systemd: systemd-initctl.service: main process exited, code=exited, status=1/FAILURE
    Feb 20 20:16:38 server systemd: Unit systemd-initctl.service entered failed state.
    Feb 20 20:16:38 server systemd: systemd-initctl.service failed.
    Feb 20 20:16:38 server systemd: Started /dev/initctl Compatibility Daemon.
    Feb 20 20:16:38 server systemd: Starting /dev/initctl Compatibility Daemon...
    Feb 20 20:16:38 server systemd-initctl: Failed to get D-Bus connection: Connection refused
    Feb 20 20:16:38 server systemd: systemd-initctl.service: main process exited, code=exited, status=1/FAILURE
    Feb 20 20:16:38 server systemd: Unit systemd-initctl.service entered failed state.
    Feb 20 20:16:38 server systemd: systemd-initctl.service failed.
    Feb 20 20:16:38 server systemd: Started /dev/initctl Compatibility Daemon.
    Feb 20 20:16:38 server systemd: Starting /dev/initctl Compatibility Daemon...
    Feb 20 20:16:38 server systemd-initctl: Failed to get D-Bus connection: Connection refused
    Feb 20 20:16:38 server systemd: systemd-initctl.service: main process exited, code=exited, status=1/FAILURE
    Feb 20 20:16:38 server systemd: Unit systemd-initctl.service entered failed state.
    Feb 20 20:16:38 server systemd: systemd-initctl.service failed.
    Feb 20 20:16:38 server systemd: Started /dev/initctl Compatibility Daemon.
    Feb 20 20:16:38 server systemd: Starting /dev/initctl Compatibility Daemon...
    Feb 20 20:16:38 server systemd-initctl: Failed to get D-Bus connection: Connection refused
    Feb 20 20:16:38 server systemd: systemd-initctl.service: main process exited, code=exited, status=1/FAILURE
    Feb 20 20:16:38 server systemd: Unit systemd-initctl.service entered failed state.
    Feb 20 20:16:38 server systemd: systemd-initctl.service failed.
    Feb 20 20:16:38 server systemd: start request repeated too quickly for systemd-initctl.service
    Feb 20 20:16:38 server systemd: Failed to start /dev/initctl Compatibility Daemon.
    Feb 20 20:16:38 server systemd: Unit systemd-initctl.socket entered failed state.
    Feb 20 20:16:38 server systemd: systemd-initctl.service failed.
    
    Do vtedy ziadny problem.
    # systemctl reboot
    Failed to get D-Bus connection: Connection refused
    
    Na nete nic konkretneho, resp. riesia podobne problemy, ale za inych okolnosti.

    Co s tym?

    Vdaka.

    Řešení dotazu:


    Odpovědi

    20.2.2020 20:47 GeorgeWH | skóre: 42
    Rozbalit Rozbalit vše Re: Nefunkcny systemd po instalacii balika
    # shutdown -r now
    Failed to open /dev/initctl: No such device or address
    Failed to talk to init daemon.
    # ps aux | grep dbus
    dbus       456  0.0  0.0  58088  1160 ?        Ss    2019   0:00 /usr/bin/dbus-daemon --system --address=systemd: --nofork --nopidfile --systemd-activation
    # ps aux | grep systemd
    root         1  0.0  0.0  51464  3188 ?        Ss    2019  44:08 /usr/lib/systemd/systemd --system --deserialize 14
    root       338  0.0  0.3  47272 14088 ?        Ss    2019   4:33 /usr/lib/systemd/systemd-journald
    root       377  0.0  0.0  44464   392 ?        Ss    2019   0:00 /usr/lib/systemd/systemd-udevd
    dbus       456  0.0  0.0  58088  1160 ?        Ss    2019   0:00 /usr/bin/dbus-daemon --system --address=systemd: --nofork --nopidfile --systemd-activation
    20.2.2020 20:55 GeorgeWH | skóre: 42
    Rozbalit Rozbalit vše Re: Nefunkcny systemd po instalacii balika
    Tak "pomohlo" poslanie Ctrl+Alt+Del - sice ostal visiet pri dosiahnuti Shutdown targetu, ale disky myslim, odpojil, takze ok.
    k3dAR avatar 20.2.2020 22:08 k3dAR | skóre: 63
    Rozbalit Rozbalit vše Re: Nefunkcny systemd po instalacii balika
    kdyz by priste nepomohlo ani to, tak SysRq
    porad nemam telo, ale uz mam hlavu... nobody
    21.2.2020 01:17 GeorgeWH | skóre: 42
    Rozbalit Rozbalit vše Re: Nefunkcny systemd po instalacii balika
    Ano na to som myslel, ale potom ma este napadol ten C+A+D.
    20.2.2020 22:32 R
    Rozbalit Rozbalit vše Re: Nefunkcny systemd po instalacii balika
    echo b >/proc/sysrq-trigger a dufat, ze to potom nabootuje. Veriaci clovek sa moze aj pomodlit, ale najlepsie k Lennartovi.
    k3dAR avatar 21.2.2020 00:03 k3dAR | skóre: 63
    Rozbalit Rozbalit vše Re: Nefunkcny systemd po instalacii balika
    to udela reboot naprasaka, doporucuju doplnit info o tom co udelat pred tim, viz
    porad nemam telo, ale uz mam hlavu... nobody
    Řešení 1× (Filip Jirsák)
    michich avatar 21.2.2020 01:17 michich | skóre: 51 | blog: ohrivane_parky
    Rozbalit Rozbalit vše Re: Nefunkcny systemd po instalacii balika
    Ten systém byl nainstalován rovnou ve verzi 7.5, nebo upgradován z některé předchozí verze? Je /var/run symlink na /run ?

    Podle logu systemd neumřel, ale z nějakého důvodu nefunguje D-Bus. Zajímavé je, že se se systemd nedomluvil ani systemctl pod rootem. To totiž nepoužívá komunikaci přes systémový D-Bus, ale socket /run/systemd/private. V /run má svůj socket i systémový D-Bus, takže se asi něco špatného stalo právě s /run.

    Když nejde systemctl, dá se systemd domluvit aspoň pomocí signálů (man systemd, sekce SIGNALS). Případně sync; reboot -f
    21.2.2020 01:24 GeorgeWH | skóre: 42
    Rozbalit Rozbalit vše Re: Nefunkcny systemd po instalacii balika
    Ano, zrejme to bude tym. Uz som nieco podobne davnejsie riesil, ale spravalo sa to inac. Starsie instalacie nemali /var/run symlink na /run (bol to aj tento pripad), ale preco to vyskocilo prave teraz? Neupgradoval sa ziadny systemd balik.

    Otazka c.2 - to teraz bude takto blbnut kazdy "starsi" system po upgrade?
    21.2.2020 07:40 Peter Golis | skóre: 65 | blog: Bežné záležitosti | Bratislava
    Rozbalit Rozbalit vše Re: Nefunkcny systemd po instalacii balika
    Dobrá otázka. Ale skúsil si sa opýtať na fóre danej distribúcie ako majú riešené to zlinkovanie /var/run na /run pri upgrade balíkov (alebo pri štarte)?
    michich avatar 21.2.2020 11:36 michich | skóre: 51 | blog: ohrivane_parky
    Rozbalit Rozbalit vše Re: Nefunkcny systemd po instalacii balika
    V 7.0 už /var/run jako symlink byl. Ten systém byl upgradován z verze 6? Postup pro upgrade RHEL 6 na 7 popisuje Migration Planning Guide. Jsou k tomu nástroje preupg a redhat-upgrade-tool. Pokud vím, v CentOSu ale nejsou. Jedna z kapitol uvádí:
    • 2.3.1.1. Preparing your file system for upgrade

      If /var is on a separate partition, you must manually convert /var/run and /var/lock to symbolic links: [...]

    • 2.3.1.2. Verifying a successful upgrade

      [...] Check that the following symbolic links exist:

      • /bin is a symbolic link to /usr/bin
      • /sbin is a symbolic link to /usr/sbin
      • /lib is a symbolic link to /usr/lib
      • /lib64 is a symbolic link to /usr/lib64
      • /var/run is a symbolic link to /run
      • /var/lock is a symbolic link to /run/lock

    preco to vyskocilo prave teraz?
    RPM skriptlet při upgrade balíčku libsepol zavolal reexec systemd. Hned v tu chvíli systemd zalogoval problém s připojením na D-Bus. Myslím, že něco bylo špatně už dříve, ale až s tím reexecem se to projevilo.
    michich avatar 21.2.2020 11:41 michich | skóre: 51 | blog: ohrivane_parky
    Rozbalit Rozbalit vše Re: Nefunkcny systemd po instalacii balika
    Zákazníci používající RHEL a Insights se o chybně nastaveném /var/run dozvědí. V Insights je na to definované pravidlo.
    21.2.2020 12:56 GeorgeWH | skóre: 42
    Rozbalit Rozbalit vše Re: Nefunkcny systemd po instalacii balika
    Bola to instalacia z live cd centos 7 cez yum --installroot=..., a potom dodatocna konfiguracia cez chroot.

    Ale vsimol som si, ze poslednu dobu uz ten symlink vytvara, takze sa nieco muselo zmenit v centos 7.

    Založit nové vlákno • Nahoru

    Tiskni Sdílej: Linkuj Jaggni to Vybrali.sme.sk Google Del.icio.us Facebook

    ISSN 1214-1267   www.czech-server.cz
    © 1999-2015 Nitemedia s. r. o. Všechna práva vyhrazena.