abclinuxu.cz AbcLinuxu.cz itbiz.cz ITBiz.cz HDmag.cz HDmag.cz abcprace.cz AbcPráce.cz
AbcLinuxu hledá autory!
Inzerujte na AbcPráce.cz od 950 Kč
Rozšířené hledání
×

dnes 11:33 | IT novinky

Red Hat kupuje společnost Codenvy stojící za stejnojmenným webovým (cloudovým) integrovaným vývojovým prostředím (WIDE) postaveném na Eclipse Che.

Ladislav Hagara | Komentářů: 0
dnes 08:55 | Nová verze

V listopadu 2014 byl představen fork Debianu bez systemd pojmenovaný Devuan. Po dva a půl roce jeho vývojáři oznámili vydání první stabilní verze 1.0. Jedná se o verzi s dlouhodobou podporou (LTS) a její kódové jméno je Jessie, podle planetky s katalogovým číslem 10 464.

Ladislav Hagara | Komentářů: 6
včera 20:22 | Zajímavý článek

Nadace Raspberry Pi vydala již osmapadesáté číslo (pdf) stostránkového anglicky psaného časopisu MagPi věnovanému Raspberry Pi a projektům postaveným na tomto jednodeskovém počítači a druhé číslo (pdf) časopisu Hello World primárně určeného pro učitele informatiky a výpočetní techniky.

Ladislav Hagara | Komentářů: 0
včera 19:55 | Humor

Portál Stack Overflow informuje na svém blogu, že pomohl ukončit editor Vim už více než milionu vývojářů. V loňském roce například hledal odpověď na otázku Jak ukončit editor Vim v průměru 1 z 20 000 návštěvníků.

Ladislav Hagara | Komentářů: 10
včera 19:22 | Nová verze

Po pěti měsících od vydání verze 3.5.0 byla vydána nová stabilní verze 3.6.0, tj. první z nové řady 3.6, minimalistické linuxové distribuce zaměřené na bezpečnost Alpine Linux (Wikipedie). Z novinek lze zmínit například podporu dvou nových 64bitových platforem little-endian POWER machines (ppc64le) a IBM z Systems (s390x) nebo nové balíčky Rust 1.17.0, Cargo 0.18.0, GHC 8.0.2 a Julia 0.5.2.

Ladislav Hagara | Komentářů: 0
24.5. 21:33 | Bezpečnostní upozornění

V Sambě byla nalezena a opravena bezpečnostní chyba CVE-2017-7494. Má-li útočník právo ukládat soubory na vzdálený server, může tam uložit připravenou sdílenou knihovnu a přinutit smbd server k jejímu načtení a tím pádem ke spuštění libovolných příkazů. Chyba je opravena v upstream verzích 4.6.4, 4.5.10 a 4.4.14. Chyba se týká všech verzí Samby od verze 3.5.0 vydané 1. března 2010.

Ladislav Hagara | Komentářů: 5
24.5. 20:44 | Nová verze

Byla vydána nová stabilní verze 4.3.0 integrovaného vývojového prostředí (IDE) Qt Creator. Z novinek lze zmínit například integraci editoru kódu do Qt Quick Designeru.

Ladislav Hagara | Komentářů: 1
24.5. 20:11 | Bezpečnostní upozornění

Společnost Check Point informuje na svém blogu o novém vektoru útoku. Pomocí titulků lze útočit na multimediální přehrávače VLC, Kodi, Popcorn Time, Stremio a pravděpodobně i další. Otevření útočníkem připraveného souboru s titulky v neaktualizovaném multimediálním přehrávači může vést ke spuštění libovolných příkazů pod právy uživatele. Ukázka na YouTube. Chyba je opravena v Kodi 17.2 nebo ve VLC 2.2.6.

Ladislav Hagara | Komentářů: 11
23.5. 15:18 | Zajímavý software

CrossOver, komerční produkt založený na Wine, je dnes (23. 5. 2017) dostupný ve slevě. Roční předplatné linuxové verze vyjde s kódem TWENTYONE na $21, resp. $1 v případě IP z chudších zemí. Firma CodeWeavers, která CrossOver vyvíjí, významně přispívá do Wine. Přidaná hodnota CrossOver spočívá v přívětivějším uživatelském rozhraní, integraci do desktopu a podpoře.

Fluttershy, yay! | Komentářů: 26
23.5. 15:11 | Zajímavý projekt

V únoru loňského roku bylo představeno několik útoků na celou řadu bezdrátových klávesnic a myší s názvem MouseJack. Po více než roce lze chybu opravit, tj. aktualizovat firmware, také z Linuxu. Richardu Hughesovi se podařilo navázat spolupráci se společností Logitech, získat od nich dokumentaci, přesvědčit je, aby firmware poskytovali přímo a ne jako součást .exe souboru, aby mohl být popis začleněn do služby Linux Vendor Firmware Service (LVFS) a aktualizace tak mohla proběhnou přímo z Linuxu pomocí projektu fwupd.

Ladislav Hagara | Komentářů: 2
Chystáte se pořídit CPU AMD Ryzen?
 (6%)
 (32%)
 (1%)
 (8%)
 (44%)
 (9%)
Celkem 620 hlasů
 Komentářů: 62, poslední 19.5. 01:57
    Rozcestník

    Dotaz: Nefunkcni ifconfig

    mikirc avatar 2.1.2007 17:55 mikirc | skóre: 19 | blog: MikiSoft | Vsetín
    Nefunkcni ifconfig
    Přečteno: 223×
    Preji hezky den Mam jeden maly ale zasadni problem. Aktualizoval jsem kernel z verze genkernel-x86_64-2.6.17-gentoo-r8 na verzi genkernel-x86_64-2.6.18-gentoo-r4 A zavadec jsem SPRAVNE prepsal ten je bez chyby napsany. Po resetnuti mi to napsalo tyto chyby

    http://nahraj.cz/uploads/764933629/683380193459a88cb67b097.85327944/P1010258.JPG

    http://nahraj.cz/uploads/248681741/478075869459a89a5e58389.85732061/P1010266.JPG

    pak jsem teda od kamose sehnal scripty a nakopiroval jsem je do te slozky pak to psalo nejspise temto error ( delali jsme spoustu veci o pokus odstranit ty errory tak se omlouvam za pripadne zmatky ale melo by to byt dobre)

    http://nahraj.cz/uploads/637342791/1432795621459a8aa70c9982.45692430/P1010268.JPG

    ten se nam asi podarilo odstanit nebo zmenit na tento

    http://nahraj.cz/uploads/780290146/165907627459a8bc0237614.10201122/P1010295.JPG

    pokazde jsem zkusil prikaz ifconfig a ten nevypise ani lo

    Gentoo:ifconfig

    Gentoo:

    no a tim padem nefunguje sit, pouzivam 64bit gentoo a jadro kompiluji pres genkernel

    dekuji za kazdou radu ktera povede k odstraneni toho problemu a jeste pri restartu to pise toto

    http://nahraj.cz/uploads/145132724/1767846952459a8dd0f2dc25.01259536/P1010269.JPG

    a PC musim resetnout rucne samo to neudela
    Byl jednou jeden...

    Odpovědi

    2.1.2007 20:19 Jack Hokus | skóre: 32 | blog: LostHeaven
    Rozbalit Rozbalit vše Re: Nefunkcni ifconfig
    Dobrý den,

    předem uvádím, že nemám Gentoo, tak budu trochu vařit z vody. Podle těch snímků obrazovky soudím, že Vám chybí celá řada modulů.

    Máte možnost nabootovat nějaké funkční jádro? V lilo.conf by jste měl mit odkaz i na starý kernel.

    Jack Hokus
    http://www.jackhokus.cz/
    2.1.2007 20:26 Michal Kubeček | skóre: 71 | Luštěnice
    Rozbalit Rozbalit vše Re: Nefunkcni ifconfig

    Nabootujte s původním jádrem (doufám, že jste si ho ponechal jako volbu, dokud jste nezkontroloval, že systém s novým korektně naběhne) a zkontrolujte, zda jsou nainstalované všechny moduly, případně ještě jednou použijte depmod (ale na novou verzi).

    P.S.: jestli vám nefunguje ifconfig, kvůli tomu není potřeba truchlit, horší bude, že vám ta rozhraní nejspíš neukáže ani ip

    pdp7 avatar 2.1.2007 20:47 pdp7 | skóre: 33 | blog: Mravenec_v_LCD_monitoru | Zákupy u České lípy
    Rozbalit Rozbalit vše Re: Nefunkcni ifconfig
    Typicky :-D ifconfig nefunguje - dyt to je uplne jedno. Hlavni je ip..... ble :-D
    pdp7 avatar 2.1.2007 20:48 pdp7 | skóre: 33 | blog: Mravenec_v_LCD_monitoru | Zákupy u České lípy
    Rozbalit Rozbalit vše Re: Nefunkcni ifconfig
    Nemam rad prikaz ip .. ma syntaxi na BLITI!! :-D
    2.1.2007 20:57 Michal Kubeček | skóre: 71 | Luštěnice
    Rozbalit Rozbalit vše Re: Nefunkcni ifconfig
    Co máte nebo nemáte rád, to je váš problém. Podstatné je, že koncepce příkazu ifconfig už skoro osm let neodpovídá tomu, co se podle něj (ne)má nastavovat, což je u konfiguračního nástroje dost závažný problém. To je jako byste nastavoval netfilter pomocí příkazu ipchains a tvrdil, že je to tak správně. Vlastně je to ještě o něco horší - ipchains je obsolete až od jádra 2.4, ifconfig už od 2.2.
    2.1.2007 20:59 Michal Kubeček | skóre: 71 | Luštěnice
    Rozbalit Rozbalit vše Re: Nefunkcni ifconfig
    Pokud by fungoval bez problémů správný konfigurační nástroj, pak by nefunkčnost toho, který je už osm let obsolete (a který pořádně nefunguje už dávno), by opravdu nebyla problémem hodným pozornosti.
    2.1.2007 21:55 tezkatlipoka | skóre: 35
    Rozbalit Rozbalit vše Re: Nefunkcni ifconfig
    myslim ze je na case aby jsi zpracoval nejaky svuj "Main Kampf" a zanechal ho jako dedictvi budoucim.
    Vaše řeč budiž ano, ano, ne, ne. Co je nad to, je od ďábla.
    pdp7 avatar 2.1.2007 22:10 pdp7 | skóre: 33 | blog: Mravenec_v_LCD_monitoru | Zákupy u České lípy
    Rozbalit Rozbalit vše Re: Nefunkcni ifconfig
    mikirc avatar 2.1.2007 22:21 mikirc | skóre: 19 | blog: MikiSoft | Vsetín
    Rozbalit Rozbalit vše Re: Nefunkcni ifconfig
    ja bych rad vyresil svuj problem a necetl blbe pripominky mimo tema
    Byl jednou jeden...
    2.1.2007 22:34 Michal Kubeček | skóre: 71 | Luštěnice
    Rozbalit Rozbalit vše Re: Nefunkcni ifconfig
    No, jestli čekáte radu ve stylu "Napište 'abrakadabra' a všechno bude zase fajn", budete asi zklamán. Takhle rozvrtaný systém je typ problémů, které se korespondenčně řeší velmi těžko.
    mikirc avatar 2.1.2007 22:44 mikirc | skóre: 19 | blog: MikiSoft | Vsetín
    Rozbalit Rozbalit vše Re: Nefunkcni ifconfig
    no pokud se najde nekdo poctivi tak jsem ochoten poskytnout i ssh v nejhorsim pripade
    Byl jednou jeden...
    2.1.2007 22:53 Michal Kubeček | skóre: 71 | Luštěnice
    Rozbalit Rozbalit vše Re: Nefunkcni ifconfig
    Jestli nevidíte žádný interface, dokonce ani lo, pochybuji, že se na ten stroj půjde přihlásit pomocí ssh…
    mikirc avatar 2.1.2007 23:20 mikirc | skóre: 19 | blog: MikiSoft | Vsetín
    Rozbalit Rozbalit vše Re: Nefunkcni ifconfig
    live cd ubuntu + chroot tak to delam ja
    Byl jednou jeden...
    houska avatar 3.1.2007 12:31 houska | skóre: 41 | blog: HW
    Rozbalit Rozbalit vše Re: Nefunkcni ifconfig
    poctivy - mlady
    mikirc avatar 2.1.2007 21:08 mikirc | skóre: 19 | blog: MikiSoft | Vsetín
    Rozbalit Rozbalit vše Re: Nefunkcni ifconfig
    stay kernel dela uplne to same a nevim proc nebo cojsem spatne udelal a jeste poznamku IP mam pevnou tu mam od poskytovatele danou a v nastavovacich souborech kde se nastavuje IP, brana, DNS je vse spravne nastavene
    Byl jednou jeden...
    2.1.2007 21:08 ZeXx86 | skóre: 19 | blog: ZeXx86 blog | Orlová
    Rozbalit Rozbalit vše Re: Nefunkcni ifconfig
    Kernel jsme zkouseli vratit, dokonce na 2 predchozi verze, a ani jedna nefunguje, dela to to stejne, zkouseli sme kompilovat znova kernel (ten stary i novy) prez genkernel all (taky sme to zkouseli nastavit vprez --menuconfig) proste nic nepomaha ..
    ZeX/OS - http://zexos.org
    2.1.2007 21:18 Michal Kubeček | skóre: 71 | Luštěnice
    Rozbalit Rozbalit vše Re: Nefunkcni ifconfig
    Podle některých z těch hlášek to vypadá, že vám chybějí i některé pomocné soubory, které potřebují ke své funkci startovací skripty. Ale to by chtělo nějakého Gentoo-guru, aby vám k tomu řekl víc.
    vencour avatar 2.1.2007 22:31 vencour | skóre: 55 | blog: Tady je Vencourovo | Praha+západní Čechy
    Rozbalit Rozbalit vše Re: Nefunkcni ifconfig

    Bohužel mám MDV a tedy se mohu jen vyjádřit, co bych dělal v tomto případě v takové situaci - "přejel" to znovu instalací, tedy nechal opět přepsat systémové soubory. Případně bych někam zálohoval disk, abych si s tím moh pozdějš hrát, na volné místo někde na disku.

    Jinak by šlo použít pro přenos logů "ven" nějaké live distro - se kterým snad budete mít přístup na net, flashku atd., tedy zároveň i k logům na disku.

    Ty nejhlubší objevy nečekají nutně za příští hvězdou. Jsou uvnitř nás utkány do vláken, která nás spojují, nás všechny.
    2.1.2007 23:19 Haaja | skóre: 25 | blog: haaja | Praha
    Rozbalit Rozbalit vše Re: Nefunkcni ifconfig
    A stejny problem to dela i kdyz nepouzijete genkernel a initrd, ale zkompilujete jadro pomoci make && make modules_install?

    Co vam hlasi lspci o te sitovce? A v dmesg je co?
    3.1.2007 11:29 Jack Hokus | skóre: 32 | blog: LostHeaven
    Rozbalit Rozbalit vše Re: Nefunkcni ifconfig
    Dobrý den,

    trochu jsem se zamyslel nad Vašim problémem a napadlo mne par veci, snad něco z toho pomůže vyřešit Váš problém.

    Jednak se zkuste dostat do jednouživatelského režimu, kde běží jen mimum služeb. Uvidíte co to udělá.

    Druhá možnost by byla vytáhnout, třeba pomocí chrootu z nějakého live CD seznam nainstalovaných balíčků a porovnat jej pomocí nějakého programu, tuším diff se s funkčním gentoo, zjistil by jste tím, co Vám chybí.

    A když už jsme u těch balíčku, lze pocí balíčkovacího systému Gentoo nechat vypsat seznam poškozených či špatně nainstalovaných balíčků? A pokud se takové balíčky najdou, lze je nechat znovu nainstalovat (přepsat starou instalaci novou)?

    Omlouvám se, že jen tak střílím od boku, ale zatím nic lepšího nemám

    S pozdravem Jack Hokus
    http://www.jackhokus.cz/
    3.1.2007 11:37 Haaja | skóre: 25 | blog: haaja | Praha
    Rozbalit Rozbalit vše Re: Nefunkcni ifconfig
    LiveCD, chroot a stahnout novy system znova (rozumej /etc). Pripadne dat pak znova emergovat system.
    3.1.2007 12:18 Filip Jirsák | skóre: 66 | blog: Fa & Bi
    Rozbalit Rozbalit vše Re: Nefunkcni ifconfig
    Genkernel jestli se nepletu používá initramdisk, vytvořil se vám správně a bootujete s tím správným initramdiskem?

    Že by se jen tak samy od sebe poničily startovací skripty se mi nezdá moc pravděpodobné. A okopírovat je jen tak od jinud asi také nebude zrovna nejlepší řešení, třeba na mém Gentoo s baselyout-1.12.6 žádný adresář /lib/rcscripts/net.modules.d/ neexistuje (na jiném Gentoo s baselyaout-1.12.5 existuje). Zkuste znovu nainstalovat baselayout
    emerge -a --oneshot baselayout
    
    Pokud by se to pokoušelo stahovat novou verzi, vnuťte mu instalaci té verze, kterou máte právě nainstalovanou a od které máte distribuční soubory. Tím byste měl dostat do pořádku základní inicializační skripty. Uvidíte, co se bude dít dál, možná vám chybí zkompilované nějaké moduly jádra, nebo je máte zkompilované, ale nenahrají se.
    3.1.2007 16:06 Ash
    Rozbalit Rozbalit vše Re: Nefunkcni ifconfig
    Máte to pěkně zmršené.

    Vypadá to na staré startovací skripty /etc/init.d/něco. Jste si jist, že jste nezapomněl na etc-update nebo dispatch-conf", podle toho, co používáte? To je asi nejpravděpodobnější

    # find /etc/ -name "._*"

    by vám nemělo nic vypsat. Pokud ano, tak etc-update a vše v /etc/init.d/ aktualizujte novou verzí.

    Další možnost je, že jste si ty skripty při aktualizaci nějak zmršil. Ale spíš se mi zdá, že jsou prostě neaktuální :( /etc/init.d/net.* by neměl hledat functions v adresáři helpers.d, protože functions tam už nějaký čas není.

    Nesnažte se asi dávat někam nějaké soubory, aby se to initskriptům líbilo, ony pokud po aktualizaci samy od sebe zmizely, tak k tomu byl asi nějaký důvod, spíš se snažte aktualizovat ty iniskripty, aby nehledaly to, co nemáte.
    3.1.2007 16:16 Ash
    Rozbalit Rozbalit vše Re: Nefunkcni ifconfig
    Pokud to nepomůže, tak se tam případně chrootněte z LiveCD a emerge --update -av system a etc-update. To už musí© pomoct :D
    mikirc avatar 3.1.2007 21:08 mikirc | skóre: 19 | blog: MikiSoft | Vsetín
    Rozbalit Rozbalit vše Re: Nefunkcni ifconfig
    Gentoo ~ # emerge --update -av system

    These are the packages that would be merged, in order:

    Calculating system dependencies... done!

    [blocks B ] sys-apps/pam-login (is blocking sys-apps/shadow-4.0.18.1)

    [ebuild U ] app-arch/gzip-1.3.5-r10 [1.3.5-r8] USE="nls -build -pic -static" 323 kB

    [ebuild U ] sys-devel/gcc-config-1.3.13-r4 [1.3.13-r3] 0 kB

    [ebuild NS ] sys-devel/gcc-4.1.1-r1 USE="fortran nls (-altivec) -bootstrap - build -doc -gcj -gtk (-hardened) -ip28 -ip32r10k -mudflap (-multilib) -multislot (-n32) (-n64) -nocxx -objc -objc++ -objc-gc -test -vanilla" 38,320 kB

    [ebuild U ] sys-libs/timezone-data-2006p [2006g] USE="nls%*" 336 kB

    [ebuild U ] sys-libs/glibc-2.4-r4 [2.3.6-r4] USE="nls nptl -build -glibc-com pat20 -glibc-omitfp -hardened (-multilib) -nptlonly -profile (-selinux) (-erando m%)" 15,711 kB

    [ebuild U ] app-crypt/hashalot-0.3-r2 [0.3-r1] 78 kB

    [ebuild U ] sys-fs/e2fsprogs-1.39 [1.38] USE="nls -static" 0 kB

    [ebuild U ] sys-apps/util-linux-2.12r-r4 [2.12r-r1] USE="crypt nls perl -old -crypt (-selinux) -static (-pam%*)" 1,504 kB

    [ebuild U ] app-arch/bzip2-1.0.3-r6 [1.0.3-r5] USE="-build -static" 653 kB

    [ebuild U ] app-arch/tar-1.16-r2 [1.15.1] USE="nls -static (-build%) (-bzip2 %*)" 1,743 kB

    [ebuild U ] sys-process/psmisc-22.2 [21.9] USE="X%* ipv6 nls (-selinux)" 238 kB

    [ebuild U ] net-misc/rsync-2.6.8-r2 [2.6.0-r6] USE="ipv6%* -acl -build -stat ic -xinetd (-livecd%)" 754 kB

    [ebuild U ] sys-apps/shadow-4.0.18.1 [4.0.7-r4] USE="cracklib%* nls pam -nou suid (-selinux) -skey" 1,480 kB

    [ebuild U ] net-misc/openssh-4.4_p1-r6 [4.2_p1-r1] USE="X%* pam tcpd -X509 - chroot -hpn -kerberos -ldap -libedit (-selinux) -skey -smartcard -static (-ipv6% *) (-sftplogging%)" 1,019 kB

    [ebuild U ] sys-apps/net-tools-1.60-r12 [1.60-r11] USE="nls -static (-build% )" 296 kB

    [ebuild U ] app-editors/nano-1.3.12-r1 [1.3.9] USE="ncurses nls spell -debug -justify -minimal -slang -unicode (-build%)" 1,221 kB

    [ebuild U ] sys-apps/man-pages-2.42 [2.20] USE="nls" 1,777 kB

    [ebuild N ] app-i18n/man-pages-cs-0.16 241 kB

    Total size of downloads: 65,702 kB

    !!! Error: The above package list contains packages which cannot be installed !!! at the same time on the same system.

    For more information about Blocked Packages, please refer to the following section of the Gentoo Linux x86 Handbook (architecture is irrelevant):

    http://www.gentoo.org/doc/en/handbook/handbook-x86.xml?full=1#blocked

    Pokud dobre chpu tak to chce abych vsechny tyto balicky odblokoval??
    Byl jednou jeden...
    3.1.2007 23:16 Ritchie | skóre: 27 | blog: Ritchie's | Berlin
    Rozbalit Rozbalit vše Re: Nefunkcni ifconfig
    Nejprve odinstalujte pam-login emerge -Cav pam-login a následně nainstalujte novou verzi shadow emerge -uav shadow. Ebuild pam-login totiž již není potřeba, akorát překáží, neboť jeho funkci zajišťuje nová verze ebuildu shadow. Samozřejmě se nedoporučuje po odinstalování pam-login a před instalací shadow odhlašovat, neboť je velká pravděpodobnost, že byste se už nepřihlásil.
    mikirc avatar 3.1.2007 23:33 mikirc | skóre: 19 | blog: MikiSoft | Vsetín
    Rozbalit Rozbalit vše Re: Nefunkcni ifconfig
    uz to resit nemusime rozhodl jsem se pro new instalaci asi chyba byla v tom zejsem mel vezdi 2006.0 a udelal jsem neco pro verzi 2006.1 teda tak mi to bylo receno
    Byl jednou jeden...
    4.1.2007 18:52 Ash
    Rozbalit Rozbalit vše Re: Nefunkcni ifconfig
    To bude nějaká ptákovina. Ty profily hlavně určují nastavení USE a definují základní balíčky, nemyslím že byste "udělal něco pro 2006.1" a ono se to rozbilo. Ale nevím jak jste to instaloval, jestli pořádně nebo jestli to nebylo nějaké to grafické vobechcvátko :) --
    Links: Gentoo Linux AMD64 Handbook.

    Založit nové vláknoNahoru

    Tiskni Sdílej: Linkuj Jaggni to Vybrali.sme.sk Google Del.icio.us Facebook

    ISSN 1214-1267   www.czech-server.cz
    © 1999-2015 Nitemedia s. r. o. Všechna práva vyhrazena.