abclinuxu.cz AbcLinuxu.cz itbiz.cz ITBiz.cz HDmag.cz HDmag.cz abcprace.cz AbcPráce.cz
AbcLinuxu hledá autory!
Inzerujte na AbcPráce.cz od 950 Kč
Rozšířené hledání
×
dnes 17:11 | Bezpečnostní upozornění

V PHP byla nalezena bezpečnostní chyba CVE-2021-21703 zneužitelná k lokální eskalaci práv. Opravena je v upstream verzi 8.0.12.

Ladislav Hagara | Komentářů: 0
dnes 14:11 | Zajímavý projekt

Na Crowd Supply běží kampaň na podporu zařízení KrakenSDR s pěti přijímači RTL-SDR. Lze je používat nezávisle nebo současně jako radiozaměřovač nebo pasivní radar.

Ladislav Hagara | Komentářů: 9
dnes 11:11 | Komunita

Implementace OpenPGP Sequoia PGP byla přelicencována z GPL 2+ na LGPL 2+. Vývojáři to zdůvodňují na dvou příkladech: Apple nepovoluje GPL software ve svém App Storu a problém s GPL má také Thunderbird.

Ladislav Hagara | Komentářů: 0
dnes 10:11 | IT novinky

Problémy s výrobou a dodáváním má také Raspberry Pi. Raspberry Pi 4 s 2 GB RAM proto dočasně zdražilo z 35 na 45 dolarů.

Ladislav Hagara | Komentářů: 2
dnes 09:11 | Nová verze

Byla vydána vývojová verze 2.99.8 svobodné aplikace pro úpravu a vytváření rastrové grafiky GIMP. Jedná se o další krok směrem k verzi 3 postavené na GTK 3. Přehled novinek i s náhledy v oznámení o vydání a v souboru NEWS na GitLabu. Stabilní verze je 2.10.28.

Ladislav Hagara | Komentářů: 0
dnes 07:00 | Zajímavý článek

Obsáhlý zápisek v blogu jednoho z vývojářů Haiku, svobodného operačního systému inspirovaného BeOS, popisuje nejen zkušenosti s notebookem Lenovo ThinkPad T510 a posléze W541, ale průběžně také rozvíjí úvahy o svobodném softwaru, právu na opravu (right to repair), (ne)zveřejňování specifikací hardwaru, dotýká se politiky podepisování distribučních klíčů nejen Secure Boot aj.

Fluttershy, yay! | Komentářů: 13
včera 23:44 | Nová verze

OpenJS Foundation, oficiální projekt konsorcia Linux Foundation, oznámila vydání verze 17.0.0 a krátce na to 17.0.1 otevřeného multiplatformního prostředí pro vývoj a běh síťových aplikací napsaných v JavaScriptu Node.js (Wikipedie). Přehled novinek v článku na Medium.

Ladislav Hagara | Komentářů: 4
včera 20:33 | IT novinky

Microsoft představil vscode.dev aneb Visual Studio Code běžící ve webovém prohlížeči.

Ladislav Hagara | Komentářů: 5
včera 15:22 | Komunita

Organizace Software Freedom Conservancy podala žalobu (pdf) na výrobce televizorů Vizio kvůli opakovanému porušování licence GPL.

Ladislav Hagara | Komentářů: 5
včera 13:33 | Nová verze

Byla vydána nová verze 1.31 webového prohlížeče Brave (Wikipedie, GitHub). Výchozím webovým vyhledávačem se stává Brave Search. Ten lze využívat i v jiných prohlížečích na adrese search.brave.com. Uživatelé Brave se mohou podílet na jeho vylepšování, pokud povolí v nastavení Web Discovery Project (WDP).

Ladislav Hagara | Komentářů: 2
Kolik monitorů (obrazovek) používáte současně?
 (49%)
 (36%)
 (14%)
 (1%)
Celkem 394 hlasů
 Komentářů: 29, poslední 19.10. 07:04
Rozcestník



Dotaz: Zope Gentoo chybi pyexpat

19.12.2005 14:41 Scarabeus IV | skóre: 20 | blog: blogisek_o_gentoo | Praha
Zope Gentoo chybi pyexpat
Přečteno: 100×
Ahoj,
pri spusteni prikazu
USE="~x86" emerge -vD zope
tak mi to napise chybu ze to chce:

The Python interpreter you are using does not appear to have the 'pyexpat'
library module installed.  For many Zope features to work properly, including
Zope Page Templates, you must install a Python interpreter which includes the
pyexpat module, or install the pyexpat library into your Python interpreter
manually.  The file which represents the library is named 'pyexpat.so' (UNIX)
or 'pyexpat.dll' (Windows) and is typically located in the 'lib-dynload'
directory of your Python's library directory.  Some Python packagers ship the
pyexpat module as a separate installable binary. If you are using a
system-provided Python installation, you may want to look for a 'python-xml'
or 'python-pyexpat' package (or something like it) and install it to make the
pyexpat module available to Zope.  If you've compiled your Python interpreter
from source, you may need to recompile and reinstall it after installing James
Clark's expat libraries and development packages (look for libexpat.so and
expat.h). Typically, these come as part of your operating system's libexpat
and libexpat-dev packages, respectively.
Bohuzel potrebuju k praci zopa ve verzi 2.8 takze musim pouzivat tenhle maskovanej balicek, ale tu samou hlasku mi to hodi i kdyz to pustim ke stazeni obicejnej co je uz odmaskovanej.
Diky za kazdej nazor

Odpovědi

19.12.2005 16:17 razor
Rozbalit Rozbalit vše Re: Zope Gentoo chybi pyexpat
Se Zope žádnou zkušenost nemám, ale skusil bych nainstalovat pyxml.
19.12.2005 18:06 Scarabeus IV | skóre: 20 | blog: blogisek_o_gentoo | Praha
Rozbalit Rozbalit vše Re: Zope Gentoo chybi pyexpat
bohuzel pyxml mam a stale mi to hazi tu chybku.
19.12.2005 18:22 razor
Rozbalit Rozbalit vše Re: Zope Gentoo chybi pyexpat
Teďkom jsem zkoušel nainstalovat net-zope/zope-2.8.4, a to se nainstalovalo OK (i bez pyxml). Možná by se šiklo emerge --sync, jestli máte poslední zope ebuild starší.
19.12.2005 18:26 razor
Rozbalit Rozbalit vše Re: Zope Gentoo chybi pyexpat
Mám tedy ještě nainstalováno: dev-libs/expat, jestli to nehraje roli.
19.12.2005 18:59 Scarabeus IV | skóre: 20 | blog: blogisek_o_gentoo | Praha
Rozbalit Rozbalit vše Re: Zope Gentoo chybi pyexpat
mmo ja predelal emerge toho balicku aby nepouzival python 2.3 ale 2.4 a uz to jede. Diky za pomoc
19.12.2005 19:10 ghostmonk
Rozbalit Rozbalit vše Re: Zope Gentoo chybi pyexpat
mozna by stacilo spustit python-updater http://www.gentoo.org/news/en/gwn/20051003-newsletter.xml

Založit nové vláknoNahoru

Tiskni Sdílej: Linkuj Jaggni to Vybrali.sme.sk Google Del.icio.us Facebook

ISSN 1214-1267   www.czech-server.cz
© 1999-2015 Nitemedia s. r. o. Všechna práva vyhrazena.