abclinuxu.cz AbcLinuxu.cz itbiz.cz ITBiz.cz HDmag.cz HDmag.cz abcprace.cz AbcPráce.cz
AbcLinuxu hledá autory!
Inzerujte na AbcPráce.cz od 950 Kč
Rozšířené hledání
×
    dnes 02:33 | IT novinky

    Canonical oznámil vydání Zephyr 26.04 LTS. Jedná se o komerční distribuci operačního systému pro mikrokontroléry Zephyr (Wikipedie) s podporou až 15 let.

    Ladislav Hagara | Komentářů: 0
    dnes 02:00 | Zajímavý projekt

    Gravity Linux je linuxová distribuce určená pro Apple Silicon s čipy M4 a novějšími. Vydána byla alfa verze pro M4 Mac mini. Gravity Linux je fork Asahi Linuxu.

    Ladislav Hagara | Komentářů: 0
    včera 22:22 | Zajímavý projekt

    Hister je osobní soukromý vyhledávač, který lze provozovat na vlastním stroji. Umí prohledávat lokální soubory, importovat historii a záložky z webových prohlížečů, procházet vybrané weby a pomocí rozšíření pro Firefox a Chrome indexovat obsah právě navštívených stránek. Nad vytvořeným indexem pak nabízí vyhledávání prostřednictvím webového rozhraní, příkazové řádky a díky podpoře MCP i nástrojům umělé inteligence. Tento

    … více »
    AfD 💙 | Komentářů: 0
    včera 13:33 | IT novinky

    Ministerstvo dopravy uznalo prozatímní schválení asistenčního systému Tesla FSD Supervised vydané nizozemským schvalovacím orgánem RDW. Připojilo se tak k Nizozemsku a dalším pěti evropským státům. Systém je díky tomuto rozhodnutí možné používat za podmínek prozatímního schválení také na území České republiky. Tesla FSD Supervised je asistenčním systémem úrovně 2 podle klasifikace SAE (částečná automatizace řízení). Řidič se

    … více »
    Ladislav Hagara | Komentářů: 12
    včera 11:22 | Upozornění

    Někteří zákazníci O2 mohou aktuálně zaznamenat zhoršenou dostupnost internetových služeb. Na odstranění potíží se pracuje [Facebook].

    Ladislav Hagara | Komentářů: 7
    včera 01:22 | Nová verze

    PyPy (Wikipedie), tj. implementace Pythonu v RPythonu, alternativa CPythonu v C, byla vydána v nové major verzi 8.0.0. Podporuje Python 2.7, 3.11 a 3.12.

    Ladislav Hagara | Komentářů: 0
    včera 00:22 | Komunita
    V rakouském Štýrském Hradci probíhá konference vývojářů a uživatelů desktopového prostředí KDE Plasma Akademy 2026. O víkendu proběhly přednášky. Videozáznamy jsou k dispozici na YouTube.
    Ladislav Hagara | Komentářů: 3
    20.9. 23:55 | Bezpečnostní upozornění

    V jádře Linux byly nalezeny a v upstremu ve verzích 5.10.270, 5.15.221, 6.1.188, 6.6.157, 6.12.109, 6.18.50 a 7.2.4 již opraveny 4 kritické zranitelnosti umožňující eskalaci práv: DirtyAH6 (CVE-2026-80844), TUNderflow (CVE-2026-81000), PPPoEject (CVE-2026-68121) a DiagSpill (CVE-2026-74469).

    Ladislav Hagara | Komentářů: 0
    20.9. 23:11 | Zajímavý článek

    Německá policie a celníci zneužívají ke čtení zpráv komunikačních aplikacích WhatsApp, Signal, Telegram nebo Threema velice jednoduchý trik, který nevyžaduje prolomení šifrování, spear phishing, odposlech SMS či jinou technicky náročnou metodu. Příslušníkům státního aparátu pouze stačí získat krátký přístup k odemčenému telefonu a prostřednictvím QR kódu propojit účet s oficiální desktopovou nebo webovou aplikací v policejním

    … více »
    AfD 💙 | Komentářů: 7
    19.9. 02:11 | IT novinky Ladislav Hagara | Komentářů: 0
    Které desktopové prostředí na Linuxu používáte?
     (9%)
     (7%)
     (4%)
     (21%)
     (29%)
     (8%)
     (5%)
     (2%)
     (14%)
     (20%)
    Celkem 2710 hlasů
     Komentářů: 31, poslední 13.8. 00:27
    Rozcestník

    Dotaz: apache httpd.conf nastaveni pro localhost

    17.3.2007 15:09 Gioconda | skóre: 1
    apache httpd.conf nastaveni pro localhost
    Přečteno: 3233×
    Čau, apache2 si chci nastavit abych na nem mohl testovat doma skripty, ale porad mi to vypisuje tohle:
    prikaz apache2
    (98)Address already in use: make_sock: could not bind to address 127.0.0.1:80
    no listening sockets available, shutting down
    Unable to open logs
    
    a pri pripojeni z prohlizece na http://localhost/ mi to vypise stranku "Test Page for Apache Installation" tohle je z httpd.conf
    \< VirtualHost *>
     ServerName localhost
     ServerAdmin nekdo@torad.horke
     DocumentRoot /home/www/Deals
     ErrorLog /home/www/Deals/errorlog
     TransferLog /home/www/Deals/transferlog
    \< /VirtualHost>
    Listen 127.0.0.1:80

    Odpovědi

    17.3.2007 15:33 Platonix
    Rozbalit Rozbalit vše Re: apache httpd.conf nastaveni pro localhost
    Měl bych pro tebe 2 tipy.

    1. Apache zkus spouštět pomocí /etc/init.d/apache2 start. Ve tvém případě místo start spíše restart, protože Apache už běží. To, jak jsi psal by ti spustilo apache podruhé a to už nejde, protože ten první (první instance) už obsadil port 80.

    2. Nejsem si jist, ale ty obrácený lomítka v konfiguráku možná znamenají komentář a bylo by fajn je zkusit smazat. Jinak rozhodně jsem si jist, že apache je třeba restartovat po každé změně konfigurace, aby si ji načetl.
    17.3.2007 20:57 Gioconda | skóre: 1
    Rozbalit Rozbalit vše Re: apache httpd.conf nastaveni pro localhost
    1. diky, jenze po restartu pomoci "/etc/init.d/apache2 restart", nebo restartu pc a nasledne "/etc/init.d/apache2 start" dostanu
     * Starting apache2 ...                                                   [ !! ]
    
    a nemuzu se dopatrat jak zjistit co mi temi vykricniky chce rict protoze kdyz pak zadam do prohlizece http://localhost/ tak dostanu "Promblem loading page" se zpravou "Unable to connect"

    2. jo, ty obraceny lomitka jsem zkousel na abclinuxu protoze mi virtualhost s < a > bralo jako znacku a tak sem to chtel escapovat(nevsiml jsem si ze je tady moznost dat < rovnou zakodovane) a tak jsem dal jen mezeru mezi < virtualhost a zapomnel to odstranit
    Milan 17.3.2007 21:05 Milan "Nemo" Cingroš | skóre: 27 | blog: Nautilus | Plzeň
    Rozbalit Rozbalit vše Re: apache httpd.conf nastaveni pro localhost
    Podívej se do logu (/var/log/apache2/error_log), vykřičníky znamenají, že se spuštění nepovedlo. Ale podle toho co píšeš, tak proces asi obsadí port 80 a stále běží.
    Soutěžte na české LinuxWiki a vyhrajte plyšového Tuxe.
    17.3.2007 21:05 Pavel1 | skóre: 33
    Rozbalit Rozbalit vše Re: apache httpd.conf nastaveni pro localhost
     * Starting apache2 ...                                                   [ !! ]
    
    To znamená, že spuštění nedopadlo úspěšně. Ale proč, toť otázka, možností je víc. Mrkni třeba do logů, tam by mohl být napsán důvod (třeba chyba v konfiguráku, ...)
    17.3.2007 21:28 Gioconda | skóre: 1
    Rozbalit Rozbalit vše Re: apache httpd.conf nastaveni pro localhost
    dekuji vsem, tak uz mi to funguje.v logu jsem zjistil ze jsem pro errorlog zadal jen adresar ale ne primo soubor takze mi to cele blokovalo, stacilo to dopsat /www/errorlog/errorlog a /etc/init.d/apache2 restart a vse jede :-)

    Založit nové vláknoNahoru

    Tiskni Sdílej: Linkuj Jaggni to Vybrali.sme.sk Google Del.icio.us Facebook

    ISSN 1214-1267   www.czech-server.cz
    © 1999-2015 Nitemedia s. r. o. Všechna práva vyhrazena.