abclinuxu.cz AbcLinuxu.cz itbiz.cz ITBiz.cz HDmag.cz HDmag.cz abcprace.cz AbcPráce.cz
AbcLinuxu hledá autory!
Inzerujte na AbcPráce.cz od 950 Kč
Rozšířené hledání
×
    dnes 03:33 | Komunita

    Proběhl Snapdragon Summit 2026. Společnost Qualcomm se mimo jiné pochlubila během Linuxu na čipech Snapdragon X2. Zatím pouze v ranní verzi vhodné pro vývojáře linuxových distribucí a přispěvatele do jádra Linux.

    Ladislav Hagara | Komentářů: 0
    včera 21:11 | Nová verze

    Byla vydána nová verze 2.0 klienta F-Droid určeného pro instalaci bezplatných a otevřených mobilních aplikací do Androidu ze softwarového repozitáře F-Droid (Wikipedie). Jedná se o alternativu k Google Play.

    Ladislav Hagara | Komentářů: 3
    včera 12:11 | Komunita

    Debian Inference Portal nabízí vývojářům Debianu bezplatný přístup ke službám AI/LLM. Sponzorem je společnost Scaleway.

    Ladislav Hagara | Komentářů: 0
    včera 11:44 | Bezpečnostní upozornění

    Robert Ressl nalezl ve WordPressu kritickou zranitelnost CVE-2026-87902 s CVSS 9.2. Útočníkům umožňuje neoprávněný přístup k souborům a vzdálené spuštění kódu (RCE). Opravena je ve verzích 7.1.2, 7.0.6, 6.9.9…

    Ladislav Hagara | Komentářů: 0
    včera 03:33 | IT novinky

    Společnost Meta na dvoudenní konferenci Meta Connect 2026 představuje své novinky. Vypíchnout lze lehké brýle s funkci VR Meta VR Glasses. Do prodeje půjdou na jaře 2027 za cenu 1299,99 dolarů.

    Ladislav Hagara | Komentářů: 0
    23.9. 14:44 | Nová verze

    Google Chrome 154 byl prohlášen za stabilní. Nejnovější stabilní verze 154.0.8037.57 přináší řadu novinek. Podrobný přehled v poznámkách k vydání. Opraveno bylo 108 bezpečnostních chyb. Vylepšeny byly také nástroje pro vývojáře.

    Ladislav Hagara | Komentářů: 6
    23.9. 14:33 | IT novinky

    Vláda sníží v příštím roce výdaje na IT služby státu o 1,4 miliardy korun. Úspory má umožnit lepší koordinace nákupu služeb napříč resorty prostřednictvím nového zmocněnce. Celkové roční výdaje státu na informační technologie a digitalizaci se podle údajů ministerstva průmyslu a obchodu pohybují okolo 20 až 25 miliard korun ročně, pro letošek bylo na 320 projektů vyčleněno 21 miliard.

    Ladislav Hagara | Komentářů: 4
    23.9. 14:22 | IT novinky

    Irská komise pro ochranu dat (DPC) uložila americké technologické společnosti Google ze skupiny Alphabet pokutu 403 milionů eur (9,8 miliardy Kč) za neoprávněné nakládání s údaji o poloze uživatelů. Firma podle komise porušila evropské nařízení o ochraně osobních údajů (GDPR). DPC uvedla, že při šetření zjistila, že si lidé nemuseli být vědomi skutečnosti, že jejich poloha byla využívána například k ovlivňování prostřednictvím reklam nebo k odvozování jejich zájmů, a mohli tak ztratit kontrolu nad svými osobními údaji.

    Ladislav Hagara | Komentářů: 2
    23.9. 02:11 | IT novinky

    Byla oznámena beta verze nového video kodeku Pyrowave pro streamování her v Steam Remote Play. S vysokou propustností a nízkou latencí. S podporou HDR a YUV 4:4:4.

    Ladislav Hagara | Komentářů: 0
    23.9. 01:11 | Nová verze

    Byl vydán Sublime Text 4 Build 4213. Sublime Text (Wikipedie) je proprietární multiplatformní editor textových souborů a zdrojových kódů. Ke stažení a k vyzkoušení je zdarma. Pro další používání je nutná licence v ceně 99 dolarů. Spolu se Sublime Merge je cena 168 dolarů.

    Ladislav Hagara | Komentářů: 0
    Které desktopové prostředí na Linuxu používáte?
     (9%)
     (7%)
     (4%)
     (21%)
     (29%)
     (8%)
     (5%)
     (2%)
     (14%)
     (21%)
    Celkem 2726 hlasů
     Komentářů: 31, poslední 13.8. 00:27
    Rozcestník

    Dotaz: apache httpd.conf nastaveni pro localhost

    17.3.2007 15:09 Gioconda | skóre: 1
    apache httpd.conf nastaveni pro localhost
    Přečteno: 3233×
    Čau, apache2 si chci nastavit abych na nem mohl testovat doma skripty, ale porad mi to vypisuje tohle:
    prikaz apache2
    (98)Address already in use: make_sock: could not bind to address 127.0.0.1:80
    no listening sockets available, shutting down
    Unable to open logs
    
    a pri pripojeni z prohlizece na http://localhost/ mi to vypise stranku "Test Page for Apache Installation" tohle je z httpd.conf
    \< VirtualHost *>
     ServerName localhost
     ServerAdmin nekdo@torad.horke
     DocumentRoot /home/www/Deals
     ErrorLog /home/www/Deals/errorlog
     TransferLog /home/www/Deals/transferlog
    \< /VirtualHost>
    Listen 127.0.0.1:80

    Odpovědi

    17.3.2007 15:33 Platonix
    Rozbalit Rozbalit vše Re: apache httpd.conf nastaveni pro localhost
    Měl bych pro tebe 2 tipy.

    1. Apache zkus spouštět pomocí /etc/init.d/apache2 start. Ve tvém případě místo start spíše restart, protože Apache už běží. To, jak jsi psal by ti spustilo apache podruhé a to už nejde, protože ten první (první instance) už obsadil port 80.

    2. Nejsem si jist, ale ty obrácený lomítka v konfiguráku možná znamenají komentář a bylo by fajn je zkusit smazat. Jinak rozhodně jsem si jist, že apache je třeba restartovat po každé změně konfigurace, aby si ji načetl.
    17.3.2007 20:57 Gioconda | skóre: 1
    Rozbalit Rozbalit vše Re: apache httpd.conf nastaveni pro localhost
    1. diky, jenze po restartu pomoci "/etc/init.d/apache2 restart", nebo restartu pc a nasledne "/etc/init.d/apache2 start" dostanu
     * Starting apache2 ...                                                   [ !! ]
    
    a nemuzu se dopatrat jak zjistit co mi temi vykricniky chce rict protoze kdyz pak zadam do prohlizece http://localhost/ tak dostanu "Promblem loading page" se zpravou "Unable to connect"

    2. jo, ty obraceny lomitka jsem zkousel na abclinuxu protoze mi virtualhost s < a > bralo jako znacku a tak sem to chtel escapovat(nevsiml jsem si ze je tady moznost dat < rovnou zakodovane) a tak jsem dal jen mezeru mezi < virtualhost a zapomnel to odstranit
    Milan 17.3.2007 21:05 Milan "Nemo" Cingroš | skóre: 27 | blog: Nautilus | Plzeň
    Rozbalit Rozbalit vše Re: apache httpd.conf nastaveni pro localhost
    Podívej se do logu (/var/log/apache2/error_log), vykřičníky znamenají, že se spuštění nepovedlo. Ale podle toho co píšeš, tak proces asi obsadí port 80 a stále běží.
    Soutěžte na české LinuxWiki a vyhrajte plyšového Tuxe.
    17.3.2007 21:05 Pavel1 | skóre: 33
    Rozbalit Rozbalit vše Re: apache httpd.conf nastaveni pro localhost
     * Starting apache2 ...                                                   [ !! ]
    
    To znamená, že spuštění nedopadlo úspěšně. Ale proč, toť otázka, možností je víc. Mrkni třeba do logů, tam by mohl být napsán důvod (třeba chyba v konfiguráku, ...)
    17.3.2007 21:28 Gioconda | skóre: 1
    Rozbalit Rozbalit vše Re: apache httpd.conf nastaveni pro localhost
    dekuji vsem, tak uz mi to funguje.v logu jsem zjistil ze jsem pro errorlog zadal jen adresar ale ne primo soubor takze mi to cele blokovalo, stacilo to dopsat /www/errorlog/errorlog a /etc/init.d/apache2 restart a vse jede :-)

    Založit nové vlákno • Nahoru

    Tiskni Sdílej: Linkuj Jaggni to Vybrali.sme.sk Google Del.icio.us Facebook

    ISSN 1214-1267   www.czech-server.cz
    © 1999-2015 Nitemedia s. r. o. Všechna práva vyhrazena.