abclinuxu.cz AbcLinuxu.cz itbiz.cz ITBiz.cz HDmag.cz HDmag.cz abcprace.cz AbcPráce.cz
Inzerujte na AbcPráce.cz od 950 Kč
Rozšířené hledání
×
    dnes 02:00 | Nová verze

    PCSX2 (Wikipedie), tj. emulátor herní konzole Sony PlayStation 2, byl vydán v nové major verzi 2.0 (𝕏, Mastodon). Přehled novinek i s náhledy v příspěvku na blogu.

    Ladislav Hagara | Komentářů: 0
    včera 04:55 | Nová verze

    Byla vydána verze 30.2 svobodného softwaru OBS Studio (Open Broadcaster Software, Wikipedie) určeného pro streamování a nahrávání obrazovky počítače. Přehled novinek na GitHubu. Instalovat lze také z Flathubu.

    Ladislav Hagara | Komentářů: 0
    12.7. 17:11 | Nová verze

    Byl vydán Thunderbird 128 “Nebula”, tj. nová major verze poštovního klienta Thunderbird. Podrobnosti v poznámkách k vydání.

    Ladislav Hagara | Komentářů: 0
    11.7. 20:55 | IT novinky

    Aktivistický technologický kolektiv NoLog.cz spustil 7 nových služeb: anon.nolog.cz - NoLog identita, talk.nolog.cz - videokonferenční systém OpenTalk, vault.nolog.cz - bezpečný správce hesel pro jednotlivce a skupiny, search.nolog.cz - anonymní vyhledávač, kdy.nolog.cz - snadné domlouvání společných termínů, md.nolog.cz - editor pro společnou práci na textech ve formátu Markdown a nolog.chat - šifrovaný chat pro jednotlivce a skupiny.

    Ladislav Hagara | Komentářů: 1
    11.7. 02:33 | Nová verze

    V lednu byl otevřen editor kódů Zed od autorů editoru Atom a Tree-sitter. Tenkrát běžel pouze na macOS. V květnu byly oznámeny pokroky při portaci na Linux. Dnes byly oznámeny oficiální linuxové buildy.

    Ladislav Hagara | Komentářů: 68
    11.7. 00:22 | Zajímavý článek

    Behdad Esfahbod pro článek Stav vykreslování textu v roce 2024 sesbíral, jaký software se používá pro vykreslování textu na open-source desktopu. Volně navazuje na přehled z let 2009 až 2012. Autor je hlavní vývojář knihovny HarfBuzz.

    Fluttershy, yay! | Komentářů: 5
    10.7. 18:55 | IT novinky

    Po 17 letech ukončila svou činnost (𝕏, Facebook) mezinárodní nezisková organizace Girls in Tech (Wikipedie) usnadňující ženám vstup do světa technologií. Došly finance. V dubnu ze stejného důvodu skončila organizace Women Who Code.

    Ladislav Hagara | Komentářů: 94
    10.7. 15:55 | Nová verze

    Byla vydána (𝕏) nová verze 9.6 z Debianu vycházející linuxové distribuce DietPi pro (nejenom) jednodeskové počítače. Přehled novinek v poznámkách k vydání.

    Ladislav Hagara | Komentářů: 0
    10.7. 15:22 | IT novinky

    Společnosti O2 Czech Republic a Nordic Telecom Holding podepsaly 24. 6. 2024 smlouvu o prodeji stoprocentního podílu v Nordic Telecom Regional. Transakce podléhá schválení příslušnými úřady.

    Ladislav Hagara | Komentářů: 19
    10.7. 13:33 | Bezpečnostní upozornění

    Blast-RADIUS, zranitelnost v AAA protokolu RADIUS související s použitím hašovací funkce MD5. S vlastní doménou a logem.

    Ladislav Hagara | Komentářů: 2
    Rozcestník

    Dotaz: kdelibs

    10.4.2009 16:16 Radicz
    kdelibs
    Přečteno: 151×

    Dobrý den, v oblasti linuxu jsem nový, teprve se kamarádíme. Mam menší problém s jednou chybou, jestli to tu už někde je tak se omlouvám, zkoušel jsem hledat, ale ani nevim pod čim hledat. Chyba mi vyskočí vždy po zadáni příkazu emerge --deep --update --newuse world.

    !!! Multiple package instances within a single package slot have been pulled
    !!! into the dependency graph, resulting in a slot conflict:

    kde-base/kdelibs:3.5

      ('ebuild', '/', 'kde-base/kdelibs-3.5.9-r4', 'merge') pulled in by
        ~kde-base/kdelibs-3.5.9 required by ('ebuild', '/', 'kde-base/klaptopdaemon-3.5.9', 'merge')
        ~kde-base/kdelibs-3.5.9 required by ('installed', '/', 'kde-base/superkaramba-3.5.9', 'nomerge')
        (and 3 more)

      ('ebuild', '/', 'kde-base/kdelibs-3.5.10-r2', 'merge') pulled in by
        ~kde-base/kdelibs-3.5.10 required by ('installed', '/', 'kde-base/kate-3.5.10', 'nomerge')
        ~kde-base/kdelibs-3.5.10 required by ('installed', '/', 'kde-base/kdebase-kioslaves-3.5.10-r1', 'nomerge')
        ~kde-base/kdelibs-3.5.10 required by ('installed', '/', 'kde-base/kxkb-3.5.10', 'nomerge')
        (and 43 more)

    opravdu nevim co po mě chce a nevim jak to spravit. Myslel jsem si že stačí když schodim dolu kdelibs tak jsem zamaskoval kdelibs 3.5.10 a dal jsem tam z5 3.5.9 ktery jsou podle internetu gut. Děkuji za případné odpovědi.

     

    Odpovědi

    vencour avatar 10.4.2009 16:24 vencour | skóre: 56 | blog: Tady je Vencourovo | Praha+západní Čechy
    Rozbalit Rozbalit vše Re: kdelibs

    Pokud se nepletu, tak emerge vidí jeden balíček ve více verzích? Co udělá samotný emerge kdelibs -pv?

    Ty nejhlubší objevy nečekají nutně za příští hvězdou. Jsou uvnitř nás utkány do vláken, která nás spojují, nás všechny.
    10.4.2009 16:37 Radicz
    Rozbalit Rozbalit vše Re: kdelibs

    udela

    Calculating dependencies... done!
    [ebuild     U ] kde-base/kdelibs-3.5.10-r2 [3.5.9] USE="acl alsa cups jpeg2k kdehiddenvisibility tiff -arts -avahi -bindist -branding -debug -doc -fam -kerberos -legacyssl -lua -openexr -spell -utempter (-kdeenablefinal%*) (-xinerama%*)" 0 kB

     

    vencour avatar 10.4.2009 16:42 vencour | skóre: 56 | blog: Tady je Vencourovo | Praha+západní Čechy
    Rozbalit Rozbalit vše Re: kdelibs

    Ty jedeš na x86 i na ~x86? Tedy stable i unstable? Co máš v /etc/make.conf u ACCEPT_KEYWORDS?

    Ty nejhlubší objevy nečekají nutně za příští hvězdou. Jsou uvnitř nás utkány do vláken, která nás spojují, nás všechny.
    10.4.2009 16:50 Radicz
    Rozbalit Rozbalit vše Re: kdelibs

    mam tam ~amd64 ale je predtim # tak ze je to asi zakomentovany

    vencour avatar 10.4.2009 16:55 vencour | skóre: 56 | blog: Tady je Vencourovo | Praha+západní Čechy
    Rozbalit Rozbalit vše Re: kdelibs

    Já mam poslední stable verzi 3.5.9-r4 ... takže buď je něco špatně u Tebe nebo u mne? Že Ti to nabízí i unstable kde.

    Ty nejhlubší objevy nečekají nutně za příští hvězdou. Jsou uvnitř nás utkány do vláken, která nás spojují, nás všechny.
    David Watzke avatar 10.4.2009 17:00 David Watzke | skóre: 74 | blog: Blog... | Praha
    Rozbalit Rozbalit vše Re: kdelibs
    V původním příspěvku tvrdíš, že máš 3.5.10 zamaskovaný, ale podle tohoto výpisu to zamaskovaný evidentně není. Tak jak to teda je?
    “Being honest may not get you a lot of friends but it’ll always get you the right ones” ―John Lennon
    10.4.2009 17:13 Radicz
    Rozbalit Rozbalit vše Re: kdelibs

    Myslel jsem si ze jsem to zamaskoval ale asi jsem udelal nekde nejakou botu

    David Watzke avatar 10.4.2009 17:18 David Watzke | skóre: 74 | blog: Blog... | Praha
    Rozbalit Rozbalit vše Re: kdelibs
    No jak už jsem řekl, problém je v tom, že ty bys tohle neměl mít potřebu maskovat, jelikož je to pod ~keywordem. Podívej se do /etc/portage/package.keywords, jestli tam kdelibs není náhodou odmaskovaný.
    “Being honest may not get you a lot of friends but it’ll always get you the right ones” ―John Lennon
    David Watzke avatar 10.4.2009 16:25 David Watzke | skóre: 74 | blog: Blog... | Praha
    Rozbalit Rozbalit vše Re: kdelibs
    1) proč nechceš kdelibs 3.5.10?

    2) problém je v tom, že když chceš zamaskovat kdelibs 3.5.10, musíš zamaskovat i zbytek KDE 3.5.10, jinak ti to bude přesně takhle řvát, protože ostatní balíčky z KDE 3.5.10 chtěj ty nový kdelibs...
    “Being honest may not get you a lot of friends but it’ll always get you the right ones” ―John Lennon
    10.4.2009 16:35 Radicz
    Rozbalit Rozbalit vše Re: kdelibs

    sem myslel ze to preve ony delaj tu chybu mam teda nainstalovat kdelibs 3.5.10 ? Kdyz sem je tam mel tak tam ta chyba stejna ale byla

    David Watzke avatar 10.4.2009 17:01 David Watzke | skóre: 74 | blog: Blog... | Praha
    Rozbalit Rozbalit vše Re: kdelibs
    Když jsi nahodil kdelibs 3.5.10, tak pro změnu řvaly 3.5.9 balíčky, že chtěj starší kdelibs :-) Prostě si nainstaluj jednu verzi KDE (všech balíčků), je jedno jakou, jestli používáš stable, tak asi 3.5.9. Vůbec by ti to nemělo nabízet 3.5.10, pokud jsi se do ničeho nehrabal a sám to neodmaskovával.
    “Being honest may not get you a lot of friends but it’ll always get you the right ones” ―John Lennon
    10.4.2009 17:17 Radicz
    Rozbalit Rozbalit vše Re: kdelibs

    Určitě jsem jsemto sám odmaskoval, odmaskoval jsem i kdelibs 4 nco neco a to se pak zacli dit veci. Mam teda zkompilovat z5 ty kdelibs 3.5.10 ? nebo mam radsi nechat ty stary ? co dporučujete ?

    David Watzke avatar 10.4.2009 17:23 David Watzke | skóre: 74 | blog: Blog... | Praha
    Rozbalit Rozbalit vše Re: kdelibs
    No, pokud necháš kdelibs 3.5.10, musíš odmaskovat a nahodit i zbytek KDE 3.5.10. Jinak naopak musí bejt vše 3.5.9. Co doporučuju? Z těch dvou spíš 3.5.10, protože je to asi poslední vydání z řady 3.5 a opravuje pár bot. Obecně doporučuju přejít na KDE 4. Sám používám SVN trunk, kterej bych začátečníkovi nedoporučil, ač je to v tuhle chvíli asi nejlepší možnost, protože KDE 4.2 mělo ještě dost much, i když 4.2.2 už by mělo bejt celkem v pohodě. Takže jedna možnost je počkat chvíli až se dostane KDE 4.2.2 do stromu a pak ho odmaskovat (nebo nahodit kde-testing overlay, ale to opět není nic moc pro začátečníka).
    “Being honest may not get you a lot of friends but it’ll always get you the right ones” ―John Lennon

    Založit nové vláknoNahoru

    Tiskni Sdílej: Linkuj Jaggni to Vybrali.sme.sk Google Del.icio.us Facebook

    ISSN 1214-1267   www.czech-server.cz
    © 1999-2015 Nitemedia s. r. o. Všechna práva vyhrazena.