abclinuxu.cz AbcLinuxu.cz itbiz.cz ITBiz.cz HDmag.cz HDmag.cz abcprace.cz AbcPráce.cz
AbcLinuxu hledá autory!
Inzerujte na AbcPráce.cz od 950 Kč
Rozšířené hledání
×
    dnes 03:33 | IT novinky

    Společnost Meta na dvoudenní konferenci Meta Connect 2026 představuje své novinky. Vypíchnout lze lehké brýle s funkci VR Meta VR Glasses. Do prodeje půjdou na jaře 2027 za cenu 1299,99 dolarů.

    Ladislav Hagara | Komentářů: 0
    včera 14:44 | Nová verze

    Google Chrome 154 byl prohlášen za stabilní. Nejnovější stabilní verze 154.0.8037.57 přináší řadu novinek. Podrobný přehled v poznámkách k vydání. Opraveno bylo 108 bezpečnostních chyb. Vylepšeny byly také nástroje pro vývojáře.

    Ladislav Hagara | Komentářů: 3
    včera 14:33 | IT novinky

    Vláda sníží v příštím roce výdaje na IT služby státu o 1,4 miliardy korun. Úspory má umožnit lepší koordinace nákupu služeb napříč resorty prostřednictvím nového zmocněnce. Celkové roční výdaje státu na informační technologie a digitalizaci se podle údajů ministerstva průmyslu a obchodu pohybují okolo 20 až 25 miliard korun ročně, pro letošek bylo na 320 projektů vyčleněno 21 miliard.

    Ladislav Hagara | Komentářů: 1
    včera 14:22 | IT novinky

    Irská komise pro ochranu dat (DPC) uložila americké technologické společnosti Google ze skupiny Alphabet pokutu 403 milionů eur (9,8 miliardy Kč) za neoprávněné nakládání s údaji o poloze uživatelů. Firma podle komise porušila evropské nařízení o ochraně osobních údajů (GDPR). DPC uvedla, že při šetření zjistila, že si lidé nemuseli být vědomi skutečnosti, že jejich poloha byla využívána například k ovlivňování prostřednictvím reklam nebo k odvozování jejich zájmů, a mohli tak ztratit kontrolu nad svými osobními údaji.

    Ladislav Hagara | Komentářů: 2
    včera 02:11 | IT novinky

    Byla oznámena beta verze nového video kodeku Pyrowave pro streamování her v Steam Remote Play. S vysokou propustností a nízkou latencí. S podporou HDR a YUV 4:4:4.

    Ladislav Hagara | Komentářů: 0
    včera 01:11 | Nová verze

    Byl vydán Sublime Text 4 Build 4213. Sublime Text (Wikipedie) je proprietární multiplatformní editor textových souborů a zdrojových kódů. Ke stažení a k vyzkoušení je zdarma. Pro další používání je nutná licence v ceně 99 dolarů. Spolu se Sublime Merge je cena 168 dolarů.

    Ladislav Hagara | Komentářů: 0
    22.9. 21:55 | Zajímavý článek

    Firma Anthropic, tvůrce AI modelu Claude, začala v oblasti Sanfranciského zálivu v tichosti provozovat vlastní biotechnologickou laboratoř. Anthropic prý chce pomocí AI urychlit hledání léků na nemoci, jimž farmaceutický průmysl dle názoru firmy věnuje příliš málo pozornosti. Firma tvrdí, že laboratoř se zatím soustředí především na základní biologii, nikoli přímo na vývoj léčiv. Farmaceutický výzkum je pro generálního ředitele Daria Amodeie velice osobní téma, jeho otec zemřel na hepatitidu C několik málo let před objevením účinné léčby.

    AfD 💙 | Komentářů: 4
    22.9. 21:44 | Humor

    Vědci z Googlu dokončili mapu všech neuronových spojení v mozku (tzv. konektom) samečka mušky octomilky obecné (drosophila melanogaster), hlavním cílem je komparativní analýza s již zmapovaným mozkem samičky. S tímto veřejně dostupným modelem, čítajícím přibližně 160 000 neuronů, se začali bavit nadšenci. Mozek mouchy pohání experimentálního kryptoburzovního bota Stonkfly, případně si zahrál počítačové hry Beat Saber, Mario64 a samozřejmě DOOM (gameplay videa). Ani mozek samičky nezůstal stranou, vyzkoušel si Minecraft.

    AfD 💙 | Komentářů: 6
    22.9. 16:22 | Nová verze

    Alibaba Cloud je dalším sponzorem nadace Omacom Foundation stojící za linuxovou distribucí Omarchy. Přislíbená částka je 3 miliony dolarů, tj. 1 milion dolarů ročně po dobu tří let. Stejná částka jako u DigitalOcean.

    Ladislav Hagara | Komentářů: 5
    22.9. 16:11 | Nová verze

    Byla vydána nová verze 262 správce systému a služeb systemd (Wikipedie, GitHub).

    Ladislav Hagara | Komentářů: 0
    Které desktopové prostředí na Linuxu používáte?
     (9%)
     (7%)
     (4%)
     (21%)
     (29%)
     (8%)
     (5%)
     (2%)
     (14%)
     (21%)
    Celkem 2721 hlasů
     Komentářů: 31, poslední 13.8. 00:27
    Rozcestník

    Dotaz: postfix relay access denied

    Mr.Yoda avatar 27.7.2009 23:27 Mr.Yoda | skóre: 17 | blog: jakub | Louny
    postfix relay access denied
    Přečteno: 7829×
    Příloha:

    Zdravim, přes webmail jdou mejly odesílat, ale jakmile na něj odpovim nebo napíšu novou zprávu, tak mi to okamžitě pošle mejl s následujícím..

     

    You message for <info@seedbox.cz> from 2009/07/27 could not be delivered.
    It's attached below.

    Důvod / Reason:
    ---------------

    554 smtp; 554 5.7.1 <info@seedbox.cz>: Relay access denied

    Chyba transakce.
    Transaction failed.

     

    V příloze je postconf.

    :-* Debian

    Odpovědi

    28.7.2009 07:41 Martin H.
    Rozbalit Rozbalit vše Re: postfix relay access denied

    mynetwork a mydestination je špatně. Máš nastavený relay pouze pro loopback, proto ti chodí webmail. Viz. vzorový main.conf

    Mr.Yoda avatar 28.7.2009 08:58 Mr.Yoda | skóre: 17 | blog: jakub | Louny
    Rozbalit Rozbalit vše Re: postfix relay access denied

    nasvatil jsem mydestination = $myhostname, $mydomain, mail.$mydomain, localhost

    do mynetworks jsem nastavil ip serveru a nic, pak jsem nastavil mynetworks = (nic) a zase relay access denied :)

    už jsem z toho zoufalej

    :-* Debian
    28.7.2009 09:35 linuxik | skóre: 32 | Milovice
    Rozbalit Rozbalit vše Re: postfix relay access denied

    Priklad nastaveni mynetworks

    mynetworks = 127.0.0.0/8 172.16.0.0/12 192.168.1.0/24
    

    proste adresy nebo cele site  pocitacu pro ktere chces aby mailserver posilal zptavy i na  jine domeny nez mas v mydestination.

    Petr Bravenec avatar 28.7.2009 09:37 Petr Bravenec | skóre: 43 | blog: Bravenec
    Rozbalit Rozbalit vše Re: postfix relay access denied
    Do mynetworks nepřijde "adresa serveru", ale seznam adres, ze kterých je relaying možný. Moje domácí síť má rozsah adres 10.10.1.0 až 10.10.1.255, do mynetworks jsem dal 10.10.1.0/24 (celý rozsah 256 adres) a můžu tak vyřizovat poštu pro kohokoliv ve své domácí síti.
    Petr Bravenec - Hobrasoft s.r.o.
    Mr.Yoda avatar 28.7.2009 11:12 Mr.Yoda | skóre: 17 | blog: jakub | Louny
    Rozbalit Rozbalit vše Re: postfix relay access denied

    Ok, ale to neni domácí server, je na tom pár domén, který bere z mysql.

    :-* Debian
    Petr Bravenec avatar 28.7.2009 08:00 Petr Bravenec | skóre: 43 | blog: Bravenec
    Rozbalit Rozbalit vše Re: postfix relay access denied
    myhostname              = pocitac.domena.cz
    mydomain                = domena.cz
    myorigin                = $mydomain
    mydestination           = localhost
    inet_interfaces         = all
    mynetworks              = 127.0.0.0/8
    relay_domains           = $mynetworks
    alias_database          = hash:/etc/postfix/aliases
    local_transport         = error:local delivery is disabled
    
    Podobný konfigurační soubor main.cf mívám na všech počítačích, které se primárně nezabývají poštou. Potřebujete nejspíš doplnit další IP/sítě (čárkou oddělené), ze kterých se má pošta odesílat (v textu zvýrazněno).
    Petr Bravenec - Hobrasoft s.r.o.
    Mr.Yoda avatar 30.7.2009 13:41 Mr.Yoda | skóre: 17 | blog: jakub | Louny
    Rozbalit Rozbalit vše Re: postfix relay access denied

    To bych z toho ale přece musel udělat open relay nebo ne? Nepotřebuju ze kterých, ale jenom na ten počítač přece ne?

    :-* Debian
    30.7.2009 21:40 Martin H. | skóre: 27 | blog: linservis | Brno
    Rozbalit Rozbalit vše Re: postfix relay access denied
    OpenRelay by byl, pokud by byl mynetwork = 0/0 - tedy všechny počítače a všechny sítě.

    Pokud máš JEN veřejnou IP adresu, pak musíš použít nějakou SASL autorizaci pro SMTP (já využívám Dovecot), pokud máš dvě sítě, tedy veřejnou IP a vnitřní síť s NATem, pak do mynetworks přidej celou vnitřní síť (třeba 192.168.1.0/24 - tedy celou podsíť 192.168.0.x).

    S IP 127.0.0.1 ti bude chodit SMTP jen přes např. Webmail, který je na stejném stroji, jako mailserver!
    --- Kapitalismus je lepší, než socialismus ... ale horší, než jsem čekal. (Jiří Suchý) ---
    2.8.2009 10:35 Filip Jirsák | skóre: 67 | blog: Fa & Bi
    Rozbalit Rozbalit vše Re: postfix relay access denied
    pokud máš dvě sítě, tedy veřejnou IP a vnitřní síť s NATem
    Důležitý je hlavně firewall, ne NAT. Pokud se dá z internetu do vnitřní sítě dostat přes NAT, je to úplně stejný open-relay, jako kdyby to bylo rovnou na veřejné IP adrese.
    Mr.Yoda avatar 31.7.2009 09:18 Mr.Yoda | skóre: 17 | blog: jakub | Louny
    Rozbalit Rozbalit vše Re: postfix relay access denied

    Já jsem to vyřešil tak, že jsem se na celý tohle vykašlal a udělal si to znova na jinym stroji ( to jsem od začátku chtěl, abych měl oddělenej mailserver od webserveru ), protože tohle je nějaká splácanina s VHCS2 (postfix + courier)

    :-* Debian
    1.8.2009 00:10 Martin H. | skóre: 27 | blog: linservis | Brno
    Rozbalit Rozbalit vše Re: postfix relay access denied
    Taky řešení :-(

    Jen jsi se ochudil o tu neskutečnou radost, když se to konečně podaří :-)

    Myslím, že rady byly přesné, škoda, že jsi je nevyzkoušel ...
    --- Kapitalismus je lepší, než socialismus ... ale horší, než jsem čekal. (Jiří Suchý) ---
    Mr.Yoda avatar 1.8.2009 10:44 Mr.Yoda | skóre: 17 | blog: jakub | Louny
    Rozbalit Rozbalit vše Re: postfix relay access denied

    Já jsem zkoušel podle toho, co jste tady psali a nic, každopádně je to ve fázi, kdy to pořád nejde a můžu to zkoušet, maily jsem vyřešil někde jinde. A někde jsem se dočetl, nestli tomu nevadí reverzní záznam?

    :-* Debian
    2.8.2009 12:16 Martin H. | skóre: 27 | blog: linservis | Brno
    Rozbalit Rozbalit vše Re: postfix relay access denied
    Už jsme ti to tady psali: chyba je zde:
    mydestination = $myhostname, $mydomain, mail.$mydomain, localhost
    mynetworks = 127.0.0.0/8 192.168.1.0/24 (tohle oprav podle vlastní sítě, tohle je příklad!)
    
    Více vysvětleno v příspěvku níže ...

    Reverzní záznamy mají vliv na komunikaci mezi SMTP servery, správně byjsi ho měl ít nastavený, něteré servery (třeba i můj) odmítají maily od serverů bez FDQN - většinou se totiž jedná o SPAMy a admin by si to měl u skutečného serveru nastavit (u správce IP rozsahu, ne u sebe).

    Relay access denied je skutečně chyba, kdy SMTP server nedůvěřuje klientovi, protože ... např. není v seznamu důvěryhodných sítí, tedy tvé vlastní (jiné než localhost). Tohle oprav ... a nezapomeň na reload postfixu!!!
    --- Kapitalismus je lepší, než socialismus ... ale horší, než jsem čekal. (Jiří Suchý) ---
    2.8.2009 10:40 Filip Jirsák | skóre: 67 | blog: Fa & Bi
    Rozbalit Rozbalit vše Re: postfix relay access denied
    Postfix funguje zároveň jako server přijímající poštu, a zároveň jako smart-relay pro „hloupé klienty“, pro které poštu rozesílá. V prvním případě rozlišuje podle domény příjemce e-mailu, zda e-mail patří do jím obhospodařovaných domén – to jsou ty uvedené u mydestination, virtual_alias_domains a virtual_mailbox_domains. Pokud vám nefunguje přijímání pošty, máte špatně nastavené tohle. Smart-relay se pak konfiguruje pomocí mynetworks – v tomto případě se bude Postfix zabývat e-mailem na jakoukoli doménu, ale zase musí odesílající počítač (resp. ten, který předává e-mail Postfixu) patřit do sítě vyjmenované v mynetworks.

    Založit nové vláknoNahoru

    Tiskni Sdílej: Linkuj Jaggni to Vybrali.sme.sk Google Del.icio.us Facebook

    ISSN 1214-1267   www.czech-server.cz
    © 1999-2015 Nitemedia s. r. o. Všechna práva vyhrazena.