Proběhl Snapdragon Summit 2026. Společnost Qualcomm se mimo jiné pochlubila během Linuxu na čipech Snapdragon X2. Zatím pouze v ranní verzi vhodné pro vývojáře linuxových distribucí a přispěvatele do jádra Linux.
Byla vydána nová verze 2.0 klienta F-Droid určeného pro instalaci bezplatných a otevřených mobilních aplikací do Androidu ze softwarového repozitáře F-Droid (Wikipedie). Jedná se o alternativu k Google Play.
Debian Inference Portal nabízí vývojářům Debianu bezplatný přístup ke službám AI/LLM. Sponzorem je společnost Scaleway.
Robert Ressl nalezl ve WordPressu kritickou zranitelnost CVE-2026-87902 s CVSS 9.2. Útočníkům umožňuje neoprávněný přístup k souborům a vzdálené spuštění kódu (RCE). Opravena je ve verzích 7.1.2, 7.0.6, 6.9.9…
Společnost Meta na dvoudenní konferenci Meta Connect 2026 představuje své novinky. Vypíchnout lze lehké brýle s funkci VR Meta VR Glasses. Do prodeje půjdou na jaře 2027 za cenu 1299,99 dolarů.
Google Chrome 154 byl prohlášen za stabilní. Nejnovější stabilní verze 154.0.8037.57 přináší řadu novinek. Podrobný přehled v poznámkách k vydání. Opraveno bylo 108 bezpečnostních chyb. Vylepšeny byly také nástroje pro vývojáře.
Vláda sníží v příštím roce výdaje na IT služby státu o 1,4 miliardy korun. Úspory má umožnit lepší koordinace nákupu služeb napříč resorty prostřednictvím nového zmocněnce. Celkové roční výdaje státu na informační technologie a digitalizaci se podle údajů ministerstva průmyslu a obchodu pohybují okolo 20 až 25 miliard korun ročně, pro letošek bylo na 320 projektů vyčleněno 21 miliard.
Irská komise pro ochranu dat (DPC) uložila americké technologické společnosti Google ze skupiny Alphabet pokutu 403 milionů eur (9,8 miliardy Kč) za neoprávněné nakládání s údaji o poloze uživatelů. Firma podle komise porušila evropské nařízení o ochraně osobních údajů (GDPR). DPC uvedla, že při šetření zjistila, že si lidé nemuseli být vědomi skutečnosti, že jejich poloha byla využívána například k ovlivňování prostřednictvím reklam nebo k odvozování jejich zájmů, a mohli tak ztratit kontrolu nad svými osobními údaji.
Byla oznámena beta verze nového video kodeku Pyrowave pro streamování her v Steam Remote Play. S vysokou propustností a nízkou latencí. S podporou HDR a YUV 4:4:4.
Byl vydán Sublime Text 4 Build 4213. Sublime Text (Wikipedie) je proprietární multiplatformní editor textových souborů a zdrojových kódů. Ke stažení a k vyzkoušení je zdarma. Pro další používání je nutná licence v ceně 99 dolarů. Spolu se Sublime Merge je cena 168 dolarů.
mysql -u root -p tak to napíše ERROR 2002 (HY000): Can't connect to local MySQL server through socket '/var/run/mysqld/mysqld.sock' (2). Hledal jsem řešení na internetu i tady na diskucíh ale nic mi nepomohlo. Přeinstalovával jsem mysql ale taky nepomohlo. Když zadám /usr/sbin/mysqld tak mi to vypíše
091112 22:10:12 InnoDB: Started; log sequence number 0 43655
091112 22:10:12 [ERROR] Can't start server: Bind on TCP/IP port: Cannot assign requested address
091112 22:10:12 [ERROR] Do you already have another mysqld server running on port: 3306 ?
091112 22:10:12 [ERROR] Aborting
091112 22:10:12 InnoDB: Starting shutdown...
091112 22:10:15 InnoDB: Shutdown completed; log sequence number 0 43655
091112 22:10:15 [Note] /usr/sbin/mysqld: Shutdown complete
Nevíte co by s tím mohlo být? Podle tohohle výpisu se zdá, že bych tam měl mít dva mysqld ale nejsem si vědom, že bych jich instaloval víc. Děkuji za odpověď.
A na portu 3306 fakt nic nežije? "netstat -apn | grep 3306" něco najde?
Fajn a nemáte ještě puštěný firewall, tedy onen port 3306 blokovaný?
a pak FAILED. A ještě jedna informace používám Debian.
Verbose jste zkoušel? Podle manu bych zkusil u spouštění následující parametry ...
-v, --verbose Write more. (-v -v -v gives the table output format). --show-warnings Show warnings after every statement.
Tipuju "mysql -u root --show-warnings -v -p"?
server1:~# mysql -u root --show-warnings -v -p
Enter password:
ERROR 2002 (HY000): Can't connect to local MySQL server through socket '/var/run/mysqld/mysqld.sock' (2)
Nebo se to někam zapisuje a mám někde hledat? Děkuji za pomoc
Mam gentoo, tam je v /etc/mysql/my.cnf nastavení cest, pokud tam máte něco podobného, pátral bych v tom směru ... (nebo jinak verzi mysql, error a google)
cat my.cnf ... [mysqld] character-set-server = utf8 default-character-set = utf8 user = mysql port = 3306 socket = /var/run/mysqld/mysqld.sock pid-file = /var/run/mysqld/mysqld.pid log-error = /var/log/mysql/mysqld.err basedir = /usr datadir = /var/lib/mysql
Mám to mám v /etc/mysql/my.cnf
A v těch logách nic nevidíte? Aneb "/var/log/mysql/*" ... ?
Jestli by tohle nemoh dělat selinux/apparmor apod.? Nedostupnost portu?
Podle ktereho navodu jsi postupoval? Dle logu to vypada, ze port 3306 je necim obsazeny. Zkus netstat -ntlp | grep 3306 , treba zjistis, ze tam uz neco posloucha.
Pripadne muzes zkusit v konfiguraku nastavit jinej port, nebo pripsanim skip-networking do /etc/mysql/my.cnf donutit mysql nepouzivat port (pro zacatek) - pak nebude pouzivat sit a db bude dostupna pouze z localhostu pres unix socket (ani jedno nepovazuji za reseni, ale muze nam to poskytnout nejake dalsi info).
server1:~# /etc/init.d/mysql restart
Stopping MySQL database server: mysqld.
Starting MySQL database server: mysqld.
Checking for corrupt, not cleanly closed and upgrade needing tables..
Myslel jsem si tedy, že to nebude fungovat. Ale opak je pravdou. Bez problému se přihlásím jak přes puttynu tak přes vnitřní síť pomocí phpmyadmin. Co tedy teď dál? Předpokládám, že zvenku se do toho asi nepřipojím co? Děkuji.
Z venci to ted je opravdu nedostupne, protoze mysql nepouziva diky skip-networking sit. Ale diky tomu vime, ze problem je v sitovy casti a ne nekde jinde...
Ted bych zkusil jestli se muze uzivatel mysql (nebo jiny, pod jehoz pravy mysql bezi) nabindovat na ten port. Pomoci ps axu | grep mysql si over, pod jakym uzivatelem mysql bezi (je to prvni sloupec) a udelej: su ten_uzivatel a pak nc -vv -l -p 3306 . Projde to? Melo by to vypsat listening on [any] 3306 ... . Pokud nemas program nc nainstalovany, najdes ho v baliku netcat.
server1:~# ps axu | grep mysql
root 4384 0.0 0.2 3088 1276 pts/0 S 11:42 0:00 /bin/sh /usr/bin/mysqld_safe
mysql 4424 0.1 3.3 127508 17144 pts/0 Sl 11:42 0:17 /usr/sbin/mysqld --basedir=/usr --datadir=/var/lib/mysql --user=mysql --pid-file=/var/run/mysqld/mysqld.pid --skip-external-locking --port=3306 --socket=/var/run/mysqld/mysqld.sock
root 4426 0.0 0.1 2212 608 pts/0 S 11:42 0:00 logger -p daemon.err -t mysqld_safe -i -t mysqld
root 17624 0.0 0.1 2352 772 pts/0 R+ 15:56 0:00 grep mysql
V gentoo mam netcat jako gnu-netcat, ještě tam je netcat a netcat6 ... něco v debianu mít budeš. V nouzi bych zkusil telnet na port 3306, něco by to mělo taky udělat ... "telnet localhost 3306".
tak by to možná opravdu bylo v pohodě. Ale tohle je děs.
nc -vv -l -p 3306 to napíše přesně to co bylo řečeno listening on [any] 3306 .... Nic víc nic míň. Co můžu udělat dál?
bind-adress na localhost. Tak jsem to udělal. Ale nepomohlo to. Už jsem to však neřešil a hledal pomoc tady. A teď jsem zase googlil a našel jsem stejný problém, který byl nakonec vyřešen tím, že tazatel přišel na to že my.cnf překopíroval odjinud a že tam měl špatný bind-adress. Tak jsem to přepsal na svoji IP vnitřní a chodí to
Jsem osel.
bind-adress nechám stále stejnou? Tedy tu co mám ve vnitřní síti?
Tiskni
Sdílej: