abclinuxu.cz AbcLinuxu.cz itbiz.cz ITBiz.cz HDmag.cz HDmag.cz abcprace.cz AbcPráce.cz
AbcLinuxu hledá autory!
Inzerujte na AbcPráce.cz od 950 Kč
Rozšířené hledání
×
    včera 22:44 | Nová verze

    Programovací jazyk Python byl vydán v nové major verzi 3.15.0. Podrobný přehled novinek v aktualizované dokumentaci.

    Ladislav Hagara | Komentářů: 0
    včera 22:33 | Zajímavý projekt

    BIGWORDS.PAGE je open-source webová aplikace, která po otevření odkazu v prohlížeči vykreslí přes celou obrazovku jednoduché informační sdělení. Zpráva i její nastavení jsou uložené v části URL za znakem #, například odkaz https://bigwords.page/#abclinuxu zobrazí jako velký bílý nápis 'abclinuxu' na černém pozadí. Obsah odkazu lze upravovat i vestavěným editorem, ten umožňuje nastavovat formátování a vizuální efekty textu, časovače, QR kódy a obrázky. Zdrojový kód je dostupný pod licencí MIT na GitHubu.

    ❗Červivý Hřib krade❗ | Komentářů: 5
    včera 11:55 | Upozornění

    V neděli 11. října proběhne rotace klíče kořenové zóny. Podruhé v historii. Ondřej Filip na blogu CZ.NIC: "Pokud je pro Vás DNS protokol spíše výzva, ale přesto spravujete nějakou síť či DNS resolver, zkuste si jednoduchý test, který připravila firma Cloudflare na této adrese. Obzvláště zbystřit byste měli, pokud uvidíte nějaká červená políčka."

    Ladislav Hagara | Komentářů: 7
    včera 09:55 | IT novinky

    Vláda Spojených států se rozhodla vyřadit americkou softwarovou společnost Microsoft a několik dalších velkých technologických podniků z programu, který umožňuje kvalifikovaným zahraničním pracovníkům získat povolení k trvalému pobytu. Oznámila to včera administrativa amerického prezidenta Donalda Trumpa. Opatření zdůvodnila rozsáhlým zneužíváním programu, který je dlouhodobě terčem kritiky ze strany Trumpových příznivců, neboť prý znevýhodňuje americké pracovníky.

    Ladislav Hagara | Komentářů: 11
    včera 09:44 | IT novinky

    Datové centrum největší ruské technologické společnosti Jandex v Rjazaňské oblasti se stalo cílem dronového útoku a zastavilo provoz. Jandexu se někdy přezdívá „ruský Google“. Provozuje nejoblíbenější internetový vyhledávač v Rusku nebo aplikace pro objednávky jídla a taxi. Využívají jej desítky milionů lidí v rusky mluvících zemích.

    Ladislav Hagara | Komentářů: 12
    včera 09:33 | Nová verze

    Francouzská společnost Mistral AI představila Mistral Large 4 (interně přezdívaný 'le Chonk', volně přeloženo 'pořádný macek'), 'open-weight multimodální hybridní instruct-and-reasoning model s architekturou granulárního MoE, nativně podporující více jak 160 jazyků'. Model má přes jeden bilión parametrů, z nichž při práci využívá 49 miliard, kontextové okno o délce milion tokenů a obrazový enkodér o 1,6 miliardách parametrů.

    … více »
    ❗Červivý Hřib krade❗ | Komentářů: 2
    včera 03:22 | Nová verze

    Svobodný multiplatformní herní engine Bevy napsaný v Rustu byl vydán ve verzi 0.20. Díky 227 přispěvatelům.

    Ladislav Hagara | Komentářů: 0
    včera 03:11 | Komunita

    Simon Long oznámil Raspberry Pi Desktop pro PC a Mac s Intelem postavený na aktualizovaném Debianu 13 Trixie. S klientem Raspberry Pi Connect pro vzdálenou správu. Ke stažení je vedle Raspberry Pi OS pro Raspberry Pi.

    Ladislav Hagara | Komentářů: 2
    8.10. 21:33 | Zajímavý projekt

    ESP32-C3 adblock přemění lacinou vývojovou desku ESP32‑C3 na samostatný DNS blokovač nejenom reklamních domén, minimalistickou alternativu k populárnímu Pi-hole. ESP32-C3 adblock místo objemných názvů domén ukládá jejich 40-bitové FNV-1a hashe do flash paměti, které pak binárně prohledává, kontrola jedné domény trvá přibližně 10 milisekund. Blocklist pojme až 537 tisíc domén a lze jej spravovat přes webové rozhraní. Projekt zatím

    … více »
    ❗Červivý Hřib krade❗ | Komentářů: 0
    8.10. 21:00 | Zajímavý software

    ArtCraft je sada open source aplikací pro práci s obrázky a videi "inspirovaných" aplikacemi od Adobe. Napsaných v Rustu. Pro MacOS, Windows i Linux. Běží také ve webovém prohlížeči. Aktuálně se jedná o 7 aplikací: PhotoCraft (Photoshop), VectorCraft (Illustrator), FilmCraft (Premiere Pro), LightCraft (Lightroom), PdfCraft (Acrobat), EffectCraft (After Effects) a DesignCraft (InDesign). Zdrojové kódy jsou k dispozici na GitHubu.

    Ladislav Hagara | Komentářů: 8
    Které desktopové prostředí na Linuxu používáte?
     (9%)
     (7%)
     (4%)
     (21%)
     (29%)
     (8%)
     (5%)
     (2%)
     (14%)
     (20%)
    Celkem 2820 hlasů
     Komentářů: 31, poslední 13.8. 00:27
    Rozcestník

    Dotaz: Jak přehrát image disku na serveru nejlépe přes internet

    2.6.2011 09:55 chinook | skóre: 28
    Jak přehrát image disku na serveru nejlépe přes internet
    Přečteno: 1073×
    Mám asi 100PC s UBUNTU 7.10. různě po republice. Chci tam dát UBUNTU 10.04. Každé PC má stejnou konfiguraci. Představa je taková, že si vytvořím IMAGE disku z UBUNTU 10.04 a nějak po internetu to přehraji na cílové stanice. Otázka zní jakým způsobem přepsat ty cílové disky. Restarty u PC nevadí, jen musí naběhnout. Je možnost rozeslat flashdisky na daná místa a nechat je připojit k PC. Je tam obsluha, ale asi jediné co zvládne, tak bude připojit ty flashdisky max. napsat jeden příkaz podle návodu. Víc asi nezvládne.

    Odpovědi

    masomlejn avatar 2.6.2011 10:20 masomlejn | skóre: 16
    Rozbalit Rozbalit vše Re: Jak přehrát image disku na serveru nejlépe přes internet
    dd if=/local_image.img | ssh user@host "dd of=/dev/sdx"
    
    masomlejn avatar 2.6.2011 10:24 masomlejn | skóre: 16
    Rozbalit Rozbalit vše Re: Jak přehrát image disku na serveru nejlépe přes internet
    No ale ted si uvedomuju, ze na tom cilovem PC by to samozrejme melo byt nabootovane treba z liveCD...takze sem ti asi moc nepomoh.
    2.6.2011 10:35 chinook | skóre: 28
    Rozbalit Rozbalit vše Re: Jak přehrát image disku na serveru nejlépe přes internet
    Napadla mě možnost vytvořit další oddíl, resp. nějaký zmenšit. Tam nahrat liveCD, přes grub spustit to liveCD a pak to přepsat. Napadne někoho něco jednoduššího?
    2.6.2011 10:57 NN
    Rozbalit Rozbalit vše Re: Jak přehrát image disku na serveru nejlépe přes internet
    A neda se to proste upgradovat pres balickovaci system ?

    NN
    2.6.2011 11:52 chinook | skóre: 28
    Rozbalit Rozbalit vše Re: Jak přehrát image disku na serveru nejlépe přes internet
    Musel bych projit upgrade pres 4 verze. Predtim nefunguje video a i tak mne to PC prijde pomalejsi, nez kdyz to nainstaluji rovnou.
    2.6.2011 10:57 Franta Hanzlík
    Rozbalit Rozbalit vše Re: Jak přehrát image disku na serveru nejlépe přes internet
    Jaké máte rozdělení disku(ů), a internetová připojení/objem nového OS? To může také rozhodovat. Je možné že skončíte u něčeho jako píše masomlejn, s minimem služeb, vypnutým logováním, RO mountnutým systémem by to teoreticky mohlo vyjít. Ale já bych si asi před akcí u kotníků podvázal podvlíkačky :)

    Když už se to nakouslo - celkem by mě zajímalo, jak podobný problém řeší jiní?
    Já jsem teď u toho, že mám 300 MB /boot, dvě systémové partišny podle konfigurace 10-40 GB, + nějaký zbytek (většinou partišny ala /home, na data, zálohování apod.), používám GPT. /boot je společný pro oba systémy, jeden je produkční a druhý na hraní a po čase na něj po internetu nahraji další konfiguraci. To že mi leží na disku pár giga ladem neřeším, a s trochou pozornosti se to nechá upgradovat i bez zásahu obsluhy na druhém konci (často tam ani není).

    2.6.2011 11:58 chinook | skóre: 28
    Rozbalit Rozbalit vše Re: Jak přehrát image disku na serveru nejlépe přes internet
    Ten IMG bude mít do 3.5GB.
    df -h
    Filesystem            Size  Used Avail Use% Mounted on
    /dev/sda3              19G  3,0G   15G  17% /
    varrun                237M   96K  237M   1% /var/run
    varlock               237M     0  237M   0% /var/lock
    udev                  237M   76K  237M   1% /dev
    devshm                237M     0  237M   0% /dev/shm
    lrm                   237M   38M  200M  16% /lib/modules/2.6.22-14-generic/volatile
    /dev/sda4              53G  220M   50G   1% /home
    
    

    Napadlo mě vytvořit image, uložit do home a rovnou z něho nabootavat. Pak odpadnou rizika s tím, že ty počítače shodím. Je to realné, dovede grub nabootovat rovnou s image?
    2.6.2011 13:51 Franta Hanzlík
    Rozbalit Rozbalit vše Re: Jak přehrát image disku na serveru nejlépe přes internet
    Podle mne to nemůže umět grub1 ani grub2, to je snad v rozporu s jejich funkcí - museli by na FS najít image (to umí), na něm najít jádro a initrd (to IMO neumí). A RC scripty by pak na spuštěném systému musely provést příslušné akce - to už by udělat zase šlo.
    Jendа avatar 3.6.2011 15:39 Jendа | skóre: 78 | blog: Jenda | JO70FB
    Rozbalit Rozbalit vše Re: Jak přehrát image disku na serveru nejlépe přes internet
    Nabootoval bych nějaký mini systém a pak tam normálně rsyncnul / bez /home. Mini systém může být buď live (které např. automaticky spustí SSH server, takže se tam budeš moct připojit a udělat to) nebo malý (třeba) Debian nainstalovaný na nějakou volnou partition (klidně do současného /home, pak to zase smažeš). GRUB má nějakou funkci, že když se nepodaří nabootovat nový systém, po restartu spustí ten původní.
    6.6.2011 16:37 chinook | skóre: 28
    Rozbalit Rozbalit vše Re: Jak přehrát image disku na serveru nejlépe přes internet
    Nepouzil jsem rsync, ale spustil UBUNTU z LIVECD. Nomountoval disk s cistou instalaci linuxu. zazalohoval linux a prenesl prikazem na jiny stroj
    
    
    tar cpf - /mnt/root | ssh ..... "cat > linux.tar" 
    
    
    tuto zalohu jsem pak rozbalil na tom samem stroji jen si tam dal disk kde je ubuntu 7.10 a na novou namountovanou partition rozbalil soubor vyse zase prikazem
    tar xpf linux.tar
    
    Do grub/menu.lst na ubuntu 7.10 jsem rucne dopsal odkud ma butovat a stroj resetl. Vse nabehlo, ale problem je, ze se stroj nechova uplne stejne jako kdyz jej pustim z disku na ktery byl puvodne nainstalovan. Napr nejde vypnout protoze nemuze zapisovat nekam do slozky /var/lib a chybi mu tam modul pulsaudio apod. Kde nastala chyba?
    8.6.2011 12:43 lertimir | skóre: 64 | blog: Par_slov
    Rozbalit Rozbalit vše Re: Jak přehrát image disku na serveru nejlépe přes internet
    Na klonování dísku je velmi dobrá clonezilla. Naklonuje MBR, partition table, partišny, jak lokálně, tak vzdáleně, přes SMB SFTP. Nikdy mne nezklamala. A vzhledem k tomu že v interaktivním režimu přímo avizuje jakými příkazy jednotlivé akce provádí, myslím že by šlo ji upravit tak, aby bootla a provedla restore disku ze zálohy dávkovým způsobem.
    10.6.2011 12:11 chinook | skóre: 28
    Rozbalit Rozbalit vše Re: Jak přehrát image disku na serveru nejlépe přes internet
    Pokud nahraju rsyncem soubory na uplne novej disk a uplne novou partition, bezi vse ok. Ale pokud to nahraji na disk kde je jiz ubuntu 7.10, tak to v logu pise chybu:
    Jun 10 11:52:57 pokladna-desktop pulseaudio[5337]: module-console-kit.c: GetSessionsForUnixUser() call failed: org.freedesktop.DBus.Error.Spawn.ExecFailed: Failed to execute program /lib/dbus-1.0/dbus-daemon-launch-helper: Success
    Jun 10 11:52:57 pokladna-desktop pulseaudio[5337]: module.c: Failed to load  module "module-console-kit" (argument: ""): initialization failed.
    Jun 10 11:52:57 pokladna-desktop pulseaudio[5337]: main.c: Module load failed.
    Jun 10 11:52:57 pokladna-desktop pulseaudio[5337]: main.c: Selhalo spuštění démona.
    Jun 10 11:52:57 pokladna-desktop pulseaudio[5334]: main.c: Spuštění démona selhalo.
    Jun 10 11:52:57 pokladna-desktop pulseaudio[5364]: module-console-kit.c: GetSessionsForUnixUser() call failed: org.freedesktop.DBus.Error.Spawn.ExecFailed: Failed to execute program /lib/dbus-1.0/dbus-daemon-launch-helper: Success
    Jun 10 11:52:57 pokladna-desktop pulseaudio[5364]: module.c: Failed to load  module "module-console-kit" (argument: ""): initialization failed.
    Jun 10 11:52:57 pokladna-desktop pulseaudio[5364]: main.c: Module load failed.
    Jun 10 11:52:57 pokladna-desktop pulseaudio[5364]: main.c: Selhalo spuštění démona.
    Jun 10 11:52:57 pokladna-desktop pulseaudio[5333]: main.c: Spuštění démona selhalo.
    
    
    a ani PC nejde vypnout, opet nejake chyby zapisu apod. Nenapada nekoho co to muze zpusobovat?
    10.6.2011 19:14 pavel
    Rozbalit Rozbalit vše Re: Jak přehrát image disku na serveru nejlépe přes internet
    rsync --delete
    13.6.2011 11:02 chinook | skóre: 28
    Rozbalit Rozbalit vše Re: Jak přehrát image disku na serveru nejlépe přes internet
    Tak to nepomohlo. Prehral jsem to
    
    /usr/bin/rsync -auzr --delete ......
    
    Bohuzel kdyz to nahraji na disk kde je již ubuntu 7.10 a mam tam volnou partition nema ke vsemu prava. Aspon to pise napr pri vypinani. Kdyz zkontroluju rucne prijdou mne stejne jako na jinem disku. Na uplne novem disku se tomu tak nedeje.

    starý disk:
    
    file -s /dev/sda4
    /dev/sda4: Linux rev 1.0 ext3 filesystem data, UUID=fabe4ec6-0044-4c03-91cc-a9cb47851ce2 (needs journal recovery) (large files)
    
    fdisk -l
    
    Disk /dev/sda: 80,0 GB, 80 000 000 000 bajtů
    hlav: 255, sektorů na stopu: 63, cylindrů: 9 726
    Jednotky = cylindry po 16065 * 512 = 8 225 280 bajtech
    Velikost sektoru (logického/fyzického): 512 bajtů / 512 bajtů
    Velikost I/O (minimální/optimální): 512 bajtů / 512 bajtů
    Identifikátor disku: 0xa54dba71
    
    Zařízení Zavádět   Začátek       Konec    Bloky    Id  Systém
    /dev/sda1   *           1         261     2096451    6  FAT16
    /dev/sda2             262         383      979965   82  Linux swap/Solaris
    /dev/sda3             384        2815    19535040   83  Linux
    /dev/sda4            2816        9726    55512607+  83  Linux
    
    
    
    nový disk kde to funguje:
    fdisk -l
    
    Disk /dev/sda: 640,1 GB, 640 135 028 736 bajtů
    hlav: 255, sektorů na stopu: 63, cylindrů: 77 825
    Jednotky = cylindry po 16065 * 512 = 8 225 280 bajtech
    Velikost sektoru (logického/fyzického): 512 bajtů / 512 bajtů
    Velikost I/O (minimální/optimální): 512 bajtů / 512 bajtů
    Identifikátor disku: 0x483fc31e
    
    Zařízení Zavádět   Začátek       Konec    Bloky    Id  Systém
    /dev/sda1               1        3825    30724281   83  Linux
    
    file -s /dev/sda1
    /dev/sda1: Linux rev 1.0 ext3 filesystem data, UUID=f8698667-1c30-4f0e-a571-5d5ef32df1b1 (needs journal recovery) (large files)
    
    
    13.6.2011 15:42 chinook | skóre: 28
    Rozbalit Rozbalit vše Re: Jak přehrát image disku na serveru nejlépe přes internet
    Tak uz vim kde je chyba. Jen nevim jak ji odstranit. Kdyz prehraji disk pod ubuntu 7.10. Tzn. nabootuju rsyncnu nebo tarem prenesu soubory, tak system nenabehne jak ma. Viz. priznaky vyse. Ale pokud vezmu live distro 10.04. tak kdyz to pretaruju nebo rsyncnu tak jede vse jak ma. Nevi nekdo co muze tu chybu zpusobovoat?
    14.6.2011 11:57 chinook | skóre: 28
    Rozbalit Rozbalit vše Re: Jak přehrát image disku na serveru nejlépe přes internet
    Tak po zkopirovani souboru partition staci preinstalovat balik dbus. Nevim proc tomu tak je, ale pomuze to.
    13.6.2011 13:52 marek
    Rozbalit Rozbalit vše Re: Jak přehrát image disku na serveru nejlépe přes internet
    Dobry den.

    Delal jsem neco podobneho, ale pro debian.

    Po docela dlouhem vyvoji jsem presel na debootstrap a sadu scriptu.

    Ten debootstrap jsem si obcas nacacheoval do taru.

    Daleko lepe se to spravovalo.

    Jedna z verzi scriptu:

    #!/bin/bash
    DISK=sda
    SWAP_SIZE=1024
    UDEV_DELAY=10
    APT_ATTEMPT_COUNT=10
    MOUNTPOINT=/mnt/mountpoint
    
    #pokud je disk namountovan, nebo na nej swapuji, pokusim se odmountovat, vypnout swap
    swapon -s | sed -e's%\(/dev/'$DISK'[0-9]\+\).*%swapoff  \1% p' -e d | sh
    mount | sed -e's%\(/dev/'$DISK'[0-9]\+\).*%umount \1% p' -e d | sh
    
    #zacatek disku prepisu nulama
    dd if=/dev/zero of=/dev/$DISK bs=1024 count=1024
    
    #napartisnuji
    sync
    parted /dev/$DISK "mklabel msdos"
    parted /dev/$DISK 'mkpart primary ext3 0 -'$SWAP_SIZE'MB'
    parted /dev/$DISK 'mkpart primary  linux-swap -'$SWAP_SIZE'MB -0'
    sync
    
    
    #cekani na udev ..
    I=0
    while ! [ -b "/dev/${DISK}1" ]
    do
            [ $I -ge $UDEV_DELAY ] && exit 11
            echo -n "warning: waiting for /dev/${DISK}1 " 2>&1
            sleep 1
            echo -n "."
            I=$((I+1))
    done
    
    #vytvorim filesystem, pripravim swap
    mkfs.ext3 "/dev/${DISK}1" && mkswap "/dev/${DISK}2" || exit 13
    
    #radsi prepnu locale na C, pokud namountim nove vytvorenu fs, tak pokracuji. Jinak v panice koncim.
    export LANG=C
    mount  "/dev/${DISK}1" $MOUNTPOINT
    if [ $? = 0 ]
    then
            cd $MOUNTPOINT
            export DEBIAN_FRONTEND=noninteractive
            debootstrap lenny . http://10.67.132.144:3142/ftp.us.debian.org/debian
            echo "wise" > etc/hostname
            echo "127.0.0.1 localhost" >> etc/hosts
            echo "127.0.0.1 wise" >> etc/hosts
            mount proc -t proc proc
            echo "do_initrd = Yes" >> etc/kernel-img.conf
            echo "do_symlinks = Yes" >> etc/kernel-img.conf
            cp /etc/apt/sources.list etc/apt/sources.list
            echo -e "cs_CZ ISO-8859-2\ncs_CZ.UTF-8 UTF-8" >> etc/locale.gen
            chroot . apt-get update
            chroot . apt-get upgrade
            chroot . pwconv
            vim -es +"%s/^root:.*$/$(getent shadow root)/" +'wq' etc/shadow
            chroot . bash -c 'I=0; while ! apt-get --yes install tofrodos cstocs console-tools usplash imagemagick ipcalc vim less ssh grub  module-init-tools locales xserver-xorg-video-all xfonts-base icewm xterm gcc xdialog libc6-dev sudo  numlockx psmisc xwit xtermcontrol telnet cupsys cupsys-client linux-image-686 acpid x11-xserver-utils; do  [ $I -ge '$APT_ATTEMPT_COUNT' ] && exit 14 ;echo "zkousim znovu";apt-get update;I=$((I+1)); done '
            mkdir ./boot/grub/
            echo quit |  grub --no-floppy --batch --device-map=./boot/grub/device.map
            DEVICE=$(sed -e"s%^(\(hd[0-9]\+\))[[:blank:]]\+/dev/"${DISK}"$%\1% p" -e d ./boot/grub/device.map)
            echo -e "default=0\ntimeout=2\ntitle debian\nroot ($DEVICE,0)\nkernel ($DEVICE,0)/vmlinuz root=/dev/${DISK}1 vga=791 splash quiet\ninitrd /initrd.img" > ./boot/grub/menu.lst
            echo -e "root ($DEVICE,0)\ninstall ($DEVICE,0)/usr/lib/grub/i386-pc/stage1 ($DEVICE) ($DEVICE,0)/usr/lib/grub/i386-pc/stage2 ($DEVICE,0)/boot/grub/menu.lst\nquit" |grub --batch
            export LANG=cs_CZ.UTF-8
            chroot . rm /etc/alternatives/editor
            chroot . ln -s /etc/alternatives/vim /etc/alternatives/editor
            chroot . rm  /etc/alternatives/usplash-artwork.so
            chroot . ln -s  /usr/lib/usplash/usplash-theme-umcp4.so  /etc/alternatives/usplash-artwork.so
            echo "/dev/${DISK}1       /               ext3    errors=remount-ro       0       1" >> ./etc/fstab
            echo "/dev/${DISK}2       none            swap    sw                      0       0" >> ./etc/fstab
            cat > etc/network/interfaces << EOF
                            auto eth0
                            iface eth0 inet dhcp
                            up /etc/network/dhcp.cache
                            auto lo
                            iface lo inet loopback
                            address 127.0.0.1
                            netmask 255.0.0.0
    EOF
            cat >> etc/cups/printers.conf << EOF
    <Printer lp>
    Info lp
    DeviceURI parallel:/dev/lp0
    State Idle
    StateTime 1207299306
    Accepting Yes
    Shared Yes
    JobSheets none none
    QuotaPeriod 0
    PageLimit 0
    KLimit 0
    OpPolicy default
    ErrorPolicy stop-printer
    </Printer>
    EOF
            cat >> etc/usplash.conf << EOF
    xres=1024
    yres=768
    EOF
            chroot . useradd -m uzivatel
            cp -a /opt/skelet/* .
            echo 'uzivatel localhost= NOPASSWD: /usr/bin/X' >> etc/sudoers
            echo 'uzivatel localhost= NOPASSWD: /usr/local/sbin/networkrestart' >> etc/sudoers
            chroot . update-initramfs -u
            umount ./proc
            cd ..
            kill $(lsof -Fp $MOUNTPOINT | tr -d "p") 2>/dev/null
            umount $MOUNTPOINT
    else
            exit 12
    fi
    
    
    echo "Hotovo, doinstalovano."
    
    Marek

    Založit nové vlákno • Nahoru

    Tiskni Sdílej: Linkuj Jaggni to Vybrali.sme.sk Google Del.icio.us Facebook

    ISSN 1214-1267   www.czech-server.cz
    © 1999-2015 Nitemedia s. r. o. Všechna práva vyhrazena.