abclinuxu.cz AbcLinuxu.cz itbiz.cz ITBiz.cz HDmag.cz HDmag.cz abcprace.cz AbcPráce.cz
AbcLinuxu hledá autory!
Inzerujte na AbcPráce.cz od 950 Kč
Rozšířené hledání
×
    dnes 17:44 | IT novinky

    Společnost System76 představila pracovní stanici Thelio Mira AI s předinstalovaným Pop!_OS s prostředím COSMIC nebo Ubuntu. Nakonfigurovat lze až s 16jádrovým CPU AMD Ryzen 9 9950X, 192 GB DDR5 RAM, dvěma GPU NVIDIA RTX Pro 6000 a 192 GB GPU pamětí.

    Ladislav Hagara | Komentářů: 1
    dnes 17:00 | Komunita

    DigitalOcean je sponzorem nadace Omacom Foundation stojící za linuxovou distribucí Omarchy. Přislíbená částka je 3 miliony dolarů, tj. 1 milion dolarů ročně po dobu tří let.

    Ladislav Hagara | Komentářů: 2
    včera 21:11 | Zajímavý software

    Na stránkách PostgreSQL bylo představeno LibreDB Studio. Jedná se o open-source self-hostované SQL IDE pro (nejenom) PostgreSQL v prohlížeči. Zdrojové kódy jsou k dispozici na GitHubu pod licencí MIT.

    Ladislav Hagara | Komentářů: 4
    včera 16:00 | Nová verze

    Byla vydána nová verze 12.0 media serveru Jellyfin (Wikipedie). Přehled novinek v poznámkách k vydání. Pro vyzkoušení je k dispozici Demo Server. Jellyfin je fork media serveru Emby, původně Media Browser.

    Ladislav Hagara | Komentářů: 1
    včera 04:44 | Bezpečnostní upozornění

    V MikroTik RouterOS bylo nalezeno šest zranitelností společně pojmenovaných MikroTrick umožňujících útočníkovi, pokud má přístup k SSH, získat plnou kontrolu nad zařízením bez nutnosti autentizace. Ve verzích RouterOS 7.25beta3, 7.24.2, 7.23.4 a 6.49.21 je již opraveno.

    Ladislav Hagara | Komentářů: 9
    včera 04:00 | Nová verze

    Byla vydána verze 9.5 open source unixového operačního systému NetBSD (Wikipedie). Přehled novinek v poznámkách k vydání. Jedná se poslední vydání řady NetBSD 9. Doporučen je přechod na NetBSD 11 nebo NetBSD 10.

    Ladislav Hagara | Komentářů: 0
    7.9. 21:44 | IT novinky

    Akční adventura State of Mind je na portále GOG.com zdarma, akce trvá do 10. září.

    ʚĭɞ 🍉 | Komentářů: 2
    7.9. 13:22 | IT novinky

    Na Kickstarteru běží kampaň na podporu malého robotický psa Petoi Quaddle. Postaven je na ESP32-S3. V několika variantách. S řadou senzorů. Programovat lze pomocí Pythonu, C++ nebo i vizuálních bloků. Zkoušet a trénovat lze v simulátoru.

    Ladislav Hagara | Komentářů: 1
    6.9. 22:11 | Pozvánky

    Dětem začala škola a nedobrovolně se tak musí vzdělávat. Avšak pro dospělé, kteří se chtějí vzdělávat nebo naopak se o vědomosti podělit, je tu Virtuální Bastlírna - jako každý měsíc si můžete online a zdarma nezávazně popovídat o vědě a technice nejen s bastlíři, ale i s vývojáři, vědci nebo profesory. A čemu se strahováci budou věnovat? Blíží se KiCAD 11 s nespočtem novinek, z nichž zde musí zmínit alespoň možnost kótování a závislostí z

    … více »
    bkralik | Komentářů: 1
    6.9. 19:33 | Komunita

    Asahi Linux, tj. Linux pro Apple Silicon, oficiálně podporuje čipy M3 (M3, M3 Pro a M3 Max).

    Ladislav Hagara | Komentářů: 9
    Které desktopové prostředí na Linuxu používáte?
     (10%)
     (7%)
     (4%)
     (21%)
     (29%)
     (7%)
     (6%)
     (2%)
     (14%)
     (21%)
    Celkem 2629 hlasů
     Komentářů: 31, poslední 13.8. 00:27
    Rozcestník

    Dotaz: Apache2 a systemd

    28.4.2015 23:00 Uzovka
    Apache2 a systemd
    Přečteno: 838×
    Jsem volako zmeteny z toho.. po upgradu na debian jessie mi apache2 bezi, ale kdyz se podivam na status, je to samej error.. v logu sem nic nenasel:
    service apache2 status
    ● apache2.service - LSB: Apache2 web server
       Loaded: loaded (/etc/init.d/apache2)
       Active: failed (Result: exit-code) since Út 2015-04-28 21:25:25 CEST; 1h 31min ago
      Process: 3409 ExecStart=/etc/init.d/apache2 start (code=exited, status=1/FAILURE)
    
    dub 28 21:25:25 server apache2[3409]: Starting web server: apache2 failed!
    dub 28 21:25:25 server apache2[3409]: The apache2 instance did not start within 20 seconds. Please read the log files to discover problems ... (warning).
    dub 28 21:25:25 server systemd[1]: apache2.service: control process exited, code=exited status=1
    dub 28 21:25:25 server systemd[1]: Failed to start LSB: Apache2 web server.
    dub 28 21:25:25 server systemd[1]: Unit apache2.service entered failed state.
    
    Za pripadne rady predem diky.

    Odpovědi

    29.4.2015 10:59 rastos | skóre: 63 | blog: rastos
    Rozbalit Rozbalit vše Re: Apache2 a systemd
    Toto je presne to, čo mi vzbudzuje obavy pri systemd.

    Nepíše sa niečo v /var/log/apache2/error.log , /var/log/daemon.log, /var/log/syslog ?

    Vo výstupe z "journalctl -b " ?
    30.4.2015 07:48 Thomas123 | skóre: 15
    Rozbalit Rozbalit vše Re: Apache2 a systemd
    Jsou to dva dny, co jsem s tím taky zápasil. Logy budou ve /var/log/syslog a důvod, proč ti to dělá co to dělá bude asi podobný jako u mě tady
    30.4.2015 09:54 rastos | skóre: 63 | blog: rastos
    Rozbalit Rozbalit vše Re: Apache2 a systemd
    ... důvod, proč ti to dělá co to dělá bude asi podobný jako u mě tady
    To asi nebola tá správna linka, či hej?
    30.4.2015 13:30 Thomas123 | skóre: 15
    Rozbalit Rozbalit vše Re: Apache2 a systemd
    Link je správný, kupodivu mně Apache nešel nastartovat a postupně jsem dohledával útržky informací ze syslogu a pokaždé to ztroskotalo na něčem jiném. Postupně jsem opravoval konfiguraci z 2.2 (Wheezy) na 2.4 (Jessie) a už to běží.
    michich avatar 29.4.2015 17:48 michich | skóre: 51 | blog: ohrivane_parky
    Rozbalit Rozbalit vše Re: Apache2 a systemd
    Nespouštíš ho náhodou ještě nějak jinak než z této service? Jestliže tedy běží, pod kterou cgroup spadá jeho PID? (Podívej se, co řekne systemctl status $PID. Nebo ho najdi ve výstupu systemd-cgls.)
    30.4.2015 08:45 j
    Rozbalit Rozbalit vše Re: Apache2 a systemd
    Ze prej je debian stabilni distro sem nekde slysel ... a ze prej s upgrade nikdy nejsou problemy ...

    Hele prvni co zkus je to proste tomu systemd uplne smazat, aby vubec netusil ze tam nejakej apache je. Pokud nastartuje, tak minimalne vis, ze mas hledat nejakej script kterej ho nahazuje.
    30.4.2015 10:34 Uzovka
    Rozbalit Rozbalit vše Re: Apache2 a systemd
    Takze jsem nakonec vyrestartoval komplet server a uz to je ok i po restartech samotneho apache2:
    ● apache2.service - LSB: Apache2 web server
       Loaded: loaded (/etc/init.d/apache2)
       Active: active (running) since St 2015-04-29 17:05:34 CEST; 17h ago
      Process: 18288 ExecStop=/etc/init.d/apache2 stop (code=exited, status=0/SUCCESS)
      Process: 7352 ExecReload=/etc/init.d/apache2 reload (code=exited, status=0/SUCCESS)
      Process: 18326 ExecStart=/etc/init.d/apache2 start (code=exited, status=0/SUCCESS)
       CGroup: /system.slice/apache2.service
               ├─ 7441 /usr/sbin/apache2 -k start
               ├─ 7442 /usr/sbin/apache2 -k start
               ├─ 8493 /usr/sbin/apache2 -k start
               ├─ 8502 /usr/sbin/apache2 -k start
               ├─ 8506 /usr/sbin/apache2 -k start
               ├─ 8509 /usr/sbin/apache2 -k start
               ├─15889 /usr/sbin/apache2 -k start
               ├─16722 /usr/sbin/apache2 -k start
               ├─16767 /usr/sbin/apache2 -k start
               ├─18342 /usr/sbin/apache2 -k start
               └─27926 /usr/sbin/apache2 -k start
    
    dub 30 06:25:18 server apache2[7352]: Reloading web server: apache2.
    Warning: Journal has been rotated since unit was started. Log output is incomplete or unavailable.
    
    Asi to bylo jen v nejakem pochybnem stavu, snad to uz bude makat bez problemu.

    Založit nové vláknoNahoru

    Tiskni Sdílej: Linkuj Jaggni to Vybrali.sme.sk Google Del.icio.us Facebook

    ISSN 1214-1267   www.czech-server.cz
    © 1999-2015 Nitemedia s. r. o. Všechna práva vyhrazena.