Přímý přenos (YouTube) z konference LinuxDays 2026, jež probíhá tento víkend v Praze v prostorách FIT ČVUT. Na programu je spousta zajímavých přednášek.
Byla vydána nová verze 0.17.0 programovacího jazyka Zig (Codeberg, Wikipedie). Přispělo 206 vývojářů. Přehled novinek v poznámkách k vydání.
Open-source projekt OpenDLSS-NR je 'bitově přesná reimplementace' neuronové rendrovací sítě DLSS 5 od společnosti NVIDIA, jenže pro grafické API Vulkan (DLSS slouží k vylepšování klasickým způsobem vyrendrovaných snímků pomocí lokálních modelů umělé inteligence, a to v reálném čase). Projekt není nijak spojen se společností NVIDIA, je pouze pro OS Windows a natrénované váhy modelu si uživatelé musí obstarat sami. Zdrojový kód je k dispozici na GitHubu, pod licencí MIT s výjimkou pro komponenty třetích stran.
Společnost Cloudflare představila Clef a Clef-Flash, open-source rozhodovací modely určené pro rychlou a konzistentní klasifikaci vstupů. Na rozdíl od klasických LLM vracejí tyto modely deterministické striktně typované strukturované odpovědi s exaktními pravděpodobnostmi, tedy odpovědi ve stylu přelomového modelu Jev.
… více »Byla vydána beta verze Ubuntu 26.10 s kódovým názvem Stonking Stingray. Přehled novinek v poznámkách k vydání. Dle plánu by Ubuntu 26.10 mělo vyjít 15. října 2026.
Byla vydána verze 1.99.0 programovacího jazyka Rust (Wikipedie). Podrobnosti v poznámkách k vydání. Vyzkoušet Rust lze například na stránce Rust by Example.
Od 13. do 15. října proběhne v Praze OpenSSL Conference 2026. Na YouTube lze zhlédnout videozáznamy přednášek z loňského roku.
Eben Upton oznámil další zdražení jednodeskových počítačů Raspberry Pi. Tentokrát 2 GB varianty o 12,50 dolarů. Nově 2 GB Raspberry Pi 4 stojí 67,50 dolarů a 2 GB Raspberry Pi 5 stojí 77,50 dolarů.
OpenMandriva ROME, tj. průběžně aktualizovaná (rolling) edice linuxové distribuce OpenMandriva, byla vydána ve verzi 26.09. Vedle Flatpaku také s podporou Snapu.
Edison Design Group po více než 30 letech zveřejnil zdrojový kód svého EDG C/C++ front-endu. Ten proslul širokou podporou standardů C++ a kompatibilitou s dialekty kompilátorů od Microsoftu, GNU, Clangu, Sunu a dokonce i s prehistorickým cfrontem. EDG byl použit například v kompilátoru Intel C++ Classic, kompilátoru NVCC od firmy NVIDIA pro platformu CUDA nebo v našeptávači kódu IntelliSense v produktech společnosti Microsoft. Projekt nyní spravuje organizace The C++ Alliance a kód je dostupný pod licencí Apache 2.0, doplněnou o výjimky projektu LLVM.
service apache2 status ● apache2.service - LSB: Apache2 web server Loaded: loaded (/etc/init.d/apache2) Active: failed (Result: exit-code) since Út 2015-04-28 21:25:25 CEST; 1h 31min ago Process: 3409 ExecStart=/etc/init.d/apache2 start (code=exited, status=1/FAILURE) dub 28 21:25:25 server apache2[3409]: Starting web server: apache2 failed! dub 28 21:25:25 server apache2[3409]: The apache2 instance did not start within 20 seconds. Please read the log files to discover problems ... (warning). dub 28 21:25:25 server systemd[1]: apache2.service: control process exited, code=exited status=1 dub 28 21:25:25 server systemd[1]: Failed to start LSB: Apache2 web server. dub 28 21:25:25 server systemd[1]: Unit apache2.service entered failed state.Za pripadne rady predem diky.
... důvod, proč ti to dělá co to dělá bude asi podobný jako u mě tadyTo asi nebola tá správna linka, či hej?
systemctl status $PID. Nebo ho najdi ve výstupu systemd-cgls.)
● apache2.service - LSB: Apache2 web server
Loaded: loaded (/etc/init.d/apache2)
Active: active (running) since St 2015-04-29 17:05:34 CEST; 17h ago
Process: 18288 ExecStop=/etc/init.d/apache2 stop (code=exited, status=0/SUCCESS)
Process: 7352 ExecReload=/etc/init.d/apache2 reload (code=exited, status=0/SUCCESS)
Process: 18326 ExecStart=/etc/init.d/apache2 start (code=exited, status=0/SUCCESS)
CGroup: /system.slice/apache2.service
├─ 7441 /usr/sbin/apache2 -k start
├─ 7442 /usr/sbin/apache2 -k start
├─ 8493 /usr/sbin/apache2 -k start
├─ 8502 /usr/sbin/apache2 -k start
├─ 8506 /usr/sbin/apache2 -k start
├─ 8509 /usr/sbin/apache2 -k start
├─15889 /usr/sbin/apache2 -k start
├─16722 /usr/sbin/apache2 -k start
├─16767 /usr/sbin/apache2 -k start
├─18342 /usr/sbin/apache2 -k start
└─27926 /usr/sbin/apache2 -k start
dub 30 06:25:18 server apache2[7352]: Reloading web server: apache2.
Warning: Journal has been rotated since unit was started. Log output is incomplete or unavailable.
Asi to bylo jen v nejakem pochybnem stavu, snad to uz bude makat bez problemu.
Tiskni
Sdílej: