abclinuxu.cz AbcLinuxu.cz itbiz.cz ITBiz.cz HDmag.cz HDmag.cz abcprace.cz AbcPráce.cz
AbcLinuxu hledá autory!
Inzerujte na AbcPráce.cz od 950 Kč
Rozšířené hledání
×
dnes 08:00 | Zajímavý článek

Portál Stack Overflow po roce opět vyzpovídal své uživatele, jedná se především o vývojáře softwaru, a zveřejnil detailní výsledky průzkumu. Průzkumu se letos zúčastnilo více než 80 tisíc vývojářů. Z Česka jich bylo 792. Ze Slovenska 252. Celkově bylo 91,67 % mužů a 5,31 % žen.

Ladislav Hagara | Komentářů: 2
dnes 07:00 | Zajímavý článek

Valentina Palmiotti ze společnosti Grapl v příspěvku na blogu podrobně rozebírá bezpečnostní chybu CVE-2021-3490 v Linuxu, konkrétně v eBPF, zneužitelnou k lokální eskalaci práv. Chyba byla v upstreamu opravena již v květnu.

Ladislav Hagara | Komentářů: 0
dnes 06:00 | Pozvánky

Od pátku 6. srpna do neděle 8. srpna proběhne online The Raku Conference, tj. konference věnovaná programovacímu jazyku Raku.

Ladislav Hagara | Komentářů: 0
včera 13:00 | IT novinky

Zítra končí bezpečnostní konference Black Hat USA 2021 (Twitter) a začíná bezpečnostní konference DEF CON 29 (Twitter). Kvůli COVID-19 letos probíhají obě konference hybridně, v Las Vegas i virtuálně. V rámci Black Hat budou vyhlášeny výsledky letošní Pwnie Awards (Twitter). Pwnie Awards oceňují to nejlepší, ale i to nejhorší z IT bezpečnosti (bezpečnostní Oscar a Malina v jednom). Viz nominace.

Ladislav Hagara | Komentářů: 0
včera 09:00 | Zajímavý článek Ladislav Hagara | Komentářů: 6
včera 08:00 | Pozvánky

MojeFedora.cz zve na online konferenci Nest with Fedora 2021 (Flock to Fedora). Konference proběhne od čtvrtka 5. srpna do soboty 7. srpna, vždy od 14:00. Na programu je řada zajímavých přednášek.

Ladislav Hagara | Komentářů: 0
včera 07:00 | Nová verze

CrossOver, komerční produkt založený na Wine, byl vydán ve verzi 21. Přehled novinek v ChangeLogu. Verze 21 je založena na Wine 6.0 s více než 8 300 vylepšeními.

Ladislav Hagara | Komentářů: 4
3.8. 16:22 | IT novinky

Byla vydána videohra o stínech minulosti Svoboda 1945: Liberation. Druhá světová válka skončila, ale ve vesnici Svoboda na česko-německém pohraničí mír nenastal. Přijeli jste rozhodnout desetiletí trvající spor. Komu věřit? Jak s tím souvisí vaše rodina? Vyzpovídejte svědky a odhalte pravdu o vlastní minulosti ve hře, jakou jste ještě nehráli.

Ladislav Hagara | Komentářů: 17
3.8. 15:22 | Komunita

Dnes 3. srpna od 20:00 a o týden 10. srpna od 20:00 proběhne online konference Qubes virtual mini-summit 2021 věnovaná operačnímu systému zaměřenému na bezpečnost Qubes OS (Wikipedie). Přednášky lze sledovat na YouTube.

Ladislav Hagara | Komentářů: 0
3.8. 07:00 | Nová verze

Po půl roce od vydání verze 2.33 byla vydána nová verze 2.34 knihovny glibc (GNU C Library). Přehled novinek v poznámkách k vydání.

Ladislav Hagara | Komentářů: 0
Jak synchronizujete data mezi zařízeními?
 (21%)
 (22%)
 (14%)
 (17%)
 (25%)
Celkem 76 hlasů
 Komentářů: 10, poslední dnes 15:58
Rozcestník



Dotaz: Chyba cmake

3.11.2016 10:16 zburo
Chyba cmake
Přečteno: 427×
Dobrý den, mám taký problém že mi pri kompilácii vyhodí takúto hlášku. Predtým som to robil 100x a všetko prebehlo v poriadku. Neviete kde môže byť chyba? Za odpoveď ďakujem

root@debian:/usr/src/oscam-svn/build# cmake ..

-- pthread found. Adding pthread support

-- SSL IS NOT INCLUDED IN THIS COMPILATION

CMake Error at /usr/share/cmake-2.8/Modules/FindOpenSSL.cmake:263 (list):

list GET given empty list

Call Stack (most recent call first):

CMakeLists.txt:239 (find_package)

CMake Error at /usr/share/cmake-2.8/Modules/FindOpenSSL.cmake:264 (list):

list GET given empty list

Call Stack (most recent call first):

CMakeLists.txt:239 (find_package)

CMake Error at /usr/share/cmake-2.8/Modules/FindOpenSSL.cmake:266 (list):

list GET given empty list

Call Stack (most recent call first):

CMakeLists.txt:239 (find_package)

CMake Error at /usr/share/cmake-2.8/Modules/FindOpenSSL.cmake:268 (list):

list GET given empty list

Call Stack (most recent call first):

CMakeLists.txt:239 (find_package)

-- openssl found.

-- librt found (needed by libusb).

-- PCSC headers found (/usr/include/PCSC). Adding PCSC support

--

-- operating system: Linux

-- target system: x86_64-linux-gnu

-- revision: 11279

-- use system libcrypto functions

-- use system pcsc functions

-- use system pthread functions

--

-- Configuring incomplete, errors occurred!

root@debian:/usr/src/oscam-svn/build#

Řešení dotazu:


Odpovědi

3.11.2016 12:48 chrono
Rozbalit Rozbalit vše Re: Chyba cmake
Ak je nainštalované OpenSLL 1.0.2+ tak je potrebná novšia verzia cmake (3.1.2 prípadne aj staršia, musí mať ale integrovanú opravu pre novšie verzie OpenSSL).
4.11.2016 16:23 zburo
Rozbalit Rozbalit vše Re: Chyba cmake
Ale nikde nedokážem nájsť ako to cmake updatnúť. Nie som zase nejaký znalec linuxu. Nejaké riešenia som našiel ale zatial nič nepomohlo.
4.11.2016 18:56 Andrej | skóre: 49 | blog: Republic of Mordor
Rozbalit Rozbalit vše Re: Chyba cmake

Stačí mít normální aktuální distribuci a balíčkovací systém se o update CMake postará sám. Není třeba CMake nijak explicitně ručně aktualizovat, stačí se ujistit, že se pravidelně provádí aktualizace systému. Na mém stroji mám teď zrovna například:

$ cmake --version
cmake version 3.6.2
5.11.2016 09:40 zburo
Rozbalit Rozbalit vše Re: Chyba cmake
V ktorom súbore zistím verziu cmake? Tieto dva riadky ktoré si sem napísal. Prehladal som snáď všetky adresáre ale nikde to nemôžem nájsť. Ďakujem a sorry za blbé otázky. Už som bezradný. Aj som našiel polopatický návod na inštaláciu cmake 3.6.2 ale aj pri nej mi vyhadzuje tie isté chyby. Takže možno je problém aj niekde inde. Možno stará verzia openssl.
5.11.2016 11:27 chrono
Rozbalit Rozbalit vše Re: Chyba cmake
Pre zistenie verzie stačí spustiť cmake --version. (každopádne podľa tej cesty /usr/share/cmake-2.8 ide o verziu 2.8.x).

PS: Ak si neodinštaloval tú starú verziu, tak je možné, že aj po skompilovaní tej novej to stále používalo tú starú verziu.

PPS: Akú distribúciu to vlastne používaš?
Řešení 1× (zburo)
Jendа avatar 5.11.2016 16:19 Jendа | skóre: 77 | blog: Jenda | JO70FB
Rozbalit Rozbalit vše Re: Chyba cmake
Podle hostname Debian a podle verze cmake je to wheezy. Tam bych asi začal, snažit se rozchodit vývojovou verzi nějakého software na skoro 4 roky starém systému mi přijde mrhání časem.
Je to vlastně jenom taková obyčejná mikrovlnka, jenom otevřená ven.
7.11.2016 11:00 zburo
Rozbalit Rozbalit vše Re: Chyba cmake
Toto som presne potreboval. Nakopnúť. Tak som nainštaloval Debian 8 jessie ktorému som sa snažil vyhýbať lebo mi tam nesedelo pár vecí. Síce po inštalácii cmake som mal verziu 3.0.2 ale už to konečne funguje. Ďakujem za nakopnutie.
Jendа avatar 5.11.2016 16:17 Jendа | skóre: 77 | blog: Jenda | JO70FB
Rozbalit Rozbalit vše Re: Chyba cmake
dpkg -l|grep balíček. Třeba i pro to openssl.
Je to vlastně jenom taková obyčejná mikrovlnka, jenom otevřená ven.

Založit nové vláknoNahoru

Tiskni Sdílej: Linkuj Jaggni to Vybrali.sme.sk Google Del.icio.us Facebook

ISSN 1214-1267   www.czech-server.cz
© 1999-2015 Nitemedia s. r. o. Všechna práva vyhrazena.