Proběhl Snapdragon Summit 2026. Společnost Qualcomm se mimo jiné pochlubila během Linuxu na čipech Snapdragon X2. Zatím pouze v ranní verzi vhodné pro vývojáře linuxových distribucí a přispěvatele do jádra Linux.
Byla vydána nová verze 2.0 klienta F-Droid určeného pro instalaci bezplatných a otevřených mobilních aplikací do Androidu ze softwarového repozitáře F-Droid (Wikipedie). Jedná se o alternativu k Google Play.
Debian Inference Portal nabízí vývojářům Debianu bezplatný přístup ke službám AI/LLM. Sponzorem je společnost Scaleway.
Robert Ressl nalezl ve WordPressu kritickou zranitelnost CVE-2026-87902 s CVSS 9.2. Útočníkům umožňuje neoprávněný přístup k souborům a vzdálené spuštění kódu (RCE). Opravena je ve verzích 7.1.2, 7.0.6, 6.9.9…
Společnost Meta na dvoudenní konferenci Meta Connect 2026 představuje své novinky. Vypíchnout lze lehké brýle s funkci VR Meta VR Glasses. Do prodeje půjdou na jaře 2027 za cenu 1299,99 dolarů.
Google Chrome 154 byl prohlášen za stabilní. Nejnovější stabilní verze 154.0.8037.57 přináší řadu novinek. Podrobný přehled v poznámkách k vydání. Opraveno bylo 108 bezpečnostních chyb. Vylepšeny byly také nástroje pro vývojáře.
Vláda sníží v příštím roce výdaje na IT služby státu o 1,4 miliardy korun. Úspory má umožnit lepší koordinace nákupu služeb napříč resorty prostřednictvím nového zmocněnce. Celkové roční výdaje státu na informační technologie a digitalizaci se podle údajů ministerstva průmyslu a obchodu pohybují okolo 20 až 25 miliard korun ročně, pro letošek bylo na 320 projektů vyčleněno 21 miliard.
Irská komise pro ochranu dat (DPC) uložila americké technologické společnosti Google ze skupiny Alphabet pokutu 403 milionů eur (9,8 miliardy Kč) za neoprávněné nakládání s údaji o poloze uživatelů. Firma podle komise porušila evropské nařízení o ochraně osobních údajů (GDPR). DPC uvedla, že při šetření zjistila, že si lidé nemuseli být vědomi skutečnosti, že jejich poloha byla využívána například k ovlivňování prostřednictvím reklam nebo k odvozování jejich zájmů, a mohli tak ztratit kontrolu nad svými osobními údaji.
Byla oznámena beta verze nového video kodeku Pyrowave pro streamování her v Steam Remote Play. S vysokou propustností a nízkou latencí. S podporou HDR a YUV 4:4:4.
Byl vydán Sublime Text 4 Build 4213. Sublime Text (Wikipedie) je proprietární multiplatformní editor textových souborů a zdrojových kódů. Ke stažení a k vyzkoušení je zdarma. Pro další používání je nutná licence v ceně 99 dolarů. Spolu se Sublime Merge je cena 168 dolarů.
Řešení dotazu:
Když zadám požadavek do prohlizece a nez se to dostane na pozadovany stroj tak to projde pres desitky stroju a taky na kazdem neni nainstalovany pozadovany certifikat.Jenže ty stroje, přes které to prochází, se nazývají routery, a operují na L3. Proxy operuje na L7. A k řešení dotazu: záleží, jestli ti stačí spojení přepojit na správný stroj, pak proxy dešifrování provádět nebude a jenom se koukne na SNI hlavičku, nebo chceš dělat něco složitějšího, pak je potřeba TLS spojení terminovat na proxy (a pokud je síť za ní důvěryhodná, tak se naopak neprovozuje TLS na koncovém webserveru).
záleží, jestli ti stačí spojení přepojit na správný strojAno, myslim, ze to by mi stacilo a certifikat bych nainstaloval jen na cilovem stroji. Poradis jak toho docílit?
PS: a pres proxy muzu prohnat i port 22?Ne, SSH neposílá žádné informace, kvůli kterým by dávalo použití proxy smysl.
PS: a pres proxy muzu prohnat i port 22?(jak by sis představoval že bude vypadat výsledek/čeho tím chceš dosáhnout?)
PS: a pres proxy muzu prohnat i port 22?Áno, môžeš. Ale nie som si istý či naozaj chceš ssh over http proxy a nie klasický PAT.
PS: a pres proxy muzu prohnat i port 22?SSH a HTTPS si spolu nerozumí, ale existuje například sslh, které podle začátku protokolu detekuje, co to je zač a pošle to odpovídající službě na jiný port. Nevýhoda je, že cílová služba nevidí vzdálenou IP adresu, což u může vadit (logy, zabezpečení).
Když bude certifikát na tom proxy serveru, je to HTTP/HTTPS reverzní proxy.
Když má být až na cílovém serveru, je to TCP proxyuvedl jsi tedy dvě možnosti
TCP proxy proxy funguje tak, že TCP spojení je zakončené na proxy serverua teď z té druhé možnosti děláš zase tu první, tak jak to tedy je? ;)
server {
listen 443;
server_name www.domena1.net;
location / {
proxy_pass https://192.168.1.101;
proxy_set_header Host $host;
proxy_set_header X-Real-IP $remote_addr;
proxy_set_header X-Forwarded-For $proxy_add_x_forwarded_for;
proxy_connect_timeout 150;
proxy_send_timeout 100;
proxy_read_timeout 100;
proxy_buffers 4 32k;
client_max_body_size 8m;
client_body_buffer_size 128k;
}
}
server {
listen 443;
server_name www.domena2.net;
location / {
proxy_pass https://192.168.1.102;
proxy_set_header Host $host;
proxy_set_header X-Real-IP $remote_addr;
proxy_set_header X-Forwarded-For $proxy_add_x_forwarded_for;
proxy_connect_timeout 150;
proxy_send_timeout 100;
proxy_read_timeout 100;
proxy_buffers 4 32k;
client_max_body_size 8m;
client_body_buffer_size 128k;
}
}
listen 443 by muselo být ssl a musela by tam být konfigurace certifikátů, případně další konfigurace SSL:
server {
listen 443 ssl;
server_name www.domena1.net;
ssl_certificate www.domena1.net.crt;
ssl_certificate_key www.domena1.net.key;
…
}
Vy asi chcete TCP proxy, tj. SSL zakončené až na cílovém serveru. Pak moc nevidím důvod mít tam v roli TCP proxy HTTP(S) server, protože dovnitř SSL spojení neuvidí, jenom si z SNI na začátku spojení přečte, kam má to spojení předat. Ale nginx umí i tohle, příklad konfigurace je v Module ngx_stream_ssl_preread_module. Ale já jsem nginx jako TCP proxy nikdy nepoužíval, takže víc než tenhle odkaz a odkaz na dokumentaci TCP/UDP proxy nginxu vám asi neporadím.
Vy asi chcete SSL zakončené až na cílovém serveru.Ano
Pak moc nevidím důvod mít tam v roli TCP proxy HTTP(S) server, protože dovnitř SSL spojení neuvidí, jenom si z SNI na začátku spojení přečte, kam má to spojení předat.Tak pokud není důvod mít tam v roli TCP proxy HTTP(S) server, tak jak to udělat? A co třeba spustit nějaký DNS server, ten by neuměl podle názvu domény poslat všechny požadavky https a https na příslušnou vnitřní IP adresu?
tak je to na "závažné porušení Zákoníku práce", už vzhledem k GDPR.GDPR nemá se zákoníkem práce nic společného, týká se ochrany osobních údajů. A je účinné až od 25. května 2018.
Když si tam uděláte nějakou vlastní cestu mimo oficiální kanály, asi vás nebudou mít rádi.Tak že použití proxy serveru se jedná o neoficiální kanál?
Tak pokud není důvod mít tam v roli TCP proxy HTTP(S) server, tak jak to udělat?Stačilo by použít nějaký TCP proxy server, který umí směrovat podle SNI. Ale pokud tam chcete přesměrovávat i HTTP, stejně tam potřebujete použít HTTP proxy server, takže pak je nginx dobrá volba.
A co třeba spustit nějaký DNS server, ten by neuměl podle názvu domény poslat všechny požadavky https a https na příslušnou vnitřní IP adresu?DNS žádné HTTP a HTTPS požadavky nikam neposílá. DNS jenom přeloží název na IP adresu. Nejlepší by bylo, kdybyste napsal, jaký problém řešíte. Takhle se jen pokoušíme trefit do nějaké vaší představy o řešení.
Nejlepší by bylo, kdybyste napsal, jaký problém řešíte. Takhle se jen pokoušíme trefit do nějaké vaší představy o řešení.Řeším stále ten stejný problém. Mám nainstalovaný na serveru proxmox a v něm několik virtuální serverů (VM-100, VM-101, VM-102 atd..) a každou doménu chci nasměrovat na samostatný virtuální server tak, aby se vyžadovaly SSL certifikáty až na cílových virtuálních strojích a taky aby byly v každém log ip adresa uživatele který přišel na stránky, ne ip adresa proxy serveru. To je všechno.
kolik funkčních IP adres na interfejsech má samotný proxmox?Všechny domény jsou nasměrovány na jedinou IP adresu.
Jakou bránu (gateway) mají ty virtuály?IP adresu přiděluje DHCP server podle MAC adresy toho virtuálu (Address Reservation)
Přes co všechno chodí provoz do toho proxmoxu?Nerozumím otázce
Mají ty virtuály něco společného nebo jsou navzájem nezávislé?Co například můžou mít společné?
Maj ty domény něco společného, každá jedna jednotlivěCo například můžou mít společné?
Kdybych měl na hypervizoru bridge a ve virtuálu web sevrery, tak můžu pustit provoz přímo. Takže proč Vám tohle nevyhovuje?A "kdo/co" by se v takovém případě staralo o to na jaky server poslat požadovanou doménu?
proxy_set_header Host $http_host; proxy_set_header X-Real-IP $remote_addr; proxy_set_header X-Forwarded-For $proxy_add_x_forwarded_for; proxy_set_header X-Forwarded-Port 80 proxy_set_header X-Forwarded-Proto httpA tohle pro HTTPS server:
proxy_set_header Host $http_host; proxy_set_header X-Real-IP $remote_addr; proxy_set_header X-Forwarded-For $proxy_add_x_forwarded_for; proxy_set_header X-Forwarded-Port 443 proxy_set_header X-Forwarded-Proto httpsNginx tak předá informace o původním spojení (IP adresa klienta, port, protokol, požadované hostname) do HTTP hlaviček, odkud si je cílový server převezme. Cílový server k tomu musí být nakonfigurován, aby ty hlavičky neakceptoval od každého klienta, ale jenom od konkrétního proxy serveru. Např. Apache pro to má mod_remoteip, Nginx má modul ngx_http_realip_module.
RemoteIPHeader X-Real-IP RemoteIPInternalProxy X.X.X.Xkde za X.X.X.X dosadíte IP adresu toho nginx serveru tak, jak ji vidí Apache.
server {
listen 443 ssl;
server_name example.com;
ssl_certificate /example.com.pem;
ssl_certificate_key /example.com.key.pem;
location / {
proxy_pass http://192.168.0.101;
proxy_set_header Host $http_host;
proxy_set_header X-Real-IP $remote_addr;
proxy_set_header X-Forwarded-For $proxy_add_x_forwarded_for;
proxy_set_header X-Forwarded-Port 80;
proxy_set_header X-Forwarded-Proto https;
proxy_connect_timeout 150;
proxy_send_timeout 100;
proxy_read_timeout 100;
proxy_buffers 4 32k;
client_max_body_size 8m;
client_body_buffer_size 128k;
}
}
Nastavení Apache
<VirtualHost *:80>
ServerName example.com
ServerAdmin webmaster@localhost
DocumentRoot /var/www/html
RemoteIPHeader X-Real-IP
RemoteIPInternalProxy 192.168.0.99
ErrorLog ${APACHE_LOG_DIR}/error.log
CustomLog ${APACHE_LOG_DIR}/access.log combined
</VirtualHost>
Modul remoteip jsem povolil
a2enmod remoteipApache jsem restartoval
systemctl restart apache2Soubor access.log
192.168.0.99 - - [08/Apr/2018:01:27:06 +0200] "GET / HTTP/1.0" 200 260 "-" "Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:59.0) Gecko/20100101 Firefox/59.0" 192.168.0.99 - - [08/Apr/2018:01:27:14 +0200] "GET / HTTP/1.0" 200 262 "-" "Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:59.0) Gecko/20100101 Firefox/59.0" 192.168.0.99 - - [08/Apr/2018:01:29:05 +0200] "GET / HTTP/1.0" 304 142 "-" "Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:59.0) Gecko/20100101 Firefox/59.0"
combined formát logu, aby se místo hostname logovala hlavička X-Real-IP:
LogFormat "%{X-Real-IP}i %l %u %t \"%r\" %>s %b \"%{Referer}i\" \"%{User-Agent}i\"" combined
LogFormat "%{X-Real-IP}i %l %u %t \"%r\" %>s %b \"%{Referer}i\" \"%{User-Agent}i\"" combined
ale tohle ano
LogFormat "%{X-Real-IP}i %l %u %t \"%r\" %>s %b \"%{Referer}i\" \"%{User-Agent}i\"" warn
LogFormat "%{X-Real-IP}i %l %u %t \"%r\" %>s %b \"%{Referer}i\" \"%{User-Agent}i\"" info
LogFormat "%{X-Real-IP}i %l %u %t \"%r\" %>s %b \"%{Referer}i\" \"%{User-Agent}i\"" notice
LogFormat "%{X-Real-IP}i %l %u %t \"%r\" %>s %b \"%{Referer}i\" \"%{User-Agent}i\"" debug
Mám tedy nechat něco jiného než combined?
BTW: a to co tady psal uživatel vencour o GDPR, můžu takovou konfiguraci ve finále legálně používat nebo ne? Nerad bych se dostal do nějakých problémů.
Kazda domena z tech x koncovych stroju ma svuj vlastni certifikat?Ano
Na proxy urcis jenom cestu a ssl ukoncis na koncovych strojich.Tuto variantu bych chtěl ale nevím jak.
Nebo to udelas tak ze ssl ukoncis na proxy a pak posilas na koncove stroje nesifrovany trafic.Takto to nechci
V cem je problem? Napsat konfiguraci?Ano, napsat konfiguraci
Pouzivas httpd nebo neco jineho?Na tuto otázku nedokážu přesně odpovědět jelikož ji nerozumím:(
Co přesně má být výsledkem?Potřebuji aby proxy přesměrovalo https (podle nazvu domény) na danou IP adresu, ale bez toho, abych nemusel ssl certifikáty řešit v tom proxy ale až na cílovém stroji. Něco takového ale nefunguje to.
server {
listen 443;
server_name www.domena1.net;
location / {
proxy_pass https://192.168.1.101;
proxy_set_header Host $host;
proxy_set_header X-Real-IP $remote_addr;
proxy_set_header X-Forwarded-For $proxy_add_x_forwarded_for;
proxy_connect_timeout 150;
proxy_send_timeout 100;
proxy_read_timeout 100;
proxy_buffers 4 32k;
client_max_body_size 8m;
client_body_buffer_size 128k;
}
}
server {
listen 443;
server_name www.domena2.net;
location / {
proxy_pass https://192.168.1.102;
proxy_set_header Host $host;
proxy_set_header X-Real-IP $remote_addr;
proxy_set_header X-Forwarded-For $proxy_add_x_forwarded_for;
proxy_connect_timeout 150;
proxy_send_timeout 100;
proxy_read_timeout 100;
proxy_buffers 4 32k;
client_max_body_size 8m;
client_body_buffer_size 128k;
}
}
<VirtualHost *:443> ServerName www.domena1.net SSLProxyEngine On SSLProxyCheckPeerCN on SSLProxyCheckPeerExpire on ProxyPass / https://192.168.0.101 ProxyPassReverse / https://192.168.0.101 </VirtualHost> <VirtualHost *:443> ServerName www.domena2.net SSLProxyEngine On SSLProxyCheckPeerCN on SSLProxyCheckPeerExpire on ProxyPass / https://192.168.0.102 ProxyPassReverse / https://192.168.0.102 </VirtualHost>Ale Apache nejde restartovat, journalctl -xe vypíše
-- Unit apache2.service has failed. -- -- The result is failed. Mar 20 01:36:09 100 systemd[1]: apache2.service: Unit entered failed state. Mar 20 01:36:09 100 systemd[1]: apache2.service: Failed with result 'exit-code'. Mar 20 01:38:17 100 systemd[1]: Starting The Apache HTTP Server... -- Subject: Unit apache2.service has begun start-up -- Defined-By: systemd -- Support: https://www.debian.org/support -- -- Unit apache2.service has begun starting up. Mar 20 01:38:18 100 apachectl[1683]: AH00558: apache2: Could not reliably determine the server's fully qualified domain name, using 0.0.0.100. Set the 'ServerName' directive global Mar 20 01:38:18 100 apachectl[1683]: (98)Address already in use: AH00072: make_sock: could not bind to address [::]:443 Mar 20 01:38:18 100 apachectl[1683]: (98)Address already in use: AH00072: make_sock: could not bind to address 0.0.0.0:443 Mar 20 01:38:18 100 apachectl[1683]: no listening sockets available, shutting down Mar 20 01:38:18 100 apachectl[1683]: AH00015: Unable to open logs Mar 20 01:38:18 100 apachectl[1683]: Action 'start' failed. Mar 20 01:38:18 100 apachectl[1683]: The Apache error log may have more information. Mar 20 01:38:18 100 systemd[1]: apache2.service: Control process exited, code=exited status=1 Mar 20 01:38:18 100 systemd[1]: Failed to start The Apache HTTP Server. -- Subject: Unit apache2.service has failed -- Defined-By: systemd -- Support: https://www.debian.org/support -- -- Unit apache2.service has failed. -- -- The result is failed. Mar 20 01:38:18 100 systemd[1]: apache2.service: Unit entered failed state. Mar 20 01:38:18 100 systemd[1]: apache2.service: Failed with result 'exit-code'.Co je prosím špatně? Díky
Mar 20 01:38:18 100 apachectl[1683]: (98)Address already in use: AH00072: make_sock: could not bind to address [::]:443Nemuze se pripojit na port 443 - uz na nem nejspis neco posloucha.
Mar 20 01:38:18 100 apachectl[1683]: (98)Address already in use: AH00072: make_sock: could not bind to address 0.0.0.0:443
Tiskni
Sdílej: