abclinuxu.cz AbcLinuxu.cz itbiz.cz ITBiz.cz HDmag.cz HDmag.cz abcprace.cz AbcPráce.cz
AbcLinuxu hledá autory!
Inzerujte na AbcPráce.cz od 950 Kč
Rozšířené hledání
×
    dnes 21:11 | Nová verze

    Byla vydána nová verze 2.0 klienta F-Droid určeného pro instalaci bezplatných a otevřených mobilních aplikací do Androidu ze softwarového repozitáře F-Droid (Wikipedie). Jedná se o alternativu k Google Play.

    Ladislav Hagara | Komentářů: 1
    dnes 12:11 | Komunita

    Debian Inference Portal nabízí vývojářům Debianu bezplatný přístup ke službám AI/LLM. Sponzorem je společnost Scaleway.

    Ladislav Hagara | Komentářů: 1
    dnes 11:44 | Bezpečnostní upozornění

    Robert Ressl nalezl ve WordPressu kritickou zranitelnost CVE-2026-87902 s CVSS 9.2. Útočníkům umožňuje neoprávněný přístup k souborům a vzdálené spuštění kódu (RCE). Opravena je ve verzích 7.1.2, 7.0.6, 6.9.9…

    Ladislav Hagara | Komentářů: 1
    dnes 03:33 | IT novinky

    Společnost Meta na dvoudenní konferenci Meta Connect 2026 představuje své novinky. Vypíchnout lze lehké brýle s funkci VR Meta VR Glasses. Do prodeje půjdou na jaře 2027 za cenu 1299,99 dolarů.

    Ladislav Hagara | Komentářů: 1
    včera 14:44 | Nová verze

    Google Chrome 154 byl prohlášen za stabilní. Nejnovější stabilní verze 154.0.8037.57 přináší řadu novinek. Podrobný přehled v poznámkách k vydání. Opraveno bylo 108 bezpečnostních chyb. Vylepšeny byly také nástroje pro vývojáře.

    Ladislav Hagara | Komentářů: 7
    včera 14:33 | IT novinky

    Vláda sníží v příštím roce výdaje na IT služby státu o 1,4 miliardy korun. Úspory má umožnit lepší koordinace nákupu služeb napříč resorty prostřednictvím nového zmocněnce. Celkové roční výdaje státu na informační technologie a digitalizaci se podle údajů ministerstva průmyslu a obchodu pohybují okolo 20 až 25 miliard korun ročně, pro letošek bylo na 320 projektů vyčleněno 21 miliard.

    Ladislav Hagara | Komentářů: 3
    včera 14:22 | IT novinky

    Irská komise pro ochranu dat (DPC) uložila americké technologické společnosti Google ze skupiny Alphabet pokutu 403 milionů eur (9,8 miliardy Kč) za neoprávněné nakládání s údaji o poloze uživatelů. Firma podle komise porušila evropské nařízení o ochraně osobních údajů (GDPR). DPC uvedla, že při šetření zjistila, že si lidé nemuseli být vědomi skutečnosti, že jejich poloha byla využívána například k ovlivňování prostřednictvím reklam nebo k odvozování jejich zájmů, a mohli tak ztratit kontrolu nad svými osobními údaji.

    Ladislav Hagara | Komentářů: 2
    včera 02:11 | IT novinky

    Byla oznámena beta verze nového video kodeku Pyrowave pro streamování her v Steam Remote Play. S vysokou propustností a nízkou latencí. S podporou HDR a YUV 4:4:4.

    Ladislav Hagara | Komentářů: 0
    včera 01:11 | Nová verze

    Byl vydán Sublime Text 4 Build 4213. Sublime Text (Wikipedie) je proprietární multiplatformní editor textových souborů a zdrojových kódů. Ke stažení a k vyzkoušení je zdarma. Pro další používání je nutná licence v ceně 99 dolarů. Spolu se Sublime Merge je cena 168 dolarů.

    Ladislav Hagara | Komentářů: 0
    22.9. 21:55 | Zajímavý článek

    Firma Anthropic, tvůrce AI modelu Claude, začala v oblasti Sanfranciského zálivu v tichosti provozovat vlastní biotechnologickou laboratoř. Anthropic prý chce pomocí AI urychlit hledání léků na nemoci, jimž farmaceutický průmysl dle názoru firmy věnuje příliš málo pozornosti. Firma tvrdí, že laboratoř se zatím soustředí především na základní biologii, nikoli přímo na vývoj léčiv. Farmaceutický výzkum je pro generálního ředitele Daria Amodeie velice osobní téma, jeho otec zemřel na hepatitidu C několik málo let před objevením účinné léčby.

    AfD 💙 | Komentářů: 6
    Které desktopové prostředí na Linuxu používáte?
     (9%)
     (7%)
     (4%)
     (21%)
     (29%)
     (8%)
     (5%)
     (2%)
     (14%)
     (21%)
    Celkem 2726 hlasů
     Komentářů: 31, poslední 13.8. 00:27
    Rozcestník

    Dotaz: Mediawiki internal server error

    26.4.2018 09:13 Jack Hokus | skóre: 34 | blog: LostHeaven
    Mediawiki internal server error
    Přečteno: 598×
    Dobrý den,

    na testovací server ve virtualboxu jsem si nahodil mediawiki. Po spuštění jsem dostal chybovou hlášku: MediaWiki 1.30 internal error Installing some PHP extensions is required.

    Php mám nainstalováno, php admin jede bez problémů. Zkoušel jsem hledat, ale zatím jsem nic nenašel, má někdo nějaký nápad?

    Petr
    http://www.jackhokus.cz/

    Odpovědi

    26.4.2018 09:18 Petr
    Rozbalit Rozbalit vše Re: Mediawiki internal server error
    Php-xml a php-mbstring mas?
    26.4.2018 09:42 Jack Hokus | skóre: 34 | blog: LostHeaven
    Rozbalit Rozbalit vše Re: Mediawiki internal server error
    Dobrý den,

    zkoušel jsem vyhledat vámi uvedený balíček Php-xml a našel jsem jen tyto:
    • php5-xmlrpc php-libkolabxml1
    • php5-xmlreader
    • php5-xmlrpc
    • php5-xmlwriter
    • php7-xmlreader instalováno
    • php7-xmlrpc
    • php7-xmlwriter instalováno
    Druhý balíček jsem nenašel vůbec. Našel jsem dotaz podobný svému na tomto fóru, tak jsem hledal i mezi moduly pro apache, ale taky jsem nenašel.

    Můžete mi prosím poradit, kde hledat? Pokud jde o mnou používanou distribuci, tak je to OpenSuSe.

    Děkuji

    http://www.jackhokus.cz/
    26.4.2018 09:59 tf
    Rozbalit Rozbalit vše Re: Mediawiki internal server error
    No a na jake distribuci to zkousite?
    26.4.2018 10:34 Jack Hokus | skóre: 34 | blog: LostHeaven
    Rozbalit Rozbalit vše Re: Mediawiki internal server error
    Dobrý den,

    zkouším to na OpenSuSe

    http://www.jackhokus.cz/
    26.4.2018 10:02 NN
    Rozbalit Rozbalit vše Re: Mediawiki internal server error
    Podivej se do logu Apache, tam bude detail toho erroru..
    26.4.2018 10:30 Jack Hokus | skóre: 34 | blog: LostHeaven
    Rozbalit Rozbalit vše Re: Mediawiki internal server error
    Dobrý den,

    do logů jsem se právě podíval. Jsou tam dva soubory, jednak access_log a error_log

    V souboru error_log je toto
    [Thu Apr 26 07:38:25.784087 2018] [ssl:warn] [pid 1655] AH01873: Init: Session Cache is not configured [hint: SSLSessionCache]
    [Thu Apr 26 07:38:25.845490 2018] [mpm_prefork:notice] [pid 1655] AH00163: Apache/2.4.23 (Linux/SUSE) OpenSSL/1.0.2j-fips PHP/7.0.7 configured -- resuming normal operations
    [Thu Apr 26 07:38:25.845523 2018] [core:notice] [pid 1655] AH00094: Command line: '/usr/sbin/httpd-prefork -D SYSCONFIG -C PidFile /var/run/httpd.pid -C Include /etc/apache2/sysconfig.d//loadmodule.conf -C Include /etc/apache2/sysconfig.d//global.conf -f /etc/apache2/httpd.conf -c Include /etc/apache2/sysconfig.d//include.conf -D SYSTEMD -D FOREGROUND'
    
    Soubor access_log obsahuje toto:
    192.168.32.131 - - [25/Apr/2018:11:51:42 +0200] "GET /phpMyAdmin/js/codemirror/addon/lint/sql-lint.js?v=4.8.0.1 HTTP/1.1" 200 1048 "-" "Mozilla/5.0 (X11; Linux x86_64; rv:52.0) Gecko/20100101 Firefox/52.0"
    192.168.32.131 - - [25/Apr/2018:11:51:42 +0200] "GET /phpMyAdmin/js/vendor/codemirror/addon/lint/lint.js?v=4.8.0.1 HTTP/1.1" 200 8609 "-" "Mozilla/5.0 (X11; Linux x86_64; rv:52.0) Gecko/20100101 Firefox/52.0"
    192.168.32.131 - - [25/Apr/2018:11:51:42 +0200] "GET /phpMyAdmin/js/console.js?v=4.8.0.1 HTTP/1.1" 200 57278 "-" "Mozilla/5.0 (X11; Linux x86_64; rv:52.0) Gecko/20100101 Firefox/52.0"
    192.168.32.131 - - [25/Apr/2018:11:51:42 +0200] "GET /phpMyAdmin/themes/dot.gif HTTP/1.1" 200 43 "-" "Mozilla/5.0 (X11; Linux x86_64; rv:52.0) Gecko/20100101 Firefox/52.0"
    192.168.32.131 - - [25/Apr/2018:11:51:42 +0200] "GET /phpMyAdmin/themes/pmahomme/img/logo_right.png HTTP/1.1" 200 4306 "-" "Mozilla/5.0 (X11; Linux x86_64; rv:52.0) Gecko/20100101 Firefox/52.0"
    192.168.32.131 - - [25/Apr/2018:11:51:42 +0200] "GET /phpMyAdmin/themes/pmahomme/img/b_help.png HTTP/1.1" 200 705 "-" "Mozilla/5.0 (X11; Linux x86_64; rv:52.0) Gecko/20100101 Firefox/52.0"
    ::1 - - [25/Apr/2018:11:51:57 +0200] "OPTIONS * HTTP/1.0" 200 - "-" "Apache/2.4.23 (Linux/SUSE) OpenSSL/1.0.2j-fips PHP/7.0.7 (internal dummy connection)"
    ::1 - - [25/Apr/2018:11:51:58 +0200] "OPTIONS * HTTP/1.0" 200 - "-" "Apache/2.4.23 (Linux/SUSE) OpenSSL/1.0.2j-fips PHP/7.0.7 (internal dummy connection)"
    ::1 - - [25/Apr/2018:11:51:59 +0200] "OPTIONS * HTTP/1.0" 200 - "-" "Apache/2.4.23 (Linux/SUSE) OpenSSL/1.0.2j-fips PHP/7.0.7 (internal dummy connection)"
    192.168.32.131 - - [25/Apr/2018:11:55:39 +0200] "GET /phpMyAdmin/ HTTP/1.1" 200 14150 "-" "Mozilla/5.0 (X11; Linux x86_64; rv:52.0) Gecko/20100101 Firefox/52.0"
    192.168.32.131 - - [25/Apr/2018:11:55:57 +0200] "GET /mediawiki/ HTTP/1.1" 500 921 "-" "Mozilla/5.0 (X11; Linux x86_64; rv:52.0) Gecko/20100101 Firefox/52.0"
    192.168.32.131 - - [26/Apr/2018:08:33:40 +0200] "GET /mediawiki/ HTTP/1.1" 500 921 "-" "Mozilla/5.0 (X11; Linux x86_64; rv:52.0) Gecko/20100101 Firefox/52.0"
    192.168.32.131 - - [26/Apr/2018:08:33:40 +0200] "GET /mediawiki/resources/assets/mediawiki.png HTTP/1.1" 200 22508 "http://192.168.32.131/mediawiki/" "Mozilla/5.0 (X11; Linux x86_64; rv:52.0) Gecko/20100101 Firefox/52.0"
    192.168.32.131 - - [26/Apr/2018:08:33:40 +0200] "GET /favicon.ico HTTP/1.1" 404 1036 "-" "Mozilla/5.0 (X11; Linux x86_64; rv:52.0) Gecko/20100101 Firefox/52.0"
    192.168.32.131 - - [26/Apr/2018:08:33:40 +0200] "GET /favicon.ico HTTP/1.1" 404 1036 "-" "Mozilla/5.0 (X11; Linux x86_64; rv:52.0) Gecko/20100101 Firefox/52.0"
    192.168.32.131 - - [26/Apr/2018:09:06:36 +0200] "GET /mediawiki HTTP/1.1" 301 240 "-" "Mozilla/5.0 (X11; Linux x86_64; rv:52.0) Gecko/20100101 Firefox/52.0"
    192.168.32.131 - - [26/Apr/2018:09:06:36 +0200] "GET /mediawiki/ HTTP/1.1" 500 921 "-" "Mozilla/5.0 (X11; Linux x86_64; rv:52.0) Gecko/20100101 Firefox/52.0"
    
    Nevím, co přesně hledat, tak jsem to bral podle data. Pokud je třeba něco dodat, dejte vědět.
    http://www.jackhokus.cz/
    26.4.2018 11:08 Aleš Kapica | skóre: 52 | blog: kenyho_stesky | Ostrava
    Rozbalit Rozbalit vše Re: Mediawiki internal server error
    Jasně ti to píše, že chybí nějaké rozšíření. Nevím jakým postupem jsi to instaloval, ale vypadá to, jako bys použil nějaký konfigurák, co obsahuje nastavení pro nějaké rozšíření, jaké nemáš.

    Já v takovém případě nejprve zakomentuji všechna rozšíření a pak je postupně povoluji, dokud se neobjeví ta chyba. Může to být totiž i jeho špatnou verzí.
    26.4.2018 11:43 Jack Hokus | skóre: 34 | blog: LostHeaven
    Rozbalit Rozbalit vše Re: Mediawiki internal server error
    Dobrý den,

    vycházel jsem z několika návodů:

    Mediawiki 1 Mediawiki 2 Apache, databáze, PHP admin

    Pokud jde o ty konfigurační soubory, tak jsem žádné nepřebíral, nainstaloval jsem balíčky podle návodu. Takže všechny konfigurační soubory jsou distribuční. Tohle je můj první pokus o něco takového, takže jediný konfigurační soubor, který mne v této souvislosti mne napadá je php.ini, měl jste na mysli ten, nebo jiný?

    Petr

    http://www.jackhokus.cz/
    26.4.2018 13:32 Aleš Kapica | skóre: 52 | blog: kenyho_stesky | Ostrava
    Rozbalit Rozbalit vše Re: Mediawiki internal server error
    Kdepák.. Hlavní konfigurační soubor MediaWiki je LocalSettings.php v kořenu adresáře kde jsou zdrojáky.

    Jinak se omlouvám, ale videonávody jsou upřímně řečeno na hovno. Stejně jako instalace přes klikátka. Ovšem každopádně výsledkem instalačního procesu by měl být výše zmíněný soubor.

    26.4.2018 19:47 Jack Hokus | skóre: 34 | blog: LostHeaven
    Rozbalit Rozbalit vše Re: Mediawiki internal server error
    Dobrý večer,

    není se za co omlouvat, teď už jsem doma, zítra se na to mrknu. O existenci konfiguračního souboru LocalSettings.php jsem neměl ani ponětí.

    Petr
    http://www.jackhokus.cz/
    30.4.2018 08:45 Jack Hokus | skóre: 34 | blog: LostHeaven
    Rozbalit Rozbalit vše Re: Mediawiki internal server error
    Dobrý den,

    při hledání řešení jsem pro sebe objevil příkaz php -m, takže tady je seznam u modulů.
    [PHP Modules]
    bz2
    Core
    ctype
    curl
    date
    dom
    filter
    gd
    gettext
    hash
    iconv
    json
    libxml
    mbstring
    mysqli
    mysqlnd
    openssl
    pcre
    PDO
    pdo_mysql
    pdo_sqlite
    Reflection
    session
    SimpleXML
    SPL
    sqlite3
    standard
    tokenizer
    xml
    xmlreader
    xmlrpc
    xmlwriter
    zip
    
    http://www.jackhokus.cz/
    30.4.2018 08:50 Aleš Kapica | skóre: 52 | blog: kenyho_stesky | Ostrava
    Rozbalit Rozbalit vše Re: Mediawiki internal server error
    No. Jelikož křišťálovou kouli nemám, tak ti alespoň přihodím seznam modulů které mám nainstalované na serveru co mi běží wiki já. Pozn.: Výpisy jsou dva, protože ty servery spravuji dva.
    [PHP Modules]
    bz2
    calendar
    Core
    ctype
    date
    dom
    exif
    fileinfo
    filter
    ftp
    gd
    gettext
    hash
    iconv
    json
    libxml
    mbstring
    mysqli
    mysqlnd
    openssl
    pcntl
    pcre
    PDO
    pdo_mysql
    Phar
    posix
    readline
    Reflection
    session
    shmop
    SimpleXML
    sockets
    SPL
    standard
    sysvmsg
    sysvsem
    sysvshm
    tokenizer
    wddx
    xml
    xmlreader
    xmlwriter
    xsl
    Zend OPcache
    zip
    zlib
    
    [Zend Modules]
    Zend OPcache
    
    
    Tohle je ten druhý
    [PHP Modules]
    bcmath
    bz2
    calendar
    Core
    ctype
    date
    dba
    dom
    ereg
    exif
    fileinfo
    filter
    ftp
    gd
    gettext
    hash
    iconv
    imap
    json
    ldap
    libxml
    mbstring
    mcrypt
    memcache
    memcached
    mhash
    mysql
    mysqli
    openssl
    pcntl
    pcre
    PDO
    pdo_mysql
    Phar
    posix
    readline
    Reflection
    session
    shmop
    SimpleXML
    soap
    sockets
    SPL
    standard
    sysvmsg
    sysvsem
    sysvshm
    tokenizer
    wddx
    xml
    xmlreader
    xmlrpc
    xmlwriter
    Zend OPcache
    zip
    zlib
    
    [Zend Modules]
    Zend OPcach
    
    30.4.2018 10:38 NN
    Rozbalit Rozbalit vše Re: Mediawiki internal server error
    a nebo se podivam do manualu..

    Založit nové vlákno • Nahoru

    Tiskni Sdílej: Linkuj Jaggni to Vybrali.sme.sk Google Del.icio.us Facebook

    ISSN 1214-1267   www.czech-server.cz
    © 1999-2015 Nitemedia s. r. o. Všechna práva vyhrazena.