Byla vydána nová verze 10.6 sady aplikací pro SSH komunikaci OpenSSH. Přináší řadu důležitých bezpečnostních oprav, vylepšení funkcí a oprav chyb. Povoluje hybridní postkvantový podpisový algoritmus ssh-mldsa44-ed25519.
Americká společnost Reflection AI světu představila Beam, open-weight model s 501 miliardami parametrů (z toho 23 miliard aktivních), určený především pro programování a práci autonomních agentů. Podle autorů jejich model nabízí výkon srovnatelný s většími modely při výrazně nižších nárocích na výpočetní výkon. Beam nyní ještě prochází závěrečným testováním, na stránkách Reflection AI se však lze zaregistrovat a získat předběžný přístup. Váhy modelu, dokumentace a nástroje pro vývojáře mají být zveřejněny v průběhu tohoto měsíce.
OpenCourant je komunitní fork OpenRadioss, tj. open source softwaru pro simulace havárií, nárazů a vysoce nelineárních dynamických dějů metodou konečných prvků. Společnost Siemens v loňském roce dokončila akvizici společnosti Altair Engineering, jež před čtyřmi lety uvolnila open source verzi OpenRadioss svého proprietárního softwaru Radioss. Minulý týden Siemens OpenRadioss pohřbil. Integroval jej do svého softwaru Simcenter, webovou stránku OpenRadioss přesměroval na Simcenter a repozitář OpenRadioss na GitHubu odstranil.
Pořadatelé devátého ročníku komunitního setkání správců nejen českých a slovenských sítí – CSNOG 2027, které se uskuteční 20. a 21. ledna, vyhlásili Call for Abstracts. Náměty na vystoupení mohou zájemci přihlašovat do 31. října na webu akce a vybírat mohou ze tří sekcí – správa sítí, legislativa a regulace a akademické projekty. Zveřejněny byly také Call of Partners určené sponzorům a partnerům setkání, kteří by například chtěli mít na
… více »Strata je open-source inferenční engine, který umožňuje lokálně provozovat rozsáhlý čínský model Qwen3.8-Flash-Next, který by jinak nejspíše vyžadoval serverovou infrastrukturu, na běžném herním počítači s alespoň 12 GB VRAM, 32 GB RAM a dostatkem místa na SSD. Nároky na paměť a rychlost generování se liší s použitou variantou modelu Qwen. Zdrojový kód je dostupný na GitHubu, pod licencí MIT.
Americký prezident Donald Trump oznámil vznik federální Jednotky pro superinteligenci (Super Intelligence Force), která má koordinovat postup vlády, technologických firem, náboženských organizací a dalších institucí v oblasti rychle se rozvíjející umělé inteligence (Trumpem oficiálně nazývanou superinteligencí). SIF, podřízená přímo Trumpovi, má pomoci Spojeným státům udržet v oblasti SI technologický náskok nad světem a
… více »Klient je e-mailový klient pro GNOME s nativní podporou Proton Mailu, PGP a spamfiltrem řízeným AI. Napsaný je v Go s GTK4 a libadwaita. Připojuje se přímo k Proton Mailu (bez Proton Bridge), ke Gmailu, k Seznam.cz a k libovolné schránce IMAP/SMTP. Každou novou zprávu nejdřív posoudí spamfiltr a teprve potom ji ukáže a ohlásí. Rozhraní je česky a anglicky.
Hra Doom nově běží také v SQL databázi CedarDB. Představen byl SQLDoom. Vyzkoušet lze online demo. Zdrojové kódy jsou k dispozici na GitHubu.
Multiplatformní open source aplikace scrcpy (Wikipedie) pro zrcadlení připojeného zařízení se systémem Android na desktopu a umožňující ovládání tohoto zařízení z desktopu, byla vydána v nové verzi 5.0. S podporou hardwarového dekódování videa na desktopu.
Moderní linker mold, rychlejší alternativa k LLVM lld nebo wild, byl vydán v nové major verzi 3.0.0. Přepsán byl z C++ do Rustu.
ping –c3 tecmint.lan #Domain Name vypíše IP jedno DC $ ping –c3 adc1.tecmint.lan #FQDN vypíše IP adc1 $ ping –c3 adc1 #Host vypíše IP adc1 $ host –t tecmint.lan vypíše IP jedno DC $ host –t adc1.tecmint.lan vypíše IP adc1 $ host –t SRV _kerberos._udp.tecmint.lan # UDP Kerberos SRV record vypise hostname jednotlivých dc ve tvaru adc1.tecmint.lan $ host -t SRV _ldap._tcp.tecmint.lan # TCP LDAP SRV record vypise hostname jednotlivých dc ve tvaru adc1.tecmint.lan host objectGUID._msdcs.tecmint.lan Vypíše IP odpovídajících IP Všechny tyto testy DNS jsem ověřil na jednotlivých DC a všude to funguje
3 - opravil db příkazem:cat /etc/hosts 127.0.0.1 localhost verejnaip dc2.tecmint.lan dc2 verejnaip dc1.tecmint.lan dc1 cat /etc/hostname dc1 cat /etc/resolv.conf cat /etc/resolv.conf domain tecmint.lan search tecmint.lan nameserver verejnaip toho konkretniho DC cat /etc/samba/smb.conf cat /etc/samba/smb.conf # Global parameters [global] netbios name = DC1 realm = TECMINT.LAN workgroup = TECMINT server role = active directory domain controller dns forwarder = 8.8.8.8 log level = 3 [netlogon] path = /var/lib/samba/sysvol/tecmint.lan/scripts read only = No [sysvol] path = /var/lib/samba/sysvol read only = No cat /etc/krb5.conf [libdefaults] default_realm = TECMINT.LAN dns_lookup_realm = false dns_lookup_kdc = true
4 - na DC1, které má všechny role syncl čas ntp.cesnet.cz. Ostatní DC si syncují čas z DC1 5 - z jednoho stroje přehrál tdbbackup -s .bak /var/lib/samba/private/idmap.ldb na ostatní 6- z jednoho stroje rsyncem syncuji sysvol na ostatnisamba-tool dbcheck --cross-ncs --fix
7 - resetoval acl na policies a od té doby příkaz samba-tool ntacl sysvolcheck na žádném DC nic nevypíše takže to je ok. Po té co jsem udělal kroky výše, doména se stala stabilnější, replikace ani na jednom stroji nehlásí errory. Když jedno DC vypnu klienti se připojí na druhé. Ale nepomohlo mně to na opravu GPO, jediné co se tedy opravilo je, že je můžu vytvářet. Ale když dám gpupdate, tak to vypíše:rsync -XAavz --delete-after --progress --stats /var/lib/samba/sysvol/ root@dc2:/usr/local/samba/var/locks/sysvol/
Myslel jsem tedy, že pomůže dát novější sambu. Vzal jsem tedy stroj DC3 se sambou Version 4.5.16-Debian. Připojil do domény, provedl replikaci. Je ještě potřeba něco dělat? Protože když ostatní DC vypnu, tak se ke klientům připojí jen ADMINI, ostatním userům to píše přístup odepřen. Nový stroj jde k novému dc připojit i když vypnu stávajíc dva staré. Replikace ani na jednom ze tří strojů nehlásí chyby. Zkusil jsem i verzi Version 4.9.8-Debian. Stáhl jsem balík někde z netu, tak snad je ok. Ke stroji se normálně připojila, ale samba nenaběhne.Updating Policy... User policy could not be updated successfully. The following errors were encount ered: The processing of Group Policy failed. Windows could not determine if the user a nd computer accounts are in the same forest. Ensure the user domain name matches the name of a trusted domain that resides in the same forest as the computer ac count. Computer Policy update has completed successfully. To diagnose the failure, review the event log or run GPRESULT /H GPReport.html f rom the command line to access information about Group Policy results. C:\GPRESULT /H GPReport.html INFO: The user "TECMINT\Administrator" does not have RSOP data.
Napadá někoho čím by to ještě mohlo být? Dá se nějak nastavení resetovat na defaultní hodnoty? Případně co dál ještě lze udělat?Jun 7 00:32:35 adc1 winbindd[751]: [2019/06/07 00:32:35.669334, 0] ../source3/winbindd/winbindd_cache.c:3160(initialize_winbindd_cache) Jun 7 00:32:35 adc1 winbindd[751]: initialize_winbindd_cache: clearing cache and re-creating with version number 2 Jun 7 00:32:35 adc1 winbindd[751]: [2019/06/07 00:32:35.681141, 0] ../source3/winbindd/winbindd_util.c:131(add_trusted_domain) Jun 7 00:32:35 adc1 winbindd[751]: add_trusted_domain: Got null SID for domain [zakaznici] Jun 7 00:32:35 adc1 winbindd[751]: [2019/06/07 00:32:35.682859, 0] ../source3/winbindd/winbindd_util.c:1245(init_domain_list) Jun 7 00:32:35 adc1 winbindd[751]: init_domain_list: init_domain_list_dc failed Jun 7 00:32:35 adc1 winbindd[751]: [2019/06/07 00:32:35.687269, 0] ../source3/winbindd/winbindd.c:1454(winbindd_register_handlers) Jun 7 00:32:35 adc1 winbindd[751]: unable to initialize domain list Jun 7 00:32:35 adc1 samba: task[winbindd_parent][746]: [2019/06/07 00:32:35.713580, 0] ../source4/winbind/winbindd.c:46(winbindd_done) Jun 7 00:32:35 adc1 samba: task[winbindd_parent][746]: winbindd daemon died with exit status 1 Jun 7 00:32:35 adc1 samba: task[winbindd_parent][746]: [2019/06/07 00:32:35.714446, 0] ../source4/smbd/service_task.c:36(task_server_terminate) Jun 7 00:32:35 adc1 samba: task[winbindd_parent][746]: task_server_terminate: task_server_terminate: [winbindd child process exited]
Je možné vyzálohovat pouze počítače a uživatele a vše obnovit do nového čistého DC?To bude asi nejjednodušší dělat z Windows. Nikdy jsem to netestoval, ale snad by mohlo fungovat tohle: Active Directory user backup and recovery tool.
[2019/06/17 06:25:12.544457, 2] ../source3/winbindd/winbindd_rpc.c:333(rpc_name_to_sid) name_to_sid: failed to lookup name: NT_STATUS_NONE_MAPPED [2019/06/18 16:41:19.417299, 3] ../source4/auth/kerberos/krb5_init_context.c:80(smb_krb5_debug_wrapper) Kerberos: target ^B does not have secrets at this KDC, need to proxy [2019/06/18 16:41:19.417363, 3] ../source4/auth/kerberos/krb5_init_context.c:80(smb_krb5_debug_wrapper) Kerberos: Failed building TGS-REP to ipv4:x.x.x.x:10079 [2019/06/18 16:41:19.417424, 3] ../source4/smbd/service_stream.c:66(stream_terminate_connection) Terminating connection - 'kdc_tcp_call_loop: proxying requested when not RODC' [2019/06/18 16:41:23.777427, 3] ../lib/ldb-samba/ldb_wrap.c:325(ldb_wrap_connect) ldb_wrap open of secrets.ldb
Tiskni
Sdílej: