abclinuxu.cz AbcLinuxu.cz itbiz.cz ITBiz.cz HDmag.cz HDmag.cz abcprace.cz AbcPráce.cz
AbcLinuxu hledá autory!
Inzerujte na AbcPráce.cz od 950 Kč
Rozšířené hledání
×
    dnes 16:11 | Nová verze

    Adaptable Linux Platform je nová distribuce od SUSE, která má v budoucnu nahradit SLE (openSUSE Leap); navazuje na stávající SLE Micro. Základem je „neměnný“ HostOS, aplikace běží v kontejnerech. Nyní jsou dostupné obrazy prototypu nazvaného „Les Droites“. Zatím má podporovat především šifrování disku a kontejnerizaci, ale bez větší integrace.

    Fluttershy, yay! | Komentářů: 2
    dnes 14:33 | Komunita

    Mesa umí skrze VA-API hardwarovou podporu H.264, H.265 a VC-1. Ve Fedora Linuxu ale musí být tato podpora z důvodů softwarových patentů zakázána.

    Ladislav Hagara | Komentářů: 6
    dnes 08:00 | IT novinky

    Intel na dvoudenní akci Intel Innovation 2022 představuje své novinky. První den představil 13. generaci procesorů Intel Core. Nejvýkonnější Intel Core i9-13900K má 24 jader (8 výkonných a 16 úsporných) a 32 vláken a může běžet až na 5,8 GHz. Jeho cena je 589 dolarů.

    Ladislav Hagara | Komentářů: 8
    včera 22:22 | IT novinky

    Sociální síť VK (VKontaktě) a další VK aplikace byly odstraněny z App Store [Заявление от VK].

    Ladislav Hagara | Komentářů: 30
    včera 21:22 | Nová verze

    Google Chrome 106 byl prohlášen za stabilní. Nejnovější stabilní verze 106.0.5249.61 přináší řadu oprav a vylepšení (YouTube). Opraveno bylo 20 bezpečnostních chyb. Vylepšeny byly také nástroje pro vývojáře (YouTube).

    Ladislav Hagara | Komentářů: 0
    včera 19:44 | Nová verze

    Laboratoře CZ.NIC vydaly novou verzi 4.21.0 aplikace Datovka, tj. svobodné multiplatformní desktopové aplikace pro přístup k datovým schránkám a k trvalému uchovávání datových zpráv v lokální databázi. Nové vlastnosti: Nový formát databáze tagů. Staré databáze jsou automaticky převedeny na nový formát. Lze importovat účty z dat exportovaných z mobilní aplikace. Při generování emailů lze zvolit libovolnou kombinaci příloh, zda se má

    … více »
    Ladislav Hagara | Komentářů: 0
    včera 11:33 | Nová verze

    RSS čtečka NewsFlash byla vydána v nové major verzi 2.0. Proběhla portace na GTK 4 a libadwaita. Instalovat ji lze také z Flathubu.

    Ladislav Hagara | Komentářů: 2
    26.9. 23:00 | IT novinky Ladislav Hagara | Komentářů: 16
    26.9. 15:33 | Zajímavý článek

    Christian Hergert se rozepsal o novinkách v nejnovější verzi 43.0 integrovaného vývojového prostředí GNOME Builder. Instalovat ji lze už i z Flathubu.

    Ladislav Hagara | Komentářů: 4
    26.9. 14:33 | Zajímavý projekt

    Objective-See je neziskovka zaměřená na bezpečnost macOS. Vyvíjí open source nástroje, stojí za knihou The Art of Mac Malware (online zdarma) a organizuje konferenci #OBTS (Objective by the Sea).

    Ladislav Hagara | Komentářů: 2
    Bavíte se s chatboty na webových stránkách e-shopů, bank, mobilních operátorů atd.?
     (22%)
     (5%)
     (48%)
     (25%)
    Celkem 279 hlasů
     Komentářů: 0
    Rozcestník


    Dotaz: Debian a upgrade na testing :(

    16.2.2004 12:53 Josef Benes | skóre: 2
    Debian a upgrade na testing :(
    Přečteno: 249×
    Ahoj, Omlouvam se ,ze muj dotaz bude asi hloupej, sle uz nevim jak na to :( Nainstaloval jsem Knoppixe a myslenka byla ho pomoci apt-get upgrade prekopat na posledniho debiana s novym softem. Je to do desktopu, takze spis na hrani... Jenze jsem narazil na zavislosti :( Nejde mi skoro nic instalovat upgradovat a podobne protoze chybi a nejdou nainstalovt balicky libqt3-mt-de a nasledne pak libxcursor-dev, nepomuze ani volba apt-get -f install. Pokusil jsem se o upgrade na posledni testing verzi, kterou bych rad mel, jenze po stazeni cca 260 Mb v 500 balickach jsem opet skoncil na vyse uvedenych problemech, nevi nekdo jak z toho ?? Pripadne prilozim vypisy apt a podobne. Dik za kazdou rozumnou radu.

    Odpovědi

    wil-m avatar 16.2.2004 13:02 wil-m | skóre: 17
    Rozbalit Rozbalit vše Debian a upgrade na testing :(
    /etc/apt/sources.list by mel vypadat nejak takhle asi, pak by to melo jet v pohode. hlavne se musi dat po uprave toho souboru nejdrive apt-get update a pak apt-get upgrade. teprve pak bych daval instalace

    # Primary

    deb http://ftp.cz.debian.org/debian stable main contrib
    deb-src http://ftp.cz.debian.org/debian stable main contrib
    deb http://ftp.cz.debian.org/debian unstable main contrib
    deb-src http://ftp.cz.debian.org/debian unstable main contrib
    deb http://ftp.cz.debian.org/debian testing main contrib
    deb-src http://ftp.cz.debian.org/debian testing main contrib
    deb ftp://ftp.zcu.cz/pub/linux/debian stable main contrib
    deb-src ftp://ftp.zcu.cz/pub/linux/debian stable main contrib
    deb ftp://ftp.zcu.cz/pub/linux/debian unstable main contrib
    deb-src ftp://ftp.zcu.cz/pub/linux/debian unstable main contrib
    deb ftp://ftp.zcu.cz/pub/linux/debian testing main contrib
    deb-src ftp://ftp.zcu.cz/pub/linux/debian testing main contrib
    deb http://ftp.sh.cvut.cz/debian stable contrib main
    deb-src http://ftp.sh.cvut.cz/debian stable contrib main
    deb http://ftp.sh.cvut.cz/debian unstable contrib main
    deb-src http://ftp.sh.cvut.cz/debian unstable contrib main
    deb http://ftp.sh.cvut.cz/debian testing contrib main
    deb-src http://ftp.sh.cvut.cz/debian testing contrib main

    deb ftp://ftp.us.debian.org/debian stable main
    deb-src ftp://ftp.us.debian.org/debian stable main contrib
    deb ftp://ftp.us.debian.org/debian testing main contrib
    deb-src ftp://ftp.us.debian.org/debian testing main contrib
    deb ftp://ftp.us.debian.org/debian unstable main contrib
    deb-src ftp://ftp.us.debian.org/debian unstable main contrib
    16.2.2004 13:17 Josef Benes | skóre: 2
    Rozbalit Rozbalit vše Debian a upgrade na testing :(
    Tam bych problem nehledal, zdroje mam podobne a myslim, ze i spravne, prvini jsem dal apt-get update a teprve pak jsem zkousel upgradovat, mozna je tam problem s tim ,ze je to knoppix :(
    wil-m avatar 16.2.2004 13:27 wil-m | skóre: 17
    Rozbalit Rozbalit vše Debian a upgrade na testing :(
    ja mam mepis, ktery neni taky "cisty deb". pokud je tam vsude testing nebo unstable, tak uz po apt-get update a pak upgrade nevidim duvod, proc by to nemelo jet, mepis slape jak ma.
    16.2.2004 13:28 Maude Lebowski
    Rozbalit Rozbalit vše Debian a upgrade na testing :(
    Mozna byla chyba, ze jsi si neprecetl upgrdaovaci manual debianu. Tam je napsano ze se ma udelat

    (nechat ve zdrojich pouze testing nebo unstable)

    apt-get update

    apt-get dist-upgrade

    to je prave kvuli zavyslostem... jestli mas moznost, tak to udelej cele znova vcetne novce instalce knoppixu. Jinak proc jet na testing, kdyz tu mame unstable:-)
    16.2.2004 13:51 Josef Benes | skóre: 2
    Rozbalit Rozbalit vše Debian a upgrade na testing :(
    Tak jsem zkusil prepsat zdroje podle vyse uvedenych pak jsem provedl apt-get update (nejake ftp jsou nedostupne, ale jen par) a nasledne jsem provedl apt-det dist-upgrade a jsem tam kde jsem byl :(

    >apt-get dist-upgrade

    Reading Package Lists... Building Dependency Tree... You might want to run `apt-get -f install' to correct these. The following packages have unmet dependencies: libqt3-mt-dev: Depends: libxcursor-dev but it is not installed
    16.2.2004 14:04 Maude
    Rozbalit Rozbalit vše Debian a upgrade na testing :(
    a co udela to 'apt-get -f install'?
    16.2.2004 14:28 Josef Benes | skóre: 2
    Rozbalit Rozbalit vše Debian a upgrade na testing :(
    :/# apt-get -f install Reading Package Lists... Done Building Dependency Tree... Done Correcting dependencies... Done The following extra packages will be installed: libxcursor-dev The following NEW packages will be installed: libxcursor-dev 0 upgraded, 1 newly installed, 0 to remove and 683 not upgraded. 41 not fully installed or removed. Need to get 0B/29.2kB of archives. After unpacking 139kB of additional disk space will be used. Do you want to continue? [Y/n] Y (Reading database ... 113266 files and directories currently installed.) Unpacking libxcursor-dev (from .../libxcursor-dev_1.0.2-4_i386.deb) ... dpkg: error processing /var/cache/apt/archives/libxcursor-dev_1.0.2-4_i386.deb (--unpack): trying to overwrite `/usr/X11R6/include/X11/Xcursor/Xcursor.h', which is also in package xlibs-dev Errors were encountered while processing: /var/cache/apt/archives/libxcursor-dev_1.0.2-4_i386.deb E: Sub-process /usr/bin/dpkg returned an error code (1)
    wil-m avatar 16.2.2004 15:54 wil-m | skóre: 17
    Rozbalit Rozbalit vše Debian a upgrade na testing :(
    41 not fully installed or removed. chyba bude zrejme tady. jsou tam "zaseknuty nektery nedoreseny baliky. existuje prikaz na vyreseni tohohle problemu, ted si jen vzpomenout jaky :)) zkusil bych jeste odinstalovat onen balik xlibs-dev na kterym to taky rve a pak znova zkusit nainstalovat pozadovany balik a pak zase xlibs-dev... :/# apt-get -f install Reading vidim dobre, ze tam neni udano, ktery balik se ma nainstalovat nebo jsi ten udaj proste z nejake priciny smaznul? :)
    16.2.2004 18:25 Maude
    Rozbalit Rozbalit vše Debian a upgrade na testing :(
    dkg --fix-missing

    ale obavam se, ze tohle bude najelepsi odinstalovat ten balik a znova naisntalovat jinou versi.. chce to podrobnejsi zkoumani tech versi co jsou v ofifialni sade a knoppixu

    aby se nemuselo odinstalvavat vse co na tom zavysi je dobre davat na jednom radku v apt-install nebo dpkg vic souboru, jednu versi oninstalovat a druhou zaroven naisntalovat...
    17.2.2004 09:39 Josef Benes | skóre: 2
    Rozbalit Rozbalit vše Debian a upgrade na testing :(
    Tak se nedari ani ten balik xlibs-dev odinstalovat, ale aspon je videt co je tam za verzi. Treba to nekomu neco rekne :(

    apt-get remove xlibs-dev

    Reading Package Lists... Done

    Building Dependency Tree... Done

    You might want to run `apt-get -f install' to correct these:

    The following packages have unmet dependencies:

    libgtk1.2-dev: Depends: xlibs-dev but it is not going to be installed

    libmng-dev: Depends: xlibs-dev (>= 4.1.0-0) but it is not going to be installed

    libqt3-mt-dev: Depends: xlibs-dev (>= 4.2.1) but it is not going to be installed

    Depends: libxcursor-dev but it is not going to be installed

    libxaw7-dev: Depends: xlibs-dev but it is not going to be installed

    libxft2-dev: Depends: xlibs-dev but it is not going to be installed

    libxrender-dev: Depends: xlibs-dev (> 4.2.1) but it is not going to be installed

    xlibmesa-gl-dev: Depends: xlibs-dev but it is not going to be installed

    E: Unmet dependencies. Try 'apt-get -f install' with no packages (or specify a solution).
    17.2.2004 09:51 Robert Krátký | skóre: 94 | blog: Robertův bloček
    Rozbalit Rozbalit vše Debian a upgrade na testing :(
    Snazis se michat dohromady nekolik verzi XFree. Zjisti si, jaka verze X je v tom Knoppixu. Pokud je vyssi nez v unstable, budes mit s upgradem vzdy potize. Resenim by bylo upgradovat na xfree 4.3 z experimental vetve.

    Ty duplicitni soubory - u kterych ti selze instalace baliku - jsou prave dusledkem nekompatibilnich verzi XFree.

    Jedinym rozumnym resenim je postupne upgradovat vsechny konfliktni baliky a vytvorit 'cisty' unstable system (bez primesi knoppixovych verzi baliku). Pak ovsem pozbyva smyslu pouzivat jako zaklad ten Knoppix. Nejjednodussi by bylo stahnout minimalni inst. ISO Debianu a z nej provest rovnou instalaci unstable po siti.
    17.2.2004 09:58 Josef Benes | skóre: 2
    Rozbalit Rozbalit vše Debian a upgrade na testing :(
    No puvodne jsem tn knoppix bral jako zaklad pro unstable debian, ale nemel jsem debiani CD a tak jsem si myslel, ze se to da provest i tak, ze nainstaluji knoppix a pak z nej udelam unstable Debian. Jinak :
    # XFree86 -version
    
    XFree86 Version 4.3.0 (Debian 4.3.0-0ds4 20030416150820
     dstone@aedificator)
    Release Date: 18 March 2003
    X Protocol Version 11, Revision 0, Release 6.6
    Build Operating System: Linux 2.4.21-pre5 i686 [ELF]
    Build Date: 16 April 2003
            Before reporting problems, check http://www.XFree86.Org/
            to make sure that you have the latest version.
    Module Loader present
    OS Kernel: Linux version 2.4.22-xfs (root@Knoppix) (gcc
     version 2.95.4 20011002 (Debian prerelease)) #1 SMP Fr
     Sep 19 17:55:45 CEST 2003
    17.2.2004 12:01 Robert Krátký | skóre: 94 | blog: Robertův bloček
    Rozbalit Rozbalit vše Debian a upgrade na testing :(
    No, zde je jadro pudla. Ten Knoppix pouziva XFree 4.3, ktere uz pred pomernerne dlouhou dobou balickoval D. Stone. V Debian unstable je vsak stale jeste uz asi 16. verze XFree 4.2.1. Takze ted, kdyz se snazis 'upgradovat' na unstable, ve skutecnosti by se jednalo o _downgrade_. A pokud takovou vec nereknes aptu natvrdo, nebude se mu chtit.

    Doporucuji misto toho upgradovat XFree na verzi, ktera je ted v Debian experimental. Pridej si do /etc/apt/sources.list radek, ve kterem bude unstable zameneno za experimental (ale radek s unstable tam ponech). Pak proved selektivni upgrade vsech X baliku. K tomu muzes u apt-get vyuzit parametr
    -t experimental
    Az to bude hotovo, upgraduj postupne ostatni baliky. Predpokladam, ze budes chtit i KDE 3.2. K tomu muzes pouzit baliky od muesliho (ktere jsou zavisle na tom XFree z experimental).
    17.2.2004 12:03 Robert Krátký | skóre: 94 | blog: Robertův bloček
    Rozbalit Rozbalit vše Debian a upgrade na testing :(
    Btw, dej si pak pozor, aby sis neupgradoval na experimental celou distribuci.
    17.2.2004 13:12 Josef Benes | skóre: 2
    Rozbalit Rozbalit vše Debian a upgrade na testing :(
    Uz to jde, diky moc. Bylo to tim Xfree... Jeste jednou vsem MOC DEKUJI !

    Založit nové vláknoNahoru

    Tiskni Sdílej: Linkuj Jaggni to Vybrali.sme.sk Google Del.icio.us Facebook

    ISSN 1214-1267   www.czech-server.cz
    © 1999-2015 Nitemedia s. r. o. Všechna práva vyhrazena.