abclinuxu.cz AbcLinuxu.cz itbiz.cz ITBiz.cz HDmag.cz HDmag.cz abcprace.cz AbcPráce.cz
AbcLinuxu hledá autory!
Inzerujte na AbcPráce.cz od 950 Kč
Rozšířené hledání
×
včera 15:11 | Nová verze

Byl vydán Debian 10.6, tj. šestá opravná verze Debianu 10 s kódovým názvem Buster. Řešeny jsou především bezpečnostní problémy, ale také několik vážných chyb. Instalační média Debianu 10 lze samozřejmě nadále k instalaci používat. Po instalaci stačí systém aktualizovat.

Ladislav Hagara | Komentářů: 1
25.9. 23:11 | Bezpečnostní upozornění

Byly zveřejněny informace o bezpečnostní chybě BLURtooth (CVE-2020-15802) v Bluetooth 4.2 a 5.0 v Cross-Transport Key Derivation (CTKD). Útočník může provádět MITM nebo navázat spojení s libovolným zařízením. Podrobnosti v článku (pdf).

Ladislav Hagara | Komentářů: 1
25.9. 21:44 | IT novinky

Byly zveřejněny informace o úniku zdrojových kódů Windows XP.

Ladislav Hagara | Komentářů: 15
25.9. 15:22 | Zajímavý projekt

Chcete proniknout do tajů gitu? Klikněte na Learn Git Branching. Vizuální a interaktivní tutoriál ve webovém prohlížeči.

Ladislav Hagara | Komentářů: 0
25.9. 13:22 | Nová verze

Po roce od vydání verze 4.0 byla vydána nová major verze 5.0 softwaru pro správu elektronických knih Calibre (Wikipedie). Přehled novinek v poznámkách k vydání. Zdůraznit lze přechod na Python 3.

Ladislav Hagara | Komentářů: 14
25.9. 07:00 | Komunita

Pořadatelé konference DevConf.cz 2021, již třináctého ročníku jedné z největších akcí zaměřených na Linux a open source ve střední Evropě, vyhlásili CFP (Call for Papers). Konference proběhne jenom online a to 18. až 20. února 2021.

Ladislav Hagara | Komentářů: 0
24.9. 15:44 | Zajímavý článek

Národní bezpečnostní agentura (NSA) vydala podrobnou příručku pro nastavení UEFI Secure Bootu (pdf).

Ladislav Hagara | Komentářů: 4
24.9. 15:22 | Nová verze

Byl vydán PostgreSQL ve verzi 13.0. Přehled novinek v poznámkách k vydání.

Ladislav Hagara | Komentářů: 6
24.9. 15:00 | Zajímavý software

Nezávislý tým herních vývojářů Orama Interactive vydal novou verzi 0.8 svobodného sprite editoru Pixelorama. Editor Pixelorama je postaven na herním enginu Godot a nově běží také na webu. Zdrojové kódy jsou k dispozici na GitHubu.

Ladislav Hagara | Komentářů: 0
24.9. 14:00 | Zajímavý software

Mozilla Foundation na svém blogu představila Social Media Analysis Toolkit (SMAT). Jedná se o open source nástroj pro analýzu a vizualizaci online komunikace a trendů na sociálních sítí. Zdrojové kódy jsou k dispozici na GitLabu.

Ladislav Hagara | Komentářů: 2
Používáte aplikaci eRouška?
 (19%)
 (3%)
 (2%)
 (11%)
 (51%)
 (8%)
 (6%)
Celkem 436 hlasů
 Komentářů: 35, poslední 20.9. 21:50
Rozcestník

Dotaz: GPRS na ppp > 2.4.2

Luboš Doležel (Doli) avatar 18.2.2005 20:47 Luboš Doležel (Doli) | skóre: 98 | blog: Doliho blog | Kladensko
GPRS na ppp > 2.4.2
Přečteno: 159×
Ahoj,

mám probém, který už jsem vlastně vyřešil - no spíš jsem zjistil, kvůli čemu to je, ale skutečné řešení je asi (zatím) nemožné.

Nainstaloval jsem si PPTP, zkompiloval podporu Microsoftího MPPE - připojení do VPN jede OK. Aby PPTP chodilo, je zapotřebí ppp-2.4.3-0.cvs_20040527 (jinak chyba /usr/sbin/pppd: In file /etc/ppp/peers/Vigard: unrecognized option 'require-mppe' pptpconfig: pppd process terminated by signal 2 (failed) pptpconfig: SIGINT . Jenže s touhle verzí PPP nechodí připojení přes GPRS - vyhodí chybu:

Feb 18 20:12:48 localhost pppd[8281]: By default the remote system is required to authenticate itself
Feb 18 20:12:48 localhost pppd[8281]: (because this system has a default route to the internet)
Feb 18 20:12:48 localhost pppd[8281]: but I couldn't find any suitable secret (password) for it to use to do so.
Feb 18 20:12:48 localhost pppd[8281]: (None of the available passwords would let it use an IP address.)

Takže GPRS mi jede jen s verzí ppp-2.4.2.

Nejdřív mě napadlo nahlásit to jako bug, chtěl jsem zjistit "homepage" PPP pro Linux, jenže vzhledem k množství výsledků "PPP AND Linux" a jiných podobných query na Googlu jsem to nezjistil :-).

Neví někdo řešení tohoto problému, případně alespoň adresu WWW stránek vývojářů PPP? Není zapotřebí u verze 2.4.3 jen něco "donastavit"?

Odpovědi

Luboš Doležel (Doli) avatar 18.2.2005 21:00 Luboš Doležel (Doli) | skóre: 98 | blog: Doliho blog | Kladensko
Rozbalit Rozbalit vše Re: GPRS na ppp > 2.4.2
No tak jsem to vyřešil: v PPTPCONFIG se nesmí zvolit require-mppe - ale i přesto je použito, takže to faká tak jak má (= bezpečně).

Založit nové vláknoNahoru

Tiskni Sdílej: Linkuj Jaggni to Vybrali.sme.sk Google Del.icio.us Facebook

ISSN 1214-1267   www.czech-server.cz
© 1999-2015 Nitemedia s. r. o. Všechna práva vyhrazena.