abclinuxu.cz AbcLinuxu.cz itbiz.cz ITBiz.cz HDmag.cz HDmag.cz abcprace.cz AbcPráce.cz
AbcLinuxu hledá autory!
Inzerujte na AbcPráce.cz od 950 Kč
Rozšířené hledání
×
dnes 20:22 | Pozvánky

Zítra proběhne jednodenní online konference InstallFest 2021. Na programu je celá řada zajímavých přednášek, workshopů a také stánků. Dění lze sledovat na Twitteru.

Ladislav Hagara | Komentářů: 0
dnes 13:11 | Nová verze

Byla vydána nová verze 6.5 v Javě napsané aplikace pro komplexní návrh rozmístění nábytku a dalšího vybavení v interiérech Sweet Home 3D. Vyzkoušet lze online verzi. Nedávno byly aktualizovány také knihovny nábytku.

Ladislav Hagara | Komentářů: 0
dnes 08:00 | Humor

Nové verze webových prohlížečů Firefox a Chrome byly vydávány každých 6 týdnů. Vývojářům Firefoxu se nelíbilo, že Chrome bude mít vždy větší číslo verze, proto se rozhodli vydávat nové verze Firefoxu každé 4 týdny. Aktuální stav: Firefox 86 byl vydán v 8. týdnu a Chrome 89 v 9 týdnu letošního roku. V kterém týdnu bude mít Firefox větší číslo verze než Chrome?

… více »
Ladislav Hagara | Komentářů: 29
dnes 07:00 | Zajímavý článek

Thom Holwerda popisuje na OSnews pracovní stanici Raptor Blackbird Secure Desktop (architektura POWER9) a své zkušenosti s ní včetně provozu desktopových aplikací.

Fluttershy, yay! | Komentářů: 1
dnes 06:00 | Nová verze

Byla vydána nová verze 1.54 editoru zdrojových kódů Visual Studio Code (Wikipedie). Přehled novinek i s náhledy a animovanými gify v poznámkách k vydání. Ve verzi 1.54 vyjde také VSCodium, tj. komunitní sestavení Visual Studia Code bez telemetrie a licenčních podmínek Microsoftu.

Ladislav Hagara | Komentářů: 2
včera 14:23 | Zajímavý článek

Check Point zveřejnil report, podle kterého NSA v roce 2013 vytvořila exploit pro operační systém MS Windows. Exploit sloužil k lokální eskalaci práv. O rok později tento exploit ukradli hackeři z Číny. Až po dvou letech byl exploit zveřejněn a Microsoft vydal aktualizaci. Jinými slovy, celé téma se točí o tom, jak NSA zřejmě přispěla ke globálnímu snížení kybernetické bezpečnosti. Celý příběh podrobně naleznete na checkpoint.com.

Max | Komentářů: 6
včera 09:11 | Komunita

Framework Flutter (Wikipedie) pro vývoj mobilních, webových i desktopových aplikací byl vydán ve verzi 2 a související programovací jazyk Dart (Wikipedie) byl vydán ve verzi 2.12. Proběhla online konference Flutter Engage. Videozáznam je k dispozici na YouTube. Canonical zde oznámil (Twitter, YouTube), že Flutter je výchozí volba pro vývoj nových aplikací pro Ubuntu.

Ladislav Hagara | Komentářů: 0
včera 09:00 | IT novinky

Společnost AMD na YouTube představila novou grafickou kartu AMD Radeon RX 6700 XT postavenou na architektuře RDNA 2. V prodeji bude od 18. března. Její cena byla stanovena na 479 dolarů.

Ladislav Hagara | Komentářů: 22
včera 08:00 | Nová verze

Uživatelsky přívětivý shell fish byl vydán ve verzi 3.2.0 Vylepšuje uživatelské rozhraní (doplňování, práce s historií úprav textu aj.), přidává napovídání argumentů dalších aplikací, zjednodušuje syntaxi (expanze rozsahů), opravuje chyby.

Fluttershy, yay! | Komentářů: 0
3.3. 16:00 | Zajímavý software

Steam Link je nově dostupný také pro 64bitový x86 Linux. Streamovat hry z výkonného počítače s nainstalovanou službou Steam lze tedy vedle telefonu, tabletu nebo televize i do počítače s Linuxem. Instalovat Steam Link lze z Flathubu. Od prosince 2018 je k dispozici Steam Link pro Raspberry Pi.

Ladislav Hagara | Komentářů: 0
Vzděláváte se formou hromadných online kurzů (MOOC)?
 (57%)
 (10%)
 (1%)
 (6%)
 (26%)
Celkem 114 hlasů
 Komentářů: 0
Rozcestník

Dotaz: Gentoo & MySQL s UTF-8

18.4.2005 09:55 mike
Gentoo & MySQL s UTF-8
Přečteno: 170×
dobry den, som uplny zaciatocnik s gentoo, potreboval by som vyriesit 2 problemy na ktore som narazil po uspesnom nainstalovani 1. nechapem, preco sa mi po 'emerge mysql' nainstaloval MySQL server (a klient) radu 4.0.x, konkretne 4.0.24. MySQL 4.1.x nie je stable ? ako mozem upgradnut na 4.1.x tak, aby som nenarusil portage strom ? totiz mohol by som si stiahnut zdrojaky 4.1 z mysql.com a skompilovat samozrejme, ale radsej by som to chcel spravit tak, aby portage vedel o tom ze sa upgradlo MySQL 2. druhy problem spociva v nastaveni kodovania MySQL servera, totiz ja blbec som pri instalacii gentoo nenastavil do /etc/locales.build toto: en_US/ISO-8859-1 en_US.UTF-8/UTF-8 cs_CZ/ISO-8859-2 cs_CZ.UTF-8/UTF-8

a tym padom sa mi mysql server/klient (a predpokladam ze aj ostatne aplikacie) neskompilovali s podporou UTF-8. u ostatnych aplikacii by mi to ani tak nevadilo, ale u mysql servera to nutne potrebujem, teraz ked sa skusim pripojit na mysql tak: bash-2.05b# mysql --default-character-set=utf8 mysql: Character set 'utf8' is not a compiled character set and is not specified in the '/usr/share/mysql/charsets/Index' file

v locales.build uz samozrejme mam vyssie spominane riadky ohladom kodovania a skusal som znovu 'emerge mysql' ale po restarte /etc/init.d/mysql restart a opat skusani pripojit sa s utf-8 charsetom je vysledok rovnaky.

vopred vsetkym dakujem mike

Odpovědi

18.4.2005 10:07 jm
Rozbalit Rozbalit vše Re: Genntoo & MySQL s UTF-8
Nechapu...

- Pokud jsi do /etc/locales.build nenastavil nic, tak jsi mel na serveru vsechna locale. Navic se uplatni jenom tehdy, pokud mas nastaveny flag userlocales
local use flags (searching: userlocales)
************************************************************
[-    ] userlocales (sys-libs/glibc):
build only the locales specified in /etc/locales.build
- Vyse uvedeny konfigurak je vyhradne pro kompilaci glibc

- Pro vsechny ostatni aplikace je USE="unicode"

- Co si tak precist dokumentaci...

- Opravit vyse uvedene a emerge -av --newuse world

- Zaverem si precti dokumentaci k MySQl.
18.4.2005 10:24 Radomír Fojtík | skóre: 33 | blog: jen to zkouším | Tísek
Rozbalit Rozbalit vše Re: Genntoo & MySQL s UTF-8
Co se tyce pouzivani portage spravnym zpusobem , doporucuji tusim 2 dil z 3 dilneho serialu o gentoo na root.cz. Dulezite jsou soubory v /etc/portage/* Chcete to nejnovejsi mysql, ktere vsak jeste nebylo "dostatecne otestovano"?
echo "dev-db/mysql" >> /etc/portage/package.unmask
echo "dev-db/mysql ~x86" >> /etc/portage/package.keywords
Mozna bude treba stejnym zpusobem pridat jeste nejakou zavislost. Vse podstatne se dozvite po prikazu

emerge -pv =dev-db/mysql-4.1.8-r1
18.4.2005 12:03 mike
Rozbalit Rozbalit vše Re: Genntoo & MySQL s UTF-8
mysql 4.1 sa mi nepodarilo rozbehat, totiz emerge nenasiel 'mysql-4.1.8.tar.gz' na ziadnom mirrore Mysql.com tak som un-mergol mysql-4.0, dal som do make.conf 'USE=unicode' a mergol mysql-4.0 znova a restartol mysql server, ale opat to iste

mysql: Character set 'utf8' is not a compiled character set and is not specified in the '/usr/share/mysql/charsets/Index' file

ako keby ho ten USE flag nezaujimal. v com moze byt problem ? dakujem
18.4.2005 12:15 Michal Čihař | skóre: 61 | blog: Bláboly | Praha
Rozbalit Rozbalit vše Re: Genntoo & MySQL s UTF-8
A proč nepoužiješ aktuální? MySQL 4.1.8 je děravá.
18.4.2005 12:22 mike
Rozbalit Rozbalit vše Re: Genntoo & MySQL s UTF-8
no pretoze emerge -s 'mysql' mi ponukne max. 4.1.8 a nechcem to velmi robit 'bez emerge'. to by ani nebol ten najvacsi problem (aj ked by som radsej 4.1) stve ma to utf-8 kodovanie a keby sa mi nejako podarilo rozbehat 4.1 aj s utf-8 kodovanim tak by to bolo uplne super :) v USE mam 'unicode' skusal som 'premergovat' to mysql ale nejako sa mu do utf-8 nechce...
18.4.2005 12:28 jm
Rozbalit Rozbalit vše Re: Genntoo & MySQL s UTF-8
Budes s tim mit akorat problemy, tahle rada proste zatim nefunguje. Flag unicode je irelevantni, zadny takovy pro mysql neexistuje.
18.4.2005 12:26 jm
Rozbalit Rozbalit vše Re: Genntoo & MySQL s UTF-8
Zadna aktualnejsi nez 4.1.8 v Gentoo neni. Rada 4.1 je "hardmasked" a unsupported.
18.4.2005 12:36 Michal Čihař | skóre: 61 | blog: Bláboly | Praha
Rozbalit Rozbalit vše Re: Genntoo & MySQL s UTF-8
Tak to bych doporučil přejít na jinou distribuci :-)
18.4.2005 13:01 jm
Rozbalit Rozbalit vše Re: Genntoo & MySQL s UTF-8
Kvuli MySQL 4.1? Hmm, to se vyplati. Viz odkaz o par prispevku niz. :-)
18.4.2005 12:44 Radomír Fojtík | skóre: 33 | blog: jen to zkouším | Tísek
Rozbalit Rozbalit vše Re: Genntoo & MySQL s UTF-8
"hardmasked" je, ale proc unsupported? Kde se to da zjistit? /usr/portage/profiles/package.mask:
# Masking for testing
=dev-db/mysql-4.1*
spis problem vidim v jedne jeho zavislosti:
# Mysql 4.1.3 changed the number of arguments to shutdown breaking
# this module. This version of the perl module should work, but is
# super-untested and is, therefore, masked.
=dev-perl/DBD-mysql-2.9004
18.4.2005 12:59 jm
Rozbalit Rozbalit vše Re: Genntoo & MySQL s UTF-8
/usr/portage/profiles/package.mask contains a list of packages that should not be merged by users and comments detailing the specific reason why. Package.mask is used to prevent merging of packages that are broken, break something else, or badly need testing before going into ~ARCH KEYWORDS in the tree. When adding to package.mask, always commit package.mask prior to committing the masked ebuild. This prevents the ebuild from hitting users before the updated package.mask does.
Zmineny modul je potreba jedine tehdy, pokud se MySQL kompiluje s podporou perlu, to rozhodne neni ten duvod. BTW? Tohle nestaci?
18.4.2005 13:24 Radomír Fojtík | skóre: 33 | blog: jen to zkouším | Tísek
Rozbalit Rozbalit vše Re: Genntoo & MySQL s UTF-8
Ja rozumim, ale rici, ze rada 4.1 je unsupported se mi zda az prilis. Snad je to tim, ze si "unsupported" vylozi kazdy trosku jinak.
18.4.2005 13:38 Michal Čihař | skóre: 61 | blog: Bláboly | Praha
Rozbalit Rozbalit vše Re: Genntoo & MySQL s UTF-8
Nějak nechápu co ten odkaz má ukázat...
18.4.2005 13:43 jm
Rozbalit Rozbalit vše Re: Genntoo & MySQL s UTF-8
No, ze z tech 266 bugu v rade 4.1 by ty opravene clovek spocital na prstech jedne ruky, takze fakt nechapu, proc by tohle mela nejaka distribuce resit.
18.4.2005 13:54 Michal Čihař | skóre: 61 | blog: Bláboly | Praha
Rozbalit Rozbalit vše Re: Genntoo & MySQL s UTF-8
Není logické, že nejvíc nevyřešených bugů je v aktuální verzi?
18.4.2005 14:17 jm
Rozbalit Rozbalit vše Re: Genntoo & MySQL s UTF-8
Jasne, a proto je potreba, aby byla v distribucich (pokud mozno oznacena jako stabilni) a aby lidi co nejvic otravovali vyvojare te distribuce, ze MySQL a spousta s tim souvisejicich veci nefunguje.

A kdyz tomu tak nahodou neni, tak je potreba zmenit distribuci, protoze stoji za starou backoru. :-P
18.4.2005 16:03 Michal Čihař | skóre: 61 | blog: Bláboly | Praha
Rozbalit Rozbalit vše Re: Genntoo & MySQL s UTF-8
Většina distribucí dnes používá verzi 4.1, takže chyby které se najdou jsou hlášené na tuto verzi. Většina těchto chyb bude i v té starší verzi, kterou obhajuješ, ale to nikoho nezajímá.

Pokud se ty chyby co byly nahlášené na starší poraří zreprodukovat, tak se chyba přeřadí k novější verzi (pokud ne tak se zavře jako vyřešená).

Nechápu proč zůstávat u starší verze, kde je mizerná šance že se něco opraví.

Rozhodování o tom co je a není stabilní bych spíš nechal na vývojářích MySQL než na distributorech, kteří nemůžou mít takový přehled o stavu kódu.
18.4.2005 12:20 jm
Rozbalit Rozbalit vše Re: Genntoo & MySQL s UTF-8
1/ Rekompilujes uplne zbytecne, potrebujes MySQL 4.1.x.
dev-db/mysql-4.0.24

latin1 big5 cp1251 cp1257 croat czech danish dec8 dos estonia euc_kr gb2312 gbk german1 
greek hebrew hp8 hungarian koi8_ru koi8_ukr latin1_de latin2 latin5 sjis swe7 tis620 ujis 
usa7 win1250 win1251ukr win1251
Vidis tam snad nekde utf8? Proc si neprectes tu dokumentaci?

2/ Sprav si nastaveni mirroru, nejlepe je v make.conf zakomentuj, me teda stahovani normalne funguje.

3/ MySQL se spousti pomoci /etc/init.d/mysql start. Az nainstalujes verzi 4.1, tak by bylo dobre nastavit konfiguracni soubor v /etc/mysql/my.cnf
18.4.2005 12:27 mike
Rozbalit Rozbalit vše Re: Genntoo & MySQL s UTF-8
dakujem 1. mam to chapat tak ze mysql-4.0 nepodporuje utf-8 ? 2. nastavenie mirroru si viem spravit, a stahovanie cez emerge mi takisto funguje(u inych softverov) akurat mysql-4.1.8.tar.gz nevie najst ani na mysql.com ani na ostatnych mirroroch. viete mi dat presnu adresu kde je gentoo mirror aj s funkcnym mysql-4.1.8.tar.gz ? resp. nasiel som si presne ten subor na jednom ftp serveri (nie gentoo mirror), ked ho umiestnim do portage bude ho emerge brat z lokalneho disku, ze ?

3. to viem, dakujem
18.4.2005 12:39 jm
Rozbalit Rozbalit vše Re: Genntoo & MySQL s UTF-8
1/ Ano

2/ Uz nikde neni. Jedina moznost - udelat si vlastni ebuild pro 4.1.11. Upozornuju, pravdepodobne nezkompijes php/mod_php, takze cela tahle snaha je dost o nicem.
18.4.2005 12:43 mike
Rozbalit Rozbalit vše Re: Genntoo & MySQL s UTF-8
2. to s tym mod_php nechapem, apache s php mi uz v pohode bezi a pokial som si vsimol tak mysql nema mod_php ako dependency. alebo som vas zle pochopil ? inac nasiel som toto: http://ftp.physics.auth.gr/pub/mirrors/afs/physics.auth.gr/service/gentoo-portage/distfiles/ a to mysql-4.1.8 tam je

inac je mi skoro jedno ci budem mat 4.0 alebo 4.1 ide mi hlavne o to utf-8. ako to vyriesit a aku verziu tam 'narvat' ? diky
18.4.2005 12:46 jm
Rozbalit Rozbalit vše Re: Genntoo & MySQL s UTF-8
Pokud upgradnes MySQL na 4.1, tak mod_php prestane s MySQL fungovat (aspon u me), je potreba ho prekompilovat.

Pokud jsi nekde nasel 4.1.8, tak si to stahni do /usr/portage/distfiles a zkus emerge.

Verze 4.0.x neumi utf8. Howgh!
18.4.2005 12:51 mike
Rozbalit Rozbalit vše Re: Genntoo & MySQL s UTF-8
aha, ok, DIKY moc
18.4.2005 13:19 unchallenger | skóre: 69 | blog: unchallenger
Rozbalit Rozbalit vše Re: Genntoo & MySQL s UTF-8
Já jedu už roky na 3.23 v UTF-8 ;-)

Ale pochybuji, že někdo updatnul ten patch pro 4.0.x, když se očekávala podpora v 4.1...
18.4.2005 13:12 Radomír Fojtík | skóre: 33 | blog: jen to zkouším | Tísek
Rozbalit Rozbalit vše Re: Genntoo & MySQL s UTF-8
dal som do make.conf 'USE=unicode' a mergol mysql-4.0 znova
Trosku obecneji, pokud menim USE v make.conf, vzdy provedu prikaz

emerge -avuD --newuse world && revdep-rebuild -av

aby se zmena dotkla vsech ebuildu s tim kterym USE, pro definovani USE jen pro konkretni balicky mame soubor package.use.

Jinak v Using UTF-8 with Gentoo pisou:

It is wise to add unicode to your global USE flags in /etc/make.conf, and then to remerge sys-libs/ncurses and also sys-libs/slang if appropriate: ...

Založit nové vláknoNahoru

Tiskni Sdílej: Linkuj Jaggni to Vybrali.sme.sk Google Del.icio.us Facebook

ISSN 1214-1267   www.czech-server.cz
© 1999-2015 Nitemedia s. r. o. Všechna práva vyhrazena.