abclinuxu.cz AbcLinuxu.cz itbiz.cz ITBiz.cz HDmag.cz HDmag.cz abcprace.cz AbcPráce.cz
AbcLinuxu hledá autory!
Inzerujte na AbcPráce.cz od 950 Kč
Rozšířené hledání
×

    včera 00:33 | Nová verze

    Byla vydána OpenIndiana 2026.10. Unixový operační systém OpenIndiana (Wikipedie) vychází z OpenSolarisu (Wikipedie).

    Ladislav Hagara | Komentářů: 0
    včera 00:22 | IT novinky

    Americký výrobce polovodičů onsemi (ON Semiconductor) zrušil plány na rozšíření výroby v rožnovském závodě v Česku za dvě miliardy dolarů (podle aktuálního kurzu zhruba 43,5 mld. Kč). Důvodem je vývoj na trhu.

    Ladislav Hagara | Komentářů: 10
    7.11. 13:00 | Bezpečnostní upozornění
    Nové vydání zlib opravuje několik problémů při kompresi a dekompresi dat, přetečení bufferů, čtení mimo vyhrazenou paměť, únik neinicializovaných dat. Zvlášť významné jsou chyby v inflateGetDictionary(), inflateSync() a gzwrite(), které mohou způsobit poškození paměti. Vysoká relevance - zlib používá řada systémových i aplikačních komponent.
    vencour | Komentářů: 0
    7.11. 12:25 | Bezpečnostní upozornění
    Digicert hlásí neoprávněné čtení archivních zákaznických údajů. Došlo k němu po migraci z února 2025, po níž se interní systém, dříve dostupný jen přes VPN, stal přístupným z internetu. Chyba v oprávněních umožnila nově vytvořeným účtům číst archivní záznamy. K přístupu k datům mělo dojít mezi 27. červnem a 2. červencem 2026. DigiCert neoprávněné čtení potvrdil až 19. října 2026. Problém zpočátku vyhodnotil jako tvorbu účtů, ne jako … více »
    vencour | Komentářů: 0
    7.11. 04:44 | Pozvánky

    O víkendu probíhá na FIT VUT v Brně konference OpenAlt 2026 o otevřeném softwaru a datech, IT bezpečnosti, DIY a IoT. Na programu je spousta zajímavých přednášek. Pokud jste v Brně, stavte se. Vstup zdarma. Přednášky lze sledovat i online na VHSky a YouTube.

    Ladislav Hagara | Komentářů: 0
    7.11. 02:11 | IT novinky

    Qualcomm uzavřel víceletou dohodu se SpaceX. Bude dodávat rádiové technologie, baseband jednotky a software pro plánovanou pozemní 5G síť Starlink Mobile. Výstavba má zahrnovat desítky tisíc základnových stanic v USA. Zahájení nasazování se očekává v roce 2027. Qualcomm dohodu označuje za svůj dosud největší 5G kontrakt.

    vencour | Komentářů: 0
    7.11. 02:00 | IT novinky

    Google rozšířil Cloud Vulnerability Reward Program. Nově nabízí odměnu až 250 tisíc dolarů za vysoce závažné architektonické bezpečnostní chyby označované jako Root-in-Cloud.

    vencour | Komentářů: 0
    6.11. 12:22 | IT novinky

    V březnu byla oznámena spolupráce GrapheneOS s Motorolou. Nejnovější vlajka Motorola Signature 27 je první Motorola s oficiální podporou GrapheneOS. GrapheneOS (Wikpedie) je varianta Androidu zaměřující se na bezpečnost a soukromí.

    Ladislav Hagara | Komentářů: 0
    6.11. 04:55 | Nová verze

    Omarchy (Wikipedie) je linuxová distribuce s dlaždicovým správcem oken Hyprland. Založena je na Arch Linuxu. Vydána byla v nové verzi 4.5.0. Nově také pro Apple Silicon, konkrétně pro M1/M2/M3/Neo MacBooky.

    Ladislav Hagara | Komentářů: 4
    6.11. 03:22 | Nová verze

    Byla vydána nová stabilní verze 8.3 webového prohlížeče Vivaldi (Wikipedie). Postavena je na Chromiu 156 s bezpečnostními opravami z Chromia 157. Přehled novinek i s náhledy v příspěvku na blogu.

    Ladislav Hagara | Komentářů: 0
    Které desktopové prostředí na Linuxu používáte?
     (9%)
     (7%)
     (4%)
     (21%)
     (30%)
     (9%)
     (5%)
     (2%)
     (14%)
     (20%)
    Celkem 3009 hlasů
     Komentářů: 35, poslední 6.11. 23:27
    Rozcestník

    Dotaz: Java servlet-posílání mailů

    18.10.2010 09:57 Peta
    Java servlet-posílání mailů
    Přečteno: 623×
    Ahojte, mám aplikaci na, která 1)provádí výpočty a 2) posílá maily. Realizuji to servletem.

    Problém je, že výpočet i poslání mailu musí být udělané zaroveň. Mail posílám pomocí Transport.send().

    Jak zajistit, aby se výpočet uskutečnil pouze v případě, kdy mail skutečně dojde? Čili v případě plné schránky, špatné adresy, atd je to schopná aplikace zjistit a ten výpočet nebude.

    Řešil tohle už někdo? Existuje například v mailu nějaká chytrá vlastnost pro tohle? Díky moc za rady.

    Peťa

    Odpovědi

    18.10.2010 10:08 Filip Jirsák | skóre: 67 | blog: Fa & Bi
    Rozbalit Rozbalit vše Re: Java servlet-posílání mailů
    To není řešitelné, není možné detekovat, zda e-mail skutečně došel.
    18.10.2010 12:59 NeoV | skóre: 23
    Rozbalit Rozbalit vše Re: Java servlet-posílání mailů
    Nie je mozne zistit ci email bol doruceny!

    Je ale mozne (pokial je reporting MTA seriozne, co v drdivej vacsine je) zistit, ci email bol nedoruceny. A to za pomoci tzv. DSN - Delivery Status Notification. Toto uz ale nezistis hned... Odpovede od reporting MTA prichadzaju aj az po 72h od odoslania.

    Takze si vies urobit vzdy s odoslanim aj vypocty... a nasledne v postprocese pri spracovavani DSN sprav mozes robit nejaky ten rolback vypoctov pre nedorucene emaily.
    18.10.2010 17:53 Peta
    Rozbalit Rozbalit vše Re: Java servlet-posílání mailů
    To se mi zda dost pekne pouzitelne, diky
    18.10.2010 19:23 XY
    Rozbalit Rozbalit vše Re: Java servlet-posílání mailů
    cez DSN sa da zistit aj to ci bol mail doruceny, tj. nie len chyba, ale aj ci bol doruceny tj. uspech. v jave sa to riesi cez property mail session, konkretne:
    mail.smtp.dsn.notify=SUCCESS,FAILURE,DELAY
    mail.smtp.dsn.ret=HDRS
    sposobi ze budete informovany ako o uspechu, temp failure aj permanent failure, a v odpovedi budu prilozene hlavicky s povodneho mailu
    odporucam si kuknut prislusne rfc, uz si presne nepamatam ktore to su ale pozrite sa na: RFC 3461, RFC 3462 a RFC 3463
    18.10.2010 19:44 Filip Jirsák | skóre: 67 | blog: Fa & Bi
    Rozbalit Rozbalit vše Re: Java servlet-posílání mailů
    Hlavně je potřeba zjistit, zda to podporuje cílový server. Ne každý je totiž příznivcem toho, aby server každou funkční e-mailovou schránku poctivě nahlásil spamerovi – aby spamer zbytečně nežil v nejistotě, zda jeho e-mail dorazil. Stejně tak málokdo ocení informaci o tom, že zavirovaný e-mail nebo spam odeslaný jeho jménem někým úplně jiným se nepodařilo doručit.
    18.10.2010 21:26 NeoV | skóre: 23
    Rozbalit Rozbalit vše Re: Java servlet-posílání mailů
    mail.smtp.dsn.notify=SUCCESS nepodporuje realne ziaden svetovy mailovy server... resp. ked som tieto veci riesil (tak 1-2rok dozadu), tak sa mi nepodarilo najst ani jeden mail server, ktory by mi odpovedal SUCCESS mesidzov :-)

    Založit nové vlákno • Nahoru

    Tiskni Sdílej: Linkuj Jaggni to Vybrali.sme.sk Google Del.icio.us Facebook

    ISSN 1214-1267   www.czech-server.cz
    © 1999-2015 Nitemedia s. r. o. Všechna práva vyhrazena.